Troubleshooting - Microsoft Hyper-V Backup

Backup Restore  

Error Code: [91:9] VSS Service or writers maybe in a bad state

Problem

Volume Shadow Copy Service (VSS) error. VSS writers maybe in a bad state. For various causes, the inter operation with Volume Shadow Service can fail. Here are some of the common causes and resolutions:

Possible cause 1

VSS Writer is in an unstable state before the backup job started. This symptom can be verified by checking the status of the writer from the command prompt using the command \\\"vssadmin list writers\\\". If the VSS Writer is missing from the list, or is listed as in an unstable state, this would cause backups of Hyper-V virtual machines to fail.

Solution

Restart Hyper-V Virtual Machine Management Service to bring back the VSS writer to a stable state, which is necessary for backups. If this writer goes into an unstable state frequently, the root cause needs to be analyzed from the Windows Event Viewer.

Possible cause 2

When automatic mounting of new volumes on Windows 2008 Hyper-V host system is disabled, the online backups of (capable) guest systems will fail. Automatic fallback to an offline guest backup is not attempted.

Solution

Enable automatic mounting. To obtain and change the Mount Manager setting for automount of new volumes, follow the commands given below:

Using DISKPART command

Automount - reports the current setting for automatic mounting

Using MOUNTVOL command

Using REGISTRY Key

References

http://technet.microsoft.com/en-us/library/dd252619(WS.10).aspx

http://technet.microsoft.com/en-us/library/cc753703(WS.10).aspx

Possible cause 3

VSS Writer fails when the default path to the cluster shared volume does not match the Hyper-V Manager's path to the cluster shared volume. A symptom of such an error are the following lines in vsbkp.log:

3048 1318 08/09 09:59:23 126 CsSnapRequestor::AddVolumesToSnapshotSet() - CvClusterPrepareSharedVolumeForBackup successful for vol:[C:\\ClusterStorage\\Volume1\\] VolPathName:[C:\\ClusterStorage\\Volume1\\]

3048 1318 08/09 10:00:25 126 CsSnapRequestor::AddVolumesToSnapshotSet() - Call m_vss->AddToSnapshotSet(vol, m_shadowProvider.GetProvider(), &id) [FAILED, throwing CV exception] - Code = 0x80042306, Description = VSS_E_PROVIDER_VETO

Solution

Rename the path to the VHD from the Hyper-V Manager console. For example, if the path to the VHD file is: \""file:///C://ClusterStorage//volume1/">C:\\ClusterStorage\\volume1\",

Rename it to  \""file:///C://ClusterStorage//Volume1/">C:\\ClusterStorage\\Volume1\" to match the case. Note that the only difference is the case of the letter 'V'.

Possible cause 4

Windows Application Event viewer displays the following VSS error message:  "Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered."

A recent installation of a third party hardware provider may contribute to this failure, if an error occurred during Windows setup or during installation of a Shadow Copy provider.

Solution

Identify and temporarily uninstall any third party VSS Hardware provider (Example: NetApp's SnapDrive). If the backup succeeds, re-install the software.

Unable to backup virtual machines or VHD files with long names

Problem

Unable to backup virtual machines or VHD files with names longer than 20 characters.

Solution

Make sure the Virtual machines or VHD filenames are short, intuitive and lesser than 20 characters.

When hyper-V server references a volume that has been deleted backup fails

Problem

If the Hyper-V server references a VHD file originating on a volume that has been deleted, backups of all the Hyper-V server's virtual machines that are configured in the subclient will not complete successfully

Solution

This can be remedied by removing the reference to the VHD file from the Hyper-V server.

Completed with One or More Errors

Backup jobs from Virtual Server iDataAgent will be displayed as "Completed w/ one or more errors" in the Job History in the following cases:

 

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