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Summary of Changes

Current Version – March 2011
Assigned new Oracle document part number and revision: E20875-01. Part number is 
referenced on the title page of this document. 
Sun part number (316194401) and revision numbering system have been retired. 

Updates to support the following features:

• New Oracle hardware activation files. 
See Chapter 3, “Hardware Activation Files”  on page 109. 

• Distribution of the SL Console Web server and client via the Oracle E-Delivery 
website. 
See “Standalone SL Console Installation Tasks” on page 97 and 
Appendix D, “Web-launched SL Console Server”  on page 625. 

• Redundant Electronics feature. 
See Chapter 7, “Redundant Electronics Management” on page 359. 

• Library auto clean. 
See Chapter 11, “Drive Cleaning” on page 443. 

• Cleaning cartridge import/export. 
See “Importing and Exporting Cleaning Cartridges” on page 447. 

• Diagnostic cartridge import/export. 
See “Importing and Exporting Diagnostic Cartridges” on page 483. 

• Multi Port Fibre Channel feature. 
See “Multi-Path Connections” on page 52 and “Display HLI Port 
Status” on page 340. 

• Support for IPv6. See “IP Addresses” on page 55 and “Display Library 
Configuration Properties” on page 343. 
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Preface

This guide is intended primarily for administrators and operators of Oracle’s 
StorageTek SL3000 modular library system. It can also be used by Oracle partners 
and support representatives. 

Most of the information in this guide pertains to the library hardware, Oracle’s 
StorageTek Library Console, and related operations. For specific drive information or 
for client application software commands, see the appropriate drive or software 
documentation. 

Deaf/Hard of Hearing Access to Oracle Support 
Services

Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/support/contact.html or visit 
http://www.oracle.com/accessibility/support.html if you are hearing 
impaired.

Environmental Requirements – Airborne 
Contaminants

Control over contaminant levels in a computer room is an extremely important 
consideration when evaluating an environment. The impact of contamination on 
sensitive electronic hardware is well recognized, but the most harmful contaminants 
are often overlooked because they are so small.

Automated Tape Library components and electronics, tape drives, and media are 
subject to damage from airborne particulates. The operating environment must 
adhere to the requirements of:

ISO 14644-1 Class 8 environment 

For more information refer to the Data Center Site Planning Guide on the Oracle 
Technology Network website. 

For example:

Excessive concentrations of certain gases can accelerate corrosion and cause 
failure in electronic components. Gaseous contaminants are a particular concern in 
a computer room because of the sensitivity of the hardware.
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TABLE 0-1 lists some recommendations for gaseous limits.

TABLE 0-1  Gas Limit Recommendations 

Chemical Name Formula ASHRAE OSH (PEL) ACGIH NIOSH

Acetic Acid CH3COOH Not defined 10 ppm Not defined Not defined

Ammonia NH 3500 µg/m3 350 ppm 25 ppm Not defined

Chlorine Cl 2100 µg/m3 31 ppm (c) Not defined 0.5 ppm (c)

Hydrogen Chloride HCl Not defined 5 ppm (c) Not defined Not defined

Hydrogen Sulfide H2S 50 µg/m3 320 ppm (c) 10 ppm 10 ppm

Ozone O3 235 µg/m3 30.1 ppm Not defined Not defined

Petrol-
hydrocarbons

CnHn Not defined 500 ppm 75 ppm 300 ppm

Sulfur Dioxide SO2 80 µg/m3 35 ppm 2 ppm 0.5 ppm (c)

Sulfuric Acid H2SO4 Not defined 1 ppm Not defined 1 ppm (c)

PEL: Permissible Exposure Limit

ppm: Parts per million

µg/m3: Micrograms per cubic meter

(c): ceiling
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1

SL3000 Introduction 

The SL3000 is the latest addition to Oracle’s StorageTek modular library family, 
which includes the SL500 and SL8500 modular library systems. 

FIGURE 1-1  SL3000 Modular Library System

This chapter introduces you to the SL3000 library and its components and 
configurations, including the following topics:

• “SL3000 Features” on page 27

• “Modular Design” on page 28

• “Base Module” on page 32

• “Drive Expansion Module” on page 35

• “Cartridge Expansion Module” on page 38

• “Parking Expansion Module” on page 39

• “Access Expansion Module” on page 41

• “Tape Drives” on page 43

• “Cartridge Access Ports” on page 45
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• “Robotics Units” on page 46

• “Power Options” on page 49

• “Cooling” on page 51

• “Interfaces” on page 52

• “Library Management Software” on page 57

• “Operating Modes” on page 59
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SL3000 Features 
The SL3000 library offers customers the benefits of: 

• Scalability in storage capacity from 200 to 5925 storage cells 

• Performance from 1 to 56 tape drives 

• Support of a variety of tape drives

• Oracle’s StorageTek Any Cartridge, Any Slot support of mixed-media 

• Heterogeneous attachments using standard interfaces 

• Multiple library management software options and programs 

• Support for Internet Protocol, version 6 (IPv6) 

The SL3000 was designed to: 

• Address medium to large open systems and entry-level mainframe markets. 

• Occupy a standard datacenter footprint with measurements of approximately: 

• Height: 198 cm (78 in.), 

• Depth: 124 cm (48.8 in.), 

• Length: varies from 91.5 cm (36 in.) with one Base module, to 966.24 cm (380.4 
in.) with the maximum twelve modules (Base, DEM, eight CEMs, and two 
AEMs).
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Modular Design 
The SL3000 library provides a modular design, which allows customers to meet the 
demands of a rapidly growing and constantly changing environment. 

Modules 

There are five types of modules in an SL3000 library. The Base Module is the only 
one that is required. 

• Base Modulee – one only 

• Drive Expansion Module (DEM) – one only, attached directly to the left side of the 
Base Module 

• Cartridge Expansion Module (CEM) – up to eight total, with up to four on the left 
side of the Base Module (and optional DEM) and up to four on the right

• Parking Expansion Module (PEM) – installed always in pairs, one on each end of 
the library configuration 

• Access Expansion Module (AEM) – one or two, always installed on the end of the 
library configuration. 

Note – AEMs and PEMs cannot be installed in the same library. 

The modules consist of walls, columns, and rows that house cartridge storage cells, 
tape drives, cartridge access ports (CAPs), and robotics units (TallBots). 

CenterLine Technology

The SL3000 modular design uses CenterLine technology to help balance the work 
load and improve the performance of the library. The left side of the Base Module 
serves as the centerline. You can add other modules to the left and right of the Base 
Module. Columns to the right of the centerline have positive (+) numbers, while 
columns to the left have negative (–) numbers. 

FIGURE 1-2 on page 29 shows the library centerline and some possible module 
configurations, including: 

• Base module only 

• Base module and drive expansion module (DEM) 

• Addition of cartridge expansion modules (CEMs) and parking expansion modules 
(PEMs) s 



FIGURE 1-2  Library Configurations Around CenterLine 

Base Module Configurations Base and Drive Expansion Module Configurations
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Any Cartridge, Any Slot Technology

Mixed-media storage cells are used to hold the cartridges. This allows the SL3000 
library to support Oracle’s StorageTek Any Cartridge, Any Slot technology and 
accept a variety of media types without reconfiguring the library. 
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Cartridges lie flat and are placed in the storage cells with hub down and parallel to 
the floor. To prevent slippage, cartridges are held in place by internal retainer clips. 

Physical Capacities 

The SL3000 is scalable, with physical storage capacities from 200 to 5925 storage cells. 
In addition, the Capacity on Demand feature allows you to pay for only the capacity 
you actually use and expand capacity with minimal disruption to library operations. 

See Chapter 4, “Capacity on Demand” on page 143 for details about installing and 
managing library storage capacity. 

See TABLE 1-1 on page 31 for detailed physical capacities for each module type. To 
calculate the total accessible physical storage cells for a configuration, start with the 
standard configuration cell count, outlined with a heavy border, and then make the 
appropriate adjustments for options and positioning. Following are some examples:

• Base Module with operator’s panel, a module installed on the right, and three 
total drive arrays: 

320 + 0 + 13 – 55 – 60 = 218 

• DEM, a module installed on the left, window arrays, a CAP, and four drive 
arrays: 

410 + 88 + 23 – 77 – 66 – 72 – 78 = 228

• CEM installed to the left of CenterLine, a module installed on the left, and a CAP:

516 + 104 – 78 = 542

• PEMs (always installed in pairs), one with a CAP, one without:

308 + 312 – 78 = 542 

Optional Fire/Smoke Detection

Access ports in the ceilings of the modules are provided for optional fire suppression 
or smoke detection equipment. Installation and maintenance of this equipment must 
be arranged by the customer.



TABLE 1-1  Accessible Physical Cell Count Per Module 

Standalone or 
Position-

Independent

Adjacent Module
Installed on the:

Module Options Right Left Total Count

Base Module

Standard (with viewing window), 
standalone

320 +13 +88

With operator’s panel +0

With window storage arrays +23

With second drive array -55 -66

With third drive array -60 -72

Drive Expansion Module (DEM)

Standard (with viewing window 
and no CAP)

— 410 +88

With window storage arrays — +23

With CAP — -77

With second drive array — -55 -66

With third drive array — -60 -72

With fourth drive array — -65 -78

Cartridge Expansion Module (CEM)

Standard (no CAP), to the left of 
CenterLine 

516 +0 +104

Standard (no CAP), to the right of 
CenterLine 

620 +0 +0

With CAP -78

Parking Expansion Module (PEM)

Standard (no CAP), to the left of 
CenterLine

— 308

Standard (no CAP), to the right of 
CenterLine

— 312

With CAP -78

Access Expansion Module (AEM)

Cannot be used for long-term 
storage 

0 +104

Total accessible storage cell count 
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Base Module 
The Base Module provides both cartridge storage and a minimum of eight tape 
drives. This module includes the power configurations, robotics, electronic modules, 
cartridge access port, cartridge storage cells, tape drives, and operator controls. It 
centralizes the infrastructure for all other modules in the library. 

One and only one Base Module is required for every library installation.

TABLE 1-2  Base Module – Front View 

Configurations Capacity 

8 drives, CAP 

16 drives, CAP 

24 drives, CAP 

See 
TABLE 1-1 on 
page 31 

8 drives, CAP, and Operator panel/Window 

16 drives, CAP, and Operator panel/
Window 

24 drives, CAP, and Operator panel/
Window 

Dimensions Measurement 

Height 197 cm (77.625 in.) to 

200 cm (78.63 in.) fully adjusted 

Width 76.8 cm (30.23 in.) without covers1

91.5 cm (36 in.) with covers 

Depth 121.9 cm (48 in.) without handles

124 cm (49 in.) with handles 

Weight 265 kg (584 lb) frame only 

Service clearance 

Both doors open 

Front: 46 cm (18 in.) 

Rear: 81 cm (32 in.) 

262 cm (103 inches) 

Side clearance2 Cooling: 5 cm (2 in.) 

Installation: 91 cm (36 in.) 

Note –  

1. When additional modules are installed, the covers are 
removed from the Base Module and placed on the ends of 
the last module in the string. 

2. Required to install or remove the sides covers; they swing 
out and lift off of brackets. 
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The front of the Base Module includes the following components: 

• Single, 26-cartridge, dual-magazine cartridge access port (CAP) 

• Service door for library access 

• Front panel with three LEDs: Library Active, Service Required, and Wait. 

• Standard viewing window, which can be replaced by either of the following 
options:

• Touch-screen operator panel 

• Cartridge storage cells

The Base Module can hold up to 24 tape drives in any combination that the library 
supports – see “Tape Drives” on page 43 for a list and description. The minimum 
configuration includes one drive bay that can hold from one to eight drives. Two 
additional drive bays can be added to accommodate either 8 or 16 more drives, for a 
maximum of 24 drives. 

Note – Adding a drive bay displaces approximately 55 to 72 
additional storage cells, depending on the library configuration. 
See TABLE 1-1 on page 31 for the exact number. 

See FIGURE 1-3 on page 34 for a rear view of the Base Module. The rear door allows 
access to the following:

• Electronics control module (ECM) 

• Power distribution units (PDUs) 

• DC power supplies 

• Tape drives 

• Two one-unit rack spaces (1 unit = 44.5 mm [1.75 in.]) for vertically mounting 
auxiliary equipment, such as Ethernet switches 

Note – The Base Module does not contain any general-purpose 
19-inch rack space. 

See FIGURE B-1, “Base Module Walls” on page 608 for a detailed diagram of the wall 
layout. 



FIGURE 1-3  Base Module – Rear View Drawing 

Description 

Robotics DC power supplies 

• DCPS 1 and 2 or 3 

First drive bay (top)

The first drive bay is standard.

Drive bays are added from the top, 
down. 


Second drive bay (center) 





Third drive bay (bottom) 

Electronics control module 

HBC and HBT cards 
MPU2 Fibre Channel card (not shown)
Two cPCI power supplies 
Two cooling fans 
Two power switches (N+1 and 2N)

AC power distribution units (up to two)

• PDU 1 and PDU 2 

Drive DC power supplies (up to eight) 

• DCPS 4 through 11 
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Drive Expansion Module 
The optional Drive Expansion Module (DEM) provides the library with additional 
tape drives and cartridge storage capacity. One DEM can be included in a library 
installation, always to the left of the Base Module. 

FIGURE 1-4  Drive Expansion Module – Front View

Configurations Capacity 

8 drives 16 drives 
24 drives 
32 drives 

8 drives, CAP 
16 drives, CAP 
24 drives, CAP 
32 drives, CAP 

See 
TABLE 1-1 on 
page 31 

8 drives, CAP, and Operator panel/Window 

16 drives, CAP, and Operator panel/Window 

24 drives, CAP, and Operator panel/Window 

32 drives, CAP, and Operator panel/Window 

Dimensions1 Measurement 

Height 197 cm (77.625 in.) to 

200 cm (78.63 in.)

Width 

DEM only

Base and DEM 

 

76.8 cm (30.23 in.) 

168.3 cm (66.26 in.) with covers 2

Depth 121.9 cm (48 in.) without handles

124 cm (49 in.) with handles 

Weight 265 kg (584 lb) frame only 

Service clearance 

Both doors open 

Front: 46 cm (18 in.) 

Rear: 81 cm (32 in.) 

262 cm (103 inches) 

Side clearance3 Cooling: 5 cm (2 in.) 

Installation: 91 cm (36 in.) 

Note – 

1. The dimensions of the DEM are the same as the Base module. 

2. When additional modules are installed, the covers are removed from the Base Module and placed on the 
ends of the last module in the string. 

3. Required to install or remove the side covers; they swing out and lift off of brackets. 
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The front of the DEM includes space for the following components: 

• Service door for library access (standard) 

• Front panel with three LEDs: Library Active, Service Required, and Wait 

• Optional 26-cartridge, dual-magazine cartridge access port (CAP) 

• Standard viewing window, which can be replaced by either of the following 
options:

• Touch-screen operator panel, if not already in the Base Module 

• Cartridge storage cells

The DEM comes standard with drive slots to support up to eight tape drives. DEM 
drive slots can optionally be increased, in increments of eight, to a maximum of 32. 

Note – Adding a drive bay displaces approximately 55 to 78 
additional storage cells, depending on the library configuration. 
See TABLE 1-1 on page 31 for the exact number. 

There is an additional power system integral to the DEM to support the additional 
tape drives. 

See FIGURE 1-5 on page 37 for a rear view of the DEM. The rear door allows access to 
the following:

• Tape drives 

• Drive DC power supplies

• AC power distribution units (PDUs)

See FIGURE B-2, “Drive Expansion Module Walls” on page 609 for a detailed 
diagram of the wall layout. 



FIGURE 1-5  Drive Expansion Module – Rear View Drawing 

Description 



First drive bay (top)
The first drive bay is standard. 

Drive bays are added from the top, 
down.

Second drive bay 






Third drive bay 





Fourth drive bay 






AC Power distribution units (up to 
two) 

• PDU 3 and PDU 4 

Drive DC power supplies (up to 
eight) 

• DCPS 15 through 22 
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Cartridge Expansion Module 
The optional Cartridge Expansion Module (CEM) provides additional storage cell 
capacity and growth. No tape drives are in this module. A maximum of eight CEMs 
are supported in a single library.

The following considerations will maximize library efficiency: 

• As a best practice, CEMs should be alternated on either side of the Base Module 
and optional DEM, with the initial CEM installed directly to the right of the Base 
Module. This decreases the amount of robotics travel and provides the best use of 
cartridge storage cells. 

• If the Dual Robotics feature is installed without the use of Access Expansion 
Modules (AEMS), the two outside CEMs are converted to Parking Expansion 
Modules (PEMs). This provides areas for theTallBots to park when service is 
required. 

Each CEM adds up to 620 data cartridge physical storage cells. The capacity varies 
depending on the direction of growth (left or right) and the presence of a CAP. 

FIGURE 1-6  Cartridge Expansion Module with Base Module 

         Base Module     |               CEM

Configuration 
(next to Base with 24 drives) Capacity 

CEM (expanded left) 

CEM with optional CAP (left) See 
TABLE 1-1 on 
page 31 CEM (expanded right) 

CEM with optional CAP (right) 

Dimensions Measurement

Height 197 cm (77.625 in.) to 
200 cm (78.63 in.) fully adjusted 

Width 76.8 cm (30.23 in.) without covers1

One side cover adds 7.62 cm (3 in.) 

Depth 77.5 cm (30.5 in.) 

Weight 175 kg (385 lb) frame only

Side clearance2 Cooling: 5 cm (2 in.) 
Installation: 91 cm (36 in.) 

Service clearance, 
front and rear 

None required 

Note –  

1. When additional modules are installed, the covers are removed from the Base Module and replaced on the 
ends of the last module in the string. 

2. Required to install or remove the sides covers; they swing out and lift off of brackets. 

See FIGURE B-3, “Cartridge Expansion Module Walls” on page 610 for a detailed 
diagram of the wall layout. 
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Parking Expansion Module 
The optional Parking Expansion Modules (PEMs) provide additional storage cell 
capacity and growth, as well as space for defective TallBots to be “parked” for 
service. The parking space makes the three outer-most columns of storage cells on the 
front and rear walls inaccessible. The inaccessible cells can be left out of the module, 
or they can be installed to allow later conversion of the PEM to a CEM. PEMs do not 
include tape drives. 

PEMs are only used with the Dual Robotics feature, and they are always installed in 
pairs. They must be the last modules on the right and left sides of the library string. 

FIGURE 1-7  Parking Expansion Module 

Configuration Capacity 

PEM (expanded left) 308 cells

PEM (expanded right) 312 cells 

CAP –78 cells

Installed in pairs for the Dual Robotics 
feature. 

See 
TABLE 1-1 on 
page 31 

Dimensions1 Measurement

Height: 197 cm (77.625 in.) to 

200 cm (78.63 in.) fully adjusted 

Width: 76.8 cm (30.23 in.) without covers2

One side cover adds 7.62 cm (3 in.)

Depth: 77.5 cm (30.5 in.) 

Weight: 103.4 kg (277 lb) frame only

Side clearance Cooling: 5 cm (2 in.) 

Installation: 91 cm (36 in.)3

Service clearance 
front and rear 

None required

Note – 

1. The dimensions of the PEM are the same as the cartridge 
expansion module. 

2. When additional modules are installed, the covers are re-
moved from the Base Module and placed on the ends of 
the last module in the string. 

3. Required to install or remove the sides covers; they swing 
out and lift off of brackets. 

Note – AEMs and PEMs cannot be installed in the same library. 
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See FIGURE B-4, “Parking Expansion Module Walls” on page 611 for a detailed 
diagram of the wall layout. 
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Access Expansion Module 
The optional Access Expansion Module (AEM) provides the following capabilities: 

• Bulk loading and unloading of up to 234 cartridges at a time to and from the 
SL3000 library through the AEM CAP. The AEM is essentially a very large CAP, 
with all the characteristics of a CAP, such as online/offline state, ability to be 
shared by partitions, etc. The cartridge slots in the AEM cannot be used for long-
term cartridge storage. 

• Non-disruptive robot maintenance through the use of a safety door (or “garage” 
door), which sections off a defective robot from the other library modules. A 
Oracle service representative can safely access the disabled robot through the 
AEM access door while the library remains online. If the Dual Robotics feature is 
installed, the library can continue normal operations through the remaining 
functional robot. 

The library can include one or two AEMs. The AEM must be installed at the very end 
of the library string. If the library includes redundant TallBots, then two AEMs must 
be installed, one on each end of the library.

Note – AEMs and PEMs cannot be installed in the same library. 

AEMs do not include tape drives. 

See “AEM Operations” on page 381 for additional details about AEM functions and 
usage. 



FIGURE 1-8  Access Expansion Module 

Configuration Capacity 

AEM (expanded left) 234 CAP cells

AEM (expanded right) 234 CAP cells 

Installed in pairs for the Dual Robotics 
feature. 

See 
TABLE 1-1 on p
age 31 

Dimensions Measurement

Height: 197 cm (77.625 in.) to 

200 cm (78.63 in.) fully adjusted 

Width: 91.5 cm (36.0 in.) without covers1

One side cover adds 7.62 cm (3 in.)

Depth: 77.5 cm (30.5 in.) 

Weight: 204.12 kg (450 lb.)

Side clearance Cooling: 5 cm (2 in.) 

Installation: 91 cm (36 in.)2

Service clearance Front: 58.7 cm (23.1 in.)

Rear: Need access for Ethernet; there 
is no cover. 

Note –  

1. When additional modules are installed, the covers are re-
moved from the Base Module and placed on the ends of 
the last module in the string. 

2. Required to install or remove the side covers; they swing 
out and lift off of brackets. 
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Tape Drives 
TABLE 1-3 lists the tape drives, data path interfaces, and media types supported by 
the SL3000 library.

TABLE 1-3  Supported Tape Drives

Manufacturer Drive Type Interface Type Media

Oracle StorageTek T9840C 

T9840D

Fibre Channel

FICON

ESCON

9840

VolSafe-capable

Oracle StorageTek T10000A

T10000B

Fibre Channel

FICON

T10000Standard, Sport, and 
VolSafe

HP 

IBM

LTO 3 Fibre Channel LTO 3, LTO 3 WORM

LTO 2

LTO 1 (read only)

HP

IBM

LTO 4 Fibre Channel LTO 4, LTO 4 WORM

LTO 3, LTO 3 WORM

LTO 2 (read only)

HP IBM LTO 5 Fibre Channel LTO 5, LTO 5 WORM

LTO 4, LTO 4 WORM

LTO 3 (read only)

You can install up to 56 drives within one library, as follows:

• Up to 24 in the Base Module

• Up to 32 in a DEM 

The actual number of drives varies, depending on the AC power option and the 
media types. See TABLE 1-4 for details. 

TABLE 1-4  Power Options and Number of Drives

110–127 PDU 220–240 PDU

Base Module DEM Base Module DEM

T9840 12 14 24 32

T10000 13 16 24 32

LTO 3, 4 24 32 24 32

Mixed media varies any intermix
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Drive Trays 

In the SL3000, a single, universal drive tray accommodates all types of tape drives 
and interfaces. The SL3000 drive trays have two layers, as follows: 

• The power supply and connections are on the top. 

• The tape drive is under the power supply. 

Each drive tray slides into an eight-drive bay. 

FIGURE 1-9  Drive Tray 

Measurements 

Height: 16.5 cm (6.5 in.)

Width:   16.5 cm (6.5 in.)

Depth: 45 cm (18.5 in.)

Internal power supply cards and cabling are unique, depending on the drive type 
and interface within the drive tray. Cabling to the drive itself is out of the rear of the 
drive tray and library, then routed through the strain relief system. Both floor and 
ceiling cabling access is allowed. 
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Cartridge Access Ports 
The cartridge access port (CAP) is a vertically-mounted, rotating cylinder with two 
removable 13-slot magazines (26 cells total). CAPs are used to enter or eject 
cartridges from the library. 

The Base Module comes with one CAP as a standard feature. Optionally, one CAP 
can be installed in each expansion module, up to a maximum of ten CAPs for the 
library. 

Each CAP has its own set of controls, consisting of a small keypad and indicators. 
The CAP and its magazines rotate as a single unit. 

See “CAP Operations” on page 377 for details about using CAPs. 

FIGURE 1-10  Cartridge Access Port

1 2 1 2

3

1. Cartridge access ports 

2. Blank covers
When a CAP is not installed, a blank cover is installed. This can always be upgraded in the future 
to include a CAP. 

3. Keypad and indicator user interface. 
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Robotics Units 
The robotics unit in an SL3000 library is called a TallBot. Each library can have either 
one (standard) or two (redundant) TallBots. 

TallBots are responsible for the movement and cataloging – or audit – of cartridges 
throughout the library. 

FIGURE 1-11  TallBot

TallBot measurements are:

• Width: 30 cm (11.84 in.)

• Depth: 39 cm (15.36 in.)

• Weight: 8.6 kg (19 lb)
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TallBots are driven along two rails on the rear wall of the library – one rail at the top 
and one attached to the floor. 

Two copper strips are inserted into the top rail to provide both power and signal 
paths for TallBot operation. 

• Power comes from +48 VDC, 1200 Watt, load-sharing power supplies. 

• Signals are received and transmitted between the TallBots and the library 
controller. 

• A Rail Power Enable module is installed as a safety circuit for rail power.

Handling of the cartridges by the TallBots include: 

• Retrieving cartridges from a CAP

• Inserting cartridges into a CAP

• Inserting and retrieving cartridges to and from storage cells 

• Mounts and dismounts of cartridges to and from tape drives 

TallBots contain a laser bar code scanner that: 

• Reads the configuration blocks in each module during library initialization. See 
FIGURE B-5 “Configuration Block” on page 613 for an example. 

• Targets on cartridge storage/CAP cells and tape drives. Targets have the 
following shape, similar to the letter “N”: 

|\|

• Identifies volume IDs (VOLIDs) of cartridges during: 

• CAP entries

• Audits

The TallBot reads cartridge VOLIDs during audits and CAP enters only. Each 
cartridge’s assigned location is stored in the library controller database, and the 
TallBot uses that location to retrieve the cartridge. 

Redundant (Dual) Robotics 

The Redundant Robotics feature is offered as a high availability option. This affords:

• A speed increase for library operations

• A backup TallBot in case one should fail

This option requires PEMs at each end of the library. A defective TallBot will take 
itself offline and may move, or can be pushed, into one of the PEMs or AEMS, 
allowing the library to continue operations with one TallBot until time can be 
scheduled to replace the defective one. If AEMs are installed, the downed TallBot can 
be serviced without disruption to library operations. 

The requirements for redundant TallBot operation are:

• A 240 VAC, 2N power configuration 

• PEMs on each end of the library 
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• Dual TallBot hardware activation key 
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Power Options 

AC Power Configurations 

The following AC power source options are available:

• Limited features: 110 VAC, 50/60 Hz, at 20 Amps (range: 100–127 VAC, 50–60 Hz, 
16 Amps) 

• Full features: 220 VAC, 50/60 Hz, at 30 Amps (range: 200–240 VAC, 50–60 Hz, 
24 Amps) 

Power Distribution Units (PDUs) are located at the rear of the Base Module and 
optional DEM. 

Power Redundancy

The SL3000 provides full redundancy for tape drives, robotics units, and electronics. 
The following redundancy options are available: 

• N+1 – One AC PDU, with one extra DC power supply for DC power redundancy. 
This is the standard power configuration for the SL3000. This configuration 
requires at least a 20 Amp circuit breaker at the customer’s branch service panel. 

• 2N – Two PDUs for AC redundancy; each PDU has a set of DC power supplies 
(N DC power supplies). This configuration requires a second, separate customer 
power source. 

• 2N+1 – Two PDUs for AC redundancy; each PDU has extra DC power supplies 
for N+1 redundancy for each PDU. The second PDU does not have N+1 for the 
TallBot. 

DC Power  

Load sharing 1200 Watt DC power supplies are required for distribution of +48 VDC 
for TallBot and tape drive operation. The number of DC power supplies required 
depends on the power configuration and total number of drives in the library. 

A Rail Power Enable module is also installed as a safety circuit for rail power. Two 
cPCI power supplies (200 Watts each) distribute power to the Electronics Control 
Module. These power supplies are located below the HBT card – two on the left for 
N+1, or one on each side for 2N. 
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Library Environment Specifications
TABLE 1-5 lists the library environment specifications. Refer to your tape drive and 
media publications for their specifications.

TABLE 1-5  Library Environment Specifications

Item

Measurements

Operating Storage Transporting

Temperature +16 to +32ºC
(+60 to +90ºF)

+10 to +40ºC
(+50 to +104ºF)

-40 to +60ºC
(-40 to +140ºF)

Humidity 20 to 80% 10 to 95% 10 to 95%

Wet bulb (maximum, 
noncondensing)

+29.2ºC
(+84.5ºF)

+35ºC
(+95ºF)

+35ºC
(+95ºF)

Airborne Contamination Tape drives and media are subject to damage from airborne 
particulates. The operating environment must adhere to the 
ISO 14644 Class 8 requirements.

Altitude -76 to 3048 m (-250 to 10,000 ft)
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Cooling 
Cooling within the SL3000 is divided into three areas: 

• Library electronics 

• Tape drives 

• DC power supplies 

Library Electronics 

There are two fans located to the right of the electronics control module that provide 
cooling for the electronics in the library. Air is drawn from the floor and sides of the 
library and flows through the fans to the rear of the library. 

• These fans are monitored by the HBC card for proper operation. 

• An amber Fault indicator is on the fan assembly to indicate a failure. 

While there are two dedicated fans, one fan is sufficient to provide adequate cooling 
for the library/electronics. Nevertheless, since the fans can be replaced without 
interfering with library operations, it is best to replace a defective fan when it is 
detected. 

Tape Drives

Each tape drive tray contains one or two fans for drive cooling. 

Power for the fans is supplied through the tape drives power converter card. Air is 
drawn from the front of the drive and flows through the fan to the rear of the drive/
library. 

DC Power Supplies

Each 1200 Watt DC power supply contains a fan that pulls air from the front of the 
library, through the rear of the supply, and out the rear of the library. 
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Interfaces 
The SL3000 library supports the following types of interfaces: 

• Library Control Path – Transfers library management commands, such as 
cartridge mounts and dismounts, between the host and the library components. 
No host data is present on this interface. 

• Data Path – Transfers data between the host and the tape drives. 

• Command Line Interface – Allows an Oracle support representative to configure 
and diagnose the library.

• SNMP – Allows system administrators to query the library and receive 
information about potential problems. 

• SL Console – Allows library operators and administrators to configure and 
manage the library from a graphical user interface. 

Library Control Path 

Note – When a new library is integrated into a network, it is 
strongly recommended that the system/network administrator 
work closely with a Oracle StorageTek representative to define the 
configuration. 

The control path provides for the transfer of library management commands between 
the host and the library. The SL3000 supports the following host connection types for 
the control path: 

• TCP/IP Interface – TCP/IP protocol using Ethernet 10/100 Base-T and CAT-5 
cables 

• FC-SCSI Interface – Small Computer System Interface (SCSI) protocol and 
command set over a physical Fibre Channel interface 

A non-partitioned library can use only one interface type – either FC-SCSI or TCP/IP. 
Using the optional Partitioning feature, a library can connect to multiple hosts over a 
combination of the two interface types. See Chapter 5, “Library 
Partitioning” on page 187 for details. 

Library addressing depends on the host connection type: 

• TCP/IP hosts use a panel, row, column (PRC) numbering scheme. 

• FC-SCSI hosts use a sequential element numbering scheme, with each element 
type (storage cells, tape drives, and CAPs) having its own sequential range. 

See Appendix A, “Library Resource Addresses” on page 589 for full details. 

Multi-Path Connections

For both connection types—TCP/IP and FC-SCSI—the standard SL3000 library 
configuration includes a single port for host-to-library communications. You can add 
a second port through the following optional features:

• Dual TCP/IP (or Dual Port) – for TCP/IP connections

• Multi Port Fibre – for FC-SCSI connections
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These features must be installed and enabled by your Oracle support representative. 
See Chapter 3, “Hardware Activation Files” on page 109 for details. 

Once the optional second port is activated, both ports can be connected to the same 
host or to two different ones. The ports operate independently, and the library 
always responds to a host request on the same port that the request was received. 

In the event of a port failure, automatic failover is managed by the host software, not 
the library. See the appropriate host software documentation for details about the 
provided failover support. 

Any problems with the ports are reported in the system Event Log and the Status 
Module screen. See “Library Events” on page 479 and “Status Alert Messages” on 
page 332 for details.

TCP/IP Interface

The TCP/IP interface type uses the TCP/IP protocol over an Ethernet physical 
interface, (CAT-5, Ethernet, 10/100 BaseT cable). This interface enables either of the 
following host platforms to connect to and communicate with the library: 

• Open system platforms with ACSLS (see “Automated Cartridge System Library 
Software” on page 58 for details). 

• Enterprise-level mainframes with ELS (see “Enterprise Library Software” on 
page 57 for details). 

The library TCP/IP interface complies with the Institute of Electrical and Electronics 
Engineers standard–IEEE 802.3–for Ethernet networks. The ports are capable of auto-
negotiating the following functions: 

• Method of transmission   

• Half-duplex: Transmits data in just one direction at a time 

• Full-duplex: Transmits data in two directions simultaneously 

• Speed of the transmission 

• 10Base-T: 10 megabits per second (Mbps)

• 100Base-T: 100 megabits per second (Mbps)   

Network Configuration 

The SL3000 should be installed on a secure private network. Use the following 
configuration guidelines in order to maximize throughput and minimize resource 
contention. 

• Directly connect the library to a switch. 

• Place the library on its own subnet. 

• Use a managed switch that can:

• Set priorities on ports to give the host and library higher priority.

• Provide dedicated bandwidth between the host and the library.

• Create a VLAN between the host and the library. 
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• Use a virtual private network (VPN) to insulate host-to-library traffic. 

Oracle StorageTek’s 9300 Control Path Adapter provides the hardware connection for 
mainframe hosts. This interface adapter is installed on the mainframe and converts 
data on the Ethernet network to compatible Host Library Interface (HLI) commands. 

Library Controller Redundant Electronics

Note – This feature is available starting with SL3000 firmware 
version FRS_3.0 and SL Console version FRS_5.00. 

The optional Redundant Electronics feature provides failover protection in HLI 
libraries. If the library controller experiences errors, it automatically switches 
operations to an alternate library controller, with minimal disruption to library and 
host operations. This allows your Oracle support representative to replace the faulty 
card while the library continues normal operations. 

The Redundant Electronics feature also provides minimal disruption of library 
operations during firmware upgrades. 

FC-SCSI Interface

The FC-SCSI interface type uses the SCSI command set over a physical Fibre Channel 
connection. The Oracle StorageTek implementation of Fibre Channel conforms to the 
following standards: 

• American National Standards Institute (ANSI) 

• National Committee for Information Technology Standards (NCITS) 

Applications supporting the SCSI-3 protocol are required for FC-SCSI hosts. 

Topology

The recommended Fibre Channel topology for the SL3000 is switched fabric. A 
switched fabric provides dynamic interconnections between nodes, and multiple, 
simultaneous Fibre Channel connections for the network.

If the SL3000 is connected to a Fibre Channel switch or fabric-capable host, it 
automatically configures itself as a switched topology and can support up to 16 
million ports logged into the fabric. 

See the SL3000 Interface Reference Manual for complete information. This manual 
contains information about the SCSI command set, plus information about Fibre 
Channel operations, command implementations, topologies, cables, and connectors. 

Note – While the SL3000 supports the arbitrated loop topology, 
this topology is not recommended.

Note – The SL3000 does not support forcing arbitrated loop 
connection by setting Hard ALPAs (Arbitrated Loop Physical 
Addresses). 

Library Internal Network

The library’s internal network handles all communication between the library 
controller and the private system ports, such as:
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• CAPs

• Drive control path 

• Local operator panel 

Data Path

The data path, which is separate and distinct from the library control path supports 
the transfer of data between the host and the tape drive. Host data paths to the tape 
drives can be Fibre Channel, FICON, or ESCON, depending on the operational 
characteristics of the drive type. See “Tape Drives” on page 43 for details. 

IP Addresses

The SL3000 supports Internet Protocol, version 6 (IPv6). The following minimum 
code levels are required:

• SL3000 firmware version FRS_3.0 and SL Console version FRS_5.00.

• ACSLS 8.0.2

• HSC IPv6 PTFs:

• VM/HSC 6.2 SMS6200 L1H15F9

• MVS/HSC 6.S SOS6200 L1H1558

• MVS/HSC 7.0 SSEA700 L1H15FA

See the appropriate tape management software documentation for details on 
configuring your library with IPv6 addresses. 

Command Line Interface 

The SL3000 command line interface (CLI) is a library interface for trained and 
qualified Oracle support representatives only. This interface allows support 
representative to configure and diagnose problems with the library. 

Note – Customers do not have access to the CLI interface. 

SNMP

Simple Network Management Protocol (SNMP) allows system administrators and 
network managers to monitor and receive library status information, including the 
following: 

• Operational state of the library (such as microcode level, serial number, online/
offline status)

• Status of the CAPs (such as open, closed, number of cells)

• Library elements (number of TallBots, storage cells, CAPs) 

• Number of storage cells and media types in the library 

• Number and types of tape drives installed in the library
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Note – By default, the SNMP agent is turned off and must be 
activated by your Oracle support representative through the 
command line interface (CLI). 

The SL3000 supports the following SNMP versions: 

• SNMPv2c – For machine status queries; the information transmitted is not secure.

• SNMPv3 – For Oracle Confidential: Internal Use Only information, since it 
supports encryption and strong user identification. SNMPv3, therefore, is the 
preferred protocol for proprietary data.

Note – See the SL3000 SNMP Guide (PN 3161945xx) for detailed 
information concerning SNMP and the setup procedures.

SL Console

The StorageTek Library Console (SL Console) is a Java-based software application 
that provides a graphical user interface (GUI) for monitoring and managing the 
StorageTek SL3000 library. See Chapter 2, “StorageTek Library Console” on page 61 
for complete details. 
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Library Management Software
Library management software components control the library to perform activities 
such as mounts and dismounts, enters and ejects. They also manage their own 
cartridge databases, containing volume location and attribute information. 

Oracle offers several software components depending on the platform, connection 
type, and operating system. These include the following: 

• Direct-attach SCSI over Fibre Channel interface

• ACSLS

• Enterprise Library Software (ELS), which includes:

• CDRT (Concurrent Disaster Recovery Test)

• CSC (Client System Component) 

• ExHPDM (Extended High Performance Data Mover)

• ExPR (Expert Performance Reporter)

• LibraryStation

• MSM (MegaRAID Storage Manager)

• VTCS (Virtual Tape Control System) 

• VSM (Virtual Storage Manager) GUI

• Library Content Manager (formerly ExLM)

Note – See the appropriate library management software 
documentation for the version levels required to support the 
SL3000. 

Nearline Control Solutions

The SL3000 supports the following Oracle Nearline Control Solutions (NCS) software 
products.

• Enterprise Library Software 

• Storage Management Component

• StorageTek HTTP Server

Enterprise Library Software 

Oracle’s StorageTek Enterprise Library Software 7.0 (ELS) packages together multiple 
components along with many enhancements – all designed to reduce complexity, 
boost productivity, and improve reliability and availability in your data center. 
Compared to ELS and VTCS individual software, StorageTek Enterprise Library 
Software 7.0 delivers enhancements in several areas to provide more functions and 
increased usability at a lower price.

• Parameter pre-validation of storage management policies 

• Improved CDS recovery and logging 
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• Integrated task-oriented documentation

• Improved migration system

• Enhanced disaster recovery

• Higher availability clustering solution

• SMC simulation

• Improved client/server virtual tape volume mount processing through

• Storage Management Component (SMC) 

Storage Management Component

Oracle’s Storage Management Component (SMC) is the interface between IBM’s OS/
390 and z/OS operating systems and a Oracle StorageTek library. SMC performs the 
allocation processing, message handling, and SMS processing for the NCS solution. 
SMC resides on the MVS host system with ELS, or on a remote system using the 
Oracle StorageTek HTTP server to communicate with the ELS. SMC communicates 
with ELS to determine policies, volume locations, and drive ownership.

Library Content Manager 

Oracle’s Library Content Manager (LCM) provides automated library management 
for z/OS environments. It enhances and optimizes the overall performance of 
automated tape libraries by providing content management to assure there are 
adequate storage resources (tape drives, tape cartridges, etc.) available to run 
scheduled jobs and to run them at optimum efficiency. It also provides reporting of 
the overall operations of the library.

StorageTek HTTP Server

Oracle’s StorageTek HTTP Server for OS/390 and z/OS optionally provides the 
middleware to allow communication between the SMC (client) and a remote ELS 
subsystem (server). The HTTP server executes as a separate subsystem on the MVS 
host where the remote ELS subsystem resides. 

Automated Cartridge System Library Software

Oracle’s Automated Cartridge System Library Software (ACSLS) functions as the 
central service provider for all library operations, efficiently sharing library resources 
with ACSLS-enabled applications on any system, and allowing you to manage 
multiple libraries from a single point of control. The key benefits of using ACSLS in 
your tape environment include:

• Centralized library control across multiple StorageTek libraries, including legacy 
technology

• Optimized library performance by load-balancing hardware and executing 
parallel commands

• Reduced downtime through dynamic configuration capabilities and queuing 
commands during short-term library outages

• Enriched reporting and management capabilities for ease of use 
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Operating Modes
Four modes of operation are possible for the SL3000:

• Automated Mode 

• Manual Mode

• Maintenance Mode

• Degraded Mode

Automated Mode 

When in automated mode of operation, the library automatically mounts and 
dismounts cartridges without physical intervention by a person.

Automated operations include the following activities:

• Mounting and dismounting cartridges

• Entering and ejecting cartridges through the CAP

• Logging library events

• Drive cleaning 

See “Automated Mode of Operation” on page 325 for complete details. 

Manual Mode

Manual mode of operation occurs when the library is unavailable for system use and 
human intervention is required. An example of this situation would be when a 
library experiences an unrecoverable error, making automated mounts and 
dismounts impossible.

Another example would be where a library component cannot perform a mount to a 
drive for a particularly important job request. In this case, the library may require a 
person to enter a library, locate the cartridge, and manually mount it into the 
requested drive. 

Warning – Anyone entering the library must be advised of the 
safety procedures required of them. 

See Chapter 14, “Manual Operations” on page 573 for complete details. 

Maintenance Mode

In the case of a failure in a non-redundant library component (for example, a single 
TallBot for the entire library), the library is said to be “unavailable” to the system. In 
this case, the entire library must be placed offline until the repair is accomplished.

After the defective component has been repaired or replaced, the library can be 
placed in maintenance mode while verification tests are performed. 
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Degraded Mode

When in degraded mode, the library is still operational and online, but its operational 
efficiency is degraded due to a failing component. Examples of degraded mode are: 

• In a redundant TallBot configuration, one TallBot has failed; the other TallBot has 
assumed all mount and dismount operations for the entire library.

• A single tape drive has experienced a failure and must be replaced.
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2

StorageTek Library Console

Oracle’s StorageTek Library Console (SL Console) is a Java-based software 
application that provides a graphical user interface (GUI) for monitoring and 
managing the StorageTek SL3000 library. 

Following are some of the activities you can perform with the SL Console:

• Manage available library storage capacity

• Manage and configure library partitions (optional feature)

• View and modify status and properties of the library and associated devices 
(drives, CAP, robots, and elevators)

• Perform an audit on all or part of the library

• Perform a self-test on the library or an associated device

• Perform a diagnostic move (exercise a robot)

• Locate a cartridge

• Move a cartridge from one location to another

• Display library logs

• Display library status event messages

• Display error explanations 

• Download new library firmware while the library is in operation

• Display context-sensitive help 

SL Console Modes
Depending on your needs, you can run the SL Console in any of the following 
modes. For details and procedures, see: 

• “Local Operator Panel” on page 67 

• “Web-launched SL Console” on page 69 

• “Standalone SL Console” on page 70
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SL Console Security 
Security features built into the SL Console control both user authentication and user 
authorization. The security features include:

• User IDs – User IDs control user authentication. Each user must have a valid, 
active user ID and password to log in to the SL Console.

• Access permissions – Access permissions control user authorization. Each user ID 
is assigned a set of access permissions, which determine the types of requests the 
user can submit through the SL Console. For example, in order to modify the 
system properties of a drive, a user must log in with a user ID that has the proper 
access permissions.

When you log in to the SL Console with a valid user ID, password, and library name, 
the system authenticates your identity and then authorizes your access to the various 
SL Console functions. 

User IDs

To log in to the SL Console, you must have a valid, active user ID. Each user ID must 
be assigned a password.

There are a fixed set of user IDs at a site. The user IDs include admin (customer 
administrator), service (Oracle support representative), and oem (third-party field 
service technician). When you log in successfully, the SL Console displays your user 
ID in the status bar of the screen.

Only one user at a time can be logged in to the local operator panel. Any number of 
users can connect to a library through the standalone SL Console or Web-launched 
SL Console. 

Activation Password 

Before any users at your site can use the SL Console for the first time, your library 
administrator must activate the “admin” userid with a special activation password. 
Your Oracle support representative provides your administrator with the activation 
password, which is valid for one-time use only. 

After logging in with the activation password, the administrator must change the 
admin user ID password to ensure system security. 

For details about this process, see the appropriate library Installation Guide. 
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SL Console Screen Display 
The following figure and table explain the components of the SL Console screen. 

1 43

5

9

2

78 6

Component Name Description

1 Menu bar – includes the 
Tools Menu and the Help 
Menu 

Tools menu provides access to System Detail, Reports, Monitors, 
Utilities, Partitioning, User Management, and Log off functions. 

Help menu provides access to the table of contents of the help 
system. It also identifies the version of the SL Console in use.

2 Title bar Displays the title of the current screen. 

3 Function tabs Identifies the available functions for a screen. 

4 Options bar Location of buttons related to the screen (for example, Apply, 
Refresh, Print). Always includes the SL Console Help button (?). 
See “Synchronizing the Display With the Controller 
Database” on page 64 for details on using the Apply and Refresh 
buttons. 

5 Work area Location of the screen data. 

6 Library health indicator Identifies the library to which the SL Console is connected, and 
displays a graphical representation of the library health. 



64  SL3000 User’s Guide March 2011 

 

Modifying the Screen Layout 

Note – This feature is available starting with SL Console version 
FRS_3.30. It is available on selected screens only. 

You can modify the layout and display of selected SL Console screens as follows. 

Display Option Instructions

Sort the display by any 
column

Click the heading of the column you want to sort by. Initially the sort is 
in ascending order. Click the heading again to switch between 
ascending and descending order.

Arrange the columns in any 
order

Click and drag a column heading horizontally to any position in the 
heading row. 

Resize the columns Click the border of the column heading and drag it left or right to 
change the column width. 

Synchronizing the Display With the Controller Database

Logging In

The SL Console gets all library configuration data from the library controller. 
Therefore, you should be careful when logging in to the SL Console before the library 
has fully initialized. You may see warnings that configuration data is not yet 
available, in which case you need to exit and log in again at a later time. 
Additionally, if a library audit is performed as part of initialization, until the audit is 
complete, any configuration data displayed may not be completely up-to-date and 
accurate. 

Making Library Configuration Updates

When you first bring up an SL Console screen, the display reflects the most recently 
saved data from the library controller database. If you use the screen to modify the 
library contents or configuration, your changes do not update the controller database 
until you commit your changes by clicking the Apply button. Multiple users can 
access the library at the same time, using the SL Console, command line interface, 
and various host applications to make their own changes to the library contents and 
configuration. If other users make changes and apply them to the controller database, 
you will not see these changes until you click Apply or Refresh on your screen. 
Therefore, the display you see on the SL Console may not reflect the actual saved 
library configuration at a given point in time.

7 UserID indicator Displays the user ID currently logged in to the SL Console.

8 Server communication 
health indicator

Displays a graphical heartbeat monitor indicating the state of 
server communication health.

9 Device tree Lists the devices included in the library.

Component Name Description
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For these reasons, if you are making major modifications to the library 
configuration – adding modules, defining partitions, etc. – it is important that you 
coordinate these changes with other library users. Failure to do so could result in 
conflicts within the controller database. 

SL Console Reports 
The SL Console library reports provide information on the library and its associated 
devices (for example, drives, robots, and CAPs), events, and tape cartridges. You can 
use the reports to monitor library activity and identify potential problems. In 
addition to displaying the reports on-screen, you can save the report data to a file, 
which you can then print or include in e-mail. 

All report output is a static display of information sent from the library controller at 
the time the report is generated. The SL Console does not update the information 
dynamically unless you explicitly select the Update button on the Options bar.

Note – Running multiple instances of the standalone SL Console 
or Web-launched SL Console on the same PC or workstation can 
cause problems such as inconsistent data on reports. It is 
recommended that only one user at a time produce SL Console 
reports on a PC or workstation, unless all instances of the 
SL Console are the same version.

Report Types

The SL Console provides the following types of reports:

• Log – detailed system event logs

• Statistics – statistical information on library operations 

• Status Detail – details on the status of the library and associated devices, such as 
CAPs, drives, and robots

• Status Summary – summary information on the status of the library and 
associated devices

• Version – details about library hardware and software versions

Report Options Bar

The Options bar on each report allows you to perform the following functions:

• Search a Library Report 

• Update the report with current data 

• Save Library Report Data to a File 

Report Procedures

For report procedures, see “General SL Console Report Tasks” on page 85. 
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SL Console Help  
The SL Console Help displays information for library operators, system 
programmers, system administrators, and service representatives. 

Note – The information relates specifically to the SL Console only. 
For information about library hardware, tape drives, or host 
software, see the appropriate product publication.

Following is a sample SL Console Help screen. 

Accessing the SL Console Help 

You can display the SL Console Help from any SL Console screen. Use either of the 
following methods: 

• To display context-sensitive help for the current SL Console screen, click the? 
button in the Options bar. 

• To display general help information, click Help > Contents in the Menu bar. 

Help Navigation

The left panel of the SL Console Help screen displays either of the following:

• Table of contents (TOC) – An outline of topics and subtopics

• Index – A list of terms and topics, in alphabetical order

The right panel displays the Help topic itself. 

The top of the SL Console Help screen includes the following navigation buttons. 



Button Action

 Back Retraces your steps, going backward one topic at a time. 

 Forward Retraces your steps, going forward one topic at a time. 

 Print Displays the Print popup, which allows you to print one or more topics:

• To print the current topic, click the Print button.

• To print a different topic, click the topic title in the SL Console Help table 
of contents, and click the Print button.

• To print more than one topic, highlight the topics in the SL Console Help 
table of contents by pressing Shift-Click or Ctrl-Click, and then click the 
Print button. 

 Print Setup Displays the Page Setup popup, which allows you to modify your print 
page layout.

 TOC Displays the SL Console Help table of contents. 

 Index Displays the SL Console Help index. 
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Tips for Using the SL Console Help

• You can minimize, maximize, or resize the Help screen to accommodate your 
needs.

• You can resize the left and right panels of the Help screen by clicking the border 
between them and dragging it left or right. 

• Most topics include a Related Topics button at the bottom of the page. Click on 
this button to display and navigate to help topics containing related information. 

Local Operator Panel 
The local operator panel is an optional feature of the library, which is built in to the 
Base Module and Drive Expansion Module (DEM). It enables you to run most of the 
SL Console application directly at the library from a flat-screen display with a touch 
screen interface. 

The local operator panel has the following features:

• Flat-panel display (12.1-inch), resident within the library 

• Touch screen interface, allowing alphanumeric data entry; stylus available; see 
“Virtual Keypad” for details. 

• No keyboard or mouse option
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LEDs located directly below the local operator panel provide the following status 
information:

• Library Active – Library processor is working. 

• Wait – Library firmware is loading. 

• Service Required – Library is rebooting. 

Virtual Keypad

Some screen fields require you to make a text entry. The local operator panel displays 
a keyboard icon next to these fields. By clicking on the keyboard icon, you can 
display a virtual keypad, which allows you to enter valid alphanumeric characters 
into the field. The following figure illustrates the keyboard icons on a sample screen. 

The virtual keypad provides the standard alphanumeric and symbol characters. It 
allows you to enter only characters that are valid for the current field; characters that 
are not valid are grayed out. 

The virtual keypad also provides the following cursor movement buttons:

Button Function

Insert If highlighted, inserts text at the cursor position. 

If not highlighted, replaces text to the right of the cursor. 

Home Places cursor at the beginning of the field.

Del Deletes character to the right of the cursor.

End Places cursor at the end of the field.

Back Deletes character to the left of the cursor

Clear Clears the entire field

Left Moves cursor one character to the left

Right Moves cursor one character to the right

OK Submits the text entry in the field

Cancel Cancels the text entry in the field and dismisses the virtual keypad 
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Touch Screen Calibration

Alignment of the local operator panel touch screen is calibrated at the factory. The 
factory settings are appropriate for most situations, and it is usually not necessary for 
you to make any adjustments. On rare occasions, however, the touch screen may 
come out of alignment or need adjustment. 

To re-calibrate the touch screen, proceed as follows:

• If you have a Linux-based local operator panel, you can re-calibrate it yourself. 
See “Re-calibrate the Local Operator Panel” on page 93 for detailed instructions. 

• If you have a Windows-based local operator panel, contact your Oracle support 
representative. Windows-based local operator panels can be re-calibrated only by 
an authorized service representative. 

If you have a Linux-based local operator panel, you can re-set the touch screen to its 
factory settings at any time. See “Reset the Local Operator Panel 
Calibration” on page 96 for detailed instructions.

Web-launched SL Console
The Web-launched SL Console is a standard feature of the library. It enables the 
SL Console to be installed on a centralized Web server. Individual clients can then 
use a supported Web browser to download the Web-launched SL Console. Using the 
Web-launched SL Console you can connect to any library for which you have a valid 
user ID.

The Web-launched SL Console is delivered to clients as a Java Web Start process, 
which executes outside the browser. 

Security Considerations

The Web-launched SL Console software is digitally signed, which guarantees that it 
has been issued by Oracle Corporation and has not been altered or corrupted since it 
was created. As a Java Web Start process, the Web-launched SL Console includes the 
security features provided by the Java 2 platform.

The customer is responsible for implementing all appropriate additional security 
systems, including firewalls, user access, etc.
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Client Requirements

You can download the Web-launched SL Console to clients meeting the following 
requirements: 

Platform Solaris 9 – SPARC (Firefox 2.x)

Solaris 10 – SPARC (Firefox 2.x)

Windows 2000 – 32 bit (IE 5, IE 5.5, Firefox 2.x)

Windows XP – 32 bit (IE 6, IE 7, Firefox 2.x)

Windows Vista – 32 bit (IE 7, Firefox 2.x)

Other • Java 1.5 Plug-in (the browser will install this automatically if it is 
not present already)

• Ethernet connection to the library

• Ethernet connection to the Web-launched SL Console server 

 

Web-launched SL Console Updates

Updates to the Web-launched SL Console only need to be installed on the centralized 
Web server. Once the updates are installed on the server, they are downloaded 
automatically to all clients whenever the application is started on the client. 

Starting the Web-launched SL Console on a Client

You can use either of the following methods to start and log in to the Web-launched 
SL Console on a client: 

• From a command line (Solaris only) or supported browser. See “Log in to the 
Web-launched SL Console Using a Browser or Command Line” on page 75. 

• By double-clicking the slc.jnlp icon on your client. In order to use this method 
from a client, you must use the browser method at least once and save the 
slc.jnlp file locally. See “Log in to the Web-launched SL Console Using an 
Icon” on page 79. 

Standalone SL Console 
The standalone SL Console is a standard feature of the StorageTek SL3000 library. It 
enables you to run the SL Console application remotely from a PC or workstation 
that has a network connection to the library. Using the standalone SL Console you 
can connect to any library for which you have a valid user ID. 
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Security Considerations

The SL Console application interfaces with the primary library interface (PLI) over a 
security software layer (SSL). The SSL provides a secure communication path 
between the library and the customer’s SL Console session; this prevents an 
unauthorized network user from monitoring library activity.

Installation Requirements

You can install the standalone SL Console on a computer meeting the following 
requirements: 

Platform Solaris 9 – SPARC

Solaris 10 – SPARC

Windows 2003 Server – 32 bit

Windows XP Client – 32 bit

Windows Vista – 32 bit

Other Ethernet connection to the library

 

The standalone SL Console software is available for download at the Oracle 
Corporation E-Delivery website, which is at the following URL:

http://edelivery.oracle.com/ 

Standalone SL Console Updates 

Note – Before you can install a new version of the standalone 
SL Console, you must uninstall the previous version. See your PC 
or workstation documentation for detailed instructions. Running 
multiple versions of the SL Console on the same PC or 
workstation can cause problems such as inconsistent data on 
reports. 

Once you have uninstalled the previous version of the SL Console, see the following 
procedures for detailed instructions on upgrading the software.

• “Download the Standalone SL Console Media Pack” on page 98 

• “Install the Standalone SL Console” on page 103 
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SL Console Task Summary
SL Console tasks are divided into the following categories:

• “General SL Console Usage Tasks” on page 73

• “General SL Console Report Tasks” on page 85

• “Local Operator Panel Calibration Tasks” on page 92

• “Standalone SL Console Installation Tasks” on page 97
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General SL Console Usage Tasks

Task Page

Log in to the Local Operator Panel  74

Log in to the Web-launched SL Console Using a Browser or Command 
Line

 75

Log in to the Web-launched SL Console Using an Icon  79

Log in to the Standalone SL Console  82

Log Off the SL Console  83

Change a User Password  84
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▼ Log in to the Local Operator Panel 

Use this procedure to log in to the local library. 

Note – Only one user at a time can log in to the local operator 
panel. 

1. If the touch screen panel is blank, touch the screen anywhere to activate the 
Login screen.

2. Use the virtual keypad to enter your login information (see “Virtual 
Keypad” on page 68 for details). 

User ID: SLC_login 
Password: password 

where:

• SLC_login is the SL Console user ID.

• password is the password assigned to this user ID. 

Note – The user ID you use determines the screens you can 
access. See “SL Console Security” on page 62. 

3. Click Log on. 
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▼ Log in to the Web-launched SL Console Using a Browser or 
Command Line 

Note – Before you perform this activity, you must obtain the DNS 
alias or IP address of the SL Console server. Depending on how 
your Web-launched SL Console server has been set up, it may be 
accessible only by IP address. See your library administrator for 
assistance. 

Note – The command line option is available on Solaris platforms 
only. 

On Windows 2000, you may need to install a Java plugin for your Web browser 
before performing this procedure. You can download the plugin from the following 
location:
http://java.sun.com/products/archive/j2se/5.0_04/index.html 

On Solaris platforms, it is easier to log in to the Web-launched SL Console using the 
command line. If you prefer to log in using a Web browser, however, you need to 
download a recent version of the Firefox Web browser from the following location: 
www.mozilla.com

1. Choose your login method:

• Command line – available on Solaris only. Proceed to Step 2. 

• Web browser – available on either Windows or Solaris. Proceed to Step 3. 

2. Open a terminal window, and type the following command:

javaws http://server_ID:port_ID/opel/slc.jnlp 

where:

• server_ID is either of the following:

• IP address of the SL Console server 

• DNS alias of the SL Console server

• port_ID is the port ID of the SL Console application, typically 8080 

• opel is the name (context root) of the Web-launched SL Console application 
on the server. 

Proceed to Step 4. 

3. Start a supported Web browser on your client PC or workstation (see “Client 
Requirements” on page 70 for a list of supported browsers), and in the Location 
Bar or Address field, enter the URL of the SL Console Web Start application: 

http://server_ID:port_ID/opel

where:

• server_ID is either of the following:

• IP address of the SL Console server 

• DNS alias of the SL Console server

• port_ID is the port ID of the SL Console application; typically 8080 
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• opel is the name (context root) of the Web-launched SL Console application 
on the server. 

Note – You can bookmark this URL for future logins. 

The SL Console Launch screen appears. 

4. Click Launch Now.

The Web Start process retrieves the Web-launched SL Console application from 
the server. Any updates are downloaded automatically. 

The Opening slc.jnlp popup appears. 

5. Complete the popup as follows:



March 2011   77

 

a. Specify the action you want to take with the slc.jnlp file:

• Click the Open with Java(TM) Web Start Launcher radio button if you 
want to start the SL Console directly. 

• Click the Save to Disk radio button if you want to save the slc.jnlp file 
to your client and log in to the SL Console later. See “Log in to the Web-
launched SL Console Using an Icon” on page 79 for login instructions. 

b. Optionally click the “Do this automatically for files like this from now on” 
checkbox. If you make this selection, this popup will not appear during 
future logins. 

c. Click OK. 

If this is the first time you are running the Web-launched SL Console, a digital 
signature warning popup appears. 

6. Complete the popup as follows:

a. Verify the Publisher. 

b. Optionally click the “Always trust content from the publisher” checkbox. If 
you make this selection, this popup will not appear during future logins. 

c. Click Run.
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The SL Console Login screen appears. 

7. Enter your login information, and click Log on.

User ID: SLC_login 
Password: password 
Library: library_ID 

where:

• SLC_login is the SL Console user ID.

• password is the password assigned to this user ID. 

• library_ID is the library to which you want to connect, expressed in either of 
the following ways:

• IP address of the library 

• DNS alias of the library

Note – The user ID you use determines the screens you can 
access. See “SL Console Security”. 
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▼ Log in to the Web-launched SL Console Using an Icon

Note – In order to perform this activity, you must first save the 
Web-launched SL Console slc.jnlp file to your client. See “Log 
in to the Web-launched SL Console Using a Browser or Command 
Line” on page 75 for details. 

1. Double-click the slc.jnlp desktop icon on your client. 

The Web Start process retrieves the Web-launched SL Console application from 
the server. Any updates are downloaded automatically. 

The SL Console Launch screen appears. 

2. Click Launch Now.

The Web Start process retrieves the Web-launched SL Console application from 
the server. Any updates are downloaded automatically. 



80  SL3000 User’s Guide March 2011 

 

If this is the first time you are running the Web-launched SL Console, a security 
warning popup appears. 

3. Complete the popup as follows:

a. Verify that the Publisher is Oracle Corporation 

b. Optionally click the “Always trust content from the publisher” checkbox. If 
you make this selection, this popup will not appear during future logins. 

c. Click Run.
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The SL Console Login screen appears. 

4. Enter your login information, and click Log on.

User ID: SLC_login 
Password: password 
Library: library_ID 

where:

• SLC_login is the SL Console user ID.

• password is the password assigned to this user ID. 

• library_ID is the library to which you want to connect, expressed in either of 
the following ways:

• IP address of the library 

• DNS alias of the library

Note – The user ID you use determines the screens you can 
access. See “SL Console Security”. 
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▼ Log in to the Standalone SL Console 

1. Start the SL Console application on your PC or workstation by doing either of 
the following:

• Double-click the SL Console icon on the desktop.

• Select Start > RunSLConsole or Launch > RunSLConsole 

The SL Console starts and the Login screen appears. 

2. Enter your login information.

User ID: SLC_login 
Password: password 
Library: library_ID 

where:

• SLC_login is the SL Console user ID.

• password is the password assigned to this user ID. 

• library_ID is the library to which you want to connect, expressed in either of 
the following ways:

• IP address of the library 

• DNS alias of the library

Note – The user ID you use determines the screens you can 
access. See “SL Console Security”. 

3. Click Log on. 
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▼ Log Off the SL Console

Note – Before you log off, make sure all operations for the current 
SL Console session have completed (for example, code loads, 
audits, diagnostic moves). 

1. From any SL Console screen, select Tools > Log Off.

The Confirm popup appears. 

Note – To remain logged in to the SL Console, click Cancel. You 
are returned to the originating screen without logging off. 

2. Click OK. 

You are logged off the SL Console, and the Login screen appears. 

3. Click Exit to close the SL Console.
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▼Change a User Password 

Use this procedure to change the password for a user account. 

1. Log in to the SL Console using any of the modes available to you (local operator 
panel, Web-launched SL Console, or standalone SL Console). You must log in 
using the user account you want to modify.

2. Select Tools > User Mgmt.

The User Management screen appears. 

3. On the User tree, expand the Permanent folder, and click the user account you 
want to modify (the user account you are logged in as). 

Detailed information for the user account is displayed. 

4. Complete the following fields: Current Password, New Password, and 
Retype Password. 

5. Click Modify.

The password for the account is updated. 
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General SL Console Report Tasks

Task Page

Display a Library Report  86

Search a Library Report  88

Save Library Report Data to a File  90
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▼Display a Library Report 

Use this procedure to display library reports available from the Tools > Reports 
menu.

Note – All report output is a static display of information sent 
from the library controller at the time the report is generated. The 
SL Console does not update the information dynamically unless 
you explicitly select the Update button on the Options Bar.

If you want to search the report data or save it to a file, see the following procedures:

• “Search a Library Report” on page 88 

• “Save Library Report Data to a File” on page 90

Additional reports are available from the following menus:

• Tools > Partitions 

• Tools > Select Active Cells 

1. Select Tools > Reports. 

The reports Display screen appears. All library report options are listed in the 
navigation bar.

2. In the navigation bar, expand a report category to see the report options.

3. Click the report you want to display. 
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The selected report is displayed. 
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▼ Search a Library Report 

Use this procedure to search a library report for a specified text string. This 
procedure can be performed on any of the library report screens.

1. Select Tools > Reports. 

The reports Display screen appears. All library report options are listed in the 
navigation bar.

2. In the navigation bar, expand a report category to see the report options.

3. Click the report you want to display. 

The specified report is displayed. All report screens include the Search button on 
the Options Bar. 

4. Click Search. 

The Search Text popup appears. 

5. Enter the text string you want to search for, and click Search. 
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Note – The search is case-sensitive, and wildcards are not 
supported. 

6. The Search Results popup appears, displaying the number of occurrences of the 
text string. All instances of the text string in the report are highlighted. 

7. Click OK to dismiss the popup. 
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▼ Save Library Report Data to a File

Use this procedure to display a library report and save the data to a file. Depending 
on the report, you can save to in text (.txt), HTML, XML, or comma-separated 
values (.csv) format. This procedure can be performed from any of the library 
report screens.

Once the file is saved, you can print it or include it in e-mail. This may be useful for 
communicating about library issues with your Oracle support representative. Also, 
you can import a .csv file into a spreadsheet or charting application in order to 
better understand and interpret the data. 

1. Select Tools > Reports. 

The reports Display screen appears. All library report options are listed in the 
navigation bar.

2. In the navigation bar, expand a report category to see the report options.

3. Click the report you want to display. 

The specified report is displayed. All report screens include the Save button on 
the Options Bar. 

4. Click Save. 
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The Save popup appears. 

5. Browse to the directory where you want to save the file. In the File Name field, 
you can accept the default entry or enter a different file name. 

6. In the Files of Type pull-down, select the format in which you want to save the 
data (HTML, Text, XML, .csv). 

7. Click Save. 

The data is saved to the specified file. 

Note – If the file exists already, a popup appears prompting you 
whether you want to replace the file. 
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Local Operator Panel Calibration Tasks 

Task Page

Re-calibrate the Local Operator Panel  93

Reset the Local Operator Panel Calibration  96



March 2011   93

 

▼Re-calibrate the Local Operator Panel 

Use this procedure to change the alignment of the local operator panel touch screen. 
The touch screen comes pre-calibrated from the factory, and in most cases no 
adjustment is necessary. Typically, you would use this procedure only if the touch 
screen has come out of alignment. 

Note – This procedure can be performed only at a Linux-based 
local operator panel. To re-calibrate a Windows-based local 
operator panel, contact your Oracle support representative. 

Note – Before beginning this procedure, make sure there is no 
debris on the touch screen, as this can interfere with an accurate 
calibration. 

Note – You can re-set the touch screen to its factory settings at 
any time. See “Reset the Local Operator Panel 
Calibration” on page 96 for detailed instructions. 

1. Log in to the local operator panel.

See “Log in to the Local Operator Panel” on page 74 for detailed instructions. 

2. Select Tools > Calibrate. 

The Select Calibration Option popup appears. 

3. Click Calibrate. 
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The alignment sequence begins. Ten targets are presented sequentially on the 
screen. 

4. Gently tap in the center of each target with your finger or a pointing stylus. 

This aligns the screen according to your touch. Be sure to touch the center of each 
target so you can get an accurate calibration. 

Note – If you tap outside of a target, you can potentially mis-align 
your touch screen. Depending on the severity of the mis-
alignment, you may have trouble logging back into the local 
operator panel if you save these new settings. See Step 7 for 
instructions on discarding settings. 

After you touch the last target of the alignment sequence, the first of two 
Accept Calibration popups appears, with a Click Me button on the left side of the 
popup. 

5. Proceed as follows with the agility test, depending on whether the new 
alignment settings are good:

• To save the new alignment settings, proceed to Step 6. 

• To discard the new settings, proceed to Step 7. 

6. Use the following steps to save the new settings.

a. On the Accept Calibration popup, touch the Click Me button within the 
indicated time period. 
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• If the button depresses when you touch it directly, the touch screen is 
properly aligned. The second Accept Calibration popup appears, this time 
with a Click Me button on the right side of the popup. 

• If the button does not depress when you touch it directly, the touch screen 
is not properly aligned and you should discard the new settings. Proceed to 
Step 7. 

b. On the second Accept Calibration screen, touch the Click Me button within 
the indicated time period. 

If you depress the button successfully, the alignment settings are saved and the 
Calibration Accepted popup appears. 

c. Click OK to dismiss the popup and save the new settings.

The new settings are effective immediately, and the display returns to the 
SL Console screen. The local operator panel is not rebooted. 

7. Use the following steps to discard the new settings. 

a. On either Accept Calibration popup, let the timer run out without touching 
the Click Me button. 

The Retry Calibration countdown message appears. 

b. The calibration sequence screen is presented again. Return to Step 4 to try 
the calibration a second time. 

If you are not able to successfully calibrate the screen on the second try, the local 
operator panel is rebooted automatically, and the alignment is restored to the 
previously saved settings. 
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▼Reset the Local Operator Panel Calibration

Use this procedure to restore the alignment of the local operator panel touch screen 
to the factory settings. This procedure forces a reboot of the local operator panel, 
which takes several minutes. 

Note – This procedure is available only for a Linux-based local 
operator panel. To re-set the calibration of a Windows-based local 
operator panel, contact your Oracle support representative. 

1. Log in to the local operator panel.

See “Log in to the Local Operator Panel” on page 74 for detailed instructions. 

2. Select Tools > Calibrate. 

The Select Calibration Option popup appears. 

3. Click Reset Calibration. 

The current touch screen calibration settings are discarded, and the alignment is 
restored to the factory settings. The Calibration Reset countdown message is 
displayed. 

The local operator panel is rebooted automatically, and the display returns to the 
SL Console screen.

Note – The reboot takes several minutes. 
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Standalone SL Console Installation Tasks 

Task Page

Download the Standalone SL Console Media Pack  98

Install the Standalone SL Console  103
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▼Download the Standalone SL Console Media Pack

Use this procedure to download and extract the current SL Console Media Pack from 
the Oracle E-Delivery website. The Media Pack includes the Web-launched 
SL Console server, as well as the Web-launched SL Console client and the standalone 
SL Console. 

Note – Your Oracle support representative may have performed 
this procedure for you during library installation.

1. Start a Web browser on your PC or workstation and navigate to the Oracle 
E-Delivery website at the following URL:

http://edelivery.oracle.com/ 

 

2. Click Continue. 

3. On the Export Validation screen, make the following entries:

• Enter your contact information.

• Read the License Agreement and Export Restrictions, and click the check boxes 
to indicate your acceptance. 
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• Click Continue. 

 

4. On the Media Pack Search screen, make the following selections: 

• In the Select a Product Pack pull-down, select Oracle StorageTek Products. 

• In the Platform pull-down, select Generic Platform. 
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• Click Go. 
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5. All media packs meeting your selection criteria are displayed in the Results 
section of the screen. Select the SL Console version you want to download. 
Click Continue. 
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6. On the specific media pack screen, review the information to verify that you 
have selected the correct media pack. Click Download. 

 

7. In the popup, click Save File to save the media pack to your PC or workstation. 
Click OK. 

Note – This process may take several minutes.

8. Use the appropriate extraction utility to extract the media pack to the location of 
your choice. 

Note – To complete the installation, see “Install the Standalone 
SL Console” on page 103. 
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▼ Install the Standalone SL Console 

Use this procedure to install the standalone SL Console on your PC or workstation. 

Note – Your Oracle support representative may have performed 
this procedure for you during library installation.

Note – Prior to using this procedure, you must have downloaded 
and extracted the standalone SL Console media pack to your PC 
or workstation. See “Download the Standalone SL Console Media 
Pack” on page 98. 

1. On your PC or workstation, go to the location where you have extracted the 
standalone SL Console media pack. 

2. Open the Install folder. 

3. Open the SL Console installer file that is appropriate for your operating system. 

The installation wizard begins and the Introduction screen appears.
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Note – At any time during the installation wizard, you can click 
Cancel to cancel the installation or Previous to return to the 
previous screen and re-enter information. 

4. Review the information, and click Next. 

The Choose Install Folder screen appears. 

5. Specify where you want to install the SL Console program. You can accept the 
default location displayed, or you can click Choose to browse to a different 
directory. Click Next to continue. 
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The Choose Shortcut Folder screen appears. 

6. Enter the location where you want to create the SL Console shortcut icons. You 
can accept the default location displayed, or you can click one of the other 
choices listed and specify a different location. Click Next to continue. 

Note – On Solaris, the default location for shortcuts is the user’s 
home directory. However, shortcuts cannot be created in /, which 
is the root user’s home, so if you are installing on a Solaris 
platform as root you must choose something other than the 
default location. In this case, it is recommended that you choose 
/usr/bin or a similar location. 
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The Pre-Installation Summary screen appears.

7. Review the information and verify that it is all correct. Click Install to continue. 

The installation begins, and the Installing SL Console screen appears. 
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8. When the installation finishes, the Install Complete screen appears. 

9. Review the information and click Done to exit the installation program. 
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3

Hardware Activation Files 

Note – This feature is available starting with SL3000 firmware 
version FRS_3.0 and SL Console version FRS_5.00. 

The hardware activation utility allows you to activate and monitor selected optional 
features on the SL3000 library. Some library features are activated by the customer, 
while other must be installed and enabled by an Oracle support representative. 
TABLE 3-1 lists the available features and their activation method. 

This chapter describes the processes and SL Console screens used for features 
activated by customers. See your Oracle support representative for assistance with 
features that he or she must install and enable. 

TABLE 3-1  Library Feature Activation 

Feature
Activated by 

Customer

Enabled by Oracle 
support 

representative

SL3000 Capacity Upgrades (25, 100, 200, 500, 700, 1000) X

Dual Robotics X

Dual TCP/IP X

Multi Port Fibre Channel X

Partitioning X

Redundant Electronics X

Note – The functions described in this chapter can be performed 
from the standalone SL Console or Web-launched SL Console 
only; these functions are not available at the local operator panel. 

Oracle Hardware Activation Files
Selected SL3000 features are activated through an Oracle hardware activation file, 
which is a digitally signed Java Archive (.jar) file containing a feature activation 
key. You install one hardware activation file for each feature you have purchased. 
When you install a new hardware activation file, the included feature is added to the 
ones already activated on the library. 
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Downloading Oracle Hardware Activation Files

You download Oracle hardware activation files from the Oracle E-Delivery website at 
the following URL: 

http://edelivery.oracle.com 

Legacy Hardware Activation Files

For SL3000 libraries prior to firmware version FRS_3.0, hardware activation files 
were delivered via e-mail from Oracle Corporation. In addition, all features you 
purchased for an SL3000 library were included in a single hardware activation file. 
When you installed a new hardware activation file on the library, it would overlay 
any previously installed activation files. 

This distribution system has been replaced by the Oracle hardware activation files 
described in this chapter. When you upgrade to SL3000 firmware version FRS_3.0, all 
features that have already been activated on the library are retained. 

Once the library has been upgraded to SL3000 firmware version FRS_3.0, you use the 
processes described in this chapter to activate any new features. See “Hardware 
Activation File Installation Process” on page 111 for a summary of the process. 

Note – If your SL3000 library is running firmware prior to 
FRS_3.0, features are still delivered to you via e-mail from Oracle 
Corporation. 
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Hardware Activation File Installation Process
Following is a summary of the process you use to activate customer-activated library 
features. See TABLE 3-1 for a list of available features and their activation methods. 

Note – See your Oracle support representative for assistance with 
features that he or she must install and enable.

1. You purchase a feature for an Oracle StorageTek library from Oracle Corporation.

2. You locate the hardware activation file for the feature on the Oracle E-Delivery 
website and download it to a system accessible to the SL Console session.

3. You use the SL Console to verify and install the hardware activation file on the 
target library.

4. See the following topics for detailed information about implementing specific 
activated features:

• “Capacity on Demand” on page 143

• “Library Partitioning” on page 187

• “Redundant Electronics Management” on page 359
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Hardware Activation Tasks

Task Page

Download a New Hardware Activation File  113

Display and Verify New Hardware Activation File Contents  115

Install a New Hardware Activation File on the Target Library  118

Display Current Hardware Activation Files  122

Delete a Hardware Activation File  123

Display the Feature Audit Log  127

Note – You can perform these tasks from the standalone 
SL Console or Web-launched SL Console only. They are not 
available at the local operator panel. 



March 2011   113

 

▼Download a New Hardware Activation File

Use this procedure to download a hardware activation file from the Oracle 
E-Delivery website. The hardware activation file is a compressed archive file. You 
must download it to a system accessible to the SL Console session.

Note – See TABLE 3-1 for a list of customer-activated features. See 
your Oracle support representative for assistance with features 
that he or she must install and enable. 

Note – This procedure is not performed at the SL Console. 

1. Purchase one or more features from Oracle Corporation. 

See your Oracle support representative for assistance. 

2. Open a browser window and navigate to the Oracle E-Delivery website at the 
following URL:

http://edelivery.oracle.com/ 

 

3. Click Continue. 
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4. On the Export Validation screen, enter your contact information, read the 
License Agreement and Export Restrictions, and click the check boxes to 
indicate your acceptance. Click Continue. 

 

5. Use the pull-downs to navigate to the applicable library type and the feature 
you want to download. 

6. Save the hardware activation file to a system accessible to the SL Console 
session. 
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▼Display and Verify New Hardware Activation File Contents

Use this procedure to display a new hardware activation file before installing it on a 
target library. 

Prior to performing this procedure, you must download a new hardware activation 
file to a system accessible to the SL Console session. See “Download a New 
Hardware Activation File” on page 113. 

1. Use the SL Console to log in to the target library. 

See “General SL Console Usage Tasks” on page 73 for details. 

2. Select Tools > Hardware Activation Management, and click the Install 
Activation Keys tab. 

The Install Activation Keys screen appears. 

 

3. In the File Name field, enter the full path of the hardware activation file you 
want to display, and press Enter. Optionally, you can click Browse and navigate 
to the file location. 
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The Hardware Activation File Details appear on the screen.

 

4. Review the hardware activation file details, and then click Compare. 
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The Compare Hardware Activation Keys popup appears. 

5. Review the activation file information.

Note – Changes that will be implemented by the new hardware 
activation file, such as additional capacity or expiration date 
changes, are highlighted in red. 

6. Click OK to dismiss the popup. 
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▼ Install a New Hardware Activation File on the Target Library

Use this procedure to install a new hardware activation file on the target library. 

Prior to performing this procedure, you must download a new hardware activation 
file to a system accessible to the SL Console session. See “Download a New 
Hardware Activation File” on page 113. 

1. Use the SL Console to log in to the target library. 

See “General SL Console Usage Tasks” on page 73 for details. 

2. Select Tools > Hardware Activation, and click the Install Hardware Activation 
Keys tab. 

The Install Hardware Activation Keys screen appears. 

 

3. In the File Name field, enter the full path of the hardware activation file you 
want to install, and press Enter. Optionally, you can click Browse and navigate 
to the file location.
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The Hardware Activation File Details appear in the lower part of the screen. 

4. Review the hardware activation file details, and then click Install in the 
Options Bar. 
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The Activation File Installation Warning popup appears. 

5. Review the Features to be Installed and verify that the new hardware activation 
file is accurate. 

Note – Changes that will be implemented by the new hardware 
activation file, such as additional capacity or expiration date 
changes, are highlighted in red. 

6. If the new hardware activation file is accurate, click Yes to begin installing the 
activation file on the target library. 

7. The library controller installs the hardware activation file, and a confirmation 
popup appears. 

8. Click OK to dismiss the popup. 

9. You can verify that the activation file has been installed successfully by 
displaying the current activation files. See “Display Current Hardware 
Activation Files” on page 122 for details. 

10. Depending on the features included in the hardware activation file, you may 
need to perform additional tasks in order to use the new features. 

• See “Increasing Activated Capacity” on page 147 and “Decreasing Activated 
Capacity” on page 148 for special considerations that apply when you install a 
hardware activation file that changes the activated capacity of the library.
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• See “Installing the Partitioning Feature” on page 188 for special considerations 
that apply when you install a hardware activation file with the Partitioning 
feature. 
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▼Display Current Hardware Activation Files 

Use this procedure to display the features currently activated on the library you are 
logged in to. 

1. Select Tools > Hardware Activation, and click the Current Hardware Activation 
Keys tab. 

The Current Activation Keys screen appears, listing the currently activated 
features.

See “Hardware Activation > Current Hardware Activation Keys” on page 129 for 
detailed information about the screen fields. 
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▼Delete a Hardware Activation File 

Use this procedure to delete a hardware activation file from an SL3000 library. 

You can only delete customer-installed hardware activation files. You cannot delete 
features that have been enabled by an Oracle support representative. 

Caution – Deleting a hardware activation file is an exceptional 
situation. Be sure it is really what you want to do before you begin 
this procedure. Having extra hardware activation files installed on a 
library does not present any problems (for example, Capacity 
activation files that exceed the physical capacity of the library); the 
extra activation files are simply not used. 

Caution – Deleting a Capacity hardware activation file reduces the 
activated capacity of the affected library module. This can result in 
orphaned cartridges and data that could be lost. See “Decreasing 
Activated Capacity” on page 148 and “Orphaned Cartridges in 
Non-Partitioned Libraries” on page 145 for details. 

Caution – Deleting a Partitioning hardware activation file deletes 
the Partitioning feature from the library. See “Deleting the 
Partitioning Feature” on page 190 for details about the effects on the 
library configuration. 

1. Use the SL Console to log in to the target library. 

See “General SL Console Usage Tasks” on page 73 for details. 

2. Select Tools > Hardware Activation, and click the Delete Hardware Activation 
Files tab. 
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The Delete Hardware Activation Files screen appears. Only customer-installed 
hardware activation files are included in the list. 

3. Click the activation file you want to delete. 
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The Delete button in the Options Bar is activated, and detail for the file is 
displayed in the Associated Activation Feature Detail(s) section of the screen. 

4. Verify that you have selected the correct activation file, and click the Delete 
button. 

A Delete Confirmation popup appears. 

5. Click Yes to begin the deletion. 
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The hardware activation file is deleted from the library, and the Currently 
Installed Hardware Activation Files section is updated. 

6. Depending on the feature included in the hardware activation file, you may 
need to perform additional tasks after deleting the key. 

• See “Decreasing Activated Capacity” on page 145 for special considerations 
that apply when you delete a Capacity hardware activation file.

• See “Deleting the Partitioning Feature” on page 190 for special considerations 
that apply when you delete a Partitioning hardware activation file. 
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▼Display the Feature Audit Log 

Use this procedure to display a list of all feature activation activity that has occurred 
over the life of the library. You can use this log to verify the validity of all features 
installed on the library. 

Note – This feature is available starting with SL3000 firmware 
version FRS_3.0 and SL Console version FRS_5.00. 

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 64. 

To create a chart from this report, you can save the data to a comma-separated 
(.csv) file and then import the .csv file into a charting application. For details, see 
“Save Library Report Data to a File”. 

1. Select Tools > Reports. 

2. Expand the Audit Logs folder, and click Feature Audit Log. 

The Feature Audit Log appears. 

See “Reports > Feature Audit Log” on page 140 for detailed information about the 
screen fields. 
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Hardware Activation Screen Reference
This section includes detailed descriptions of all SL Console hardware activation file 
screens, arranged by screen navigation path. For example, 
Activation File Management > Install Activation File— Compare indicates the 
screen accessed by clicking Tools and then Hardware Activation from the Menu Bar, 
and then clicking the Install Activation File tab, and then the Compare button. 

Screen Page 

Hardware Activation > Current Hardware Activation Keys  129

Hardware Activation > Install Hardware Activation Keys  131

Hardware Activation > Install Activation File— Compare  134

Hardware Activation >Install Activation File— Install  136

Hardware Activation > Install Activation File— Compare  134

Reports > Feature Audit Log  140

Note – You can access the hardware activation file screens only 
from the standalone SL Console or the Web-launched SL Console. 
They are not available on the local operator panel. 
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Hardware Activation > Current Hardware Activation Keys

Sample Screen 

Description

Displays the contents of the hardware activation file currently installed on the library 
you are logged in to. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 64 for details. 

Screen Fields

Feature 

Name of the feature activated on the library. 

Expiration 

Number of days until the feature is due to expire or has expired. If there is no 
expiration date, the field displays “noExpiration.” 

Value 

Display only.
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Qualification for the feature, if applicable. For example, for the Capacity feature, 
this field displays the capacity the activation file provides. Depending on the 
feature, the field may be blank or indicate “None”. 

Time Remaining

Amount of time remaining until the expiration of the feature. If there is no 
expiration date, the field is blank. 

Buttons

Refresh

Click to refresh the display with current data from the library controller database. 

? (Help) 

Click to display online help for the screen. 

See Also

• Hardware Activation > Install Hardware Activation Keys 
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Hardware Activation > Install Hardware Activation Keys

Sample Screen 

Description

Allows you to display the contents of a new hardware activation file. 

Also includes buttons that allow you to initiate any of the following activities:

• Compare the new hardware activation file with the one currently installed on the 
library. 

• Install the new hardware activation file on the library. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 64 for details. 

Screen Fields

File Name

Required.

Enter the full path of the hardware activation file you want to install on the 
library. Optionally, you can click Browse and navigate to the file location. The file 
must be located on a system accessible to the SL Console session. 
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Product

Display only.

Type of library the hardware activation file is for. For example, SL3000 or SL500. 

Serial Number

Display only.

Serial number of the library the hardware activation file is for. This entry applies 
only to legacy hardware activation files. See “Legacy Hardware Activation 
Files” on page 110 for details. 

Generated On

Display only.

Date when the hardware activation file was created. 

License Type

Display only.

Type of hardware activation file. Options are:

• Oracle Hardware Activation File—File downloaded from the Oracle E-Delivery 
website. 

• Sun Hardware Activation File—Legacy file. See “Legacy Hardware Activation 
Files” on page 110 for details. 

Comment Line 1

Display only.

Optional comment concerning the hardware activation file, from Oracle 
Corporation 

Comment Line 2

Display only.

Optional comment concerning the hardware activation file, from Oracle 
Corporation 

Hardware Activation File Details

Feature

Display only.

Name of a feature included in the hardware activation file.

Expiration

Display only.
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Number of days until the feature is due to expire. If there is no expiration date, 
the field displays “noExpiration.” 

Value 

Display only.

Qualification for the feature, if applicable. For example, for the Capacity feature, 
this field displays the amount of storage capacity the activation file provides. 
Depending on the feature, the field may be blank. 

Buttons

Install

Click to install the displayed hardware activation file on the library you are 
logged in to. The Hardware Activation >Install Activation File— Install popup 
appears. 

Browse

Click to navigate to the hardware activation file you want to display and install.

Compare

Click to compare the new hardware activation file with the ones currently 
installed on the library. The Hardware Activation > Install Activation File— 
Compare popup appears. 

? (Help) 

Click to display online help for the screen. 

See Also 

• Hardware Activation > Current Hardware Activation Keys 

• Hardware Activation > Install Activation File— Compare 

• Hardware Activation >Install Activation File— Install 
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Hardware Activation > Install Activation File— Compare 

Sample Screen 

Description

Allows you to compare the following sets of activation file information: 

• Features currently activated on the library you are logged in to. 

• Feature included in the new hardware activation file you have specified in the 
Hardware Activation > Install Hardware Activation Keys screen. 

Note – Changes that will be implemented by the new hardware 
activation file, such as additional capacity or expiration date 
changes, are highlighted in red. 

This screen is a popup that appears when you click Compare on the Hardware 
Activation > Install Hardware Activation Keys screen. 

Screen Fields

Current Features

Display only.

List of features, expiration dates, and values for all features currently activated on 
the library you are logged in to. 
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Features to be Installed

Display only.

Name, expiration date, and values for the feature included in the specified new 
hardware activation file. Changes that will be implemented by the new hardware 
activation file, such as additional capacity or expiration date changes, are 
highlighted in red. 

Buttons

OK

Click to dismiss the popup and return to the previous screen. 

See Also

• Hardware Activation > Install Hardware Activation Keys 

• Hardware Activation >Install Activation File— Install 
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Hardware Activation >Install Activation File— Install 

Sample Screen 

Description

Allows you to compare the following sets of activation file information: 

• Features currently activated on the library you are logged in to. 

• Feature included in the new hardware activation file you have specified in the 
Hardware Activation > Install Hardware Activation Keys screen. 

Warning messages are displayed if installation of the new hardware activation file 
will result in features being removed from the library.  

After comparing the activation file information, you can install the new hardware 
activation file on the library by clicking the Yes button. 

This screen is a popup that appears when you click Install on the Hardware 
Activation > Install Hardware Activation Keys screen. 

Depending on the features included in the hardware activation file, you may need to 
perform additional tasks in order to use the new features.

• See “Increasing Activated Capacity” on page 147 and “Decreasing Activated 
Capacity” on page 148 for special considerations that apply when you install a 
hardware activation file that changes the activated capacity of the library.

• See “Deleting the Partitioning Feature” on page 190 for special considerations that 
apply when you install a hardware activation file with the Partitioning feature. 



March 2011   137

 

Screen Fields

Current Features

Display only.

List of features, expiration dates, and values for all features currently activated on 
the library you are logged in to. 

Features to be Installed

Display only.

Name, expiration date, and values for the feature included in the specified new 
hardware activation file. Warning messages are displayed if installation of the 
hardware activation file will result in features being removed from the library. 

Buttons

Yes

Click to install the specified hardware activation file on the library. The library 
controller verifies the validity of the hardware activation file and installs it. 

No 

Click to cancel the update and return to the previous screen. 

See Also

• Hardware Activation > Install Hardware Activation Keys 

• Hardware Activation > Install Activation File— Compare 
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Hardware Activation > Delete 

Sample Screen 

Description

Allows you to review and delete selected hardware activation files from the 
library. Only customer-installed hardware activation files appear on this screen 
for deletion. 

Caution – Deleting a hardware activation file is an exceptional 
situation and can have significant effects on library operations. See 
“Delete a Hardware Activation File” on page 123 for considerations. 

Screen Fields

Currently Installed Hardware Activation Files

File Number

Display only.

ID number assigned to the hardware activation file. The numbers indicate the 
sequence in which the features were installed on the library. There may be gaps in 
the sequence, which may result from one of the following reasons:
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• A feature was deleted.

• A feature was installed and enabled by an Oracle support representative and 
therefore does not appear on this list. 

License Type

Display only.

Type of hardware activation file. Options are:

• incremental—Oracle hardware activation file downloaded from the Oracle 
E-Delivery website. 

• absolute—Legacy Sun hardware Activation file. See “Legacy Hardware 
Activation Files” on page 110 for details. 

Associated Activation Feature Detail(s)

Feature 

Name of the feature activated on the library. 

Expiration 

Number of days until the feature is due to expire or has expired. If there is no 
expiration date, the field displays “noExpiration.” 

Value 

Display only.

Qualification for the feature, if applicable. For example, for the Capacity feature, 
this field displays the capacity the activation file provides. Depending on the 
feature, the field may be blank or may indicate “None”. 

Buttons

Delete

Click to delete the currently selected hardware activation file.

See Also

• Hardware Activation > Install Hardware Activation Keys 

• Hardware Activation >Install Activation File— Install 
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Reports > Feature Audit Log

Sample Screen 

Description

Displays a list of all feature activation activity that has occurred over the life of the 
library. You can use this log to verify the validity of all features installed on the 
library. 

Screen Fields

Feature Name

Name of the feature. 

The first line of the display is the type of library (SL3000). 

Feature Value

Special attributes of the feature. Options are:

• SN—Indicates that the serial number of the library is displayed in the Feature 
Action field. Appears on the first line of the display.

• nnnn—For capacity hardware activation files, the number of cells added or 
removed. 
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• none—Appears for all other features. 

Feature Action

Action that was performed. Options are:

• nnnnnnnn—Serial number of the library. Appears on the first line of the 
display.

• deleted—The hardware activation file for the feature was deleted.

• disabled—The feature was disabled by an Oracle support representative. 

• enabled—The feature was enabled by an Oracle support representative.

• installed—The hardware activation file for the feature was installed. 

• Summary—The feature is active on the library. 

Action Date

Date and time when the action was performed. 

Buttons

Search

Click to search a library report for a specified text string.

Update

Click to update the report with current data.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also

• Hardware Activation > Current Hardware Activation Keys 

• Hardware Activation >Install Activation File— Install 

• Hardware Activation > Install Activation File— Compare 
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4

Capacity on Demand

The SL3000 library includes RealTimeGrowth and Capacity on Demand features. 
RealTimeGrowth allows you to install physical storage capacity beyond your current 
needs. Capacity on Demand separates physical from activated capacity and allows 
you to pay only for the capacity you need. Then as your needs grow, you can expand 
storage capacity with minimal disruption to library operations. To activate additional 
capacity, you need only purchase and install a hardware activation file for the new 
capacity.

Note – Library storage capacity must be installed through the 
SL3000 hardware activation utility. See “Hardware Activation 
Files” for details. 

Note – This feature controls cartridge storage cells only. All 
installed CAPs and tape drives are active by default. 

Capacity on Demand Features and Restrictions
This section describes important features and restrictions of Capacity on Demand 
that will help you to plan for and use the feature in your SL3000 library. 

• The minimum activated capacity is 200 storage cells. 

• You can purchase additional activated capacity in increments of 25, 100, 200, 500, 
or 1000 cells. 

• Installation of additional activated capacity results in minimal disruption to 
library operations. Once verified by the library controller, the additional storage 
cells are available immediately; you do not need to reboot the library. Depending 
on the host interface (HLI or FC-SCSI), there may be a brief interruption in host 
operations as the hosts update the new resource information. See “Non-disruptive 
Capacity Changes” on page 146 for details. 

• A library’s current activated storage capacity is equal to the capacity specified in 
the most recently installed hardware activation key file. 

Terminology

The following terms are used to describe library capacity management:
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• Physical or installed capacity – The number of storage cells physically present in 
the library.

• Activated capacity – The number of storage cells specified in the installed 
hardware activation file.  

• Active cell – A storage cell that can be used for cartridge storage. By default, the 
total active cells this is the same as the activated capacity specified in the installed 
hardware activation file. You can optionally de-activate selected storage cells, 
making this less than the activated capacity. 

• Active storage region – A rectangular area of storage cells that can be used for 
cartridge storage. An active storage region can be as small as a single storage cell 
or as large as the total activated capacity for the library. 

• Inactive cell – A storage cell that is explicitly de-activated and therefore cannot be 
used for cartridge storage. 

• Selected cell – A storage cell that cannot currently be used for cartridge storage, 
but will be made active automatically by the library controller when activated 
capacity is increased. 

Active Storage Region Configuration
Active storage regions can be assigned automatically by the library controller or 
manually by the user. Automatic assignment by the library controller provides 
balanced growth of library modules.

Individual storage cells can be in either of the following states:

• Active – The cell can be used for cartridge storage. 

• Inactive – The cell has been de-activated, and therefore cannot be used for 
cartridge storage. You can monitor the cell on library displays and reports, but 
requests to move cartridges to the cell are rejected by the library controller. 

• Selected – The cell is not currently active, but will be activated automatically by 
the library controller when capacity is increased by the installation of a new 
hardware activation file. This state applies to non-partitioned libraries only. 

Only active storage cells can be used for tape cartridge storage. Inactive storage cells 
cannot be used for cartridge storage, nor can they be accessed by any hosts. 
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Cell Activation Rules

The library controller uses the following rules when adding cells to active storage 
regions:

• Cell activation starts in the left upper rear of the active storage region and moves 
to the right lower front. 

• All cells within a column are activated from top to bottom before moving to the 
next column. 

• Columns within a panel are activated from left to right. 

Non-Partitioned Libraries

Within a non-partitioned library, the library controller automatically selects all 
physical cells, but only activates a number of cells up to the total activated capacity of 
the library. Selected cells that cannot be activated due to activated capacity limits 
remain selected and will be activated automatically whenever additional activated 
capacity is installed.

When activating cells, the library controller begins at the back of the library, starting 
with the left-most module and working to the right. Then it moves to the front of the 
library, starting with the left-most module and working to the right. 

To optimize cartridge placement, you can optionally designate active storage regions 
in the library, within which the library controller applies the rules above. 

Partitioned Libraries

In partitioned libraries, the total number of storage cells allocated to all library 
partitions cannot exceed the activated capacity of the library.

In partitioned libraries, there is no default active storage region. You must explicitly 
assign storage cells to partitions, thereby configuring the active storage regions for 
each partition. See “Partitioning Process” on page 204 for details. 

When placing cartridges in storage cells, the library controller applies the predefined 
cell activation rules separately to each partition. See “Cell Activation 
Rules” on page 145 for details. 

De-activating Storage Capacity 

You can optionally reduce the size of an active storage region by de-activating 
designated storage cells. A warning message is displayed if cartridges will be 
orphaned due to the capacity reduction.

Orphaned Cartridges in Non-Partitioned Libraries

Note – For a discussion of orphaned cartridges in partitioned 
libraries, see “Orphaned Cartridges in Partitioned 
Libraries” on page 194. 
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In non-partitioned libraries, an orphaned cartridge is a cartridge located in an 
inactive storage cells. Orphaned cartridges are inaccessible to all hosts. 

A cartridge can become orphaned for a variety of reasons. Following are some 
possible causes:

• Active storage capacity has been reduced.

• The cartridge has been moved to an inactive or inaccessible cell through manual 
intervention. 

If the SL Console identifies an orphaned cartridge, it displays a warning message. 
You can then use the following tools to help you resolve and disposition the 
orphaned cartridge:

• Generate a report of orphaned cartridges. 

• Perform an audit of the library. 

• Perform a recovery move on a cartridge. 

For detailed instructions on checking for and resolving orphaned cartridges, see the 
following procedures:

• “Display an Active Storage Region Report” on page 158

• “Commit Active Storage Region Changes” on page 155

Non-disruptive Capacity Changes
Changes to active capacity result in minimal disruptions to library operations. The 
specific library behavior depends on the type of host connection, as described in the 
following sections:

• “Active Capacity Changes and HLI Connections” on page 146

• “Active Capacity Changes and FC-SCSI Connections” on page 147

Caution – Although changes to active capacity are not disruptive to 
library hosts, it is recommended that you make the library 
unavailable to other users before committing your active storage 
region changes. Because the SL Console does not validate storage 
region boundaries against the library controller database in real-
time, configuration conflicts may arise if you change active storage 
region boundaries while other users are performing cartridge 
movements or library configuration changes. See “Synchronizing 
the Display With the Controller Database” on page 64 for details. 

Active Capacity Changes and HLI Connections

With HLI libraries, you can increase active capacity without stopping host jobs or 
having host connections go offline. When you decrease capacity, the library goes 
offline only momentarily and then comes back online automatically.
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Adding Active Capacity 

Whenever you add active storage cells, the library stays online. The library controller 
sends an asynchronous message to all hosts notifying them that the library 
configuration has changed. ACSLS and ELS must perform an audit of the library in 
order to account for the new library configuration information. Hosts can continue 
processing jobs while the audit takes place. 

Removing Active Capacity 

Whenever you make any of the following types of capacity changes, the library goes 
offline temporarily. 

• De-activate a storage cell

• Remove an empty drive slot 

After the configuration change is updated in the library controller database, the 
library comes back online and the library controller sends an asynchronous message 
to all hosts notifying them that the library configuration has changed. ACSLS and 
ELS must perform an audit of the library in order to account for the new library 
configuration information. Hosts can continue processing jobs while the audit takes 
place. 

Active Capacity Changes and FC-SCSI Connections

With FC-SCSI libraries, whenever you make any of the following changes, the library 
goes offline temporarily with a Unit Attention condition: 

• Activate or de-activate a storage cell

• Activate or de-activate a drive

• Activate or de-activate CAP cells

• Add, change, or remove a host LUN connection

Multiple error messages may be generated, and all hosts must issue the appropriate 
commands to update their library configuration information. See the appropriate 
tape management software documentation for detailed procedures and commands. 
In the case of adding or removing drives, the device SCSI numbering is updated as 
well.

Increasing Activated Capacity
The following special considerations apply after you successfully install a capacity 
activation key providing additional capacity. See Chapter 3, “Hardware Activation 
Files” on page 109 for details on installing hardware activation key files. 

• The new library capacity is equal to the capacity specified in the most recently 
installed hardware activation file. 

• You do not need to reboot the library in order to begin using the new capacity, 
but you must configure all affected library host applications to recognize the new 
capacity. See “Non-disruptive Capacity Changes” on page 146 for details. 

• ACSLS and ELS must perform an audit of the library in order to account for the 
new capacity. Hosts can continue processing jobs while the audit takes place.
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• If the new activated capacity exceeds the physical capacity, a warning is 
displayed. No corrective action is necessary. 

• If the library is not partitioned, the library controller automatically activates cells 
that have not been explicitly de-activated by the user previously. In this case, no 
user intervention is required to make the new activated capacity available. If cells 
have been de-activated, however, you may need to manually select cells in order 
to start using the additional capacity. 

• If the library is partitioned, all new capacity is added as unallocated cells. You 
must allocate new storage cells to partitions manually in order to start using the 
cells; see “Design a Partition – Base, DEM, or CEM Modules” on page 212 for 
details. 

Decreasing Activated Capacity
The following special considerations apply after you successfully install a capacity 
hardware activation file resulting in reduced capacity. See Chapter 3, “Hardware 
Activation Files” on page 109 for details on installing hardware activation key files.

Note – Installing reduced capacity is an exceptional situation; be 
sure this is what you really want to do before installing the 
hardware activation key file. 

• A warning appears if cartridges will be orphaned as a result of the reduced 
capacity. See “Orphaned Cartridges in Non-Partitioned Libraries” on page 145 for 
details. 

• For non-partitioned libraries:

• The new, reduced capacity takes effect immediately. 

• The library controller de-activates cells in reverse order of their activation – the 
cells activated most recently are de-activated first. 

• For partitioned libraries:

• If the total number of cells allocated to all partitions exceeds the new activated 
capacity, the library is automatically taken offline. You must manually de-
allocate cells from partitions so the total allocation does not exceed the new 
activated capacity.

• If the total number of cells allocated to all partitions is still less than the new 
activated capacity, the new reduced capacity takes effect immediately with no 
change to the existing partition allocations. The library continues operations 
without interruption. 
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Capacity Management Tasks 
This section provides detailed instructions for all tasks involved in implementing and 
managing active storage capacity in the library. 

Storage Capacity Installation Process

Following is a summary of the process used to install new library storage capacity. 

1. You purchase and install a capacity hardware activation file for the library. See 
“Hardware Activation File Installation Process” on page 111 for details. 

2. The new activated capacity is available immediately. You do not need to re-boot 
the library. 

3. In non-partitioned libraries, by default, all newly activated cells are immediately 
available for use. Proceed as follows:

• If you want to use the default storage region configuration assigned by the 
library controller, you must configure all affected library host applications to 
recognize the new storage regions. See “Non-disruptive Capacity 
Changes” on page 146 for details. 

• If you want to modify the storage region configuration from the default, see 
“Define Active Storage Regions” on page 152. 

4. In partitioned libraries, all newly activated cells are added as “unallocated,” and 
are therefore not available for use. You must manually allocate the new cells to 
partitions. See “Partitioning Process” on page 204 for detailed instructions. 

SL Console Active Storage Region Workspace

The Select Active Cells screens, and all associated popups, give you a dynamic 
workspace to customize your activated capacity configuration. All activated capacity 
configuration information is automatically saved to the active storage region 
workspace in SL Console memory and retained for the duration of your SL Console 
session. This allows you to switch among active storage region views and leave and 
return to the Select Active Cells screens any number of times without losing your 
configuration changes.

Information in the SL Console active storage region workspace is committed to the 
library controller database only through the Apply button on the 
Select Active Cells > Select Active Cells screen. The information is lost if any one of 
the following occurs before you have committed your updates: 

• You actively log off the SL Console session.

• The SL Console session times out or the connection to the library is lost. 

• You actively refresh the active storage region workspace from the current library 
controller database. This is done through the Refresh button on the 
Select Active Cells screens. 

Caution – Although changes to active capacity are not disruptive to 
library hosts, it is recommended that you make the library 
unavailable to other users before committing your active storage 
region changes. Because the SL Console does not validate storage 



150  SL3000 User’s Guide March 2011 

 

region boundaries against the library controller database in real-
time, configuration conflicts may arise if you change active storage 
region boundaries while other users are performing cartridge 
movements or library configuration changes. See “Synchronizing 
the Display With the Controller Database” on page 64 for details. 
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Capacity Management Tasks

Task Page

Define Active Storage Regions  152

Commit Active Storage Region Changes  155

Display an Active Storage Region Report  158

Print Active Storage Region Report Data  160

Save Active Storage Region Report Data  162

Display Active Cell Detail  163

Note – The following tasks apply to non-partitioned libraries 
only. For detailed instructions on configuring storage regions for 
partitioned libraries, see “Partitioning Process” on page 204. 

Note – The following tasks can be performed only from the 
standalone SL Console or the Web-launched SL Console. They 
cannot be performed at the local operator panel. 
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▼Define Active Storage Regions 

Note – See “Hardware Activation File Installation 
Process” on page 111 for information about installing activated 
capacity. 

When you install additional activated capacity, the library controller automatically 
activates the number of storage cells equal to the activated capacity. It uses a set of 
internal rules when choosing the actual cells to activate. See “Active Storage Region 
Configuration” on page 144 for details. 

Use this procedure only if you want to do one of the following:

• Customize the active storage regions so they are different from the default 
configuration assigned by the library controller. For example, you can configure 
active storage cells so that cartridges are concentrated around the drives and the 
ends of the library are left for future growth. 

• De-activate storage cells, so the total number of active storage cells is less than the 
activated capacity. 

• De-select storage cells, so these cells will not be automatically activated when the 
library’s activated capacity is increased. 

Note – If you want to use the default storage region configuration 
defined by the library controller, you do not need to use this 
procedure. 

1. Select Tools > Select Active Cells. 
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The Module Map screen appears.

2. Click the module for which you want to define the active storage regions. 

3. Click the Select Active Cells tab.

The Select Active Cells screen appears, displaying the current configuration of 
the module you have selected.
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Note – The first time you display this screen, the number of 
selected cells is equal to the physical capacity of the library, and 
the number of active cells is equal to the library’s total activated 
capacity. 

Note – Click the Move Left or Move Right buttons to display a 
module directly adjacent to the one currently displayed. 

4. Choose the Select by method, and click either the Add or Remove radio button.

5. Use the library map to select the storage cells you want to activate or de-
activate. 

Note – See “Select Active Cells > Select Active Cells” on page 168 
for detailed instructions on using the library map. 

Your capacity configuration changes are saved to the SL Console active storage 
region workspace for the duration of this login session. You can make additional 
modifications and leave and return to the Select Active Cells screens any number 
of times without losing your changes.

6. When you are done making changes, proceed to “Commit Active Storage 
Region Changes” on page 155 to verify and commit your changes. 
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▼Commit Active Storage Region Changes 

Use this procedure to verify and commit active storage region configuration changes 
you have made on the Select Active Cells screen. This procedure warns you of the 
following possible errors:

• The library has orphaned cartridges. See “Orphaned Cartridges in Non-
Partitioned Libraries” on page 145 for details.

• Cells will be made inaccessible to library hosts. 

Caution – Although changes to active capacity are not disruptive to 
library hosts, it is recommended that you make the library 
unavailable to other users before committing your active storage 
region changes. Because the SL Console does not validate storage 
region boundaries against the library controller database in real-
time, configuration conflicts may arise if you change active storage 
region boundaries while other users are performing cartridge 
movements or library configuration changes. See “Synchronizing 
the Display With the Controller Database” on page 64 for details. 

1. Perform the steps in “Define Active Storage Regions” on page 152. 

The changes you have made are displayed on the Select Active Cells screen. 

2. In the Options Bar, click Apply. 

The boundaries of the active storage regions are verified, including the locations 
of all tape cartridges. 

Note – This verification is performed only on the active storage 
region configuration defined in the Select Active Cells screens. It 
does not verify active storage regions against the library controller 
database; therefore it cannot identify configuration conflicts that 
may arise due to other users performing cartridge movements or 
library configuration changes—through the command line 
interface, other SL Console sessions, or host applications—at the 
same time you have made changes to active storage regions. 
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The Confirm Apply popup appears, indicating whether there are any orphaned 
cartridges or other problems in the active storage region configuration. 

3. To display detailed warning messages explaining the reasons for any orphaned 
cartridges, click Details. 

You can use the Details button to toggle between the expanded and collapsed 
views of the warning messages. 

4. Optionally, in the expanded view of the warning messages you can do the 
following:

• Click Print to print the detailed message data.

• Click Save to File to save the detailed message data to a comma-separated file. 

5. Proceed as follows:

• Click No to cancel the update. 

The library controller database is not updated, but all changes you have made 
are retained on the Select Active Cells screen. 

• Click Yes to make the following updates to the library controller database and 
proceed to Step 6. 
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• White cells with a “dog-eared” left corner are made inactive.

• Purple cells without a “dog-eared” left corner are made active, up to the total 
activated capacity of the library. Purple cells that cannot be made active due to 
library activated capacity limits will remain purple and will automatically 
become active whenever additional activated capacity is installed. 

• All other cells are left unchanged. 

• The Commit Success popup appears. 

6. Click OK to return to the Select Active Cells screen. 

All newly activated cells are immediately available for use; the library does not 
need to be rebooted. 

7. All affected library host applications must now be configured to recognize 
these updates. See the appropriate tape management software documentation 
for the procedures and commands.
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▼Display an Active Storage Region Report 

Use this procedure to display the following active storage region reports:

• Cartridge Cell and Media Summary – Displays a detailed list of all library 
resources and their status (active or inactive).

• Orphaned Cartridge Report – Displays a detailed list of all orphaned cartridges.

Note – The active storage region reports display data saved to the 
library controller database. If you have made changes to the active 
storage region configuration without commiting the changes to 
the library controller, the data in these reports will differ from 
data shown on Select Active Cells screen. 

1. Select Tools > Select Active Cells, and click the View Reports tab.

The View Reports screen appears.

2. In the pull-down menu, select the report you want to display. 
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The screen is updated with current data from the library controller database. 

3. If you want to print the report data or save it to a file, see the following 
procedures:

• “Print Active Storage Region Report Data” on page 160

• “Save Active Storage Region Report Data” on page 162 
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▼ Print Active Storage Region Report Data

Use this procedure to print an active storage region report. This procedure can be 
performed from any of the active storage region report screens. 

1. Select Tools > Select Active Cells, and click the View Reports tab.

The View Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to 
File buttons. 
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3. Click Print. 

The Print popup appears. 

4. Complete the print popup, and click Print. 

The report is printed to the selected printer. 
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▼ Save Active Storage Region Report Data

Use this procedure to save active storage region report data to a comma-separated 
file (.csv format). You can use a variety of spreadsheet applications to view the file. 
This procedure can be performed from any of the active storage region report 
screens. 

1. Select Tools > Select Active Cells, and click the View Reports tab.

The View Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to 
File buttons. 

3. Click Save to File.

The Save popup appears. 

4. Browse to the directory where you want to save the file, and enter the file name. 

5. Click Save. 

The data is saved to the specified file. 
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▼Display Active Cell Detail 

Use this procedure to display which storage cells are currently active, inactive, or 
selected for activation. You can also display detailed information about cartridge, 
drive, and storage cell locations. 

Note – This procedure is available on the local operator panel.

1. Select Tools > Select Active Cells. 

The Module Map screen appears.

2. Click the module you want to display. 

3. Click the Current Active Cells tab.

The Active Cells screen appears, displaying the current configuration of the 
module you have selected.
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You can mouse-over a cell or drive to display a tooltip of detailed information. 
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Active Storage Region Screen Reference
This section includes detailed descriptions of all SL Console active storage region 
screens, arranged by screen navigation path. For example, Select Active Cells—
Select Active Cells—Confirm Apply indicates the screen accessed by clicking Tools 
and then Select Active Cells from the Menu Bar, and then clicking the 
Select Active Cells tab, and then the Confirm Apply button. 

Screen Page

Select Active Cells > Module Map  166

Select Active Cells > Select Active Cells  168

Select Active Cells > Select Active Cells—Confirm Apply  174

Select Active Cells—View Reports—Cartridge Cell and Media Summary  179

Select Active Cells—View Reports—Orphaned Cartridge Report  182

Select Active Cells—Current Active Cells  184

Note – These screens are available for non-partitioned libraries 
only. See “Partition Screen Reference” on page 252 for the screens 
used in managing capacity in partitioned libraries. 

Note – Only the Select Active Cells—Current Active Cells screen 
is available on the local operator panel. The remaining screens can 
be accessed only from the standalone SL Console or the Web-
launched SL Console.

Note – The Select Active Cells screen, and all associated popups, 
give you a dynamic workspace to design active storage regions. 
All active cell information is automatically saved to the storage 
region workspace in SL Console memory and retained for the 
duration of your SL Console session. This allows you to make 
modifications and leave and return to the Select Active Cells 
screens any number of times without losing your changes. 

Caution – Information in the SL Console active storage region 
workspace is saved to the library controller database only through 
the Apply button. If your SL Console session ends or you refresh 
the workspace data before you have committed your updates 
through the Apply button, you will lose any active storage region 
changes you have made through the Select Active Cells screens 
and all associated popups. 
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Select Active Cells > Module Map

Sample Screen

Description

Allows you to select the library module for which you want to activate or de-activate 
cells for cartridge storage. 

Screen Fields

Select a module from the map below 

The screen displays an illustration of the library’s actual module configuration. 
This information is taken directly from the library controller database. 

Click the module for which you want to select storage cells, then click the 
Select Active Cells tab. 

Buttons

? (Help) 

Click to display online help for the screen. 
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See Also

• Select Active Cells > Select Active Cells 
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Select Active Cells > Select Active Cells

Sample Screen

Description

Note – If you want to use the default active storage region 
configuration defined by the library controller, you do not need to 
use this screen. 

Allows you to define active library storage regions by selecting the storage cells you 
want to activate or de-activate for use. This allows you to configure active storage 
cells so that cartridges are concentrated around the drives, and the ends of the library 
are left for future growth.

You can make any number of cells active, up to the total activated capacity of the 
library. Selected cells that cannot become active due to activated capacity limits will 
remain selected and will automatically become active whenever additional activated 
capacity is installed. 

You can use any of the following methods to select storage cells (see “Library 
Map” on page 172 for detailed instructions): 

• Select individual cells or groups of cells 

• Select an entire column within a library module 

• Select a side within a library module (front or back) 
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• Select an entire library module 

• Select all cells within the library 

Caution – De-activating storage cells can result in orphaned 
cartridges and inaccessible data. See “Orphaned Cartridges in Non-
Partitioned Libraries” on page 145 for details. 

Note – You can select storage cells only; installed CAPs and tape 
drives are always active. 

Note – The Select Active Cells screen, and all associated popups, 
give you a dynamic workspace to design active storage regions. 
All active cell information is automatically saved to the storage 
region workspace in SL Console memory and retained for the 
duration of your SL Console session. This allows you to make 
modifications and leave and return to the Select Active Cells 
screens any number of times without losing your changes. 

Caution – Information in the SL Console active storage region 
workspace is saved to the library controller database only through 
the Apply button. If your SL Console session ends or you refresh 
the workspace data before you have committed your updates 
through the Apply button, you will lose any active storage region 
changes you have made through the Select Active Cells screens 
and all associated popups. 

Screen Fields

Select by

Required.

Indicates the method you want to use for selecting storage cells to activate or de-
activate. Options are:

• Cell – Select individual or rectangular groups of cells.

• Column – Select all cells within a column. 

• Side – Select all cells within one side of a library module. 

• Module – Select all cells within a library module. 

• Library – Select all cells within the library. 

Note – You must select either Add or Remove. 

Add 

Required.

Indicates you want to add cells to the active storage region. You will only be able 
to click inactive cells on the library map. 

Remove

Required.
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Indicates you want to remove cells from the active storage region. You will only 
be able to click active or selected cells on the library map. 

Current Library Totals

Capacity

Display only.

Total activated storage capacity of the library. 

Active Cells

Display only.

Total number of storage cells that have been made active. This cannot be greater 
than the activated Capacity of the library. 

Selection Totals 

Selected Cells 

Display only.

Total number of selected and active cells. This can be greater than the activated 
Capacity of the library. 

Unselected Cells 

Display only.

Total number of de-selected and inactive cells. 

Note – Selected Cells + Unselected Cells = library physical 
capacity

% Capacity Used 

Display only.

Percentage of total activated capacity that has been selected for use (cannot be 
greater than 100%). Calculated as:

Selected Cells / (activated) Capacity 

Interface Type 

Required.

Type of interface to be used for the library host connection. Options are:

• HLI

• FC-SCSI 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 
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Note – For additional details about modifying this field, see 
“Change the Library Interface Type (Non-Partitioned 
Libraries)” on page 348. 

Legend 

Legend for the library map. The state of each library resource (storage cell, tape 
drive, or CAP cell) is indicated as follows: 

• Not Accessible (white and x-ed out). Resource is not accessible to any host. 
Following are some possible reasons:

• Storage cells have been configured for diagnostic cartridges. 

• Drive bay has no installed drive. 

• CAP has been configured for storage, not CAP operations. 

• Inactive (white). Storage cell is not selected. 

• If the cell also has a “dog-eared” left corner, it is currently activated for use in 
the library controller database and you have selected this cell to be removed 
from the active storage region. The cell will be made inactive in the library 
controller database when you click the Apply button.

• If the cell does not have a “dog-eared” left corner, it is currently inactive in the 
library controller database. There will be no change to the cell’s status in the 
library controller database when you click the Apply button. 

• Active (“dog-eared” left corner). Indicates the status of the storage cell in the 
library controller database:

• Cells with a “dog-eared” left corner are currently active. 

• Cells with no “dog-eared” left corner are currently inactive. 

• Selected (purple). Storage cell is selected. Cells can be selected automatically by 
the library controller or manually by the user. 

• If the cell also has a “dog-eared” left corner, it is currently activated for use in 
the library controller database. There will be no change to the cell’s status in 
the library controller database when you click the Apply button.

• If the cell does not have a “dog-eared” left corner, it is currently inactive in the 
library controller database and you have selected this cell to be added to the 
active storage region. When you click the Apply button, the cell will be made 
active in the library controller database, up to the total activated capacity of the 
library. Purple cells that cannot be activated due to activated capacity limits 
will remain purple and will be activated automatically whenever additional 
activated capacity is installed. 

• No Activation Needed (brown). Resource cannot be selected on this screen 
because it is active by default; applies to all CAP cells and tape drives. 

• Cartridge (cartridge icon). Resource contains a tape cartridge. 

• Drive slots with installed drives are outlined with a thick border. Empty drive 
slots have a narrow border. 
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Library Map 

Graphical representation of the current library configuration. Initial display for 
the current SL Console login session is from the library controller database, then 
the display reflects your modifications. The display includes the following 
information:

• Type of module currently displayed (base module, drive expansion module, 
access expansion module, parking expansion module.) 

• Numeric module ID (1–12)

• Location of all resources (storage cells, tape drives, CAP cells) within the 
library 

Note – Move the cursor over any resource to display a tooltip of 
detailed information about the cell or drive, whether it is active in 
the library controller database, whether it is currently selected on 
the screen, and the identity of any resident cartridge. 

Use the library map to modify the boundaries of the active storage capacity areas. 
Depending on whether you have clicked the Add or Remove radio button, cells 
you click will be selected or de-selected. 

Depending on your choice in the Select by field, you can perform any of the 
following actions. 

• Select by cell – Select individual or groups of resources. Active storage cells do 
not need to be adjacent to one another. 

• To select an individual storage cell, double-click it.

• To select a rectangular group of storage cells, click the cell at one corner of 
the rectangle, and then click the cell diagonally opposite. 

• Select by column – Select an entire column within the module. Columns of 
active cells do not need to be adjacent to one another. Click any storage cell 
within the column you want to select. 

• Select by side – Select all storage cells within an entire module side. Active 
sides do not need to be adjacent to one another. Click any storage cell within 
the side you want to select. 

• Select by module – Select all storage cells within a module. Active modules do 
not need to be adjacent to one another. Click any storage cell within the 
module you want to select. 

• Select the library – Select all storage cells in the library. Click any storage cell in 
the library. 

Buttons

Move Left 

Click to display the library module directly to the left of the one currently 
displayed. This button is grayed out if there is no module to the left. 
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Move Right 

Click to display the library module directly to the right of the one currently 
displayed. This button is grayed out if there is no module to the right. 

Apply 

Click to update the library controller database with the current settings from the 
screen. The Confirm Apply popup appears, indicating whether there are any 
orphaned cartridges or other errors in the active storage region configuration. 

Note – This button is grayed out if you have not made any 
changes to the Select Active Cells screen since the last update. 

The status of the cells will be updated in the library controller database, as 
follows: 

• White cells with a “dog-eared” left corner are made inactive.

• Purple cells without a “dog-eared” left corner are made active, up to the total 
activated capacity of the library. Purple cells that cannot be made active due to 
library activated capacity limits will remain purple and will automatically 
become active whenever additional activated capacity is installed. 

• All other cells are left unchanged. 

Refresh

Click to refresh the screen with current data from the library controller database. 
All unapplied active storage region changes you have made during this 
SL Console login session will be discarded. The Cell Selection Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also

• Select Active Cells > Module Map 

• Select Active Cells > Select Active Cells—Confirm Apply 

• Select Active Cells—Current Active Cells 
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Select Active Cells > Select Active Cells—Confirm Apply

Sample Screen

Description

Displays a list of configuration errors in the defined active storage regions. This 
screen is a popup that appears when you click Apply on the 
Select Active Cells > Select Active Cells screen. 

After viewing the error messages, you can commit all data from the 
Select Active Cells screen to the library controller database by clicking the Yes 
button. 

Caution – Although changes to active capacity are not disruptive to 
library hosts, it is recommended that you make the library 
unavailable to other users before committing your active storage 
region changes. Because the SL Console does not validate storage 
region boundaries against the library controller database in real-
time, configuration conflicts may arise if you change active storage 
region boundaries while other users are performing cartridge 
movements or library configuration changes. See “Synchronizing 
the Display With the Controller Database” on page 64 for details. 

Possible errors include:

• The library has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” on page 194 for details.

• Storage cells have been removed from the library. 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 
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It is recommended that you resolve all errors before committing the data to the 
library controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 

Screen Fields

Warnings found

Display only.

Summary error messages regarding the storage region configuration. 

Column

Display only.

Column number where the orphaned cartridge is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right; “-1” is to the 
left.

Side

Display only.

Module side where the orphaned cartridge is located. “1” is the back wall; “2” is 
the front wall.

Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Cause for Orphaned State

Display only.

Reason why the cartridge has been identified as orphaned. Options include:

• Just Activated 

• Inactive Media 

Vol Ser 

Display only.

Volume serial number (VOLID) of the orphaned cartridge. 

Explanation

Display only.

Explanation of why the cartridge is orphaned. 

Some possible options are:

• Media was found in an inactive cell. 
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• Inactive cell with media was just activated. 

Buttons

Note – To display the Print and Save to File buttons, you may 
need to scroll down within the inner window. 

Print

Click to print the report on a selected printer.

Save to File

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Yes

Click to confirm that you want to update the library controller database with the 
current settings from the Select Active Cells. The status of the cells are updated in 
the library controller database, as follows: 

• White cells with a “dog-eared” left corner are made inactive.

• Purple cells without a “dog-eared” left corner are made active, up to the total 
activated capacity of the library. Purple cells that cannot be made active due to 
library activated capacity limits will remain purple and will automatically 
become active whenever additional activated capacity is installed. 

• All other cells are left unchanged. 

No

Click to cancel the update. The library controller database is not updated, but the 
current settings on the Select Active Cells are retained. 

Details 

Click to toggle between the expanded and collapsed views of the warning 
message display. 

See Also

• Select Active Cells > Select Active Cells 
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Select Active Cells—View Reports

Sample Screen

Description

Allows you to select one of the following active storage region reports:

• Cartridge Cell and Media Summary

• Orphaned Cartridge Report

Note – The active storage region reports display data saved to the 
library controller database. If you have made changes to the active 
storage region configuration without commiting the changes 
through the Apply button, the data in these reports will differ 
from data shown on the Select Active Cells screen. 

Screen Fields

Please select a report to display

Required.

Click the report you want to display. The drop-down menu lists all available 
active storage region reports. 
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Buttons

Apply 

Click to update the library controller database with the current settings from the 
screen. The Confirm Apply popup appears, indicating whether there are any 
orphaned cartridges or other errors in the active storage region configuration. 

Note – This button is grayed out if you have not made any 
changes to the Select Active Cells screen since the last update. 

Refresh

Click to refresh the screen with current data from the library controller database. 
All unapplied active storage region changes you have made during this 
SL Console login session will be discarded. The Cell Selection Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also

• Select Active Cells > Select Active Cells 

• Select Active Cells—View Reports—Cartridge Cell and Media Summary 

• Select Active Cells—View Reports—Orphaned Cartridge Report 
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Select Active Cells—View Reports—Cartridge Cell and Media 
Summary

Sample Screen

Description

Displays detailed information about all library resources (storage cells, tape drives, 
and CAP cells) and any stored cartridges.

Note – The active storage region reports display data saved to the 
library controller database. If you have made changes to the active 
storage region configuration without commiting the changes to 
the library controller, the data in these reports will differ from 
data shown on Select Active Cells screen. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 64 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Fields

Library 

Display only.
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Library number where the library resource is located. This is always “1”. 

Rail 

Display only.

Rail number where the library resource is located. This is always “1”. 

Column

Display only.

Column number where the library resource is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right; “-1” is to the 
left.

Side

Display only.

Module side where the library resource is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the library resource is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Element Type

Display only.

Type of library resource. Options are:

• CAP

• CELL

• DRIVE

Vol Ser 

Display only.

Volume serial number (VOLID) of the cartridge resident in the library resource, if 
applicable. 

Cell Status

Display only.

Capacity status of the library resource. Applies to storage cells only. Options are:

• Active – Cell is activated for use and can be used for cartridge storage. 

• Inactive – Cell is not activated for use and cannot be used for cartridge storage. 
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Buttons

Print

Click to print the report on a selected printer.

Save to File

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also

• Select Active Cells—View Reports

• Select Active Cells—View Reports—Orphaned Cartridge Report
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Select Active Cells—View Reports—Orphaned Cartridge Report 

Sample Screen

Description

Displays the locations and volume serial numbers (VOLIDs) of all orphaned 
cartridges in the library. Also identifies why the cartridge is orphaned. 

Note – The active storage region reports display data saved to the 
library controller database. If you have made changes to the active 
storage region configuration without commiting the changes to 
the library controller, the data in these reports will differ from 
data shown on Select Active Cells screen. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 64 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Fields

Column

Display only.
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Column number where the orphaned cartridge is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right; “-1” is to the 
left.

Side

Display only.

Module side where the orphaned cartridge is located. “1” is the back wall; “2” is 
the front wall.

Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Vol Ser 

Display only.

Volume serial number (VOLID) of the orphaned cartridge. 

Explanation

Display only.

Explanation of why the cartridge is orphaned. 

Some possible options are:

• Media was found in an inactive cell. 

• Inactive cell with media was just activated. 

Buttons

Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also

• Select Active Cells—View Reports 

• Select Active Cells—View Reports—Orphaned Cartridge Report 
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Select Active Cells—Current Active Cells

Sample Screen

Description

Displays current active library storage regions. Shows which storage cells are 
currently active, inactive, or selected for activation.

This is the only Select Active Cells screen that is available on the local operator 
panel.

Note – This screen is display only. 

Screen Fields

For detailed descriptions of the screen fields, see 
“Select Active Cells > Select Active Cells” on page 168. 

Buttons

Refresh

Click to refresh the display with current data from the library controller database. 

? (Help) 

Click to display online help for the screen. 
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See Also

• Select Active Cells > Select Active Cells 
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5

Library Partitioning

Note – Library partitioning must be installed through the SL3000 
hardware activation utility. See “Hardware Activation Files” for 
details. 

Library partitioning allows sections of the SL3000 library to be assigned for exclusive 
use by specified hosts. For example, you can configure one group of storage cells and 
drives to be used only for Symantec operations, and another group only for Tivoli 
operations.This allows you to configure an SL3000 library for applications running on 
multiple operating systems. 

Partitioning Features and Restrictions
This section describes important features and restrictions of library partitioning that 
will help you to configure and use partitioning in your SL3000 library. 

• You can configure up to eight partitions within an SL3000 library. 

• A partition can be as small as a single storage cell or tape drive, or a whole 
rotational or AEM CAP. Cells and drives within a partition do not need to be 
adjacent. 

• Storage cells, CAPs, and tape drives allocated to a partition can be used only by 
the hosts assigned to that partition. Hosts assigned to other partitions cannot 
access the contents of these cells, CAPs, and drives. See “Storage Cells and 
Drives” on page 194 for details. 

• Storage cells, CAPs, and drives not allocated to any partition cannot be accessed 
by any hosts. For example, you might leave an area of cells unallocated, in 
preparation for future partitioning. 

• Host-partition connections can use either the FC-SCSI or HLI (TCP/IP) interface. 

• Whole rotational or AEM CAPs can be allocated for exclusive use by one 
partition, or they can be shared by multiple partitions. See “Partitions and 
Rotational and AEM CAPs” on page 196 for details.

• CAPs can only be shared by partitions with the same host interface type. That is, 
FC-SCSI and HLI partitions cannot both share the same CAP. 
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• With the non-disruptive partitioning (NDP) feature, there is minimal host 
disruption whenever resources are allocated to a partition, and changes made to 
one partition do not impact other partitions or their host connections. See “Non-
Disruptive Partitioning” on page 201 for details. 

Enabling and Disabling Partitioning
In order for you to use partitions in a library, the partitioning feature must be 
installed through the hardware activation utility. See Chapter 3, “Hardware 
Activation Files”  on page 187 for details. 

A library with partitioning enabled can be in either of the following states: 

• Partitioned – The library has at least one user-defined partition with a valid 
partition ID. 

• Non-partitioned – The library has no user-defined partitions. A non-partitioned 
library behaves in the same manner as a library that does not have partitioning 
enabled; that is all active storage cells, drives, and rotational and AEM CAPs are 
accessible to all hosts. 

To disable partitioning on a library, you must first delete all partitions. The library 
state will then change to “non-partitioned.” 

Partition Planning
The partitioning feature offers great flexibility in the use of your library. It also 
requires careful planning, a thorough knowledge of library wall and storage cell 
mapping, and expertise in configuring and administering host software applications. 
There must be clear communication among all parties involved, including system 
programmers and administrators, library operators, and your Oracle service 
representative. 

Before creating partitions, you must plan the storage area that is needed for resident 
tape cartridges and anticipate the number of required free cells. You must 
understand the boundaries of each partition and the host ownership relationships. 
You must verify that all tape drives and cartridges have been moved to the proper 
locations, according to the planned assignments.   

Installing the Partitioning Feature

The following special considerations apply after you successfully install the 
Partitioning feature on a previously non-partitioned library. 

• You can begin creating partitions immediately; you do not need to reboot the 
library first.

• Until you create at least one partition, the library remains in a non-partitioned 
state; that is all activated storage cells, drives, and rotational and AEM CAPs are 
accessible to all hosts. 
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Allocated Storage Capacity

In partitioned libraries, the total number of storage cells allocated to all library 
partitions cannot exceed the activated capacity of the library. 

In partitioned libraries, there is no default active storage region. You must explicitly 
assign storage cells to partitions, thereby configuring the active storage regions for 
each partition. See “Partitioning Process” on page 204 for details. 

When assigning cartridges to storage cells, the library controller applies the 
predefined cell selection rules separately to each partition. See “Cell Activation 
Rules” on page 145 for details. 

Partition Configurations

You must use the standalone SL Console or Web-launched SL Console to configure 
library partitions; the partitioning screens are not available on the local operator 
panel. 

To configure a partition, you must define the following information: 

• Partition Summary Information

• Host-Partition Connections

• Partition Boundaries

For detailed instructions on defining library partitions, see “Partitioning 
Process” on page 204. 

Partition Summary Information

Partition summary information includes the partition ID, name, and host-partition 
connection type (HLI or FC-SCSI). Partition IDs must be unique and can range 
from 1–8. 

Host-Partition Connections

Host-partition connections identify the hosts that are able to access a partition. Each 
partition appears to the host as a separate library. A host can control one or more 
partitions. In addition, it is possible for more than one host to control a single 
FC-SCSI partition, but it is recommended that you exercise caution in implementing 
this configuration, as some host applications may not allow for resource sharing. 

HLI Host-Partition Connections

An HLI (Host Library Interface) partition can have up to 16 assigned hosts. You 
define the HLI host-partition connection configuration through the library 
management software (ACSLS or ELS). Therefore there are no SL Console screens to 
display or maintain this information. See the appropriate tape management software 
documentation for details. 
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FC-SCSI Host-Partition Connections

An FC-SCSI partition can have one or more host-partition connections. The host-
partition connection configuration is user-defined and consists of the following 
information: 

• World Wide Port Name of the FC-SCSI host bus adapter 

• Logical unit number (LUN) of the host 

See “Configure a Host-Partition Connection” on page 210 for detailed instructions on 
defining this information. 

Partition Boundaries

Partition boundaries identify the storage cells, drives, and rotational and AEM CAPs 
that are part of each partition. Only unallocated cells can be added to a partition, and 
only allocated cells can be removed. 

You can define partition boundaries in any of the following ways:

• Select individual cells or rectangular groups of cells to add or remove from a 
partition. Cells or cell groups do not have to be contiguous.

• Select a module column to add or remove from a partition. Columns do not have 
to be contiguous. 

• Select an entire module side (front or back) to add or remove from a partition. 
Sides do not have to be contiguous. 

• Select an entire module to add or remove from a partition. Modules do not have 
to be contiguous. 

Note – It is possible to have partitions with no allocated 
resources. 

Deleting the Partitioning Feature
You can delete the Partitioning feature by deleting the Partitioning hardware 
activation file from the library. See “Delete a Hardware Activation File” on page 123 
for detailed instructions. You must reboot the library after deleting the Partitioning 
activation file in order for the deletion to take effect.

Note – Deleting the Partitioning feature is an exceptional 
situation; be sure this is what you really want to do. 

Note – The Partitioning feature cannot be deleted if it was 
activated by a legacy hardware activation file prior to SL3000 
firmware version FRS_3.0. 

Deleting the Partitioning feature has the following effects on the library 
configuration:

• Changes the library state to “non-partitioned.” 

• Makes all activated storage cells, drives, and CAPs accessible to all hosts.

• All existing partition summary information and resource allocations are retained, 
but not usable. If the Partitioning activation file is later re-installed, the partition 
allocations are restored. 
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Partitions and Library Resources

Library Resource Addresses 

Resource addresses uniquely identify each resource (storage cells, drives, and 
rotational and AEM CAPs) within the library. The SL3000 library and attached hosts 
use the following addressing schemes: 

• Library Internal Address

• Host SCSI Element Address

• HLI-PRC Address

Each partition appears to a host as a separate library; this is reflected in the partition 
address. 

For additional details about library resource addressing, see Appendix A, “Library 
Resource Addresses”  on page 589. 

Library Internal Address

The library internal address is used by the SL3000 library controller and the 
SL Console device tree to identify the physical location of each resource. The 
addressing scheme used by the SL3000 is a five-digit, comma-separated value, 
specifying the library, rail, column, side, and row, as viewed from the front of the 
library, facing the drive bays. 

The format of the SL3000 library internal address is l,r,c,s,w where:

• l = library or partition number; this value is always “1”. 

• r = rail number; this value is always “1”.

• c = column number. Column numbering is referenced from the left edge of the 
Base Module, as you face the inside back wall, as follows:

• Numbering is static, allowing modules to be added without renumbering 
existing columns. 

• Columns within and to the right of the Base Module are numbered positively 
(+), in ascending sequence from left to right. 

• Columns to the left of the Base Module are numbered negatively (-), in 
descending sequence from right to left. 

• Base Module panels are always “1” to “6”. 

• DEM panels (if present) are always “-1” to “-6”.

• If there is no DEM and a CEM is to the left of the Base Module, then columns 
“-1” to “-6” are skipped and the CEM is assigned columns “-7” to “-12”. 

• CEM columns to the right of the Base Module start with “7”. 

• Left AEM columns are always numbered “–33” to “–31”. Right AEM columns 
are always “31” to “33”. In other words, AEM columns are numbered as if a 
DEM and four CEMS are installed to the left, and four CEMs are installed to 
the right, of the Base Module. 
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• s = side. Back wall = “1”; front wall = “2”.

• w = row number. Numbered consecutively from the top, down. Valid values are 
“1” to “52”, with row “1” at the top. 

Host SCSI Element Address

SCSI element addresses are used by hosts with a FC-SCSI connection to the SL3000 
library. Each library resource available to a host is identified by a unique SCSI 
element address. 

Following are rules for SCSI element numbering within partitioned libraries:

• Each SCSI element address is a single integer, up to four digits in length. 

• Starting SCSI element addresses for each library resource type are as follows:

• CAPs – 10  

• Drives – 1000  

• Storage cells – 2000  

• SCSI element numbering restarts for each partition. For example, storage cell 
numbering starts with “2000” for each partition within a given library. 

• Numbering starts at the upper-left back of the library, as viewed from the front of 
the library. Numbering continues to the lower-right front by frame module. 
Numbering within a panel goes by 

• SCSI element addresses for a partition start at the lowest module, row, and 
column within the partition, then proceed by row until the end of the column, 
then increment by column until the end of the module. 

• SCSI element numbering is continuous within each partition, even if cell locations 
for the partition are not adjacent. 

• When additional resources are allocated to an existing FC-SCSI partition, the 
original resources are not renumbered. This helps to minimize disruption to the 
FC-SCSI host.

• Drive element numbering includes occupied drive slots only; empty drive slots 
are not assigned a SCSI element address. 

SCSI Element Address Examples

A library’s Base and storage expansion modules are allocated to Partition 1, and the 
Drive Module is allocated to Partition 2. SCSI element numbering is as follows:

• For Partition 1, the first available storage cell in the Base Module is assigned 
element address “2000”. Numbering continues sequentially through the last 
available cell in the storage module, running from top-left through bottom-right. 
Installed drives in the Base Module are assigned sequential element addresses, 
starting with “1000” for the top left drive. 

• For Partition 2, the first available storage cell in the Drive Module is assigned 
element address “2000”. Numbering continues sequentially through the last 
available cell in the Drive Module, running from top-left through bottom-right. 
Installed drives in the Drives Module are assigned sequential element addresses, 
starting with “1000” for the top left drive.
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HLI-PRC Address

The HLI-PRC (Host Library Interface-Panel, Row, Column) address is used by hosts 
with an HLI connection to the SL3000 library, including ACSLS and ELS. The 
HLI-PRC address uniquely identifies each library resource accessible to the host and 
is assigned by the host software.

The HLI-PRC address is an eight-digit value specifying the library, panel, row, and 
column where the resource is located. The format is ll:pp:rr:cc, where:

• ll = Library number; this value is always “00”. 

• pp = Panel number. Numbering is relative to the Base Module, as follows:

• Base Module panels are always “12” and “13”. 

• Modules to the left of the Base Module are numbered in descending sequence, 
starting with “11”; modules to the right are numbered in ascending sequence, 
starting with “14”. 

• Rear walls are assigned even numbers; front walls are assigned odd numbers. 

• DEM panels (if present) are always “10” and “11”.

• If there is no DEM and a CEM is to the left of the Base Module, then panels 
“10” and “11” are skipped and the CEM is assigned panels “8” and “9”. This 
allows you to add a DEM to the left of the Base Module at a later date without 
renumbering modules. 

• For AEM panel numbering, see “HLI CAP numbering – rotational and AEM 
CAPs” on page 193. 

• rr = Row number within the panel. Numbered consecutively from the top, down. 
Valid values are 0–51, with row 0 at the top. 

• cc = Column number within the panel. Numbered consecutively from left to right, 
starting at the front of the module. Each panel has a maximum of six columns; 
therefore, valid column values are 0–5. 

HLI CAP numbering – rotational and AEM CAPs

Note – ELS displays HLI-PRC addresses in hexadecimal notation. 
Therefore, panels 10, 11, and 12 are displayed as “0A”, “0B”, and 
“0C” respectively. ACSLS and the SL Console display HLI-PRC 
addresses in decimal notation. 

Library CAP numbers are assigned by module, from left to right: 

• Base Module CAP = 6

• DEM CAP = 5

• Rotational CAPs in CEMs to the left of the Base Module = 1–4

• Rotational CAPs in CEMs to the right of the Base Module = 7–10

• AEM CAP to the left of the Base Module = 0

• AEM CAP to the right of the Base Module = 11

Rotational CAPs contain a single column of cells with 26 rows; cells are numbered 0–
25. 
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The AEM contains a bulk load CAP with 234 cells arranged in six columns. Column 
numbering starts at the rear wall and runs left to right (columns 0–2); then proceeds 
to the front wall and runs left to right (columns 3–5). 

Storage Cells and Drives 

All storage cells, tape drives, and cartridges allocated to a partition can only be 
accessed by host connections assigned to the partition. For example, if a group of 
tape drives is allocated to a partition, only the hosts assigned to that partition can use 
those drives. 

Storage cells and drives that are not allocated to any partition cannot be accessed at 
all. For example, you can leave an area of cells unallocated in preparation for a 
planned future partition. 

On the SL Console screens and reports, storage cells and drives appear in any of the 
following states:

• Allocated – Assigned to the current partition. 

• Unallocated (or Unassigned) – Not assigned to any partition; available to be 
assigned to any current partition. 

• Unavailable – Assigned to another partition. 

• Not accessible – Not available for host operations; for example, cells reserved for 
diagnostic cartridges, cells that are physically blocked, and cells that are inactive. 

Note – TallBots are shared resources and cannot be allocated 
exclusively to a partition. 

To display partition assignments for storage cells and drives, see “Partitions—
Reports—Cartridge Cell and Media Summary” on page 301. 

Orphaned Cartridges in Partitioned Libraries

Note – For a discussion of orphaned cartridges in non-partitioned 
libraries, see “Orphaned Cartridges in Non-Partitioned 
Libraries” on page 145. 

In partitioned libraries, an orphaned cartridge is a cartridge located in an unallocated 
cell or drive (that is, a cell or drive not allocated to any defined partition). 

Caution – If a host encounters an orphaned cartridge it might treat 
the cartridge as scratch and overwrite the data. Therefore, it is very 
important to disposition orphaned cartridges properly. 

A cartridge can become orphaned for a variety of reasons. Following are some 
possible causes:

• Partition boundaries have changed.

• A partition has been deleted. 

• The cartridge has been moved to an unallocated or inaccessible cell through 
manual intervention. 
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If the SL Console identifies an orphaned cartridge, it displays a warning message. 
You can then use the following tools to help you resolve and disposition the 
orphaned cartridge:

• Generate a report of orphaned cartridges. 

• Perform an audit of the library. 

• Perform a recovery move on a cartridge. 

For detailed instructions on checking for and resolving orphaned cartridges, see the 
following procedures:

• “Verify Partition Configurations” on page 216

• “Resolve Orphaned Cartridges” on page 219

• “Commit Partition Configuration Changes” on page 220
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Partitions and Rotational and AEM CAPs 
Note – AEM CAPs are subject to the same partitioning rules and 
restrictions as rotational CAPs. Throughout this section, the term 
“CAP” refers to both types of CAPs. 

Note – The SL3000 does not support common CAPs, split CAPs, 
or the allocation of individual CAP cells to a partition. 

When configuring CAPs, you must plan carefully for anticipated CAP usage. A 
partition can only use the CAPs explicitly allocated to it. There is no “common” CAP 
in the SL3000. 

When you allocate a CAP to a partition, all cells in the CAP are allocated as a whole. 
It is not possible to allocate or de-allocate individual cells within a CAP. There is no 
“split” CAP in the SL3000. 

Using CAPS in a Partitioned Library

A rotational or AEM CAP is a shared library resource – that is, it can be used by all 
partitions in the library. A CAP can be used by only one partition at a time, however. 
While a partition is using a CAP for enters or ejects, the CAP is reserved to that 
partition and unavailable to all others. 

In order for a partition to reserve a CAP, all of the following conditions must be met:

• The CAP must be available – that is, not reserved by any other partition. 

• The CAP must be empty.

• The CAP must be closed and locked.

For additional details, see “CAP “Ownership”” on page 197. 

CAP Allocations

All CAPs in a partitioned library are unallocated by default. You allocate CAPs to 
partitions through the following screens:

• “Partitions—Design (Step 3b)” on page 276, for Base, Drive, and CEM modules

• “Partitions—Design (Step 3b) – AEMs Only” on page 282, for AEM modules

CAP allocations can take either of the following forms:

• Dedicated – The CAP is allocated for the exclusive use of one partition.

• Shared – The CAP is allocated for the use of more than one specified partition. See 
“Shared CAPs” for details. 

Once a CAP is allocated, it becomes either an FC-SCSI CAP or an HLI CAP, 
depending on the host interface type of the first partition to which it is allocated. For 
example, if you allocate a previously unallocated CAP to a partition with an FC-SCSI 
interface, the CAP becomes an FC-SCSI CAP. Subsequent allocations of the CAP can 
be to other FC-SCSI partitions only. To change the CAP from FC-SCSI to HLI, you 
must first de-allocate the CAP from all FC-SCSI partitions, and then allocate the CAP 
to an HLI partition.
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Note – CAP allocations are not required; it is possible to have 
partitions with no allocated CAP. 

Note – Because FC-SCSI host applications typically do not use 
CAP reservations, it is recommended that you dedicate at least 
one CAP to each FC-SCSI partition whenever possible. This allows 
each partition to operate independently from the others and 
allows you to avoid the resource contention issues that can arise 
through shared CAPs.

Shared CAPs

Because a library can have more partitions than CAPs, it may be necessary to share 
CAPs among partitions. Only partitions with the same host interface type can share a 
CAP. For example, any number of FC-SCSI partitions can share a group of one or 
more CAPs, and any number of HLI partitions can share a different group of CAPs, 
but HLI and FC-SCSI partitions cannot both share any of the same CAPs. 

A partition can have only dedicated CAPs or shared CAPs. For example, it is not 
possible for a partition to have a dedicated CAP while sharing another CAP; both 
CAPs must be either dedicated or shared. 

Note – You must carefully manage shared CAP usage among 
FC-SCSI hosts in order to avoid contention. See “CAP 
“Ownership”” on page 197 for details. 

CAP Auto Enter Mode 

CAP auto enter mode allows a library operator to open a CAP and initiate an enter 
operation without issuing an explicit enter request and without an explicit 
reservation from a host application. Auto enter mode is available for CAPs that have 
been dedicated to a partition. CAPs in auto enter mode are left unlocked. 

Auto enter mode is managed by the host applications. See the appropriate tape 
management software documentation for details. 

CAP “Ownership” 

A CAP can be used by only one partition at a time for enters and ejects. A partition 
can take ownership of a CAP in any of the following ways:

• The CAP is dedicated to one partition. In this case the partition always has 
exclusive ownership of the CAP.

• A host application reserves the CAP prior to an enter or eject operation. This 
typically applies to HLI host applications only. See “CAP 
Reservations” on page 198 for details. 

• The user explicitly associates the partition to the CAP. This applies to FC-SCSI 
CAPs only. See “FC-SCSI CAP Associations” on page 199 for details. 

While a partition has ownership of a CAP, the CAP is reserved exclusively to that 
partition and unavailable to all others. The library sends “CAP opened” and “CAP 
closed” messages only to the host holding the reservation. 
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For HLI CAPs only, when a host attempts to reserve a CAP already reserved by 
another partition, the library sends a message to the requesting host identifying the 
partition ID and host ID holding the reservation. 

CAP States

A CAP must be unlocked in order for you to open it to insert or remove cartridges. 
When a CAP is unlocked, the light on the CAP button is turned on. 

When you close a CAP, the TallBot performs an audit to determine whether there are 
cartridges present. During the audit the CAP is locked and the light on the CAP 
button is turned off. Once the audit is completed, the CAP is returned to its default 
state. 

The following table describes the default states of the various types of CAPs within a 
partitioned library. 

Type of CAP Default State
Default CAP Button 
Light Condition Comment

HLI – dedicated or 
shared 

Locked Off Host reservation unlocks the CAP 
and turns the light on. See “CAP 
Reservations” on page 198 for 
details. 

HLI – auto enter mode Unlocked On

FC-SCSI – dedicated Unlocked On

FC-SCSI – shared Locked Off Partition-CAP association unlocks 
the CAP and turns the light on. See 
“FC-SCSI CAP 
Associations” on page 199 for 
details.

CAP Reservations

Both FC-SCSI and HLI hosts can make use of CAP reservations. CAP reservations 
give a partition exclusive ownership of a shared CAP for the duration of an enter or 
eject operation. When the operation is finished, the host application must release the 
reservation to make the CAP available to other partitions sharing the CAP. No other 
partitions can access the CAP until the first one has terminated the operation and 
released the reservation. 

For a partition to reserve a CAP, the CAP must be unreserved (applies to shared 
CAPs only), empty, and closed. 

HLI CAP Reservations 

HLI host applications use a strict reservation scheme to manage CAP usage among 
host clients, and therefore always reserve a CAP before unlocking it or moving a 
cartridge to it. When an HLI host application attempts to reserve a CAP already 
reserved by another partition, the library controller sends a message to the requesting 
host identifying the partition ID and host ID holding the reservation. 
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Releasing CAP Reservations 

In normal operations, a CAP reservation for an ACSLS or ELS host is released in the 
following ways:

• Enter operations – After all cartridges have been successfully entered into the 
library, the host explicitly terminates the enter command. The library controller 
releases the CAP after verifying that the CAP is closed and empty. 

• Eject operations – After all cartridges have been successfully ejected, the host 
automatically terminates the eject operation. The library controller releases the 
CAP after verifying that the CAP is closed and empty. 

If for some reason a CAP reservation is not released as described above, the CAP will 
be unavailable to all other partitions, and cartridges belonging to the first partition 
may remain in the CAP. In this case, it is recommended that you terminate the enter 
or eject from the host holding the reservation. This ensures a normal release of the 
CAP reservation. 

Note – See the ACSLS or ELS documentation for details about 
terminating enters and ejects. 

Overriding CAP Reservations 

In some cases, you may not be able to access the host holding a reservation and 
therefore cannot perform a normal release of the CAP. This may be because the host 
has terminated or because you lack physical access or security authorization to issue 
commands to the host. In these cases, you can override (unreserve) the CAP 
reservation manually. See “Override a CAP Reservation” on page 249 for the detailed 
procedure. 

Note – Use extreme care when using the SL Console to override a 
CAP reservation. If you do not complete the procedure, the CAP 
could be left unavailable to all partitions, and/or cartridges 
assigned to one partition could be entered into another partition.

Note – You can use the SL Console to override a CAP reservation 
only in a partitioned library. If a library is not partitioned, CAP 
reservations must always be released through ACSLS or ELS. 

FC-SCSI CAP Reservations 

Most FC-SCSI host applications do not use CAP reservations. FC-SCSI host 
applications typically assume sole ownership of a CAP and therefore do not 
coordinate CAP sharing well. To avoid contention among partitions for a shared 
CAP, you must manually associate a partition to a CAP. See “FC-SCSI CAP 
Associations” on page 199 for details. 

FC-SCSI CAP Associations 

If a FC-SCSI partition shares CAPs with other partitions, you must manually 
associate the partition to its CAPs prior to initiating an enter or eject operation. See 
“Associate an FC-SCSI Partition to Its Shared CAPs” on page 244 for the detailed 
procedure.
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A partition-CAP association gives a partition exclusive ownership of its shared CAPs, 
similar to a CAP reservation. This ensures that cartridges are always entered into the 
correct partition and prevents other partitions from taking ownership of a shared 
CAP that is already in use. 

The following rules apply when making partition-CAP associations:

• You can associate only one partition at a time to a CAP. 

• Selecting a partition causes all its allocated CAPs to be associated to it at once; you 
cannot select individual CAPs to be associated to the partition. 

• Partition-CAP associations remain active until you explicitly remove them; the 
associations are not automatically removed when the enter or eject operation 
completes. 

• Partition-CAP associations are removed during library reboots, power cycles, 
library door open/close operations, or CAP initializations 

• Partition-CAP associations are removed if the CAP becomes allocated to a 
different partition through the Design (Step 3b) screen. 

• If a partition-CAP association is removed while the CAP is open or has cartridges 
in it, the CAP ownership will be changed to the “default” requester (the library 
controller), and the CAP will be unavailable to all partitions. You must empty and 
close the CAP before it can be associated to any partitions. 
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Non-Disruptive Partitioning
The non-disruptive partitioning (NDP) feature minimizes the number of host 
interruptions that occur when partitions are modified. The library does not need to 
be taken offline for every partition change, and hosts are insulated from partition 
changes that do not affect them directly.

Prior to this feature, whenever a partition was changed in any way, all partitions 
would go offline while the library controller database was updated. As a result, 
library outages needed to be coordinated across all hosts connected to a partitioned 
library. 

The specific functions of the NDP feature vary, depending on the type of host-
partition connection. For details, see the following sections:

• “NDP and HLI Partitions” on page 201

• “NDP and FC-SCSI Partitions” on page 202

Caution – Although partition changes are not disruptive to library 
hosts, it is recommended that you make the library unavailable to 
other users before committing your partition workspace changes. 
Because the SL Console does not validate partition boundaries 
against the library controller database in real-time, configuration 
conflicts may arise if you change partition boundaries while other 
users are performing cartridge movements or library configuration 
changes. See “Synchronizing the Display With the Controller 
Database” on page 64 for details. 

NDP and HLI Partitions

With HLI partitions, you can allocate additional resources to a partition without 
stopping host jobs or having the partition go offline. In general, a partition goes 
offline only when resources are de-allocated. In all cases, neighboring partitions are 
always left undisturbed.

Allocating Additional Resources to a Partition

Whenever you make any of the following types of partition changes, the affected 
partition stays online: 

• Allocate a storage cell 

• Allocate a drive 

• Allocate a CAP 

The library controller sends an asynchronous message to all hosts connected to the 
partition that the library configuration has changed. The hosts experience a brief 
interruption as they update their library configuration information, and then they 
automatically continue processing jobs. 
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Removing Allocations from a Partition

Whenever you make any of the following types of partition changes, the affected 
partition goes offline briefly: 

• De-allocate a storage cell

• De-allocate a drive

• Remove an empty drive slot

After the configuration change is updated in the library controller database, the 
partition automatically comes back online and the library controller notifies all hosts 
connected to the partition that a configuration change has occurred. The hosts 
experience a brief interruption as they update their library configuration information, 
and then they automatically continue processing jobs. 

NDP and FC-SCSI Partitions

All changes to an FC-SCSI partition cause the affected partition to go offline with a 
Unit Attention condition. Neighboring partitions and their connected hosts are not 
disturbed.

Host Connection Changes

Host connection changes include the following activities:

• Add a host-partition connection

• Change the LUN for a host-partition connection 

• Delete a host-partition connection

Whenever you change a host LUN or add a LUN connection mapping for a host, the 
affected partition goes offline with a LUNS Data Has Changed Unit Attention 
condition. The hosts connected to the partition must issue the appropriate commands 
to update their library configuration information. See the appropriate tape 
management software documentation for detailed procedures and commands.

If a host has unique ITL nexus connection mappings for each partition connection, 
then only the partition experiencing the connection change is affected. 

Partition Configuration Changes

Partition configuration changes include the following activities:

• Allocate a storage cell 

• Allocate a drive 

• De-allocate a storage cell

• De-allocate a drive

• De-allocate a CAP 

Whenever you make any of these changes, the affected partition goes offline with a 
Mode Parameters Have Changed Unit Attention condition. The hosts connected to 
the partition must issue the appropriate commands to update their library 
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configuration information; see the appropriate tape management software 
documentation for detailed procedures and commands. In the case of adding or 
removing drives, the device SCSI numbering is updated as well. 
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Partitioning Process
Note – Library partitioning must be installed through the SL3000 
hardware activation utility. See “Hardware Activation Files” for 
details. 

Partition Configuration Process

When configuring library partitions for the first time, it is recommended that you use 
the library partition screens in the following sequence: 

1. Instructions (Step 1) – Review summary instructions for the partition 
configuration process. 

2. Summary (Step 2) – Display summary partition configuration and host-partition 
connection information. Optionally access other screens to perform the following 
tasks:

• Add Partition

• Modify Partition

• Delete Partition

Note – The following tasks are available for FC-SCSI host-
partition connections only. 

• Add Connection

• Modify Connection

• Delete Connection

3. Module Map (Step 3a) – Select the library module for which you want to design 
detailed partition boundaries. 

4. Design (Step 3b) – Display and optionally modify detailed partition boundary 
information. Optionally access other screens to perform the following tasks:

• Verify Partition Configurations 

• Refresh the display with current data from the library controller database

5. Commit (Step 4) – Commit all changes made in the Summary(2) and Design (3b) 
screens, and all associated popups, to the library controller database. Optionally 
access other screens to perform the following task: 

• Refresh the display with current data from the library controller database

You can use the Reports screen at any time to display, and optionally save or print, 
partition configuration information from the library controller database. 

SL Console Partition Workspace

The partition Summary (Step 2) and Design (Step 3b) screens, and all associated 
popups, give you a dynamic workspace to design your library partitions. All 
partition configuration information is automatically saved to the partition workspace 
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in SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among partition views and leave and return to the partition 
screens any number of times without losing your configuration changes.

Information in the SL Console partition workspace is committed to the library 
controller database only through the Commit (Step 4) screen. The information is lost 
if any one of the following occurs before you have committed your updates: 

• You actively log off the SL Console session.

• The SL Console session times out or the connection to the library is lost. 

• You actively refresh the SL Console workspace from the current library controller 
database. This is done through the Refresh button on the Summary (Step 2) and 
Design (Step 3b) screens. 

Caution – Although partition changes are not disruptive to library 
hosts, it is recommended that you make the library unavailable to 
other users before committing your partition workspace changes. 
Because the SL Console does not validate partition boundaries 
against the library controller database in real-time, configuration 
conflicts may arise if you change partition boundaries while other 
users are performing cartridge movements or library configuration 
changes. See “Synchronizing the Display With the Controller 
Database” on page 64 for details. 
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Partitioning Task Summary
Partitioning tasks are divided into the following categories:

• “Partition Configuration Tasks” on page 207

• “Partition Management Tasks” on page 223

• “Partition Report Tasks” on page 236

• “CAP Operation Tasks” on page 243
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Partition Configuration Tasks

Task Page

Review Partitioning Instructions  208

Create a Partition  209

Configure a Host-Partition Connection (FC-SCSI partitions only)  210

Design a Partition – Base, DEM, or CEM Modules  212

Design a Partition – AEM Modules  214

Verify Partition Configurations  216

Resolve Orphaned Cartridges  219

Commit Partition Configuration Changes  220
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▼Review Partitioning Instructions

Use this procedure to review the partitioning process. 

1. Select Tools > Partitions.

The first time you make this selection during an SL Console login session, the 
Instructions (Step 1) screen appears automatically. 

2. Review the instructions on the screen before proceeding with other partitioning 
tasks. 
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▼Create a Partition 

Use this procedure to create a new library partition and assign its storage capacity. 
You can create up to eight partitions, with IDs from 1–8. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab. 

The Summary (Step 2) screen appears.

2. Click Add Partition. 

The Add Partition popup appears. 

3. Select the Partition ID you want to add, and enter the Name, Capacity, and 
Interface Type.

Note – Partition IDs do not need to be contiguous. For example, 
you can create partition 2 and partition 4, with no partitions 1 or 
3. 

4. Click OK. 

Your partition configuration changes are saved to the SL Console partition 
workspace for the duration of this login session. 

To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 216 and “Commit 
Partition Configuration Changes” on page 220. 
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▼Configure a Host-Partition Connection

Note – This procedure applies to FC-SCSI host-partition 
connections only. HLI host-partition connections are configured 
through the host library management software (ELS or ACSLS), 
not through the SL Console. See the ELS or ACSLS documentation 
for details. 

Use this procedure to configure the connection between a host and a selected 
partition. You must perform this procedure in order for the partition to be accessible 
by the host.

Each partition can have up to nine host connections. Also, each host can connect to 
multiple partitions. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. Click the partition to which you want to add a host connection

Note – If you select an HLI partition, all the buttons in the Details 
section of the screen are grayed out. 

3. Click Add Connection. 
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The Add Connection popup appears. 

4. Enter the Initiator (WWPN) and LUN. 

Note – Each initiator connected to the library must have one 
library partition assigned to LUN 0. When you verify or commit 
partition configuration changes, the SL Console will notify you if 
an initiator does not meet this requirement. 

5. Click OK. 
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▼Design a Partition – Base, DEM, or CEM Modules

Use this procedure to add or remove library resources (storage cells, tape drives, and 
rotational CAPs) from a partition. 

Note – This procedure applies to Base, DEM, or CEM modules. 
See “Design a Partition – AEM Modules” on page 214 for detailed 
instructions on allocating or de-allocating an AEM CAP to or from 
a partition. 

Note – Library resources can be allocated to only one partition at 
a time. If you want to add resources to a partition but the 
resources are already allocated to another partition, you must first 
remove the resources from the assigned partition, and then add 
them to the new partition. 

1. Select Tools > Partitions.

2. Click the Module Map (Step 3a) tab. 

The Module Map (Step 3a) screen appears. 

3. Click the module for which you want to design a partition. 

4. Click the Design (Step 3b) tab.
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The Design (Step 3b) screen appears, displaying the current configuration of the 
module you have selected.

5. In the Partition pull-down menu, select the partition you want to configure. 

All screen fields are updated to reflect the current configuration for the selected 
partition. 

Note – Click the Move Left or Move Right buttons to display a 
module directly adjacent to the one currently displayed. 

6. Choose the Select by method, and click either the Add or Remove radio button.

7. Use the library map to select the resources you want to add or remove. 

Note – See “Partitions—Design (Step 3b)” on page 276 for detailed 
instructions on using the library map. 

Your partition configuration changes are saved to the SL Console partition 
workspace for the duration of this login session. 

To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 216 and “Commit 
Partition Configuration Changes” on page 220. 
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▼Design a Partition – AEM Modules 

Use this procedure to add or remove an AEM CAP to or from a partition. 

You can allocate or de-allocate the entire AEM at one time; it is not possible to 
allocate just part of an AEM to a partition. AEMs can be shared by multiple partitions 
that share the same host-partition interface (HLI or FC-SCSI). 

Note – See “Design a Partition – Base, DEM, or CEM 
Modules” on page 212 for detailed instructions on adding or 
removing library resources in Base, DEM, or CEM modules to or 
from a partition. 

1. Select Tools > Partitions.

2. Click the Module Map (Step 3a) tab. 

The Module Map (Step 3a) screen appears. 

3. Click the AEM you want to allocate to a partition. 

4. Click the Design (Step 3b) tab.
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The Design (Step 3b) screen appears, displaying the current configuration of the 
AEM you have selected. 

5. In the Partition pull-down menu, select the partition you want to configure. 

All screen fields are updated to reflect the current configuration for the selected 
partition. 

Note – Click the Move Left or Move Right buttons to display a 
module directly adjacent to the one currently displayed. 

6. Click either the Add or Remove radio button.

7. Click anywhere on the library map to select the AEM and indicate that you 
want to allocate or de-allocate it to or from the partition. 

Your partition configuration changes are saved to the SL Console partition 
workspace for the duration of this login session. 

To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 216 and “Commit 
Partition Configuration Changes” on page 220. 



216  SL3000 User’s Guide March 2011 

 

▼ Verify Partition Configurations 

Use this procedure to verify partition configuration changes you have made during 
this SL Console login session. This procedure warns you of the following possible 
errors:

• A partition has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” on page 194 for details.

• Library resources have been removed from a partition. 

• A host connected to the library does not have a partition assigned to LUN 0. 

• The library’s capacity is oversubscribed; that is total partition allocations exceed 
activated capacity.

Note – This procedure verifies only one partition at a time. If you 
need to verify multiple partitions, you must repeat this procedure 
separately for each partition. 

1. Select Tools > Partitions.

2. Click the Module Map (Step 3a) tab. 

The Module Map (Step 3a) screen appears. 

3. Click the module for which you want to verify a partition. 

The module is highlighted on the screen. 

4. Click the Design (Step 3b) tab.
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The Design (Step 3b) screen appears, displaying the current configuration of the 
module you have selected.

5. In the Partition pull-down menu, select the partition you want to verify. 

All screen fields are updated to reflect the current configuration for the selected 
partition. 

6. In the Options Bar, click Verify. 

The boundaries of the selected partition are verified, including the locations of all 
tape cartridges. 

Note – This verification is performed on the current partition 
configuration in the SL Console partition workspace only. It does 
not verify current partition boundaries against the library 
controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge 
movements or library configuration changes—through the 
command line interface, other SL Console sessions, or host 
applications—at the same time you have made partition changes. 

The Verify Results popup appears, indicating whether there are any orphaned 
cartridges, oversubscribed storage capacity, or other errors in the current partition 
configuration. 

Note – If library capacity is oversubscribed (that is, total partition 
allocations exceed activated capacity), before you can proceed to 
“Commit Partition Configuration Changes” on page 220, you must 
remove storage cells from partition allocations to bring the total 
allocated cells within the library’s activated capacity. 

7. To display detailed warning messages explaining the reasons for any orphaned 
cartridges, click Details. 
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You can use the Details button to toggle between the expanded and collapsed 
views of the warning messages. 

8. Optionally, in the expanded view of the warning messages you can do the 
following:

• Click Print to print the detailed message data.

• Click Save to save the detailed message data to a comma-separated file. 

9. Click OK to dismiss the Verify Results popup and return to the Design 
(Step 3b) screen. 

Note – It is recommended that you follow the “Resolve Orphaned 
Cartridges” on page 219 procedure before committing your 
changes to the library controller database. 
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▼Resolve Orphaned Cartridges

If the SL Console identifies an orphaned cartridge, it displays a warning message. 
You should resolve and disposition all orphaned cartridges before proceeding to 
“Commit Partition Configuration Changes” on page 220. 

You can performing any of the following actions to resolve orphaned cartridges: 

• Print a report of orphaned cartridges. 

• Perform an audit of the library. 

• Perform a recovery move on an orphaned cartridge. 
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▼Commit Partition Configuration Changes 

Caution – This procedure updates the library controller database 
with all partition configuration changes you have made during this 
SL Console session. Failure to use this procedure before logging out 
of the current SL Console session will cause all your library 
configuration changes to be lost.

Caution – Although partition changes are not disruptive to library 
hosts, it is recommended that you make the library unavailable to 
other users before committing your partition workspace changes. 
Because the SL Console does not validate partition boundaries 
against the library controller database in real-time, configuration 
conflicts may arise if you change partition boundaries while other 
users are performing cartridge movements or library configuration 
changes. See “Synchronizing the Display With the Controller 
Database” on page 64 for details. 

Note – It is recommended that you follow the “Resolve Orphaned 
Cartridges” on page 219 procedure before performing this 
procedure. 

Note – You cannot perform this procedure if current library 
capacity is oversubscribed (that is, total partition allocations 
exceed activated capacity). The Apply button is grayed out, and 
before you can proceed, you must remove storage cells from 
partition allocations to bring the total allocated cells within the 
library’s activated capacity.

1. Vary the library offline to ACSLS and ELS. 

See the appropriate tape management software documentation for the procedures 
and commands.

2. Select Tools > Partitions, and click the Commit (Step 4) tab.

The Commit (Step 4) screen appears.

3. In the Options Bar, click Apply. 

The boundaries of the selected partition are verified, including the locations of all 
tape cartridges. 
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The Confirm Apply popup appears, indicating whether there are any orphaned 
cartridges or other problems in the current partition configuration. 

4. To display detailed warning messages explaining the reasons for any orphaned 
cartridges, click Details. 

You can use the Details button to toggle between the expanded and collapsed 
views of the warning messages. 

5. Optionally, in the expanded view of the warning messages you can do the 
following:

• Click Print to print the detailed message data.

• Click Save to save the detailed message data to a comma-separated file. 

6. Proceed as follows:

• Click No to cancel the update. The library controller database is not updated, 
but all partition changes from this login session are retained in the SL Console 
partition workspace. 

• Click Yes to update the library controller database.
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The Commit Success popup appears. 

Click OK to return to the Commit (Step 4) screen. 

7. All affected library host applications must now be configured to recognize 
these updates. See the appropriate tape management software documentation 
for the procedures and commands. 
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Partition Management Tasks

Task Page

Modify Partition Summary Information  224

Delete a Partition  225

Modify the Interface Type of a Host-Partition Connection  227

Modify FC-SCSI Host-Partition Connection Detail  229

Delete a FC-SCSI Host-Partition Connection  231

Refresh the SL Console Partition Workspace  233

Reallocate Library Resources  234

Make a Hardware Change to a Partitioned Library  235
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▼Modify Partition Summary Information

Use this procedure to change the name or allocated storage capacity of an existing 
partition.

Note – To change the host-partition connection type (HLI or 
FC-SCSI), see “Modify the Interface Type of a Host-Partition 
Connection” on page 227. 

Note – You cannot change the partition ID. To assign a different 
Partition ID, you must delete the old partition and create a new 
one with the new ID. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Partition Summary section, select the partition you want to modify. 

3. Click Modify Partition.

The Modify a Partition popup appears.

4. Enter the changes you want to make. 

5. Click OK to confirm the changes. 
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▼Delete a Partition

Use this procedure to delete a partition from the library. The following changes are 
made to the library partition configuration:

• All resources allocated to the partition are marked available. 

• All host connections for the partition are deleted. 

• The partition ID is deleted. 

Caution – Deleting partitions can result in orphaned cartridges and 
data that could be lost. See “Orphaned Cartridges in Partitioned 
Libraries” on page 194 for details. 

Note – Deleting all partitions from the library causes the library 
state to change to “non-partitioned.” All active storage cells, 
drives, and rotational or AEM CAPs will be accessible to all hosts.

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Partition Summary section, click the partition you want to remove.

3. Click Delete Partition.

A confirmation popup appears.

4. Click OK to confirm the deletion. 

• If partitions still remain in the library, proceed to Step 7. 
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• If no partitions remain, the Select Library Interface Type popup appears. 

5. Select the library interface type you want to assign for all host connections to 
the library. Options are:

• HLI

• FC-SCSI

6. Click OK to confirm the change. 

7. The updates are made as follows:

Your partition configuration changes are saved to the SL Console partition 
workspace for the duration of this login session. 

To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 216 and “Commit 
Partition Configuration Changes” on page 220. 

If there are no partitions remaining in the library, when you commit the updates 
the library state will change to “non-partitioned”. 
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▼Modify the Interface Type of a Host-Partition Connection 

Use this procedure to change the host-partition connection type of an existing 
partition. You should use this procedure with caution, due to the following possible 
effects:

• Changing the interface type can result in the loss of active host connections. 

• Changing the interface type from FC-SCSI to HLI can result in the loss of FC-SCSI 
connection detail. 

• Because rotational and AEM CAPs cannot be shared across partition types, 
changing the interface type can result in the loss of existing shared CAP 
assignments. Dedicated CAP assignments are not affected. 

Note – To change the name or allocated storage capacity of an 
existing partition, see “Modify Partition Summary 
Information” on page 224. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Partition Summary section, click the partition you want to modify. 

3. Click Modify Partition.

The Modify a Partition popup appears.

4. In the Interface Type pull-down, select the interface type you want to assign. 
Click OK.
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5. The SL Console checks the current partition configuration in the SL Console 
workspace. If the partition has shared CAP allocations or, in the case of 
FC-SCSI partitions, host-partition connection detail, warning popups will 
appear. Following are sample popups that may appear. 

• Changing from HLI to FC-SCSI:

• Changing from FC-SCSI to HLI:

6. Click Yes to confirm the change. 

Your partition configuration changes are saved to the SL Console partition 
workspace for the duration of this login session. 

To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 216 and “Commit 
Partition Configuration Changes” on page 220. 
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▼Modify FC-SCSI Host-Partition Connection Detail

Note – This procedure applies to FC-SCSI host-partition 
connections only. HLI host-partition connections are configured 
through the host library management software (ELS or ACSLS), 
not through the SL Console. See the ELS or ACSLS documentation 
for details. 

Use this procedure to modify the host World Wide Port Name or LUN number of the 
library for a host-partition connection. 

Note – You cannot modify the target port number for the library; 
it is always “0”. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Summary section of the screen, click the partition for which you want to 
modify a connection. 

3. In the Connections section, click the host-partition connection you want to 
modify. 

Note – If you select an HLI partition, all the buttons in the Details 
section of the screen are grayed out. 

4. Click Modify Connection.
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The Modify a Connection popup appears.

5. Enter the changes you want to make. 

6. Click OK to confirm the changes. 

Your partition configuration changes are saved to the SL Console partition 
workspace for the duration of this login session. 

To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 216 and “Commit 
Partition Configuration Changes” on page 220. 
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▼Delete a FC-SCSI Host-Partition Connection 

Note – This procedure applies to FC-SCSI host-partition 
connections only. HLI host-partition connections are configured 
through the host library management software (ELS or ACSLS), 
not through the SL Console. See the ELS or ACSLS documentation 
for details. 

Use this procedure to delete a host-partition connection. After you perform this 
procedure, the host will no longer be able to access the partition. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Summary section of the screen, click the partition for which you want to 
delete a connection. 

Note – If you select an HLI partition, all the buttons in the Details 
section of the screen are grayed out. 

3. In the Connections section, click the host-partition connection you want to 
delete.

4. Click Delete Connection.
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A confirmation popup appears.

5. Click OK to confirm the deletion. 

Your partition configuration changes are saved to the SL Console partition 
workspace for the duration of this login session. 

To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 216 and “Commit 
Partition Configuration Changes” on page 220. 
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▼Refresh the SL Console Partition Workspace

Use this procedure to refresh the SL Console partition workspace with current data 
from the library controller database. The current data includes all updates that other 
users have made to the library controller database during your login session, through 
the command line interface, other SL Console sessions, or host applications. 

Note – After you complete this procedure, all uncommitted 
partition changes you have made during this SL Console login 
session are discarded. 

1. Select Tools > Partitions.

2. Click one of the following tabs:

• Summary (Step 2) 

• Design (Step 3b)

The selected screen appears.

3. In the Options Bar, click Refresh. 

The Partition Refresh popup appears.

4. Click Yes to confirm the refresh. 

All partition screen data is updated with current data from the library controller 
database. 
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▼Reallocate Library Resources 

Reallocating library resources (storage cells, tape drives, rotational or AEM CAPs, or 
cartridges) from one partition to another is done through one of the following 
screens: 

• “Partitions—Design (Step 3b)” on page 276, for Base, Drive, and CEM modules

• “Partitions—Design (Step 3b) – AEMs Only” on page 282, for AEM modules

You must use the following two-step process: 

1. Remove the resource from the partition it is currently allocated to.

2. Allocate the resource to a different partition. 

See “Design a Partition – Base, DEM, or CEM Modules” on page 212 for detailed 
instructions.

Caution – Reallocating resources can result in orphaned cartridges 
and data that could be lost. See “Orphaned Cartridges in 
Partitioned Libraries” on page 194 for details. 
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▼Make a Hardware Change to a Partitioned Library

Some library hardware changes, such as adding expansion modules, adding a second 
robot, or adding rotational CAP cells, may require the removal of all or part of an 
existing partitioned module. Use the following process to make such hardware 
changes without losing partitioning information for the sections of the library that are 
unchanged. 

Caution – Failure to follow this procedure could result in the loss 
of library partition configuration information after a hardware 
change. 

1. De-allocate all library resources (storage cells, rotational and AEM CAPs, and 
drives) that will be removed as part of the hardware change from the partitions 
they are currently allocated to. 

See “Design a Partition – Base, DEM, or CEM Modules” on page 212 for detailed 
instructions.

2. Power down the library. 

See “Power Down the Library” on page 581 for detailed instructions. 

3. Install the hardware change.

4. Power up the library. 

See “Power Up the Library” on page 582 for detailed instructions. 

All partition allocations for the unchanged parts of the library remain in effect.

5. Allocate the library resources that have been added due to the hardware change. 

See “Design a Partition – Base, DEM, or CEM Modules” on page 212 for detailed 
instructions.

Caution – Reallocating resources can result in orphaned cartridges 
and data that could be lost. See “Orphaned Cartridges in 
Partitioned Libraries” on page 194 for details. 
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Partition Report Tasks

Task Page

Display a Partition Report  237

Print Partition Report Data  239

Save Partition Report Data  240

Display Partition Detail  241



March 2011   237

 

▼Display a Partition Report 

Use this procedure to display any of the following partition reports:

• Cartridge Cell and Media Summary – Displays a detailed list of all resource 
partition assignments.

• Host Connections Summary – Displays detailed host-partition connection 
information for all partitions.

• Orphaned Cartridge Report – Displays a detailed list of all orphaned cartridges.

• Partition Details – Displays detailed information for a selected partition.

• Partition Summary – Displays summary information for all partitions.

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without commiting the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3b) screens. 

1. Select Tools > Partitions, and click the Reports tab.

The Reports screen appears.

2. In the pull-down menu, select the report you want to display. 
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The screen is updated with current data from the library controller database. 

3. If you want to print the report data or save it to a file, see the following 
procedures:

• “Print Partition Report Data” on page 239

• “Save Partition Report Data” on page 240 
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▼ Print Partition Report Data

Use this procedure to print a partition report. This procedure can be performed from 
any of the partition report screens. 

1. Select Tools > Partitions, and click the Reports tab.

The Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to 
File buttons. 

3. Click Print. 

The Print popup appears. 

4. Complete the print popup, and click Print. 

The report is printed to the selected printer. 
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▼ Save Partition Report Data

Use this procedure to save partition report data to a comma-separated file (.csv 
format). You can use a variety of spreadsheet applications to view the file. This 
procedure can be performed from any of the partition report screens. 

1. Select Tools > Partitions, and click the Reports tab.

The Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to 
File buttons. 

3. Click Save to File.

The Save popup appears. 

4. Browse to the directory where you want to save the file, and enter the file name. 

5. Click Save. 

The data is saved to the specified file. 
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▼Display Partition Detail 

Use this procedure to display current partition boundaries and allocations. You can 
also display detailed information about cartridge, drive, and storage cell locations. 

Note – This procedure is available on the local operator panel.

1. Select Tools > Partitions.

2. Click the Module Map (Step 3a) tab. 

The Module Map (Step 3a) screen appears. 

3. Click the module you want to display. 

The module is highlighted on the screen. 

4. Click the Current Partition Definitions tab.

The Partition Definitions screen appears, displaying the current configuration of 
the module you have selected.
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You can mouse-over a cell to display a tooltip of detailed information about the 
cell. 
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CAP Operation Tasks 

Task Page

Associate an FC-SCSI Partition to Its Shared CAPs  244

Enter Cartridges Into a Partition  246

Eject Cartridges From a Partition  247

Remove a Partition-CAP Association  248

Override a CAP Reservation  249
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▼Associate an FC-SCSI Partition to Its Shared CAPs

Use this procedure to associate an FC-SCSI partition to its shared rotational or AEM 
CAPs. This procedure gives the partition exclusive ownership of its shared CAPs 
until you explicitly remove the association. See “Remove a Partition-CAP 
Association” on page 248 for details. 

Note – This procedure cannot be used for HLI partitions because 
HLI host applications always use CAP reservations. 

Note – This procedure is not necessary for dedicated FC-SCSI 
CAPs because a partition always has ownership of its dedicated 
CAPs. 

Note – AEM CAPs are subject to the same partitioning rules and 
restrictions as rotational CAPs. Throughout this section, the term 
“CAP” refers to both types of CAPs. 

1. Select Tools > Shared CAP Assignment. 

The Shared CAP Assignment screen appears.

2. Click the checkbox of the partitions into which you want to enter cartridges. 
See “CAP Assignment” on page 318 for details on these screen fields. 
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3. Click Apply. 

The CAP Confirm popup appears. 

4. Click OK. 

5. Perform the enter or eject operation. See one of the following procedures for 
details:

• “Enter Cartridges Into a Partition” on page 246

• “Eject Cartridges From a Partition” on page 247
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▼ Enter Cartridges Into a Partition

Use this procedure to enter or bulk load cartridges into one or more partitions. 
Partitions can use only the rotational or AEM CAPs allocated to them. 

Note – If you are entering cartridges into an FC-SCSI partition 
that has one or more shared rotational or AEM CAPs, you must 
associate the partition to its CAPs before beginning this 
procedure. See “Associate an FC-SCSI Partition to Its Shared 
CAPs” for details. Failure to do this will cause the CAP to remain 
locked and will prevent the partition from acquiring ownership of 
the CAP. 

1. Follow the steps in one of the following procedures, depending on whether you 
are using a rotational or AEM CAP:

• “Enter Cartridges Through a Rotational CAP” on page 417

• “Bulk Load Cartridges Through an AEM CAP” on page 419

2. At the completion of the procedure, the CAP reservation is released, as follows:

• If you initiated this procedure from an HLI host, the host removes the 
reservation, making the CAP available to other partitions. 

• If prior to performing this procedure you performed a manual partition-CAP 
association, you can now remove the association if the partition is finished 
with the CAP. See “Remove a Partition-CAP Association” for details. 

• If the FC-SCSI partition uses a dedicated CAP, the CAP remains unlocked and 
reserved to the partition. 
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▼ Eject Cartridges From a Partition

Use this procedure to eject or bulk unload cartridges from a partitioned library. 
Partitions can use only the rotational or AEM CAPs allocated to them. 

Note – If you are entering cartridges into an FC-SCSI partition 
that has one or more shared rotational or AEM CAPs, you must 
associate the partition to its CAPs before beginning this 
procedure. See “Associate an FC-SCSI Partition to Its Shared 
CAPs” for details. Failure to do this will cause the CAP to remain 
locked and will prevent the partition from acquiring ownership of 
the CAP. 

1. Follow the steps in one of the following procedures, depending on whether you 
are using a rotational or AEM CAP:

• “Eject Cartridges Through a Rotational CAP” on page 418

• “Bulk Unload Cartridges Through an AEM CAP” on page 421

2. At the completion of the procedure, the CAP reservation is released, as follows:

• If you initiated this procedure from an HLI host, the host removes the 
reservation, making the CAP available to other partitions. 

• If prior to performing this procedure you performed a manual partition-CAP 
association, you can now remove the association if the partition is finished 
with the CAP. See “Remove a Partition-CAP Association” for details. 

• If the FC-SCSI partition uses a dedicated CAP, the CAP remains unlocked and 
reserved to the partition. 
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▼Remove a Partition-CAP Association

Use this procedure after completing an enter or eject operation if you have previously 
associated the partition to its shared rotational or AEM CAPs. This procedure 
removes the partition-CAP associations previously set, making the shared CAPs 
available to other partitions. 

Note – AEM CAPs are subject to the same partitioning rules and 
restrictions as rotational CAPs. Throughout this section, the term 
“CAP” refers to both types of CAPs. 

1. Select Tools > Shared CAP Assignment. 

The Shared CAP Assignment screen appears.

2. Clear the checkbox of the partitions with the CAP associations. See “CAP 
Assignment” on page 318 for details on these screen fields. 

3. Click Apply. 

The CAP Confirm popup appears. 

4. Click OK. 
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▼Override a CAP Reservation

Use this procedure when a partition has reserved a shared rotational or AEM CAP 
but the reservation cannot be released through the ACSLS or ELS host. 

Note – This topic applies to partitioned libraries only. If a library 
is not partitioned, CAP reservations must always be released 
through ACSLS or ELS. See the ACSLS or ELS documentation for 
details.

Note – You must follow all steps in this procedure. If you do not 
complete the procedure, the CAP could be left unavailable to all 
partitions, and/or cartridges assigned to one partition could be 
entered into another partition. 

Note – AEM CAPs are subject to the same partitioning rules and 
restrictions as rotational CAPs. Throughout this section, the term 
“CAP” refers to both types of CAPs. 

1. Select Tools > Diagnostics.

2. Expand the CAP Folder, and click the CAP whose reservation you want to 
override (unreserve). 

Note – AEM CAPs are identified as follows: column “–31” for a 
left AEM CAP, and column “31” for a right AEM CAP. 

3. Click the Unreserve tab.
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The Unreserve screen appears, identifying the partition that has reserved the 
CAP.

4. Click Apply to override the reservation.

The Unreserve Confirm popup appears, indicating “This will remove the 
reservation from the designated host...” 

• Click OK to continue with the override operation. The library removes the 
CAP reservation and sets the CAP user to “default,” which makes the CAP 
unavailable to all partitions.

• Click Cancel to cancel the override operation and return to Step 3. 

5. If the CAP is locked, unlock it at the SL Console. See “Unlock a CAP or AEM 
Access Door” on page 391 for the detailed procedure. 

6. Push the CAP button to open the CAP. 

• If it is empty, proceed to Step 8. 

• If it contains cartridges, remove them all. 

7. Label the cartridges with the partition ID displayed in Step 3. 

8. Push the CAP button to close the CAP. 

The CAP closes and locks automatically, and the CAP button light turns off.

The library audits the CAP to verify that it is empty. It then sets the CAP status to 
“unreserved,” which makes the CAP available to all partitions it is allocated to. 
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Note – You might need to refresh the CAP display to see the new 
CAP status. 

9. Contact a person responsible for managing the removed cartridges to determine 
their disposition. If they are to be re-entered into the library, they must be 
entered into the correct partition. 
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Partition Screen Reference
This section includes detailed descriptions of all SL Console partition screens, 
arranged by screen navigation path. For example, Partitions—Summary (Step 2)—
Add Connection indicates the screen accessed by clicking Tools and then Partitions 
from the Menu Bar, and then clicking the Summary (Step 2) tab, and then the 
Add Connection button. 

Note – Only the Partitions—Current Partition Definitions screen 
is available on the local operator panel. The remaining screens can 
be accessed only from the standalone SL Console or the Web-
launched SL Console.

Partition Screens are organized into the following categories:

• “Partition Summary Screens” on page 253

• “Partition Design and Commit Screens” on page 273

• “Partition Report Screens” on page 298

• “Partition CAP Operation Screens” on page 317

Note – The partition Summary (Step 2) and Design (Step 3b) 
screens, and all associated popups, give you a dynamic workspace 
to design your library partitions. All partition configuration 
information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your 
SL Console session. This allows you to switch among partition 
views and leave and return to the partition screens any number of 
times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 
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Partition Summary Screens

Partitions—Instructions (Step 1)

Partitions—Summary (Step 2)

Partitions—Summary (Step 2)—Add Connection

Partitions—Summary (Step 2)—Delete Connection

Partitions—Summary (Step 2)—Modify Connection

Partitions—Summary (Step 2)—Add Partition

Partitions—Summary (Step 2)—Delete Partition

Partitions—Summary (Step 2)—Modify Partition
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Partitions—Instructions (Step 1)

Sample Screen

Description

Displays instructions for using the partition screens.

Note – This screen appears automatically the first time you select 
Tools > Partitions during an SL Console login session. 

Screen Fields

None

Buttons

? (Help) 

Click to display online help for the screen. 

See Also

• Partitions—Summary (Step 2) 

• Partitions—Design (Step 3b) 
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• Partitions—Commit (Step 4) 

• Partitions—Reports 
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Partitions—Summary (Step 2)

Sample Screen

Description

Displays summary information for the library and, optionally, a selected partition. 

Also includes buttons that allow you to initiate any of the following activities:

• Add a new partition 

• Delete a partition from the library

• Modify partition summary information 

Note – The following buttons are available for FC-SCSI host-
partition connections only. HLI host-partition connections are 
configured through the host library management software (ELS or 
ACSLS), not through the SL Console. See the ELS or ACSLS 
documentation for details. 

• Add a new host-partition connection

• Delete a host-partition connection

• Modify the configuration of a host-partition connection
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Screen Fields

Partition Summary

Partition Number

Display only.

ID assigned to the partition. IDs can range from 1–8.

Storage Cells

Display only.

Total number of storage cells allocated to this partition. 

Drive Bays

Display only.

Total number of tape drives allocated to this partition. 

CAPs 

Display only.

Total number of rotational CAPs allocated to this partition; this number 
represents whole CAPs, not individual CAP cells. 

AEMs 

Display only.

Total number of AEMs allocated to this partition; this number represents whole 
AEMs, not individual AEM cells. 

CAP+AEM Cells

Display only.

Total number of individual rotational and AEM CAP cells allocated to this 
partition. 

%Activated Capacity 

Display only.

Percentage of the library’s activated capacity that has been allocated to this 
partition. Calculated as:

(partition) Allocated Storage Cells / (total library) Activated Capacity 

Details for Partition n 

Note – The following fields display host-partition connection 
information for the partition currently selected in the Partition 
Summary table. 
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Name

Display only.

Name assigned to the selected partition. 

Interface Type 

Display only.

Type of interface assigned to the selected host-partition connection. Options are:

• HLI

• FC-SCSI

Note – The following fields are available for FC-SCSI host-
partition connections only. 

Connections

Initiator (WWPN) 

Display only.

World Wide Port Name of the FC-SCSI host bus adapter (HBA). 

LUN

Display only.

Logical unit number of the library partition on the host. This entry must be unique 
on the host. 

Total Library Resources

Storage Cells  

Display only.

Total physical capacity of the library.

Drive Bays  

Display only.

Total number of tape drives in the library.

CAPs 

Display only.

Total number of rotational CAPs in the library.

AEMs 

Display only.

Total number of AEMs in the library.
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CAP cells

Display only.

Total number of rotational CAP cells in the library.

AEM cells 

Display only.

Total number of AEM cells in the library.

Activated Capacity 

Display only.

Total activated storage capacity of the library. 

Resources Allocated 

Storage Cells  

Display only.

Total number of storage cells allocated to all library partitions in the 
Design (Step 3b) screen. 

Drive Bays  

Display only.

Total number of tape drives allocated to all library partitions.

CAPs 

Display only.

Total number of rotational CAPs allocated to all library partitions.

AEMs 

Display only.

Total number of AEMs allocated to all library partitions.

CAP cells

Display only.

Total number of rotational CAP cells allocated to all library partitions.

AEM cells

Display only.

Total number of AEM cells allocated to all library partitions.
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Activated Capacity 

Display only.

Total activated storage capacity assigned to all library partitions through the 
Add Partition or Modify Partition screen. 

Resources Unallocated 

Storage Cells 

Display only.

Total number of storage cells in the library that are not allocated to any partition.

Drive Bays  

Display only.

Total number of tape drives in the library that are not allocated to any partition.

CAPs 

Display only.

Total number of rotational CAPs in the library that are not allocated to any library 
partition.

AEMs 

Display only.

Total number of AEMs in the library that are not allocated to any library partition.

CAP cells

Display only.

Total number of rotational CAP cells in the library that are not allocated to any 
partition.

AEM cells

Display only.

Total number of AEM cells in the library that are not allocated to any partition.

Capacity 

Display only.

Total activated storage capacity not assigned to any library partition through the 
Add Partition or Modify Partition screen. Calculated as:

(total library) Activated Capacity – (allocated) Activated Capacity 
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Buttons

Refresh 

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh 
popup appears, prompting you to confirm the refresh. 

? (Help)

Click to display online help for the screen. 

Add Partition

Click to add a new partition. The Partitions—Summary (Step 2)—Add Partition 
popup appears. 

Delete Partition

Click to delete the currently selected partition. The Partitions—Summary 
(Step 2)—Delete Partition popup appears. 

Modify Partition

Click to modify summary information for the currently selected partition. The 
Partitions—Summary (Step 2)—Modify Partition popup appears. 

Note – The following buttons are available for FC-SCSI host-
partition connections only. 

Add Connection

Click to add a new host connection to the currently selected partition. The 
Partitions—Summary (Step 2)—Add Connection popup appears. 

Delete Connection

Click to delete the currently selected host-partition connection. The Partitions—
Summary (Step 2)—Delete Connection popup appears.

Modify Connection

Click to modify the configuration of the currently selected host-partition 
connection. The Partitions—Summary (Step 2)—Modify Connection popup 
appears.

See Also

• Partitions—Summary (Step 2) 

• Partitions—Summary (Step 2)—Add Partition 

• Partitions—Summary (Step 2)—Delete Partition 

• Partitions—Summary (Step 2)—Modify Partition 

• Partitions—Summary (Step 2)—Add Connection 
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• Partitions—Summary (Step 2)—Delete Connection 

• Partitions—Summary (Step 2)—Modify Connection 

• Partitions—Module Map (Step 3a) 

• Partitions—Design (Step 3b) 

• Partitions—Commit (Step 4) 

• Partitions—Reports 
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Partitions—Summary (Step 2)—Add Connection

Sample Screen

Description

Allows you to configure the connection between a host and the selected partition. 
Each partition can have up to nine host-partition connections. 

Note – This screen is available for FC-SCSI host-partition 
connections only. HLI host-partition connections are configured 
through the host library management software (ELS or ACSLS), 
not through the SL Console. See the ELS or ACSLS documentation 
for details.

This screen is a popup that appears when you click Add Connection on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 

Screen Fields

Connections n 

Display only.

Partition ID of the selected partition. 

Initiator (WWPN)

Required.

World Wide Port Name of the FC-SCSI host bus adapter (HBA). 

Sixteen hexadecimal digits. You can enter upper- or lower-case hex digits, but the 
display is always shown in all upper-case. 
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LUN

Required.

Logical unit number of the library partition on the host. This entry must be unique 
on the host. You can create up to nine unique LUNs per partition. 

Note – Each initiator connected to the library must have one 
library partition assigned to LUN 0. When you verify or commit 
partition configuration changes, the SL Console will notify you if 
an initiator does not meet this requirement. 

Buttons

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also

• Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Delete Connection

Sample Screen

Description

Allows you to delete the selected host-partition connection. 

Note – This screen is available for FC-SCSI host-partition 
connections only. HLI host-partition connections are configured 
through the host library management software (ELS or ACSLS), 
not through the SL Console. See the ELS or ACSLS documentation 
for details.

This screen is a popup that appears when you click Delete Connection on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 

Screen Fields

None

Buttons

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also

• Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Modify Connection

Sample Screen

Description

Allows you to modify the configuration of the selected host-partition connection. 

Note – This screen is available for FC-SCSI host-partition 
connections only. HLI host-partition connections are configured 
through the host library management software (ELS or ACSLS), 
not through the SL Console. See the ELS or ACSLS documentation 
for details.

This screen is a popup that appears when you click Modify Connection on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 

Screen Fields

Initiator (WWPN)

World Wide Port Name of the FC-SCSI host bus adapter (HBA). 

Sixteen hexadecimal digits. You can enter upper- or lower-case hex digits, but the 
display is always shown in all upper-case. 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 

LUN

Required.

Logical unit number of the library partition on the host. This entry must be unique 
on the host. 
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Note – Each initiator connected to the library must have one 
library partition assigned to LUN 0. When you verify or commit 
partition configuration changes, the SL Console will notify you if 
an initiator does not meet this requirement. 

Buttons

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also

• Partitions—Summary (Step 2) 



268  SL3000 User’s Guide March 2011 

 

Partitions—Summary (Step 2)—Add Partition 

Sample Screen

Description

Allows you to add a new partition. You can create up to eight partitions, with IDs 
ranging from 1–8. 

This screen is a popup that appears when you click Add Partition on the Partitions—
Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 

Screen Fields

Select a Partition ID

Required.

Partition ID you want to add. Options are 1–8. 

The pull-down menu displays all available IDs; the default is the next available ID 
in numerical order. 

Name 

Optional.

Name you want to assign to the partition. 

0–60 ASCII characters. 

Interface Type 

Required.

Type of interface to be used for this host-partition connection. Options are:
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• HLI

• FC-SCSI 

Buttons

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also

• Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Delete Partition

Sample Screen

Description

Allows you to confirm that you want to delete the specified partition. All information 
for the partition – including host-partition connections, partition boundaries, and 
partition ID – are deleted from the SL Console partition workspace. 

This screen is a popup that appears when you click Delete Partition on the 
Partitions—Summary (Step 2). 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 

Screen Fields

None

Buttons

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also

• Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Modify Partition

Sample Screen

Description

Allows you to modify the name or host-partition connection type assigned to the 
selected partition. 

This screen is a popup that appears when you click Modify Partition on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 

Screen Fields

Modify Partition n 

Display only.

ID of the partition you want to modify. 

Name 

Required.

Name you want to assign to the partition. 

0–60 ASCII characters. 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 
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Interface Type 

Type of interface to be used for this host-partition connection. Options are:

• HLI

• FC-SCSI 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 

Note – Changing the interface type can result in the loss of active 
host connections and shared rotational or AEM CAP allocations. 
See “Modify the Interface Type of a Host-Partition 
Connection” on page 227 for details. 

Buttons

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also

• Partitions—Summary (Step 2) 
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Partition Design and Commit Screens

Partitions—Module Map (Step 3a)

Partitions—Design (Step 3b)

Partitions—Design (Step 3b) – AEMs Only

Partitions—Design (Step 3b)—Verify Results

Partitions—Commit (Step 4)

Partitions—Commit (Step 4)—Confirm Apply

Partitions—Current Partition Definitions
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Partitions—Module Map (Step 3a)

Sample Screen

Description

Allows you to select the library module for which you want to define partition 
boundaries. 

Screen Fields

Select a module from the map below 

Required.

The screen displays an illustration of the library’s actual module configuration. 
This information is taken directly from the library controller database. 

Click the module for which you want to design a partition, then click the 
Design (Step 3b) tab. 

Buttons

? (Help)

Click to display online help for the screen. 
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See Also

• Partitions—Design (Step 3b) 

• Partitions—Design (Step 3b) – AEMs Only 
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Partitions—Design (Step 3b)

Note – This section describes the Design (Step 3b) screens for 
Base, Drive, and CEM modules. For AEM modules, see 
“Partitions—Design (Step 3b) – AEMs Only” on page 282. 

Sample Screen

Description

Allows you to define partition boundaries by selecting the resources (storage cells, 
tape drives, or rotational CAPs) you want to include in the partition. You can use any 
of the following methods to add or remove resources from a partition (see “Library 
Map” on page 280 for detailed instructions): 

• Select individual cells or groups of cells 

• Select an entire column within a library module (top to bottom) 

• Select a side within a library module (front or back) 

• Select an entire library module

Note – This screen is available only if partitions have been 
defined for the library through the Partitions—Summary 
(Step 2)—Add Partition screen. 
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Caution – Changing partition boundaries can result in orphaned 
cartridges and data that could be lost. See “Orphaned Cartridges in 
Partitioned Libraries” on page 194 for details. 

Note – The partition Summary (Step 2) and Design (Step 3b) 
screens, and all associated popups, give you a dynamic workspace 
to design your library partitions. All partition configuration 
information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your 
SL Console session. This allows you to switch among partition 
views and leave and return to the partition screens any number of 
times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 

Screen Fields

Partition

Required.

Partition to which you want to add or remove resources (storage cells, tape drives, 
or rotational CAPs). 

The pull-down menu displays all valid partition IDs for the library. It also 
identifies their host interface type (FC-SCSI or HLI). If no partition IDs have been 
defined, the menu is blank. 

Note – When you select a partition, the screen is automatically 
updated to display data for that partition from the SL Console 
partition workspace. 

Select by

Required.

Indicates the method you want to use for defining partition boundaries. Options 
are:

• Cell – Select individual or rectangular groups of resources.

• Column – Select all resources within a column. 

• Side – Select all resources, except the CAP, within one side of a library module. 

• Module – Select all resources, except the CAP, within a library module. 

Note – You must select either Add or Remove. 

Add 

Required.
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Indicates you want to add resources to the partition. You will only be able to click 
unallocated resources on the library map. 

Remove

Required.

Indicates you want to remove resources from the partition. You will only be able 
to click allocated resources on the library map. 

Allocated to Partition n 

Note – The data in these fields is automatically updated from the 
SL Console partition workspace when you select a partition.

Storage Cells 

Display only.

Total number of storage cells allocated to the selected partition, based on the 
currently defined partition boundaries. 

Drive Bays

Display only.

Total number of tape drives allocated to the selected partition, based on the 
currently defined partition boundaries. 

CAP Cells

Display only.

Total number of rotational and AEM CAP cells allocated to the selected partition, 
based on the currently defined partition boundaries. 

Unallocated in Library 

Note – The data in these fields is automatically updated from the 
SL Console partition workspace when you select a partition.

StorageCells 

Display only.

Total number of storage cells in the library that are not allocated to any partition.

Drive Bays

Display only.

Total number of tape drives in the library that are not allocated to any partition.

CAP Cells

Display only.
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Total number of rotational and AEM CAP cells in the library that are not allocated 
to any partition.

Activated Capacity 

Note – This field appears only if the library has unallocated 
activated capacity. If allocations exceed activated capacity (an 
oversubscription situation), the Oversubscription field appears. 

Display only.

Total activated capacity of the library that is not allocated to any partition. 
Calculated as:

Total activated capacity – Total allocated storage cells 

Oversubscription 

Note – This field appears only if allocations exceed activated 
capacity (an oversubscription situation). If the library has 
unallocated activated capacity, the Activated Capacity field 
appears. 

Display only.

Total activated capacity of the library that has been exceeded through partition 
allocations. Calculated as:

Total allocated storage cells – Total activated capacity 

You must remove the excess allocations before you can commit your changes 
through the Commit (Step 4) screen. 

Legend 

Legend for the library map. The state of each library resource (storage cell, tape 
drive, or rotational CAP cell) is indicated as follows: 

• Not Accessible (white and x-ed out). Resource is not accessible to any partition. 
Following are some possible reasons:

• Storage cells have been configured for diagnostic cartridges. 

• Storage cells are not included in the library’s activated capacity. 

• Unallocated. Resource is currently not allocated to any partition and therefore 
available to the selected partition. 

• Partition n (gold). Resource is allocated to the selected partition, partition n. 

• Other Partitions (red). Resource is allocated to another partition and therefore 
NOT available to the selected partition. 

• Shared CAP (gray background). CAP has been assigned to at least one 
partition. The host interface type assigned to the CAP (HLI or FC-SCSI) is 
displayed. 

• Cartridge (cartridge icon). Resource contains a tape cartridge. 

• Drive slots with installed drives are outlined with a thick border. Empty drive 
slots have a narrow border. 
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Library Map 

Graphical representation of the current library configuration. Initial display for 
the current SL Console login session is from the library controller database, then 
the display reflects data from the SL Console partition workspace as you modify 
partition configurations. The display includes the following information:

• Type of module currently displayed (base module, drive expansion module, or 
parking expansion module) 

• Numeric module ID (1–12)

• Host-partition connection type of a shared CAP (FC-SCSI or HLI) 

• Location of all resources (storage cells, tape drives, rotational CAP cells) within 
the library 

Note – Move the cursor over any resource to display a tooltip of 
detailed information about the cell or drive, its partition 
assignment, and the identity of any resident cartridge. 

Note – If no partition IDs have been defined, the library map is 
display only.

Use the library map to modify the boundaries of the selected partition. Depending 
on whether you have clicked the Add or Remove radio button, all selected 
resources are either added to or removed from the partition. 

Depending on your choice in the Select by field, you can perform any of the 
following actions. 

• Select by cell – Select individual or groups of resources. Resources in a 
partition do not need to be adjacent to one another. 

• To select an individual resource, double-click it.

• To select a rectangular group of resources, click the cell or drive at one 
corner of the rectangle, and then click the cell or drive diagonally opposite. 

• Select by column – Select an entire column within the module. Columns in a 
partition do not need to be adjacent to one another. To select a column, click 
any resource within the column. 

• Select by side – Select an entire side within a module, except the CAP. Sides in 
a partition do not need to be adjacent to one another. To select one side of a 
library module, click any resource in that side. 

• Select by module – Select an entire module, except the CAP. Modules in a 
partition do not have to be adjacent to one another. To select a library module, 
click any resource in that module. 

Buttons

Move Left 

Click to display the library module directly to the left of the one currently 
displayed. This button is grayed out if there is no module to the left. 
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Move Right 

Click to display the library module directly to the right of the one currently 
displayed. This button is grayed out if there is no module to the right. 

Verify 

Click to verify partition configuration changes you have made during this 
SL Console login session. The Tools > Partitions—Design (Step 3b)—Verify 
Results popup appears, indicating whether there are any orphaned cartridges or 
other errors in the current partition configuration.

Note – This procedure verifies only one partition at a time. If you 
need to verify multiple partitions, you must repeat this procedure 
separately for each partition. 

Note – This verification is performed on the current partition 
configuration in the SL Console partition workspace only. It does 
not verify current partition boundaries against the library 
controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge 
movements or library configuration changes—through the 
command line interface, other SL Console sessions, or host 
applications—at the same time you have made partition changes. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh 
popup appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also

• Partitions—Summary (Step 2) 

• Partitions—Module Map (Step 3a)

• Partitions—Design (Step 3b) – AEMs Only

• Partitions—Design (Step 3b)—Verify Results 

• Partitions—Commit (Step 4) 

• Partitions—Current Partition Definitions 

• Partitions—Reports 
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Partitions—Design (Step 3b) – AEMs Only

Note – This section describes the Design (Step 3b) screen for AEM 
modules only. For Base, Drive, and CEM modules, see 
“Partitions—Design (Step 3b)” on page 276. 

Note – This screen is available only if the library configuration 
includes one or more AEMs. 

Sample Screen 

Description

Allows you to define partition boundaries by allocating all cells in an AEM to a 
partition. As with rotational CAPs, multiple partitions can share an AEM CAP, if the 
partitions have the same host interface type (HLI or FC-SCSI). 

Note – This screen is available only if partitions have been 
defined for the library through the Partitions—Summary 
(Step 2)—Add Partition screen. 

Caution – Changing partition boundaries can result in orphaned 
cartridges and data that could be lost. See “Orphaned Cartridges in 
Partitioned Libraries” on page 194 for details. 
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Note – The partition Summary (Step 2) and Design (Step 3b) 
screens, and all associated popups, give you a dynamic workspace 
to design your library partitions. All partition configuration 
information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your 
SL Console session. This allows you to switch among partition 
views and leave and return to the partition screens any number of 
times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 

Screen Fields

Partition

Required.

Partition to which you want to add or remove AEM CAP cells. 

The drop-down menu displays all valid partition IDs for the library. It also 
identifies their host interface type (FC-SCSI or HLI). If no partition IDs have been 
defined, the menu is blank. 

Note – When you select a partition, the screen is automatically 
updated to display data for that partition from the SL Console 
partition workspace. 

Select by

Required.

Indicates the method you want to use for defining partition boundaries. 
Regardless of the option you choose, all cells within the AEM will be selected at 
once. 

Note – You must select either Add or Remove. 

Add 

Required.

Indicates you want to add the AEM to the partition. This option is valid only if the 
AEM is currently unallocated. 

Remove

Required.

Indicates you want to remove the AEM from the partition. This option is valid 
only if the AEM is currently allocated. 
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Allocated to Partition n 

Note – The data in these fields is automatically updated from the 
SL Console partition workspace when you select a partition.

Storage Cells 

Display only.

Total number of storage cells allocated to the selected partition, based on the 
currently defined partition boundaries. 

Drive Bays

Display only.

Total number of tape drives allocated to the selected partition, based on the 
currently defined partition boundaries. 

CAP Cells

Display only.

Total number of rotational and AEM CAP cells allocated to the selected partition, 
based on the currently defined partition boundaries. 

Unallocated in Library 

Note – The data in these fields is automatically updated from the 
SL Console partition workspace when you select a partition.

Storage Cells 

Display only.

Total number of storage cells in the library that are not allocated to any partition.

Drive Bays

Display only.

Total number of tape drives in the library that are not allocated to any partition.

CAP Cells

Display only.

Total number of rotational and AEM CAP cells in the library that are not allocated 
to any partition.

Activated Capacity 

Note – This field appears only if the library has unallocated 
activated capacity. If allocations exceed activated capacity (an 
oversubscription situation), the Oversubscription field appears. 

Display only.
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Total activated capacity of the library that is not allocated to any partition. 
Calculated as:

Total activated capacity – Total allocated storage cells 

Oversubscription 

Note – This field appears only if allocations exceed activated 
capacity (an oversubscription situation). If the library has 
unallocated activated capacity, the Activated Capacity field 
appears. 

Display only.

Total activated capacity of the library that has been exceeded through partition 
allocations. Calculated as:

Total allocated storage cells – Total activated capacity 

You must remove the excess allocations before you can commit your changes 
through the Commit (Step 4) screen. 

Legend 

Legend for the library map. The state of each AEM CAP cell is indicated as 
follows: 

• Not Accessible (white and x-ed out). Resource is not accessible to any partition. 
Following are some possible reasons:

• Storage cells have been configured for diagnostic cartridges. 

• Storage cells are not included in the library’s activated capacity. 

• Unallocated. Resource is currently not allocated to any partition and therefore 
available to the selected partition. 

• Partition n (gold). Resource is allocated to the selected partition, partition n. 

• Other Partitions (red). Resource is allocated to another partition and therefore 
NOT available to the selected partition. 

• Shared AEM CAP (gray background). AEM CAP has been assigned to at least 
one partition. The host interface type assigned to the AEM CAP (HLI or 
FC-SCSI) is displayed. 

• Cartridge (cartridge icon). Resource contains a tape cartridge. 

AEM Map 

Graphical representation of the current AEM configuration. Initial display for the 
current SL Console login session is from the library controller database, then the 
display reflects data from the SL Console partition workspace as you modify 
partition configurations. The display includes the following information:

• Type of module currently displayed; for AEMs, this is always “Access 
Module”. 

• Numeric module ID (1–12)
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• Current module view indicator (“Door Closed View” or “Door Open View”) 

• Host interface type of the partition(s) to which the AEM is allocated (FC-SCSI 
or HLI) 

• CAP type; for AEMs, this is always “Bulk Load CAP”. 

• Location of all storage cells within the AEM 

Note – Move the cursor over any resource to display a tooltip of 
detailed information about the cell or drive, its partition 
assignment, and the identity of any resident cartridge. 

Note – If no partition IDs have been defined, the library map is 
display only.

Use the library map to modify the partition allocation of the AEM. Depending on 
whether you have clicked the Add or Remove radio button, the entire AEM is 
either added to or removed from the partition. 

Buttons

Move Left 

Click to display the library module directly to the left of the one currently 
displayed. This button is grayed out if there is no module to the left. 

Move Right 

Click to display the library module directly to the right of the one currently 
displayed. This button is grayed out if there is no module to the right. 

Note – The “Door Closed View” is the default AEM view. You 
can use the next two buttons to toggle between the alternate 
views. 

Show Door Open View

Click to display the layout of the AEM CAP cells as if the AEM access door were 
open and you are looking directly at the interior of the AEM. 

Show Door Closed View

Click to show display the layout of the AEM CAP cells as if the AEM access door 
were closed and you are “looking through” the front access door panel to the 
interior of the AEM. 

Verify

Click to verify partition configuration changes you have made during this 
SL Console login session. The Tools > Partitions—Design (Step 3b)—Verify 
Results popup appears, indicating whether there are any orphaned cartridges or 
other errors in the current partition configuration.

Note – This procedure verifies only one partition at a time. If you 
need to verify multiple partitions, you must repeat this procedure 
separately for each partition. 
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Note – This verification is performed on the current partition 
configuration in the SL Console partition workspace only. It does 
not verify current partition boundaries against the library 
controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge 
movements or library configuration changes—through the 
command line interface, other SL Console sessions, or host 
applications—at the same time you have made partition changes. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh 
popup appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also

• Partitions—Summary (Step 2) 

• Partitions—Module Map (Step 3a)

• Partitions—Design (Step 3b)

• Partitions—Design (Step 3b)—Verify Results 

• Partitions—Commit (Step 4) 

• Partitions—Current Partition Definitions 

• Partitions—Reports 
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Partitions—Design (Step 3b)—Verify Results

Sample Screen

Description

Displays a list of configuration errors in the current SL Console partition workspace. 

This screen is a popup that appears when you click Verify Results on the 
Partitions—Design (Step 3b) screen. 

Possible errors include:

• A partition has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” for details.

• Library resources have been removed from a partition. 

• A host-partition connection does not have a partition assigned to LUN 0 (applies 
to FC-SCSI connections only). 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 

It is recommended that you resolve all errors before committing the data to the 
library controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 

Note – The partition Summary (Step 2) and Design (Step 3b) 
screens, and all associated popups, give you a dynamic workspace 
to design your library partitions. All partition configuration 
information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your 
SL Console session. This allows you to switch among partition 
views and leave and return to the partition screens any number of 
times without losing your configuration changes. 
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Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 

Screen Fields

Note – The screen fields are the same as those displayed in the 
Partitions—Commit (Step 4)—Confirm Apply popup. 

Warnings found

Display only.

Summary error messages regarding the partition configuration. 

The library is oversubscribed. Please unallocate nnn storage cells. 

Display only.

Indicates that the total partition allocations currently exceed the library’s activated 
capacity. nnn is the number of cells you must remove from partition allocations. 
The Apply button on the Commit (Step 4) screen remains deactivated until the 
total allocated cells is within the library’s activated capacity. 

The following hosts will need re-audited

Display only.

World Wide Port Names (WWPNs) of any hosts that should re-audit their library 
partition. This may be because library resources have been deleted from the 
partition. 

The following hosts do not have Lun 0 set

Display only.

World Wide Port Names (WWPNs) of any hosts that have not defined any library 
partitions as LUN 0 on the host. This error applies to FC-SCSI host-partition 
connections only. 

The following orphaned cartridges were found

Display only.

Detailed information regarding all orphaned cartridges in the current partition 
configuration. Includes library, rail, column, side, and row location of the 
cartridge, cartridge volume serial number (VOLID), and probable causes and 
explanations why the cartridge is orphaned. 
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Buttons

Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

OK

Click to cancel the update. The library controller database is not updated, but all 
partition changes from this login session are retained in the SL Console partition 
workspace. 

Details 

Click to toggle between the expanded and collapsed views of the warning 
message display. 

See Also

• Partitions—Design (Step 3b) 

• Partitions—Commit (Step 4)—Confirm Apply 
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Partitions—Commit (Step 4)

Sample Screen

Description

Allows you to commit all data from the current SL Console partition workspace to 
the library controller database. The following data will be committed for all 
partitions: 

• Partition summary information 

• Host-partition connection configuration information 

• Partition boundary details 

Caution – Although partition changes are not disruptive to library 
hosts, it is recommended that you make the library unavailable to 
other users before committing your partition workspace changes. 
Because the SL Console does not validate partition boundaries 
against the library controller database in real-time, configuration 
conflicts may arise if you change partition boundaries while other 
users are performing cartridge movements or library configuration 
changes. See “Synchronizing the Display With the Controller 
Database” on page 64 for details. 
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Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 

Caution – It is recommended that you follow the Resolve 
Orphaned Cartridges procedure before using this screen. 

Caution – This screen updates the library controller database with 
all partition configuration changes you have made during this 
SL Console session. Failure to use this screen before logging out of 
the current SL Console session will cause all your library 
configuration changes to be lost.

Screen Fields

None 

Buttons

Apply

Click to update the library controller database with the current settings from the 
SL Console partition workspace. The Tools > Partitions—Commit (Step 4)—
Confirm Apply popup appears, indicating whether there are any orphaned 
cartridges or other errors in the current partition configuration. 

Note – This button is grayed out if total partition allocations 
currently exceed the library’s activated capacity. To activate the 
button, you must remove storage cells from partition allocations 
to bring the total allocated cells within the library’s activated 
capacity.

Note – This button is grayed out if you have not made any 
changes to the SL Console partition workspace since the last 
commit. 

? (Help) 

Click to display online help for the screen. 

See Also

• Partitions—Summary (Step 2) 

• Partitions—Design (Step 3b) 

• Partitions—Design (Step 3b)—Verify Results 

• Partitions—Commit (Step 4)—Confirm Apply 

• Partitions—Reports 
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Partitions—Commit (Step 4)—Confirm Apply

Sample Screen

Description

Displays a list of configuration errors in the current SL Console partition workspace. 
This screen is a popup that appears when you click Apply on the Partitions—
Commit (Step 4) screen. 

After viewing the error messages, you can commit all data in the SL Console partition 
workspace to the library controller database by clicking the Yes button. 

Possible errors include:

• A partition has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” for details.

• Library resources have been removed from a partition. 

• A host-partition connection does not have a partition assigned to LUN 0 (applies 
to FC-SCSI connections only). 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 

It is recommended that you resolve all errors before committing the data to the 
library controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
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the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) 
screens and all associated popups. 

Caution – Screen Fields

Note – The screen fields are the same as those displayed in the 
Partitions—Design (Step 3b)—Verify Results popup. 

Warnings found

Display only.

Summary error messages regarding the partition configuration. 

The library is oversubscribed. Please unallocate nnn storage cells. 

Display only.

Indicates that the total partition allocations currently exceed the library’s activated 
capacity. nnn is the number of cells you must remove from partition allocations. 
The Apply button on the Commit (Step 4) screen remains deactivated until the 
total allocated cells is within the library’s activated capacity. 

The following hosts will need re-audited

Display only.

World Wide Port Names (WWPNs) of any hosts that should re-audit their library 
partition. This may be because library resources have been deleted from the 
partition. 

The following hosts do not have Lun 0 set

Display only.

World Wide Port Names (WWPNs) of any hosts that have not defined any library 
partitions as LUN 0 on the host. This error applies to FC-SCSI host-partition 
connections only. 

The following orphaned cartridges were found

Display only.

Detailed information regarding all orphaned cartridges in the current partition 
configuration. Includes library, rail, column, side, and row location of the 
cartridge, cartridge volume serial number (VOLID), and probable causes and 
explanations why the cartridge is orphaned. 

Buttons

Print

Click to print the report on a selected printer.
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Save 

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Yes

Click to confirm that you want to update the library controller database with the 
current settings from the SL Console workspace. 

No

Click to cancel the update. The library controller database is not updated, but all 
partition changes from this login session are retained in the SL Console partition 
workspace. 

Details 

Click to toggle between the expanded and collapsed views of the warning 
message display. 

See Also

• Partitions—Commit (Step 4) 

• Partitions—Design (Step 3b)—Verify Results 
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Partitions—Current Partition Definitions

Sample Screen

Description

Displays current partition boundaries and allocations. This is the only Partitions 
screen that is available on the local operator panel.

Note – This screen is display only. 

Screen Fields

For detailed descriptions of the screen fields, see one of the following sections:

• “Partitions—Design (Step 3b)” on page 276, for Base, Drive, and CEM modules

• “Partitions—Design (Step 3b) – AEMs Only” on page 282, for AEMs 

Buttons

Refresh

Click to refresh the display with current data from the library controller database. 
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? (Help) 

Click to display online help for the screen. 

See Also

• Partitions—Design (Step 3b) 

• Partitions—Design (Step 3b) – AEMs Only
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Partition Report Screens

Screen Page

Partitions—Reports  299

Partitions—Reports—Cartridge Cell and Media Summary  301

Partitions—Reports—Host Connections Summary  304

Partitions—Reports—Orphaned Cartridge Report  307

Partitions—Reports—Partition Details  310

Partitions—Reports—Partition Summary  314
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Partitions—Reports

Sample Screen

Description

Allows you to select one of the following library partition reports:

• Cartridge Cell and Media Summary

• Host Connections Summary

• Orphaned Cartridge Report

• Partition Details

• Partition Summary

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without commiting the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3b) screens. 
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Screen Fields

Please select a report to display

Required.

Click the report you want to display. The drop-down menu lists all available 
library partition reports. 

Buttons

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh 
popup appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also

• Partitions—Summary (Step 2) 

• Partitions—Design (Step 3b) 

• Partitions—Commit (Step 4) 

• Partitions—Reports—Cartridge Cell and Media Summary 

• Partitions—Reports—Host Connections Summary 

• Partitions—Reports—Orphaned Cartridge Report 

• Partitions—Reports—Partition Details 

• Partitions—Reports—Partition Summary 
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Partitions—Reports—Cartridge Cell and Media Summary

Sample Screen

Description

Displays detailed information about all library resources (storage cells, tape drives, 
and rotational or AEM CAP cells) and any stored cartridges.

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without commiting the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3b) screens. 

Note – AEM CAP cells are identified as follows: left AEM CAP 
cells are in columns “-33” to “-31”; right AEM CAP cells are in 
columns “31” to “33”. 

Note – You can modify the layout and display of this screen. See 
“Modifying the Screen Layout” on page 64 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields

Column

Display only.

Column number where the library resource is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right; “-1” is to the 
left.

Side

Display only.

Module side where the library resource is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the library resource is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Partition ID

Display only.

Partition ID to which the library resource is allocated, if applicable. 

Partition Name

Display only.

Name of the partition to which the library resource is allocated, if applicable. If 
the library has no defined partitions, “Non-Partitioned Library” is displayed. 

Element Type

Display only.

Type of library resource. Options are:

• CAP (rotational or AEM) 

• CELL

• DRIVE

Vol Ser 

Display only.

Volume serial number (VOLID) of the cartridge resident in the library resource, if 
applicable. 

Cell Status

Display only.
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Capacity status of the library resource. Applies to storage cells only. Options are:

• Active – Cell is activated for use based on assigned capacity; can be used for 
cartridge storage. 

• Inactive – Cell is not activated for use; cannot be used for cartridge storage. 

HLI/SCSI Address

Display only.

Host address of the library resource. Format of the entry depends on the host-
partition connection type (HLI or FC-SCSI). 

• HLI – Format is eight digits in the following format. See “HLI-PRC 
Address” on page 193 for additional details.

ll – Library number; always 0

pp – Column number

rr – Row number

cc – Column number

• FC-SCSI – Format is four digits. See “Host SCSI Element Address” on page 192 
for details.

Buttons

Print

Click to print the report on a selected printer.

Save to File

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also

• Partitions—Reports—Host Connections Summary 

• Partitions—Reports—Orphaned Cartridge Report 

• Partitions—Reports—Partition Details 

• Partitions—Reports—Partition Summary 
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Partitions—Reports—Host Connections Summary

Sample Screen

Description

Displays detailed information about all host-partition connections for the library. 

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without commiting the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3b) screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 64 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Fields

Partitions

Note – The screen fields in this section also appear on the 
Partitions—Reports—Partition Summary report.
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Partition ID

Display only.

ID of the partition (1–8). 

Partition Name

Display only.

Name of the partition. 

Connection Type 

Display only.

Type of interface used by the host-partition connection. Options are:

• HLI 

• FC-SCSI 

Storage Cells 

Display only.

Total number of storage cells allocated to the partition.

Media in Storage Cells

Display only.

Total number of tape cartridges resident in the partition’s storage cells. 

% Storage Cells w/ Media

Display only.

Percentage of storage cells containing tape cartridges. Calculated as Media in 
Storage Cells / Storage Cells. 

Drives

Display only.

Total number of drives allocated to the partition. 

CAP Cells 

Display only.

Total number of rotational CAP cells allocated to the partition. 

AEM Cells 

Display only.

Total number of AEM CAP cells allocated to the partition. 
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Active Cells

Display only.

Total storage cell capacity assigned to the partition in the Add Partition screen. 

Host Connections

Initiator WWPN

Display only.

World Wide Port Name of an FC-SCSI host bus adapter (HBA) with a connection 
to the partition. 

LUN

Display only.

Logical unit number of the library partition on the host.

Partition ID 

Display only.

Partition ID to which the host has a connection. 

Buttons

Print

Click to print the report on a selected printer.

Save to File 

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also

• Partitions—Reports—Cartridge Cell and Media Summary 

• Partitions—Reports—Orphaned Cartridge Report 

• Partitions—Reports—Partition Details 

• Partitions—Reports—Partition Summary 
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Partitions—Reports—Orphaned Cartridge Report 

Sample Screen

Description

Displays the locations and volume serial numbers (VOLIDs) of all orphaned 
cartridges in the library. Also identifies why the cartridge is orphaned. 

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without commiting the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3b) screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 64 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Fields

Column

Display only.
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Column number where the orphaned cartridge is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right; “-1” is to the 
left.

Side

Display only.

Module side where the orphaned cartridge is located. “1” is the back wall; “2” is 
the front wall.

Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Vol Ser 

Display only.

Volume serial number (VOLID) of the orphaned cartridge. 

Explanation

Display only.

Explanation of why the cartridge is orphaned. 

Because this report is produced from the library controller database, the only 
option is:

• Unreachable from any host 

Buttons

Print

Click to print the report on a selected printer.

Save to File 

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also

• Partitions—Reports—Cartridge Cell and Media Summary 

• Partitions—Reports—Host Connections Summary 

• Partitions—Reports—Partition Details 
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• Partitions—Reports—Partition Summary 
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Partitions—Reports—Partition Details

Sample Screen

Description

Displays detailed information for a selected partition. 

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without commiting the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3b) screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 64 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields

Partition Name

Display only.

Name of the partition. 

Partition ID

Display only.

ID of the partition (1–8). 

Bar Code

Display only.

Bar code format assigned to the partition. 

Connection Type 

Display only.

Type of interface used by the host-partition connection. Options are:

• HLI 

• FC-SCSI 

Assigned Cells 

Display only.

Total number of storage cells allocated to the partition.

Available Cells 

Display only.

Total number of storage cells in the library available for allocation to the partition.

Occupied Cells 

Display only.

Total number of storage cells in the partition with tape cartridges present.

Activated Capacity 

Display only.

Total storage cell capacity assigned to the partition in the Add Partition screen. 

Assigned Drive Bays 

Display only.

Total number of drive bays allocated to the partition.



312  SL3000 User’s Guide March 2011 

 

Available Drive Bays 

Display only.

Total number of drive bays in the library available for allocation to the partition.

Number of Drives

Display only.

Total number of installed tape drives allocated to the partition. 

Occupied Drives 

Display only.

Total number of installed tape drives in the partition with tape cartridges present.

Assigned CAP cells 

Display only.

Total number of rotational CAP cells allocated to the partition through dedicated 
or shared CAPs. 

Available CAP cells

Display only.

Total number of rotational CAP cells in the library available for allocation to the 
partition. This number includes all rotational and AEM CAP cells in the following:

• CAPs not allocated to any partition. 

• CAPs not currently allocated to this partition, but allocated to other partitions 
with the same host interface type as this one. 

This number excludes all rotational and AEM CAP cells in the following:. 

• CAPs currently allocated to this partition.

• CAPs allocated to partitions with a different host interface type. 

Occupied CAP cells

Display only.

Total number of rotational CAP cells in the partition with tape cartridges present.

Assigned AEM cells 

Display only.

Total number of AEM CAP cells allocated to the partition through dedicated or 
shared AEMs. 

Available AEM cells

Display only.
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Total number of AEM CAP cells in the library available for allocation to the 
partition. This number includes all AEM cells in the following:

• AEMs not allocated to any partition. 

• AEMs not currently allocated to this partition, but allocated to other partitions 
with the same host interface type as this one. 

This number excludes all AEM cells in the following: 

• AEMs currently allocated to this partition.

• AEMs allocated to partitions with a different host interface type. 

Occupied AEM cells

Display only.

Total number of AEM CAP cells in the partition with tape cartridges present.

% Cell Capacity (Assigned Cells/Total Cells) 

Display only.

Percentage of storage cells in the library allocated to this partition. Calculated as:

Number of cells allocated to the partition / Total physical capacity of the 
library 

Buttons

Print

Click to print the report on a selected printer.

Save to File 

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also

• Partitions—Reports—Cartridge Cell and Media Summary 

• Partitions—Reports—Host Connections Summary 

• Partitions—Reports—Orphaned Cartridge Report 

• Partitions—Reports—Partition Summary 
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Partitions—Reports—Partition Summary

Sample Screen

Description

Displays summary information for all partitions in the library. 

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without commiting the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3b) screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 64 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Fields

Note – These screen fields also appear on the Partitions—
Reports—Host Connections Summary report.
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Partition ID

Display only.

ID of the partition (1–8). 

Partition Name

Display only.

Name of the partition. 

Connection Type 

Display only.

Type of interface used by the host-partition connection. Options are:

• HLI 

• FC-SCSI 

Storage Cells 

Display only.

Total number of storage cells allocated to the partition.

Media in Storage Cells

Display only.

Total number of tape cartridges resident in the partition’s storage cells. 

% Storage Cells w/ Media

Display only.

Percentage of storage cells containing tape cartridges. Calculated as Media in 
Storage Cells / Storage Cells. 

Drives

Display only.

Total number of drives allocated to the partition. 

CAP Cells 

Display only.

Total number of rotational CAP cells allocated to the partition. 

AEM Cells 

Display only.

Total number of AEM CAP cells allocated to the partition. 



316  SL3000 User’s Guide March 2011 

 

Active Cells

Display only.

Total storage cell capacity assigned to the partition in the Add Partition screen. 

Buttons

Print

Click to print the report on a selected printer.

Save to File 

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also

• Partitions—Reports—Cartridge Cell and Media Summary 

• Partitions—Reports—Host Connections Summary 

• Partitions—Reports—Orphaned Cartridge Report 

• Partitions—Reports—Partition Details 
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Partition CAP Operation Screens

CAP Assignment

Diagnostics > CAP—Unreserve
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CAP Assignment 

Sample Screen

Description

Allows you to perform either of the following actions:

• For shared FC-SCSI CAPs only, you can perform partition-CAP associations prior 
to using the CAP to enter or eject cartridges to or from a partition. Partition-CAP 
associations reserve a shared FC-SCSI CAP for the exclusive use of the selected 
partition. All shared CAPs are modified in the same way; it is not possible to 
modify control of just one shared CAP.

• For all FC-SCSI CAPs (shared or dedicated), you can give control of a CAP to the 
library controller for diagnostic operations. 

Modifications made with this screen remain in effect until they are explicitly 
removed.

Note – This screen is not available if the library has no FC-SCSI 
CAPs. 
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Note – This screen is used for both rotational and AEM CAPs. 
Throughout this section, the term “CAP” refers to both types of 
CAPs. 

The following rules apply when using this screen:

• You can use this screen for shared FC-SCSI CAPs only. You cannot use this screen 
for HLI partitions because HLI host applications always use CAP reservations.

• You do not need to use this screen for dedicated CAPs because a partition always 
has ownership of its dedicated CAPs. 

• You can associate only one partition at a time to a CAP. 

• Selecting a partition causes all its allocated CAPs to be associated to it at once; you 
cannot select individual CAPs to be associated to the partition. 

• Partition-CAP associations remain active until you explicitly remove them; the 
associations are not automatically removed when the enter or eject operation 
completes. 

• Partition-CAP associations are removed during library reboots, power cycles, 
library door open/close operations, or CAP initializations 

• Partition-CAP associations are removed if the CAP becomes allocated to a 
different partition through the Design (Step 3b) screen. 

• If a partition-CAP association is removed while the CAP is open or has cartridges 
in it, the CAP ownership will be changed to the “default” requester (the library 
controller), and the CAP will be unavailable to all partitions. You must empty and 
close the CAP before it can be associated to any partitions. 

See “Enter Cartridges Into a Partition” on page 246 and “Eject Cartridges From a 
Partition” on page 247 for complete details on using this screen in conjunction with 
the CAP Open button. 

Screen Fields

Select

Select one or more partitions for which you want to enter or eject cartridges, as 
follows: 

• Click the checkbox to select the partition; the screen is updated as follows:

• All CAPs allocated to that partition are marked with the partition number 
on the module map.

• All other partitions sharing CAPs with that partition are grayed out. 

• Clear the checkbox to de-select the partition. 

Partitions that are grayed out cannot be selected. A partition may be grayed out 
for any of the following reasons: 

• No CAPs have been allocated to the partition.

• The partition has an HLI host-connection type. 

• The CAP is currently in use by another partition that shares the CAP.
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• The CAP is currently in use by the “default” user (library operator). 

Partition Name

Display only.

Name assigned to the partition. 

Partition ID

Display only.

ID assigned to the partition. IDs can range from 1–8.

Connection Type 

Display only.

Type of interface assigned to the host-partition connection. Options are:

• HLI

• FC-SCSI

Library module map 

Display only.

The screen displays an illustration of the library’s actual module configuration. 
This information is taken directly from the library controller database. 

The CAP allocations for each partition are indicated, as follows: 

• An “X” in a library module column indicates the CAP in that module is 
allocated to the partition in that row.

• No “X” in a library module column indicates the CAP in that module is not 
allocated to the partition in that row. 

Buttons

Apply

Click to update the library controller database with the current settings from this 
screen. The CAP Confirm popup appears, prompting you to confirm the update. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh 
popup appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 
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See Also

• Partitions—Design (Step 3b) 
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Diagnostics > CAP—Unreserve

Sample Screen

Description

Allows you to override a CAP reservation that has been initiated by a host. This 
causes the library controller to remove the CAP reservation and set the CAP user to 
“default,” which makes the rotational or AEM CAP unavailable to all partitions. 

After overriding the reservation you will need to open the CAP and remove any 
cartridges. After you close the CAP, the library controller will lock and audit the CAP 
to verify that it is empty. It will then set the CAP status to “unreserved,” which 
makes the CAP available to all partitions.

Note – For FC-SCSI CAPs, overriding a CAP reservation breaks 
any partition-CAP association, even if the CAP is dedicated to the 
FC-SCSI partition. You must explicitly associate the partition to 
the CAP again before the partition can use the CAP.

Note – This screen is used for both rotational and AEM CAPs. 
Throughout this section, the term “CAP” refers to both types of 
CAPs. 

See “Override a CAP Reservation” on page 249 for the detailed procedure. 
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Screen Fields

CAP CAP_id is status. 

Display only.

Status of the selected CAP. Possible options are:

• reserved by host_name – A CAP operation has been initiated by the 
specified host; you can use this screen to unreserve the CAP.

• reserved by default – A CAP operation has been initiated at the 
SL Console; you cannot use this screen to unreserve the CAP. 

• not reserved – The CAP is not reserved; you do not need to unreserve the 
CAP. 

Module containing selected CAP is displayed below

Display only.

The screen displays an illustration of the library’s actual module configuration. 
This information is taken directly from the library controller database. 

The CAP you have selected is marked by an arrow. 

Buttons

Apply

Click to override the host CAP reservation. The CAP Confirm popup appears, 
prompting you to confirm the update. 

Note – This button is active only if the CAP status is 
“reserved by host_name”. 

? (Help) 

Click to display online help for the screen. 

See Also

• CAP Assignment
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6

Library Management 

Automated Mode of Operation
When in automated mode of operation, the library automatically mounts and 
dismounts cartridges without physical intervention by a person.

Automated operations include the following activities:

• Mounting and dismounting cartridges

• Entering and ejecting cartridges through a rotational or optional AEM CAP 

• Logging library events

• Drive cleaning 

Cartridge Mount and Dismount Activities

The primary function of the library is the automated mounting and dismounting of 
cartridges. Host mount and dismount commands are accepted by the library 
controller and translated into robotic commands that are performed by the TallBots. 

Mount Sequence

A simplified mount sequence involves the following steps:

1. A host requests that a specific volume serial number (VOLID or volser) be 
mounted in a drive.

2. The library controller transmits to the host that the VOLID is located within the 
library and a drive is available to satisfy the mount request.

3. The library assumes responsibility for the mount.

4. The host command is translated by the library controller into motion commands 
for the TallBot.

5. The cartridge is taken from its storage cell and placed in the drive.

6. The library returns status to the host that the mount operation is completed.

7. The drive performs the read/write activity directed by the host.
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Dismount Sequence

A simplified dismount sequence involves the following steps:

1. A host requests that a specific VOLID be dismounted from a drive.

2. The library controller transmits to the host that the VOLID is located in the drive 
and the library is available to satisfy the dismount request.

3. The library assumes responsibility for the dismount.

4. The host command is translated by the library controller into mechanical 
commands for the TallBot.

5. The cartridge is taken from the drive and placed into its home cell.

6. The library returns status to the host that the dismount operation is completed.

Determining When the Library is Not in Automated Mode 

The library is not in automated mode when it is not able to accept host requests. The 
following conditions indicate that the library is not in automated mode:

• A library main access door is open. 

• The TallBot does not automatically mount and dismount cartridges. 

• The device tree in the SL Console indicates that there is a problem with the 
library.
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Library and Device Status
The SL Console screen displays health indicators for each of the following devices:

• Library 

• Rotational and AEM CAPs 

• Drives

• Power supplies

• Robot(s) 

• AEM safety doors

21 3

4

The following table describes the health monitor indicators. 

Indicator Description

1 Comm 
Status

Current status of the communication channel between the SL Console and the 
library controller. Possible icons are:

Normal communications. The heartbeat monitor flashes 
periodically when the SL Console is communicating normally 
with the library controller. 

A warning. This icon appears when the server response takes 
longer than 10 seconds.
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The library health indicator (3) also reflects status alerts, which are messages about 
significant issues with the library firmware or configuration status. These messages 
can be displayed and managed on the Status Module screen, if Service is active on 
the library. See “Status Alert Messages” on page 332 for details. 

If there are multiple problems with a device or status alert conditions, the health 
indicator reflects the one that is most severe. For example, if the library has been 
varied offline (a “yellow” condition) and a CAP has experienced a failure (a “red” 
condition), the library health indicator will be red. Fixing the CAP problem will cause 
the library health indicator to change to yellow. The indicator will not return to green 
until the library has also been varied online. 

Communications Failures

If the SL Console loses communication with the library controller, after about 30–60 
seconds, the heartbeat monitor turns gray, then red, and the following error message 
appears:
Heartbeat message not received from the library controller.

You must log off from the SL Console and then log on again to restore 
communication.

An error. This icon appears when the server response takes longer 
than 30 seconds. 

2 Userid Userid currently logged in to the SL Console. 

3 Library Library to which the SL Console is connected, and a graphical representation 
of the current health of the library and its devices. Possible icons are:

All library devices are functioning normally. 

A warning. One or more devices in the library is offline or 
operating in a degraded state. 

An error. One or more devices in the library has experienced a 
failure. 

4 Device 
health 
icon

Current status of the indicated device. If a device type indicator is yellow or 
red, you can expand the device folder to display the individual device health 
icons and then display details on the specific devices that are experiencing 
abnormal conditions. 

Indicator Description
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Host Interface Type
The SL3000 supports the following control path interface options: 

• HLI (TCP/IP) – TCP/IP protocol using Ethernet 10/100 Base-T and CAT-5 cables 

• FC-SCSI – SCSI-3 protocol and command set over a physical Fibre Channel 
interface

See “Library Control Path” on page 52 for details. 

Non-Partitioned Libraries

In non-partitioned libraries, all hosts must use the same interface type to connect to 
the library. 

You can display the interface type on the System Detail > Status > General screen. 

You can change the interface type through the 
Select Active Cells > Select Active Cells screen. 

Partitioned Libraries

In partitioned libraries, both the FC-SCSI and HLI host interface types can be used; 
each partition must use one or the other. When you create a new partition, you 
specify which interface type it uses. All hosts within a partition use the same 
interface type. 

For complete details, see “Host-Partition Connections” on page 189. 
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Special Library Configuration Options 
The Library Configuration screen provides the following configuration options. In 
partitioned libraries, these options can be configured separately for each partition. 

Barcode Presentation

Note – This option applies only to FC-SCSI libraries or partitions. 

This feature controls which part of a cartridge barcode the library passes to FC-SCSI 
host applications. Options are:

• all – All eight barcode characters are passed to host applications. 

• left6 – Only the six VOLID characters, which are on the left side of the barcode, 
are passed to host applications. The domain and type characters, which are the 
two characters on the right, are not passed. This is the default setting. 

See the following sections for details:

• “Barcode Presentation” on page 414

• “Configure Barcode Presentation in a Non-Partitioned FC-SCSI 
Library” on page 423

• “Configure Cartridge Barcode Presentation for an FC-SCSI Partition” on page 425

SCSI FastLoad

Note – This option applies only to FC-SCSI libraries or partitions. 

This feature controls the criteria by which cartridge mounts are considered complete. 
Options are:

• Checked – Turns SCSI FastLoad on. A cartridge mount is considered complete 
as soon as the drive indicates that it has accepted the cartridge. 

• Unchecked – Turns SCSI FastLoad off. A cartridge mount is considered 
complete only after the cartridge has been loaded and threaded in the drive 
and the drive indicates that it is ready for read/write operations. This is the 
default setting. 

See the following sections for details: 

• “SCSI FastLoad Feature” on page 465

• “Configure SCSI FastLoad in a Non-Partitioned Library” on page 468

• “Configure SCSI FastLoad for a Partition” on page 470

Library Auto Clean 

Note – This option applies to FC-SCSI and HLI libraries or 
partitions. 

This feature controls the management of cleaning cartridge and drive clean functions. 
Options are: 
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• Checked—Turns library auto clean on. All cleaning cartridge and drive clean 
functions are managed by the library controller. 

• Unchecked—Turns library auto clean off. All cleaning cartridge and drive clean 
functions are managed by host applications, such as ACSLS or ELS, or by direct-
attach applications, such as Symantec and NetBackup. 

See the following sections for details:

• “Library Auto Clean” on page 444 

• “Host-Managed Tape Cleaning” on page 445 
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Status Alert Messages 
Note – This feature is available only if the Service is active on the 
library. 

The library Status Module provides a centralized mechanism for displaying and 
managing library status alerts, which are messages about significant issues with the 
library firmware or configuration. Status alerts also appear in the library Event Log, 
but they may become “buried” in the volume of messages there. The Status Module 
screen highlights significant messages, making it easier for you to identify and 
resolve certain problems. 

Following are examples of status alert messages that may appear on the Status 
Module screen:

• Redundant robots have been installed, but the Dual Robot hardware activation 
key is not active

• An invalid partition configuration has been detected 

The Status Module screen does not include messages about device issues, because 
details about them are displayed in the respective device status screens (CAP Status, 
Drive Status, etc.) 

A status alert message also causes the library health indicator to change to yellow or 
red, depending on the severity of the issue. See “Library and Device 
Status” on page 327 for details. 

Related Procedures

See the following procedures for details about managing status alert messages:

• “Display Library Status Alerts” on page 335

• “Clear Library Status Alerts” on page 338
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Library Management Tasks

Task Page

Display Library Status  334

Display Library Status Alerts  335

Clear Library Status Alerts  338

Display Library Events Statistics  356

Display HLI Port Status  340

Display HLI Port Status  340

Display Library Configuration Properties  343

Display Library Controller Properties  346

Display Drive Controller Properties  347

Change the Library Interface Type (Non-Partitioned Libraries)  348

Display the “Last 24 Hours” Library Energy Monitor Report  350

Display the “Last Month” Library Energy Monitor Report  352

Display the “Last Year” Library Energy Monitor Report  354
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▼Display Library Status 

Use this procedure to view the current operational state of the library. These values 
are updated whenever there is host activity, background operations, or operator 
activity.

Note – This information is also available through 
Reports > Library Details. See “Display a Library 
Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail, and click the Library folder.

2. Click the Status tab, and then the General tab.

The screen displays the current status of the library. 
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▼Display Library Status Alerts  

Note – This feature is available only if Service is active on the 
library. 

Note – If Service is not active on the library, then this screen will 
be blank except for a message indicating that the “Service 
activation is not valid.” 

Use this procedure to display library status alerts, which can help you to identify 
whether there are any current or pending issues with the library firmware or 
configuration. You might perform this procedure whenever the library health 
indicator has changed from green, to yellow or red, indicating a warning or error. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Status tab, and then the Status Module tab. 

The screen displays all library status alerts. 

Screen Fields

Clear Alert Number 

Optional.

Status alert message you want to clear from the display. 
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The pull-down displays numbers 0–20. Although you can select any one of these, 
only the numbers that correspond to clearable alert messages shown in the 
display will actually cause a message to be cleared. 

Alert #

Display only.

Sequential number assigned to the status alert message. 

Level

Display only.

Severity level of the status alert message. Options are: 

• OK – The firmware module is functioning normally. 

• Information – Information message; the firmware module is functioning 
normally. 

• Warning – The firmware module is operating in a degraded state; may indicate 
a future failure is possible. 

• Error – The firmware module has experienced a failure. 

Module Name

Display only.

Library controller firmware module that is affected by the message. 

Clearable? 

Display only.

Indicates whether the status alert message can be manually cleared from the 
display. Options are:

• Yes – Message can be cleared, and the firmware module status will be returned 
to OK. 

• No – Message cannot be cleared. Generally, OK and Information messages 
cannot be cleared. 

Description

Display only.

Full description of the status alert message. 

Buttons

Apply

Click to clear the selected alert message from the Status Module display. The 
firmware module status is returned to OK, and the library health indicator is 
updated. 
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Note – If the alert message is updated periodically, it will 
reappear with the next update cycle.

Refresh 

Click to refresh the display with current data from the library controller database. 
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▼Clear Library Status Alerts  

Note – This feature is available only if Service is active on the 
library. 

Use this procedure to clear a library firmware status alert. Not all alerts can be 
cleared.

Note – Clearing an alert only removes it from this screen display. 
It does not resolve the underlying issue. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Status tab, and then the Status Module tab. 

The screen displays all library status alerts. 

3. On the Clear Alert Number pull-down, select the alert number that you want to 
clear from the display, and Click Apply. 
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Note – Although you can select any alert number, only alerts 
marked as “Clearable” can actually be cleared. 

The alert is removed from the Status Module display. The library health indicator 
returns to green if there are no other device or status alerts. 

Note – If the alert is subject to periodic updates, it will reappear at 
the next update cycle.
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▼Display HLI Port Status 

Use this procedure to display the current status of all host LMU (library management 
unit) HLI interface ports on the library. Information includes the local TCP/IP socket, 
local IP, connection status, port status, transmission sent and received from the time 
of connection.

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Status tab, and then the HLI tab. 

The screen displays the current status and activity of all HLI ports on the library. 
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▼Display FC–SCSI Port Status 

Use this procedure to display the current status of all host FC–SCSI interface ports on 
the library. Detailed information is shown by port number. 

If the Multi Port Fibre feature has been activated on the library, then detail is shown 
for all ports. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Status tab, and then the SCSI tab. 

The screen displays the current status and properties of all FC-SCSI ports on the 
library. 

Screen Fields

Maximum Available Ports

Total number of host-library ports the library is enabled to use. Options are:

• 1 – Library is enabled for one port 

• 2 – Library is enabled for two ports. Indicates the library Multi Port Fibre 
feature is enabled. 

Available Ports

Total number of host-library ports that are installed in the library. Options are:

• 1 – Standard FC-SCSI card is installed; this provides one port 

• 2 – FC-SCSI multi-port card is installed; this provides two ports 
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Port Number

Unique port identifier. This a digit from 1 to 4. 

Health State 

Current health state of the port. Options are:

• Available – The port is enabled and available for host connections. 

• Disabled – The port is not enabled for operations. 

• Not Activated – The port is not activated because the Multi Port Fibre Channel 
feature has not been enabled on the library. 

Access State

Current accessibility state of the port. Options are:

• Active/Optimized – The port is operating normally. 

• Unavailable – The port may be disconnected or experiencing a failure. 

Topology 

Topology of the port connection. Options are:

• Private Loop

• Public Loop

• Point to Point

• Fabric

• Unknown – The port may be disconnected, not enabled, or experiencing a 
failure.

Port Speed

Speed of the port connection. Options are:

• 2 Gb – 2 gigabits per second 

• 4 GB – 4 gigabits per second

• 8 Gb – 8 gigabits per second 

• 0 Gb – indicates the library controller is unable to communicate with the port

Loop ID

Loop ID for the port. 

FC WWN Port Name

World Wide Port Name (WWPN) for the port. 

FC WWN Node Name

World Wide Node Name (WWNN) for the node that the port is on. 
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▼Display Library Configuration Properties 

Use this procedure to display the physical, mechanical, and logical configuration of 
the library. Some of the information can is set up automatically during library 
initialization, while other information can be defined by the user. 

This screen also displays details for the TCP/IP host interface, including the library 
DNS domain name, IP address, netmask, and MAC address.

Note – This information is also available through 
Reports > Library Information. See “Display a Library 
Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, and then the General tab.

The screen displays detailed information about the library. 

Screen Fields

Vendor 

Vendor is STK, for Oracle StorageTek. 

Frame Serial Number

Serial number of the library base module. 
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Library Base WWN

World Wide Node Name (WWNN) for the library. 

Module Count

Total number of modules in the library. 

Total Slot Count

Total number of physical storage cells installed in the library. Includes data 
cartridge cells as well as reserved system cells. Not all of these cells may be 
enabled for use, however. See “Display Current Hardware Activation 
Files” on page 122 for details on displaying the number of cells that are actually 
enabled. 

Empty Slot Count

Total number of unoccupied data storage cells. 

Drive Count

Total number of drives installed. 

Robot Count

Total number of robots installed. 

Cap Count

Total number of CAPs (cartridge access ports). This includes rotational and AEM 
CAPs. 

Drive Power Supply Count

Total number of drive power supplies installed. 

Hardware power Supply Count 

Total number of power supplies installed for library robotics and electronics. 

Host Interface TCP/IP 2B

These fields apply to the standard TCP/IP port. 

DNS Domain Name

DNS domain name assigned to the library. 

IP Address

IPv4 (IP version 4) address for the port, if applicable. 

IPv6 Address

IPv6 (IP version 6) address for the port, if applicable. 
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NetMask 

Netmask defined for the subnet that the port is on. 

MAC Address

MAC address for the port. 

Host Interface TCP/IP 2A 

These fields have values only if the Dual TCP/IP feature is installed and enabled on 
the library. They apply to the optional TCP/IP port. 

IP Address

IPv4 (IP version 4) address for the port, if applicable. 

IPv6 Address

IPv6 (IP version 6) address for the port, if applicable. 

NetMask 

Netmask defined for the subnet that the port is on. 

MAC Address

MAC address for the port. 
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▼Display Library Controller Properties 

View details of the library controller, including the serial number and firmware 
versions.

Note – This information is also available through 
Reports > Library Information. See “Display a Library 
Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, and then the Library Controller tab.
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▼Display Drive Controller Properties 

View details of the drive controller, including the serial number and current 
firmware versions.

Note – This information is also available through 
Reports > Library Information. See “Display a Library 
Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, and then the Drive Controller tab.

The Drive Controller screen appears. 
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▼Change the Library Interface Type (Non-Partitioned 
Libraries)

Use this procedure to change the interface type that all hosts use to connect to the 
library. 

Note – This procedure applies to non-partitioned libraries only. 
To change interface types in a partitioned library, see “Modify the 
Interface Type of a Host-Partition Connection” on page 227. 
“Modify the Interface Type of a Host-Partition 
Connection” on page 227

1. Select Tools > Select Active Cells. 

The Module Map screen appears.

2. Click the Select Active Cells tab.

The Select Active Cells screen appears, displaying the interface type currently 
assigned to the library.
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3. In the Interface Type pull-down, select the interface type you want to assign. 
Click Apply. 

The Confirm Apply popup appears. 

4. Click Yes to update the library controller database. 

The Commit Success popup appears. 

5. Click OK to return to the Select Active Cells screen. 

The new interface type is active immediately; the library does not need to be 
rebooted. 
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▼Display the “Last 24 Hours” Library Energy Monitor Report

Note – This feature is available starting with SL3000 firmware 
version FRS_2.30 and SL Console version FRS_4.30. 

The Last 24 Hours Energy Monitor Report displays minute-by-minute energy and 
average power usage for the entire library over the last 24 hours. This report helps 
you to monitor your power and energy usage and identify periods of peak and low 
usage during the day.

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 64. 

To create a chart from this report, you can save the data to a comma-separated 
(.csv) file and then import the .csv file into a charting application. For details, see 
“Save Library Report Data to a File”. 

For related reports, see the following:

• “Display the “Last Month” Library Energy Monitor Report” on page 352

• “Display the “Last Year” Library Energy Monitor Report” on page 354 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Energy Monitor - Last 24 Hours. 
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Screen Fields

Date 

Date and time of the measurements. 

kWh

Energy used by the entire library during the identified one-minute interval, 
measured in kilowatt-hours. 

kW

Average power used by the entire library during the identified one-minute 
interval, measured in kilowatts. 
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▼Display the “Last Month” Library Energy Monitor Report

Note – This feature is available starting with SL3000 firmware 
version FRS_2.30 and SL Console version FRS_4.30. 

The Last Month Energy Monitor Report displays energy and average power usage 
for the entire library, measured in 15-minute intervals over the last 32 days. This 
report helps you to analyze your power and energy usage and identify periods of 
peak and low usage during the last month. 

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 64. 

To create a chart from this report, you can save the data to a comma-separated 
(.csv) file and then import the .csv file into a charting application. For details, see 
“Save Library Report Data to a File”. 

For related reports, see the following:

• “Display the “Last 24 Hours” Library Energy Monitor Report” on page 350

• “Display the “Last Year” Library Energy Monitor Report” on page 354 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Energy Monitor - Last Month. 
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Screen Fields

Date 

Date and time of the measurements. 

kWh

Energy used by the entire library during the identified 15-minute interval, 
measured in kilowatt-hours. 

kW

Average power used by the entire library during the identified 15-minute interval, 
measured in kilowatts. 



354  SL3000 User’s Guide March 2011 

 

▼Display the “Last Year” Library Energy Monitor Report

Note – This feature is available starting with SL3000 firmware 
version FRS_2.30 and SL Console version FRS_4.30. 

The Last Year Energy Monitor Report displays energy and average power usage for 
the entire library, measured in one-day intervals over the last 365 days. This report 
helps you to analyze your power and energy usage and identify periods of peak and 
low usage during the year. 

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 64. 

To create a chart from this report, you can save the data to a comma-separated 
(.csv) file and then import the .csv file into a charting application. For details, see 
“Save Library Report Data to a File”. 

For related reports, see the following:

• “Display the “Last 24 Hours” Library Energy Monitor Report” on page 350

• “Display the “Last Month” Library Energy Monitor Report” on page 352 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Energy Monitor - Last Year. 
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Screen Fields

Date 

Date of the measurements. 

Total kWh

Total energy used by the entire library during the day, measured in kilowatt-
hours. 

Avg kW

Average power used by the entire library during the day, measured in kilowatts. 

Max kWh

Maximum 15-minute-period energy value for the day. 

Min kWh

Minimum 15-minute-period energy value for the day. 

Avg kWh

Average of all 15-minute-period energy values for the day. 

Max kW

Maximum 15-minute-period power value for the day. 

Min kW

Minimum 15-minute-period power value for the day. 

Avg kW

Average of all 15-minute-period power values for the day. 
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▼Display Library Events Statistics 

Note – This feature is available starting with SL3000 firmware 
version FRS_3.0 and SL Console version FRS_5.00. 

The General Events Statistics Report displays summary statistics about overall library 
operations. For each event, the report lists the type, number of occurrences, and the 
date and time of the last such event. 

You can change the sort order of the screen, and rearrange and resize the columns. 
See “Modifying the Screen Layout” on page 64. 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click General Events. 

The General Events screen is displayed. 

Screen Fields

Event Type

Type of library event being tracked.

Hours Running always appears as the last entry in the display. 

Number of Events

Total number of events of this type that have been recorded for the library. 
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For the Hours Running entry, this is the number of hours the library has been 
running continuously . 

Last Seen

Date and time of the most recent occurrence of the event. 

For the Hours Running entry, this is the current date and time. 
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7

Redundant Electronics Management 

Note – The information in this chapter applies only to libraries in 
which the Redundant Electronics feature has been installed and 
activated. 

Note – This feature is available starting with SL3000 firmware 
version FRS_3.0 and SL Console version FRS_5.00. 

Note – This feature is available to hosts using the HLI (TCP/IP) 
interface and to FC-SCSI hosts using ACSLS tape management 
software. It is NOT available to hosts using a native FC-SCSI 
interface. See the SL3000 FRS_3.0 Release Notes for details on the 
ACSLS and ELS software versions that are required. 

The optional SL3000 Redundant Electronics feature provides failover protection in 
HLI libraries. If the library controller experiences errors, it automatically switches 
operations to an alternate library controller, with minimal disruption to library and 
host operations. This allows your Oracle support representative to replace the faulty 
card while the library continues normal operations. 

The Redundant Electronics feature also provides minimal disruption of library 
operations during firmware upgrades. 

Note – The SL3000 offers redundancy in a variety of components, 
including TallBots and power systems. The term “Redundant 
Electronics” refers specifically to redundancy in the library and 
drive controller components. 

Activating Redundant Electronics
The Redundant Electronics feature requires all of the following hardware 
components: 

• Active library controller (HBCr) card 

• Alternate library controller (HBCr) card

• Active drive controller (HBT) card 

• Alternate drive controller (HBT) card
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Your Oracle support representative must install the necessary hardware and activate 
the feature by installing a hardware activation file. See Chapter 3, “Hardware 
Activation Files”  on page 109 for details.

Redundant Electronics Operations
The library controller (HBCr) and drive controller (HBT) cards installed across from 
one another in the card cage are partnered with one another into a “cardset”. Each 
HBCr card determines its role whenever the card is reset or rebooted. If the HBCr 
card is the active controller and its partner HBT card is installed, the controller loads 
active code and assumes the role of active controller. If the HBCr card is the alternate 
and its partner HBT card is installed, it loads standby code. The HBT card assumes 
the same role – active or alternate – as its partner HBCr card. 

Role of the Active Controller 

The active library controller behaves for the most part like the library controller in a 
non-redundant library. It accepts connections and processes requests from HLI hosts 
and the SL Console and command line interface (CLI). 

In addition to these functions, the active library controller in a library with 
Redundant Electronics continually monitors the status of the alternate library 
controller. If the active controller determines that the alternate is not healthy and able 
to become active, then it will not allow an automated or manual failover. 

Role of the Alternate Controller 

The alternate library controller accepts HLI host connections, but processes only the 
set host path group and force switchover requests; all other requests are 
sent to the active controller.

The alternate controller continually monitors the status of the active controller. If the 
alternate controller determines that the active one is not functioning normally, it 
initiates an automatic failover. See “Automatic Failover Initiation” on page 362 for 
details. 

Role of the Drive Controllers 

The two drive controller cards (HBTA and HBTB) are partnered with the library 
controller cards installed across from one another in the card cage. The active drive 
controller communicates with the library drives. The alternate drive controller does 
not run until its partner library controller card becomes the active controller. 

IP Addresses

Each library controller card requires its own unique IP address. If the Dual TCP/IP 
feature is active on the library, then each card requires two unique IP addresses: one 
for the primary port (2B) and one for the secondary (2A) port. Therefore, a library 
equipped with both Redundant Electronics and Dual TCP/IP requires four unique IP 
addresses. 
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When you use the SL Console to log into a library, you need to connect to the 
primary port on the active controller. The SL Console does not allow you to connect 
to the alternate controller, and if you attempt to do so an error message is displayed. 

After an automatic failover or manual switch, the IP address or DNS alias you need 
to specify changes because the previously active controller is now the alternate, and 
vice versa. 

How Failover Works 
In a failover, control of the library is switched from the current active controller to 
the alternate. The alternate library and drive controller cards become active, and the 
active ones become alternate. Each library controller and its partnered drive 
controller are always switched as a pair. 

A failover can be initiated either automatically or manually. This section describes 
characteristics of all failovers. See the following sections for additional details specific 
to the automatic and manual processes:

• “Automatic Failover Initiation” on page 362

• “Manual Switch” on page 363 

Failover Process 

The failover process is minimally disruptive to library operations, usually taking only 
a few minutes. The process is summarized as follows:

1. Failover is initiated automatically or manually. 

2. The status of the alternate controllers is checked. The alternate library and drive 
controllers must be operating normally in order for failover to proceed. If any of 
the following conditions exist, then the failover cannot proceed: 

• The alternate library or drive controller is in a fault state. 

• The alternate library or drive controller card is in the eject state. 

• The standby code is not running on the alternate library or drive controller 
cards. 

• A firmware download is in progress. 

• A card initialization is in progress. 

3. If functional, the active library controller attempts to complete all in-process jobs 
and copy the cartridge database to the alternate controller card. 

4. Once all in-process jobs have completed or timed out, the card roles are switched. 

5. Active software is brought up on the alternate controller, and this controller 
becomes the active one. 

6. Standby software is brought up on the previously active controller, if possible, 
and this controller becomes the alternate. If the standby software cannot be 
brought up on this controller, the controller enters a fault state. 
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What Happens to Connections

The failover process is minimally disruptive to host operations. The following 
changes occur to various connections:

• Tape management software (Symantec or Virtual Storage Manager, for example) 
users do not see an interruption. 

• HLI host applications (ACSLS and ELS) queue requests during the failover 
process, and then submit them to the library controller once the failover is 
complete. For ACSLS, the queuing and retry affects mount and dismount requests 
only. See the ACSLS and ELS documentation for details. 

• SL Console and CLI connections are terminated. Users must re-establish 
connections to the library using the IP address of the new active library controller 
(the former alternate controller). See “Log In to the Library After a 
Failover” on page 375 for detailed instructions. 

In-transit Cartridge Recovery

Any cartridges that are in-transit at the time a failover is initiated are returned to 
their home slots, if possible. If a cartridge cannot be moved to its home slot, it is 
moved to a library system cell, and the host must return the cartridge to its home cell. 

Audits

The cartridge location database resides on the active controller only and is not 
mirrored on the alternate. If the database can be copied to the alternate prior to the 
failover, then a cartridge audit is not necessary afterwards. Usually it is possible to 
copy the database in the following circumstances: 

• A manual switch 

• The active drive controller (HBTA) card is pulled or failed

Usually it is not possible to copy the database if there is a sudden hard failure in the 
active library controller. 

If an audit must be done after the failover, it is done in the background, while other 
jobs are processed. As a result, you may notice that library operations take slightly 
longer to perform until the audit is complete. In addition, if a particular request 
requires information about a location that has not yet been audited, the location will 
be audited first, causing a slight delay in processing the request. 

Automatic Failover Initiation

An automatic failover can be initiated by either the active or alternate library 
controller. 

The active library controller initiates an automatic failover in any of the following 
situations: 

• It determines that its partner drive controller (HBTA) card is not installed.

• It does not receive communication from its partner drive controller (HBTA) card 
within a defined time-out period.

• It detects a catastrophic internal software error.
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The alternate library controller initiates an automatic failover if it determines that the 
active controller is not responsive. 

Manual Switch 

You may want to perform a manual switch in the following circumstances, in order 
to verify that the alternate cards are functioning normally: 

• After initial installation of the alternate library and drive controller cards

• After a firmware upgrade

• Periodically (once a month or once a quarter, for example)

Each library controller and its partnered drive controller are always switched as a 
pair. It is not possible to manually switch only the library controllers and not the 
drive controllers, for example. 

Manual Switch Initiation 

A manual switch can be initiated through any of the following connections:

• Host tape management (ACSLS or ELS) console – From either the active or 
alternate library controller. 

• Remote SL Console – From the active library controller only. Since the SL Console 
cannot log into the alternate library controller, you cannot use the SL Console to 
initiate a manual switch from the alternate. Also, the manual switch function is 
not available from the local operator panel. 

• CLI – From either the active or alternate library controller. This function is 
available to your Oracle support representative only. 

Before initiating a manual switch, you should verify that the alternate library and 
drive controllers are running normally. See the following topics for additional 
information on card status:

• “SL Console Displays” on page 364 

• “Display Redundant Electronics Detail” on page 369 

See “Manually Switch Redundant Electronics Cards” on page 373 for detailed 
instructions on initiating a manual switch from the SL Console. 

Monitoring Status of the Controllers 

LEDs and Controls 

The LEDs and controls are the same on all four cards. Following are descriptions.

LED Color Definition

Active Green Card is functioning as the active, running active code. 



364  SL3000 User’s Guide March 2011 

 

SL Console Displays 

You can display the status of all four controller cards through the SL Console. 

Card Positions

Some SL Console displays identify the individual library controller cards as HBCA 
and HBCB and the drive controller cards as HBTA and HBTB. For both types of 
cards, the A or B suffix indicates the card’s position within the card cage, as viewed 
from the back of the machine, as follows: 

• A – Bottom card slot 

• B – Top card slot 

Card Statuses 

The possible statuses of the controller cards are described below. 

See the following topics for additional details:

• “Display Redundant Electronics Summary Information” on page 367

• “Display Redundant Electronics Detail” on page 369

Event Log Entries

Significant library and drive controller activities, such as deteriorated health, errors, 
failovers, and card ejects are logged to the Event Log. Routine activities, such as a 
card monitoring the status of its partner, are not. 

Standby Amber Card is functioning as the alternate, running standby code. 

Fault Red Card has experienced a serious error.

Eject OK Blue Card can be safely removed. Your Oracle support representative 
can initiate a card eject through the CLI. 

LED Color Definition

Status Applies to Definition

Duplex: software 
ready; switch possible

Active library controller only Card is functioning normally.

Not installed All cards Card is not installed in the machine. 

ok Active or alternate drive controller Card is functioning normally.

Pre-standby: software 
not ready

Alternate library controller only Card is loading standby code and is 
not ready to be used in an automatic 
failover or manual switch. 

Standby: software 
ready

Alternate library controller only Card is functioning normally and can 
be used in the event of an automatic 
failover or manual switch.



March 2011   365

 

Redundant Electronics and Firmware Upgrades
Firmware upgrades for libraries with the Redundant Electronics feature are 
minimally disruptive to library operations. New code is loaded and unpacked 
simultaneously on the active and alternate controller cards and on all devices. The 
code is then activated, and the active and alternate controllers and most devices are 
reinitialized; under most circumstances, TallBot initialization is bypassed. 

The loading, unpacking, and activation of code are not disruptive to library 
operations until the library is rebooted. During the reboot process (which takes 
approximately 10 minutes), the HLI host applications (ACSLS and ELS) queue all 
mount and dismount requests. Once the reboot is complete, the queued requests are 
submitted to the library controller. 
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Redundant Electronics Management Tasks

Task Page

Display Redundant Electronics Summary Information  367

Display Redundant Electronics Detail  367

Manually Switch Redundant Electronics Cards  367

Log In to the Library After a Failover  375
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▼Display Redundant Electronics Summary Information 

Note – This feature is available starting with SL3000 firmware 
version FRS_3.0 and SL Console version FRS_5.00. 

Use this procedure to display summary information about all Redundant Electronics 
cards in the library. 

1. Select Tools > System Detail, and click the Redundant Electronics folder. 

The Redundant Electronics Summary screen appears. 

Screen Fields

Device 

Options are:

Type of card. Options are:

• libraryController – Library controller card

• driveController – Drive controller card

Address 

The card’s address within the library. Options are:

• hbca – Library controller, A (bottom) slot

• hbcb – Library controller, B (top) slot 
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• hbta – Drive controller, A (bottom) slot 

• hbtb – Drive controller, B (top) slot

Card Position

Position of the card within the card cage, as viewed from the back of the machine. 
Options are:

• bottom – Bottom card slot; also referred to as the A slot 

• top – Top card slot; also referred to as the B slot 

Device State 

Current operating state of the card. Options are:

• Duplex: software ready; switch possible – Card is functioning normally. Used 
only for an active HBC card in a library with Redundant Electronics. 

• Initializing State 0 – Internal hardware manager state which may be seen 
during initialization. 

• Initializing State 1 – Internal hardware manager state which may be seen 
during initialization.

• Not installed – Card is not installed in the machine. The library has the 
Redundant Electronics feature activated, but the alternate HBC or HBT card is 
not installed. 

• ok – Card is functioning normally. Used only for HBT cards. 

• Pre-simplex: software not ready – Card is loading code. Used only for an HBC 
card in a library without Redundant Electronics. 

• Pre-standby: software not ready – Card is loading standby code and is not 
ready to be used in the event of an automatic failover or manual switch. Used 
only for an alternate HBC card in a library with Redundant Electronics. 

• Simplex: software ready – Card is functioning normally. Used only for an HBC 
card in a library without Redundant Electronics. 

• Standby: software ready –Card is functioning normally and can be used in the 
event of an automatic failover or manual switch. Used only for an alternate 
HBC card in a library with Redundant Electronics. 

• Unknown: unknown value – The active HBC card cannot communicate with 
the alternate and does not have any information about the alternate’s status. 

Health State

Current health of the card. Options are:

• error – Card has experienced a fault, such as it is in the Not Installed state. 

• warn – Card is in a degraded state, such as the card has been ejected or its 
alternate is not yet in the Standby state. 

• ok – Card is functioning normally
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▼Display Redundant Electronics Detail

Note – This feature is available starting with SL3000 firmware 
version FRS_3.0 and SL Console version FRS_5.00. 

Use this procedure to display detailed status information for the active and alternate 
library controller and drive controller cards. 

Note – If Redundant Electronics is not enabled on this library, the 
display shows as much detail as is applicable. 

1. Select Tools > System Detail. 

2. Expand the Redundant Electronics folder, and click the card you want to 
display. Cards are as follows:

• hbca – Library controller, A (bottom) slot

• hbcb – Library controller, B (top) slot 

• hbta – Drive controller, A (bottom) slot 

• hbtb – Drive controller, B (top) slot

The screen displays the current status of the selected card. 
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Screen Fields

Device 

Type of card. Options are:

• libraryController – Library controller card

• driveController – Drive controller card

Card Type

The card’s address within the library. Options are:

• hbca – Library controller, A (bottom) slot

• hbcb – Library controller, B (top) slot 

• hbta – Drive controller, A (bottom) slot 

• hbtb – Drive controller, B (top) slot

IP Address: 2B

IP address of the 2B port on the selected library controller card. The 2B port is the 
primary port for host communications. 

If no card is installed, this field displays N/A.

Note – This field applies only to library controller (HBCr) cards. 
Drive controller (HBT) cards do not have a 2B or 2A port and 
therefore always display N/A. 

IP Address: 2A

IP address of the 2A port on the specified HBCr card. The 2A port is the 
secondary port for host communications. 

If no card is installed, this field displays N/A.

Note – This field applies only to library controller (HBCr) cards. 
Drive controller (HBT) cards do not have a 2B or 2A port and 
therefore always display N/A. 

Position 

Position of the card within the card cage, as viewed from the back of the machine. 
Options are:

• Left – Bottom card slot; also referred to as the A side 

• Right – Top card slot; also referred to as the B side 

Device State

Current operating state of the card. Options are:

• Duplex: software ready; switch possible – Card is functioning normally. Used 
only for an active HBC card in a library with Redundant Electronics. 
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• Initializing State 0 – Internal hardware manager state which may be seen 
during initialization. 

• Initializing State 1 – Internal hardware manager state which may be seen 
during initialization.

• Not installed – Card is not installed in the machine. The library has the 
Redundant Electronics feature activated, but the alternate HBC or HBT card is 
not installed. 

• ok – Card is functioning normally. Used only for HBT cards. 

• Pre-simplex: software not ready – Card is loading code. Used only for an HBC 
card in a library without Redundant Electronics. 

• Pre-standby: software not ready – Card is loading standby code and is not 
ready to be used in the event of an automatic failover or manual switch. Used 
only for an alternate HBC card in a library with Redundant Electronics. 

• Simplex: software ready – Card is functioning normally. Used only for an HBC 
card in a library without Redundant Electronics. 

• Standby: software ready –Card is functioning normally and can be used in the 
event of an automatic failover or manual switch. Used only for an alternate 
HBC card in a library with Redundant Electronics. 

• Unknown: unknown value – The active HBC card cannot communicate with 
the alternate and does not have any information about the alternate’s status. 

Health State

Current health of the card. Options are:

• error – Card has experienced a fault, such as it is in the Not Installed state. 

• warn – Card is in a degraded state, such as the card has been ejected or its 
alternate is not yet in the Standby state. 

• ok – Card is functioning normally

Alternate HBC Communicating

Current communications status of the alternate library controller (HBCB) card. 
Options are:

• true – Alternate HBCr card is successfully communicating with the active card. 

• false – Alternate HBCr card is not communicating with the active card.

• N/A – Alternate HBCr card is not installed; or the selected card is not a library 
controller. 

Software Switch Allowed

Indicator of whether an automatic failover or manual switch is possible, given the 
current status of the alternate library and drive controller cards. Options are:

• true – Automatic failover or manual switch is possible. 

• false – Automatic failover or manual switch is not possible. 
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• N/A – Alternate HBCr card is not installed; or the selected card is not a library 
controller
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▼Manually Switch Redundant Electronics Cards

Note – This feature is available starting with SL3000 firmware 
version FRS_3.0 and SL Console version FRS_5.00. 

Use this procedure to switch the active and alternate controller cards. Each library 
controller and its partnered drive controller are always switched as a pair. The 
current alternate library and drive controller cards become active, and the active ones 
become alternate.

Before performing this procedure you should verify that the Software Switch 
Allowed indicator on the Redundant Electronics Status Detail screen is “true”. See 
“Display Redundant Electronics Detail” on page 369 for detailed instructions. 

Note – You will be logged off the library as part of this procedure. 
Once the switch completes, in order to log back into the library, 
you must specify the IP address or DNS alias of the new active 
library controller card. 

1. Select Tools > Diagnostics and select Redundant Electronics. 

The Redundant Electronics Switch screen appears. 

2. Click Apply to begin the switch process. 
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• If the alternate library and drive controller cards are operating normally, the 
Confirm dialog appears, prompting you to confirm that you want to proceed 
with the switch. 

• If there is a problem with the alternate library and drive controller cards, an 
error message is displayed and you are not allowed to continue with the 
switch. 

3. Click Yes to begin the switch process. 

The switch process begins, and a popup appears indicating that your SL Console 
session will be terminated.

4. Click OK to dismiss the message and log off the SL Console. 

5. Wait until the switch is complete before logging back into the library. In 
addition, you must specify the IP address or DNS alias of the new active 
controller in order to log in. See “Log In to the Library After a 
Failover” on page 375 for detailed instructions. 
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▼ Log In to the Library After a Failover 

Note – This feature is available starting with SL3000 firmware 
version FRS_3.0 and SL Console version FRS_5.00. 

Use this procedure to log in to the library after an automatic failover or manual 
switch. You need to log in by connecting to the library controller that was the 
alternate prior to the failover or switch. 

1. Obtain the IP address or DNS alias of the new active library controller. 

This was the alternate library controller prior to the failover or switch. 

2. Bring up the SL Console. See “General SL Console Usage Tasks” on page 73 for 
a list of procedures to do this.

The SL Console Login screen appears. 

3. Enter your login information, and click Log on.

User ID: SLC_login 
Password: password 
Library: library_ID 

where:

• SLC_login is the SL Console user ID.

• password is the password assigned to this user ID. 
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• library_ID is the library to which you want to connect, expressed in either of 
the following ways:

• IP address of the library 

• DNS alias of the library

Note – The user ID you use determines the screens you can 
access. See “SL Console Security”. 

4. If you are attempting to log into the wrong controller, then the following dialog 
appears. You cannot use the SL Console to log into the alternate controller. 

Click OK and return to Step 3, this time entering the information for the correct 
controller. 



March 2011   377

 

8

Rotational and AEM CAP Management

CAP Operations
Note – This section describes general CAP activities applying to 
all libraries. For information specific to CAP activities in 
partitioned libraries, see “Partitions and Rotational and AEM 
CAPs” on page 196. 

Note – Most CAP functions described in this section apply to 
AEMs as well as regular CAPs. In cases where there is a 
distinction between the two, the term “rotational CAP” is used to 
refer to regular CAPs. 

CAPs (cartridge access ports) allow a library operator to enter or eject cartridges to or 
from the library. You can use the CAPs only when the library is in automated mode. 

Rotational CAPs

One rotational CAP is always present in the base module. Optionally, the drive 
expansion module and cartridge expansion module can also each have one rotational 
CAP. 

Each rotational CAP contains two removable 13-slot magazines, allowing for a total 
of 26 cartridges to be imported or exported at one time through each CAP. 

AEM CAPs

See “AEM Operations” on page 381 for a detailed description of AEM CAPs. 
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CAP Open Sequence

Opening a rotational or AEM CAP involves the following steps:

1. A host issues a command to unlock the CAP. 

2. The CAP status is updated to “unlocked.”

3. The library operator presses the CAP button.

4. The CAP status is updated to “open.”

5. For rotational CAPs, the CAP motor is activated, and the CAP rotates outward to 
expose the magazines (rotational CAPs). 

For AEM CAPs, once the Enter LED is illuminated, the library operator can lift the 
latch and open the AEM access door (AEM CAPs). 

CAP Close Sequence

Closing a rotational or AEM CAP involves the following steps:

1. For rotational CAPs, the library operator presses the CAP button on the key pad. 
The CAP motor is activated, and the CAP rotates inward to close the CAP.

For AEM CAPs, the library operator closes the AEM access door and secures the 
latch. 

2. The library operator presses the CAP button to start the close sequence. 

3. The CAP is status is updated to “closed” and “locked.”

4. The TallBot audits all CAP slots.

CAP Auto Enter Mode

Note – CAP auto enter mode applies only to HLI libraries; it is not 
supported in FC-SCSI libraries. 

CAP auto enter mode allows a library operator to open a rotational or AEM CAP and 
initiate an enter operation without issuing an explicit enter request and without an 
explicit reservation from a host application. When in auto mode, a CAP is left 
unlocked and its LED is lit. The CAP is locked only during cartridge enter, eject, or 
audit operations. 

Auto enter mode is managed by the host applications. See the appropriate tape 
management software documentation for details. To place a CAP in auto enter mode, 
you must enter the appropriate tape management command to unlock the CAP. 

To initiate an enter operation using an automatic CAP, you only need to press the 
CAP Open button on the key pad. Auto enter mode does not affect CAP operations 
for ejecting cartridges, so you must always issue an explicit eject command to eject 
cartridges through the CAP.

Manual CAP Mode 

Manual mode is the most secure method of CAP operations. 
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When in manual mode, a rotational or AEM CAP is locked by default and its LED is 
not lit. To initiate an enter or eject operation using a manual CAP, you must enter an 
explicit enter or eject request before pressing the CAP Open button on the key pad. 

CAP States

A CAP must be unlocked in order for you to open it to insert or remove cartridges. 
When a CAP is unlocked, the light on the CAP button is turned on. 

When you close a CAP, the TallBot performs an audit to determine whether there are 
cartridges present. During the audit the CAP is locked and the light on the CAP 
button is turned off. Once the audit is completed, the CAP is returned to its default 
state. 

The following table describes the default states of the various types of CAPs within a 
non-partitioned library. 

Type of CAP Default State Default CAP Button Light Condition

HLI – manual mode Locked Off

HLI – auto enter mode Unlocked On

FC-SCSI Unlocked On 

CAP Assignment Mode 

Note – This feature is available starting with SL3000 firmware 
version FRS_2.33 and SL Console version FRS_4.47. 

Note – This feature applies only to libraries with FC-SCSI host 
connections; it is not applicable to libraries that have only HLI 
(TCP/IP) host connections. 

Note – This procedure applies to non-partitioned libraries only; it 
is not applicable to partitioned libraries. 

The CAP assignment mode controls whether library CAPs can be used for normal 
host operations or for manual operations, such as recovery moves. Prior to 
performing a recovery move to or from a CAP, you must change the library CAP 
assignment mode to “diagnostics”. This makes all library CAPs unavailable to library 
hosts and available to SL Console control. For detailed instructions on setting the 
CAP assignment mode, see “Change the CAP Assignment Mode for an FC-SCSI 
Library” on page 394. 

CAP Priorities for Cartridge Ejects by FC-SCSI Hosts

When you initiate an eject operation from an HLI host, you are able to specify the 
CAP to use. The SCSI interface, however, does not provide this level of control. The 
interface essentially aggregates all CAPs and AEMs in the library and treats them as 
one large CAP. When you initiate an eject operation from an FC-SCSI host, the 
TallBot places cartridges in CAPs, working from left to right, starting first with 
rotational CAPs, and then moving to AEMs, if applicable. 

For example, assume an FC-SCSI library with the following configuration:
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• Base module, with standard rotational CAP

• Two CEMs, with optional rotational CAPs

• Two AEMs 

Note – The following example assumes either a non-partitioned 
library, or a partitioned library in which all CAPs and AEMs are 
shared by all hosts. For partitioned libraries, the CAP priority is 
dependent on how CAPs are allocated to partitions. 

For an eject operation of 350 cartridges, the TallBot would fill CAP cells in the 
following order:

Module Number of Cartridges Total Cartridges

1 Left CEM 26 26

2 Base Module 26 52

3 Right CEM 26 78

4 Left AEM 234 312

5 Right AEM 38 350

Using CAPS in a Partitioned Library

Note – This topic applies to partitioned libraries only. See 
“Partitioning Task Summary” on page 206 for details about 
defining library partitions. 

A rotational or AEM CAP is a shared library resource – that is, it can be used by all 
partitions in the library. A CAP can be used by only one partition at a time, however. 
While a partition is using a CAP for enters or ejects, the CAP is reserved to that 
partition and unavailable to all others. 

In order for a partition to reserve a CAP, all of the following conditions must be met:
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• The CAP must be available – that is, not reserved by any other partition. 

• The CAP must be empty.

• The CAP must be closed and locked.

Additional CAP Information

See the following sections of this manual for complete details about rotational and 
AEM CAPs. 

Section Type of Information Page

“AEM Operations” Usage information that applies 
specifically to AEM CAPs

 381

“Rotational and AEM CAP 
Management Tasks”

Procedures for displaying CAP 
status and properties

 384

“Cartridge Management Tasks” Procedures for using CAPs to load 
and unload cartridges

 416

“Partitions and Rotational and AEM 
CAPs”

Partition configuration information 
relating to CAPs

 196

AEM Operations 
The AEM (access expansion module) allows a library operator to perform bulk loads 
or unloads of up to 234 cartridges at a time to or from the library. The AEM also 
allows for non-disruptive maintenance of a library TallBot. 

Note – AEMs share many of the same features and functions as 
rotational CAPs, but they also have some unique characteristics. 
This section describes what is unique to AEMs. 

AEM Access Door 

The AEM access door is the external door you open to bulk load or unload cartridges 
to or from the library. The front panel of the access door includes the following 
components: 

• Three LEDs: Wait, Enter, and Unlocked

• Two locks: 

• Service Access – Can be opened only by an Oracle support representative. 
Opening this lock releases the access door deadbolt.

• Deadbolt Override – For “fast access” to the inside of the AEM by a library 
operator. This action has the same effects on library operations as opening the 
main library access door. 

• “Operator Request CAP” button – For normal access to the inside of the AEM, to 
load or unload cartridges. Pressing this button releases the access door deadbolt. 
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• Latch – Opens and closes the access door. The latch can be opened only after you 
release the deadbolt or use the deadbolt override. 

AEM Safety Door

The safety door is the internal “garage” door, which lowers to separate the AEM 
from the rest of the library. This door allows for safe access to the inside of the AEM, 
either for a library operator to load or unload cartridges, or for an Oracle support 
representative to perform service on the TallBot or other AEM components. 

The safety door is lowered when you press the “Operator Request CAP” button on 
the AEM access door or when an Oracle support representative uses the Service 
Access lock. The safety door is not lowered if you perform an AEM “fast access” by 
unlocking the Deadbolt Override lock. 

The safety door is automatically raised when you close the AEM access door. The 
TallBot then enters the AEM and conducts an audit of all AEM cells. A full audit of 
an AEM should take less than three minutes. 

AEM CAP Functions

Each AEM CAP contains 18 removable 13-slot cartridge magazines on the front and 
back walls, for a total of 234 cartridge slots. The magazines are arranged in a 3 X 3 
configuration on each wall. The magazines are the same as those used in rotational 
CAPs.

In terms of cartridge loads and unloads, the library controller treats each AEM as a 
very large CAP. See “CAP Operations” on page 377 for information on CAP 
functions that apply to AEMs. 

Partitions and AEMs

With regard to library partitioning, AEM CAPs are subject to the same rules and 
restrictions as rotational CAPs. They can be allocated for exclusive use by one 
partition, or they can be shared by multiple partitions with the same host interface 
type. See “Partitions and Rotational and AEM CAPs” on page 196 for details. 

Non-disruptive Maintenance

The AEM allows an Oracle support representative to safely access and service a 
library TallBot without having to take the library offline. If a TallBot is defective, it 
parks itself in the AEM. The library remains online, and if redundant TallBot are 
installed, the library can continue normal operations through the remaining 
functional TallBot. 

An Oracle support representative can use a special key to unlock the Service Access 
lock on the access door. This causes the AEM safety door to lower, sectioning off the 
AEM from the rest of the library. Once the safety door is fully down, the Oracle 
support representative can open the AEM access door and safely perform 
maintenance on the defective TallBot or other AEM components, while the library 
remains online. The AEM itself is taken offline during the maintenance period, 
causing cartridge load/unload functions to be suspended. 
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When maintenance is complete, the Oracle support representative closes the access 
door, the safety door raises, the TallBot is re-initialized and performs an audit of the 
AEM CAP cartridge slots, and then the AEM is brought back online. 

Additional AEM Information

See the following sections of this manual for complete details about AEMs. 

Section Type of Information

“CAP Operations” Usage information that applies to both 
rotational CAPs and AEM CAPs

“Rotational and AEM CAP 
Management Tasks”

Procedures for displaying AEM CAP status 
and properties

“Cartridge Management Tasks” Procedures for using AEM CAPs to load and 
unload cartridges

“AEM Safety Door Management 
Tasks”

Procedures for displaying status and 
properties of the AEM safety door (“garage” 
door) 

“Partitions and Rotational and AEM 
CAPs”

Partition configuration information relating to 
both rotational and AEM CAPs

“AEM Safety Door Utility Tasks” Procedures for rebooting the AEM safety door 
(“garage” door) 

“Manual Operation Tasks” Procedures for “fast access” to the AEM 

TABLE B-1, “Access Expansion 
Module Walls” on page 612

Detailed diagram of the wall layouts 
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Rotational and AEM CAP Management Tasks

Task Page

Display Rotational and AEM CAP Summary Information  385

Display Current Rotational or AEM CAP Status  386

Display Rotational or AEM CAP Properties  389

Unlock a CAP or AEM Access Door  391

Lock a CAP or AEM Access Door  393

Change the CAP Assignment Mode for an FC-SCSI Library  394
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▼Display Rotational and AEM CAP Summary Information

Use this procedure to display summary information for all rotational and AEM CAPs 
in the library. 

Note – This information is also available through 
Reports > CAP Summary. See “Display a Library 
Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail, and click the CAP folder. 

The screen lists all the library rotational and AEM CAPs and their locations.    
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▼Display Current Rotational or AEM CAP Status 

Use this procedure to display the current operational state of a rotational or AEM 
CAP. 

Note – This information is also available on the CAP Details 
report. See “Display a Library Report” on page 86 for detailed 
instructions. 

Note – Status information on the AEM safety door, which is the 
internal “garage” door that lowers to separate the AEM from the 
rest of the library, is displayed on the Safety Door Status screen. 
See “Display AEM Safety Door Status” on page 397 for detailed 
instructions. 

Note – This screen is used for both rotational and AEM CAPs. 
Throughout this section, the term “CAP” refers to both types of 
CAPs. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to display. 

Note – AEM CAPs are identified as follows: column “–31” for a 
left AEM CAP, and column “31” for a right AEM CAP. 

3. Click Status.

The screen displays the current status of the selected CAP. 
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• For rotational CAPs: 



388  SL3000 User’s Guide March 2011 

 

• For AEM CAPs: 
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▼Display Rotational or AEM CAP Properties

Use this procedure to display static information for a rotational or AEM CAP, 
including the serial number and number of cells. 

Note – This information is also available through 
Reports > CAP Details. See “Display a Library Report” on page 86 
for detailed instructions. 

Note – For AEM CAPs, this information is also displayed on the 
Safety Door Properties screen. See “Display AEM Safety Door 
Properties” on page 398 for detailed instructions. 

Note – This screen is used for both rotational and AEM CAPs. 
Throughout this section, the term “CAP” refers to both types of 
CAPs. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to display. 

Note – AEM CAPs are identified as follows: column “–31” for a 
left AEM CAP, and column “31” for a right AEM CAP. 

3. Click Properties. 

The CAP Properties screen appears. 

• For rotational CAPs:
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• For AEM CAPs: 
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▼Unlock a CAP or AEM Access Door 

Normally a CAP or AEM access door is unlocked from a host. Use this procedure 
when you need to perform the unlock operation manually at the SL Console. 

Note – If the CAP is reserved by a host, the host must release the 
CAP reservation before you can use this procedure. 

Note – This screen is used for both rotational and AEM CAPs. 
Throughout this section, the term “CAP” refers to both types of 
CAPs. 

1. Select Tools > Diagnostics. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

Note – AEM CAPs are identified as follows: column “–31” for a 
left AEM CAP, and column “31” for a right AEM CAP. 

3. Click the Access tab. 

The Access screen appears.

4. In the Locked pull-down, click false. Click the Apply button. 
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The Confirm popup appears. 

5. Click OK.

The CAP door unlocks, and the CAP button light turns on.

Note – The CAP status changes to “unlocked” in the host library 
management software.

Note – The CAP or AEM is reserved by the library and 
inaccessible to all library hosts until you close and lock the CAP or 
AEM access door. See “Lock a CAP or AEM Access 
Door” on page 393 for details. 
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▼ Lock a CAP or AEM Access Door 

Normally a CAP or AEM access door is locked from a host. Use this procedure when 
you need to perform the lock operation manually at the SL Console. 

Note – This procedure applies only to HLI CAPs. 

Note – This screen is used for both rotational and AEM CAPs. 
Throughout this section, the term “CAP” refers to both types of 
CAPs. 

Note – If you unlock a CAP or AEM access door (see “Unlock a 
CAP or AEM Access Door” on page 391 for details.), the CAP or 
AEM is reserved by the library and unavailable to all hosts until 
you perform this procedure. 

1. Select Tools > Diagnostics. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

Note – AEM CAPs are identified as follows: column “–31” for a 
left AEM CAP, and column “31” for a right AEM CAP. 

3. Click the Access tab. 

The Access screen appears.

4. In the Locked field, click True. Click the Apply button. 

The CAP locks, and the CAP button light turns off.
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▼Change the CAP Assignment Mode for an FC-SCSI Library 

Note – This feature is available starting with SL3000 firmware 
version FRS_2.33 and SL Console version FRS_4.47. 

Use this procedure to change the CAP assignment mode for all CAPs in an FC-SCSI 
library. The CAP assignment mode controls whether library CAPs can be used for 
normal host operations or for diagnostic moves. For additional information, see 
“CAP Assignment Mode” on page 379. 

Note – This procedure applies only to libraries with FC-SCSI host 
connections; it is not applicable to libraries that have only HLI 
(TCP/IP) host connections. 

Note – This procedure applies to non-partitioned libraries only; it 
is not applicable to partitioned libraries. 

Note – This screen is used for both rotational and AEM CAPs. 
Throughout this section, the term “CAP” refers to both types of 
CAPs. 

1. Verify that all library CAPs are in the following condition: 

• Available – that is, not reserved by any host, 

• Empty, and

• Closed and locked. 

2. If you are changing the CAPs to diagnostics mode, quiesce the library to all 
hosts. See the appropriate tape management software documentation for the 
procedures and commands.

3. Select Tools > CAP Assignment. 

The CAP Assignment screen appears. The pull-down displays the current 
assignment mode setting for all CAPs in the library. 

4. In the pull-down, select the mode you want to assign, and click Apply. 

Options are:

• Diagnostics – Makes all CAPs available for diagnostic operations. Select this if 
you want to perform manual cartridge moves, such as moving cleaning or 
diagnostic cartridges from the CAPs to system cells. 
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• Host Operations – Makes all CAPs available for normal host operations. Select 
this if you want to return the library to normal tape mount/dismount 
operations.

5. Click Apply. 

A confirmation popup appears. The new CAP mode is effective immediately; the 
library does not need to be rebooted. 

6. Click OK to dismiss the popup. 
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AEM Safety Door Management Tasks

Task Page

Display AEM Safety Door Status  397

Display AEM Safety Door Properties  398
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▼Display AEM Safety Door Status 

Use this procedure to display the current state of an AEM safety door. The safety 
door is the internal “garage” door, which lowers to separate the AEM from the rest of 
the library. 

Note – Status information on the AEM access door, which is the 
door you open to bulk load or unload cartridges to or from the 
library, is displayed on the CAP Status screen. See “Display 
Current Rotational or AEM CAP Status” on page 386 for detailed 
instructions. 

1. Select Tools > System Detail. 

2. Expand the Safety Door Folder, and click the safety door you want to display. 

3. Click Status.

The Safety Door Status screen appears. 

“Door open” indicates that the safety door is up and the TallBot is free to move in 
and out of the AEM. “Door closed” indicates that the safety door is down and it is 
safe for you to open the AEM access door. 
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▼Display AEM Safety Door Properties

Use this procedure to display detailed information for an AEM safety door, including 
the serial number and current firmware versions. The safety door is the internal 
“garage” door that lowers in preparation for you to open the AEM access door.

Note – This information is also available through the CAP 
Properties screen and the CAP Details report. See “Display 
Rotational or AEM CAP Properties” on page 389 and “Display a 
Library Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Safety Door Folder, and click the safety door you want to display. 

3. Click Properties.

The Safety Door Properties screen appears. 
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9

Drive Management

You can install up to 56 drives within one library, as follows:

• Up to 24 in the Base Module

• Up to 32 in a Drive Expansion Module (DEM)

See “Tape Drives” on page 43 for a list of supported tape drives. 

Drive Identification

The library uses the following addressing schemes for each library drive:

• Library internal address – For all drives. Assigned by the library controller based 
on the library, rail, column, side, and row location of the drive. 

• HLI-PRC address (Host LMU Interface-Panel, Row, Column) – For TCP/IP host 
connections only. Assigned by host applications. 

• Host SCSI element address – For FC-SCSI host connections only. Assigned by host 
applications. 

• Drive bay address – For all drives. Assigned by the library controller based on the 
physical slot in which the drive is installed. 

• dynamic World Wide Name – For Fibre Channel connections only. Assigned by 
the library controller, according to the slot into which the drive is installed. 

See Appendix A, “Library Resource Addresses” on page 589 for details on drive 
identification and addressing schemes. 

Drive States

A drive can be in either of the following states:

• Online – The drive is available for read/write operations.

• Offline – The drive is not available for read/write operations. 
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Drive Management Tasks

Task Page

Display Drive Summary Information  401

Display Drive Status  403

Display Drive Properties  404

Display Drive VOP  405

Display Drive LED Status  407

Display Drive Tray Status  408

Display the Drive Events Report  409

Display the Drive Media Events Report  411
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▼Display Drive Summary Information

Use this procedure to display summary information for all drives in the library. 

If you need to perform a manual mount to a drive, this procedure displays a 
mapping of all addresses for each library drive:

• Firmware (internal address)

• Host software (HLI-PRC address)

• Hardware (drive bay)

The following information is also displayed:

• Access State – online, offline

• Drive State:

• Empty

• Unloaded – cartridge is present 

• Ready – cartridge is loaded

• NotCommunicating

• rewindUnload –drive is busy rewinding and unloading 

• Drive Type

• Drive serial number

• Current code version

• Drive interface type

Note – This information is also available through 
Reports > Drive Summary. See “Display a Library 
Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail, and click the Drive folder. 
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The screen lists the library drives and displays their locations.The internal 
address, drive bay, and HLI-PRC address are detailed. 
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▼Display Drive Status 

Use this procedure to display the current operational state of a drive. The 
information includes:

• Current drive and drive tray status information 

• Whether the drive is loaded

• Cartridge VOLID if the drive is loaded

• Drive cleaning information

• Host activity

Note – This information is also available through 
Reports > Drive Details. See “Display a Library 
Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click Status.

The screen displays the current status of the selected drive. 
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▼Display Drive Properties 

View detailed drive configuration information, including the drive type and serial 
number and port configuration.

Note – This information is also available through 
Reports > Drive Details. See “Display a Library 
Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click Properties. 

The Drive Properties screen appears. 
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▼Display Drive VOP

Note – This procedure is for Oracle StorageTek T10000 and 
T9840D drives only. 

Use this procedure to display the Virtual Operator Panel (VOP) for T10000 and 
T9840D drives. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click Display.

The drive VOP information appears in the Drive Virtual Op Panel section. 
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▼Display Drive Network Data

Use this procedure to display IP and MAC address data for a library drive. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click Display.

The data appears in the Network Data section. 
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▼Display Drive LED Status

Use this procedure to display current statuses of a selected drive’s LEDs, including 
loaded, online, cleaning, and trace available statuses. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click Display.

The data appears in the Drive Led Status section. 
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▼Display Drive Tray Status

Use this procedure to display the current status of a drive tray. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click DriveTray.

The Status screen appears. 
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▼Display the Drive Events Report

Note – This feature is available starting with SL3000 firmware 
version FRS_2.30 and SL Console version FRS_4.30. 

The Drive Events Report summarizes drive events and errors that have occurred on 
library drives. The report is updated whenever there is a drive event not related to 
media. You can use the report to help identify and diagnose faulty drives.

For each drive that has experienced events, the report lists the type of drive, type of 
error, the number of occurrences, and the date and time of the last such event. The 
report can display up to 70 entries. 

By default, the report is sorted in drive serial number order. Optionally, you can 
change the sort order, and rearrange and resize the columns. See “Modifying the 
Screen Layout” on page 64. 

Note – For media errors associated with drives, see “Display the 
Drive Media Events Report” on page 411. 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Drive Events. 

Screen Fields

Serial Number

Serial number of the drive.
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Drive Type

Brand and model of the drive.

Event Type

Type of event being tracked. All of these events indicate problems with the drive, 
not the media. Options are:

• Drive Error – Drive had a general problem. 

• Load Error – Drive was unable to load the cartridge. 

• Load Retry – Drive required retries to load the cartridge. 

Number of Events

Total number of events of this type that have been recorded for this drive. 

Last Seen

Date and time of the most recent occurrence of the error. 
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▼Display the Drive Media Events Report

Note – This feature is available starting with SL3000 firmware 
version FRS_2.30 and SL Console version FRS_4.30. 

The Drive Media Events Report summarizes media events that have occurred on 
library drives. The report is updated whenever a media event or error occurs. You 
can use the report to help identify and diagnose faulty drives or cartridges.

For each drive that has experienced media events, the report lists the VOLID of the 
cartridge, the type of event, the number of occurrences, and the date and time of the 
last such event. The report can display up to 500 entries. 

By default, the report is sorted in drive serial number order. Optionally, you can 
change the sort order, and rearrange and resize the columns. See “Modifying the 
Screen Layout” on page 64. 

Note – For cartridge errors not necessarily associated with drives, 
see “Display the Media Events Report” on page 440. 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Drive Media Events. 

Screen Fields

Serial Number

Serial number of the drive.
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Drive Type

Brand and model of the drive.

Cartridge Label 

VOLID of the cartridge that has experienced an event. 

Event Type

Type of media event being tracked. Options are:

• Media Error – The drive indicated there was a problem with the media; this 
could possibly also indicate a problem with the drive.

Number of Events 

Total number of events of this type that have been recorded for this cartridge on 
this drive. 

Last Seen

Date and time of the most recent occurrence of the event. 
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10

Cartridge Management

All library cartridges must have a readable external label. See Appendix C, 
“Cartridge Handling” for details. 

The ELS and ACSLS host software applications do not support unlabeled cartridges 
and will not allow them to be entered through the CAP. If you place an unlabeled 
cartridge in a CAP, the host leaves it there and you must remove it from the CAP. 

If you place an unlabeled cartridge into a storage cell manually, the TallBot leaves it 
there during a hardware audit and does not attempt to place another cartridge into 
the slot. During an ACSLS or ELS audit, however, the host moves the cartridge to the 
CAP for ejection from the library. 

The library controller will not allow you to mount an unlabeled or unknown type 
cartridge into any tape drive. 

Entering Cartridges

You can enter up to 26 cartridges at one time through each rotational CAP. You can 
bulk load up to 234 cartridges through each AEM CAP. 

Before entering a cartridge into the library, you must verify that it is labeled 
properly. Insert each cartridge in a CAP slot so that the customer label (if present) is 
facing you, the hub gear is facing down, and the cartridge label is facing you. 
Cartridges may be placed in any CAP slot, in any order; the TallBot audits all CAP 
slots when the CAP door is closed. 

Note – The CAP design prevents you from placing a T9840 or 
T10000 cartridge in the CAP, upside-down. It does not, however, 
prevent you from placing an LTO cartridge in the CAP upside-
down. 

The TallBot’s bar-code scanner reads cartridge labels only during enter operations, 
since the VOLIDs are new and must be added to the library controller database. The 
TallBot does not need to read cartridge labels during ejects. 

When a cartridge is entered into the library, it is either assigned a home cell by the 
host or mounted on a drive, depending on the reason why it was entered. The 
location of a stored cartridge is recorded in the library controller database, using the 
library internal address format (see “Library Internal Address” on page 591). The 
location is also transmitted to the host for inclusion in the host’s cartridge database.
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Ejecting Cartridges

You can eject up to 26 cartridges at one time through each rotational CAP. You can 
bulk unload up to 234 cartridges through each AEM CAP.

To eject a cartridge, you must specify the VOLID of the cartridge you want to remove 
from the library. The TallBot moves to the storage location indicated in the library 
controller database, removes the cartridge from the slot, and places the cartridge in a 
CAP slot. See “CAP Priorities for Cartridge Ejects by FC-SCSI Hosts” on page 379 for 
details on the order in which CAPs are used in FC-SCSI libraries. After the CAP is 
opened, the cartridge and its location are deleted from the library controller database 
and the host database. 

Note – The TallBot does not read cartridge labels during eject 
operations. 

Locating Cartridges

The SL Console allows you to display the library internal address of any cartridge. 
You can locate a cartridge based on any of the following criteria:

• VOLID – See “Locate a Cartridge by VOLID” on page 433 for details. 

• Library internal address – See “Locate a Cartridge by Address” on page 434 for 
details.

• Host address (FC-SCSI or HLI) – See “Locate a Cartridge by Address” on page 434 
for details.

This utility is especially useful when you need to perform a manual mount of a 
cartridge. The library management software (ELS or ACSLS) provides the VOLID 
and the HLI-PRC or FC-SCSI address of the cartridge and the drive bay address of an 
available drive. Before you enter the library, write down the VOLID, cartridge 
location, and the drive slot location. 

Barcode Presentation 

Note – This feature is available starting with SL3000 firmware 
version FRS_2.33 and SL Console version FRS_4.47. 

Note – This feature applies only to libraries with FC-SCSI host 
connections; it is not applicable to libraries that have only HLI 
(TCP/IP) host connections. 

The barcode presentation feature allows you to specify which part of a standard 
cartridge barcode the library passes to FC-SCSI host applications. 

Standard cartridge barcodes are eight characters in length, in 6+2 format, where:

• The first six characters indicate the unique volume ID (VOLID). For example, 
“NGD084”. 

• The last two characters indicate the media type and domain. For example, “L1” 
for LTO Gen 1 or “T1” for T10000. These characters are referred to as the media/
domain suffix. 
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Normally the library passes only the six VOLID characters to a host. This applies to 
both HLI and FC-SCSI connections. Some FC-SCSI host applications, however, may 
need the full eight-character barcode in order to uniquely identify a cartridge. The 
barcode presentation feature supports this requirement by allowing you to configure 
the library or partition to provide this information in all library/host 
communications. 

This feature does not affect how cartridge labels are displayed in library reports and 
screens. Nor does it affect which part of the label you must use when submitting a 
request through the SL Console or CLI. The full eight-character barcode is always 
used in these cases. 

For detailed instructions on setting the barcode presentation feature, see the 
following procedures:

• “Configure Barcode Presentation in a Non-Partitioned FC-SCSI 
Library” on page 423 

• “Configure Cartridge Barcode Presentation for an FC-SCSI Partition” on page 425 

Recovery Moves 

Using the recovery move diagnostic function, you can move a cartridge from one 
location to another. For example:

• You can return a cartridge to its original location from a CAP cell, drive, or 
another storage cell location. 

• You might decide to group cartridges by data type or to move them closer to their 
assigned drives. 

• You can eject a cleaning or diagnostic cartridge that has expired.

• You can enter a new cleaning or diagnostic cartridge and move it to a reserved 
storage cell. 

A cartridge currently in a storage cell can be moved only to a CAP, a system cell, or 
another storage cell, not to a drive. A cartridge currently in a drive, CAP, or system 
cell can be moved to any other unoccupied location in the library. See the following 
procedures for complete details:

• “Move a Specified Cartridge by VOLID” on page 436

• “Move a Cartridge From a Specified Location” on page 438

Before moving any cartridge, it is helpful to display or print a report showing where 
cartridges are currently located and which storage cells are unoccupied. See one of 
the following procedures for detailed instructions:

• “List Library Cartridges” on page 430



416  SL3000 User’s Guide March 2011 

 

Cartridge Management Tasks

Task Page

Enter Cartridges Through a Rotational CAP  417

Eject Cartridges Through a Rotational CAP  418

Bulk Load Cartridges Through an AEM CAP  419

Bulk Unload Cartridges Through an AEM CAP  418

Configure Barcode Presentation in a Non-Partitioned FC-SCSI Library  423

Configure Cartridge Barcode Presentation for an FC-SCSI Partition  425

Display Library Cartridge Information in Tabular Format  427

List Library Cartridges  430

Locate a Cartridge by VOLID  433

Locate a Cartridge by Address  434

Move a Specified Cartridge by VOLID  436

Move a Cartridge From a Specified Location  438

Display the Media Events Report  440
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▼ Enter Cartridges Through a Rotational CAP

Use this procedure to enter cartridges into the library through a rotational CAP. 

Note – This procedure applies to non-partitioned libraries. For 
partitioned libraries, see “Enter Cartridges Into a 
Partition” on page 246. 

Note – For detailed instruction on loading cartridges through an 
AEM CAP, see “Bulk Load Cartridges Through an AEM 
CAP” on page 419. 

1. Initiate the enter operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

Note – If the CAP is in auto enter mode, you can skip this step 
and proceed directly to Step 2. 

2. Push the CAP button to open the CAP. 

The CAP door opens. 

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

3. Place the cartridges in the CAP.

Insert the cartridges so that the customer label (if present) is facing up, the hub gear 
is facing down, and the cartridge label is facing you. 

You can enter the cartridges directly into the magazines while the magazines are 
in the CAP; or you can remove the magazines from the CAP, insert cartridges into 
the magazines, and then replace the cartridge-filled magazines into the CAP.

Note – Cartridges may be placed in any CAP slot, in any order; 
the TallBot audits all CAP slots when the CAP door closes.

Caution – Possible Media Damage. While cartridges that do not 
contain external labels or are placed upside-down can be entered, 
this is not advisable. It presents problems when an audit is 
performed. Likewise, cartridges that contain unreadable or 
damaged labels should not be entered. 

4. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

5. The TallBot audits the CAP and then moves the cartridges from the CAP to 
storage slots within the appropriate partition. 

When all cartridges have been moved from the CAP, the library recognizes that 
the CAP is empty and the CAP is returned to its default state. 
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▼ Eject Cartridges Through a Rotational CAP 

Use this procedure to eject cartridges from the library through a rotational CAP. 

Note – This procedure applies to non-partitioned libraries. For 
partitioned libraries, see “Eject Cartridges From a 
Partition” on page 247. 

Note – For detailed instruction on unloading cartridges through 
an AEM CAP, see “Bulk Unload Cartridges Through an AEM 
CAP” on page 421. 

1. Initiate the eject operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

You must specify the VOLIDs of the cartridges you want to remove from the 
library. For HLI hosts, you can specify the CAPs to use. For FC-SCSI hosts, the 
library uses CAPs in a pre-defined order; see “CAP Priorities for Cartridge Ejects 
by FC-SCSI Hosts” on page 379 for details. 

2. The TallBot places the cartridges into the CAPs.

When all the requested cartridges have been placed in CAPs, or all CAPs are full, 
the CAPs are unlocked. 

3. Push the CAP button to open the CAP. 

The CAP door opens. 

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

4. Remove the cartridges from the CAP.

You can remove the cartridges directly from the magazines while the magazines 
are in the CAP; or you can take the magazines out of the CAP, remove the 
cartridges from the magazines, and then replace the empty magazines in the CAP.

Note – If you do not replace the magazines in the CAP, the cells 
will be marked “absent” by the library controller. 

5. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

If more cartridges need to be exported, the TallBot continues filling the necessary 
CAPs. Wait until the CAP door is unlocked and repeat Step 3 through Step 5. 

The eject operation ends automatically when all specified cartridges have been 
ejected. 

6. The TallBot audits the CAP to verify that it is empty.

The CAP is then returned to its default state. 
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▼Bulk Load Cartridges Through an AEM CAP

Use this procedure to load cartridges into the library through an AEM CAP. You can 
load up to 234 cartridges at a time. 

Note – This procedure applies to non-partitioned libraries. For 
partitioned libraries, see “Enter Cartridges Into a 
Partition” on page 246. 

Note – For detailed instruction on entering cartridges through a 
rotational CAP, see “Enter Cartridges Through a Rotational 
CAP” on page 417. 

1. Initiate the enter operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

Note – If the AEM CAP is in auto enter mode, you can skip this 
step and proceed directly to Step 2. 

The Unlocked light on the AEM access door is lit. 

2. Push the AEM CAP button. 

The Wait light on the AEM access door starts blinking as all in-process jobs are 
finished. The robot is cleared from the AEM, and the safety door comes down. 
Depending on the level of activity in the library, this may take several minutes.

Once the safety door is completely down and the AEM is sealed, the Wait light 
stops blinking and the Enter light goes on solid.

3. Lift the latch, and open the door.

Caution – Possible Equipment Damage. DO NOT force the AEM 
access door to open or close.

4. Place the cartridges in the AEM CAP.

Insert the cartridges so that the customer label (if present) is facing up, the hub gear 
is facing down, and the cartridge label is facing you. 

You can enter the cartridges directly into the magazines while the magazines are 
in the CAP; or you can remove the magazines from the CAP, insert cartridges into 
the magazines, and then replace the cartridge-filled magazines into the CAP.

Note – Cartridges may be placed in any CAP slot, in any order; 
the TallBot audits all CAP slots when the CAP door closes.

Caution – Possible Media Damage. While cartridges that do not 
contain external labels or are placed upside-down can be entered, 
this is not advisable. It presents problems when an audit is 
performed. Likewise, cartridges that contain unreadable or 
damaged labels should not be entered. 

Caution – Possible Equipment Damage. When replacing magazines 
on the AEM walls, make sure you seat them correctly.

5. Close and latch the AEM access door.

Caution – Possible Equipment Damage. DO NOT force the AEM 
access door to open or close.

6. Push the AEM CAP button.
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The Enter light goes off, and the Wait light starts blinking. 

The safety door goes up.

7. The robot moves into the AEM, audits the AEM CAP, and then moves the 
cartridges from the AEM CAP to available storage cells. 

When all cartridges have been moved from the AEM CAP, the library recognizes 
that the AEM is empty and it is returned to its default state. 
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▼Bulk Unload Cartridges Through an AEM CAP

Use this procedure to unload cartridges from the library through an AEM CAP. You 
can unload up to 234 cartridges at a time. 

Note – For eject operations initiated from an FC-SCSI host, AEM 
CAPs are used only after all rotational CAPs have been filled. See 
“CAP Priorities for Cartridge Ejects by FC-SCSI 
Hosts” on page 379 for complete details. 

Note – This procedure applies to non-partitioned libraries. For 
partitioned libraries, see “Eject Cartridges From a 
Partition” on page 247. 

Note – For detailed instruction on ejecting cartridges through a 
rotational CAP, see “Eject Cartridges Through a Rotational 
CAP” on page 418. 

1. Initiate the eject operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

You must specify the VOLIDs of the cartridges you want to remove from the 
library. For HLI hosts, you can specify the AEM CAPs to use. For FC-SCSI hosts, 
the library uses rotational and AEM CAPs in a pre-defined order; see “CAP 
Priorities for Cartridge Ejects by FC-SCSI Hosts” on page 379 for details.

2. The TallBot places the cartridges into the AEM cells. 

When all the requested cartridges have been placed in the AEM, the AEM is 
unlocked and the Unlocked light on the AEM access door is lit. 

3. Push the AEM CAP button. 

The Wait light on the AEM access door starts blinking as all in-process jobs are 
finished. The TallBot is cleared from the AEM, and the safety door comes down. 
Depending on the level of activity in the library, this may take several minutes.

Once the safety door is completely down and the AEM is sealed, the Wait light 
stops blinking and the Enter light goes on solid.

4. Lift the latch, and open the door.

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

5. Remove the cartridges from the AEM CAP.

You can remove the cartridges directly from the magazines while the magazines 
are in the AEM; or you can take the magazines out of the AEM, remove the 
cartridges from the magazines, and then replace the empty magazines in the 
AEM. 

Caution – Possible Equipment Damage. When replacing magazines 
on the AEM walls, make sure you seat them correctly.

Note – If you do not replace the magazines in the AEM, the cells 
will be marked “absent” by the library controller. 

6. Close and latch the AEM access door.
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Caution – Possible Equipment Damage. DO NOT force the AEM 
access door to open or close.

7. Push the AEM CAP button.

The Enter light goes off, and the Wait light starts blinking. 

The safety door goes up.

8. If more cartridges need to be exported, the TallBot continues filling the 
necessary AEMs. Wait until the AEM Unlocked light is lit and repeat Step 3 
through Step 6. 

The eject operation ends automatically when all specified cartridges have been 
ejected. 

The TallBot moves into the AEM and audits the AEM CAP to verify that it is 
empty. The AEM CAP is then returned to its default state. 

Note – The audit of the AEM CAP should take less than three 
minutes. 
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▼Configure Barcode Presentation in a Non-Partitioned 
FC-SCSI Library

Note – This feature is available starting with SL3000 firmware 
version FRS_2.33 and SL Console version FRS_4.47. 

Use this procedure to configure the cartridge barcode presentation format for an 
FC-SCSI library. This specifies which part of a cartridge barcode the library passes to 
host applications that use the FC-SCSI interface. 

Note – This procedure applies only to libraries with FC-SCSI host 
connections; it is not applicable to libraries that have only HLI 
(TCP/IP) host connections. 

Note – This procedure applies to non-partitioned libraries only. 
For partitioned libraries, see “Configure Cartridge Barcode 
Presentation for an FC-SCSI Partition” on page 425. 

1. Select Tools > Configuration. 

The Library Configuration screen appears. 

2. In the Barcode Presentation pull-down, select the presentation format you want 
to use for the entire library. 

Note – The Partition Name “scsi0” indicates a non-partitioned 
library. 

Options are:

• all – All eight barcode characters are passed to host applications. 
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• left6 – Only the six VOLID characters, which are on the left side of the barcode, 
are passed to host applications. The domain and type characters, which are the 
two characters on the right, are not passed. This is the default setting. 

3. Click Apply.

A confirmation popup appears. The new barcode presentation setting is effective 
immediately; the library does not need to be rebooted. 

4. Click OK to dismiss the popup. 
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▼Configure Cartridge Barcode Presentation for an FC-SCSI 
Partition

Note – This feature is available starting with SL3000 firmware 
version FRS_2.33 and SL Console version FRS_4.47. 

Use this procedure to configure the cartridge barcode presentation format for an 
FC-SCSI partition. This specifies which part of a cartridge barcode the library passes 
to host applications accessing the partition. For details on this feature, see “Barcode 
Presentation” on page 414.

You can assign different presentation methods to each library partition. 

Note – This procedure applies only to libraries with FC-SCSI host 
connections; it is not applicable to libraries that have only HLI 
(TCP/IP) host connections. 

Note – This procedure applies to partitioned libraries only. For 
non-partitioned libraries, see “Configure Barcode Presentation in a 
Non-Partitioned FC-SCSI Library” on page 423. 

1. Select Tools > Configuration. 

The Library Configuration screen appears. 

2. In the partition Barcode Presentation pull-down, select the presentation format 
you want to use for that partition. You can use multiple pull-downs to select 
settings for more than one partition at a time. 

Options are:

• all – All eight barcode characters are passed to host applications. 
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• left6 – Only the six VOLID characters, which are on the left side of the barcode, 
are passed to host applications. The domain and type characters, which are the 
two characters on the right, are not passed. This is the default setting. 

3. Click Apply.

A confirmation popup appears. The new barcode presentation settings are 
effective immediately; the library does not need to be rebooted. 

4. Click OK to dismiss the popup. 
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▼Display Library Cartridge Information in Tabular Format

Note – This feature is available starting with SL3000 firmware 
version FRS_2.33 and SL Console version FRS_4.47. 

Use this procedure to display detailed information about all library cartridges in a 
sortable, tabular format. Information includes the cartridge VOLIDs, locations, and 
media types. You can use this report for a variety of purposes, such as:

• Locate cartridges by library internal address

• Verify that all cartridges in the library have valid, readable barcode labels

• Identify cleaning and diagnostic cartridges

• Identify cartridge media types in a mixed-media library

Note – You can modify the layout and display of this screen. See 
“Modifying the Screen Layout” on page 64 for details. 

Note – To display most of the same data in a straight text format, 
see “List Library Cartridges” on page 430. 

1. Select Tools > Reports. 

All library report options are listed in the navigation bar. 

2. Expand the Status Summary folder.

All Status Summary reports are listed. 

3. Click Cartridge Table. 
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The Cartridge Table Report is displayed. See “Screen Fields” below for a detailed 
description of each screen field. 

4. If you want to search the report data or save it to a file, see the following 
procedures:

• “Search a Library Report” on page 88 

• “Save Library Report Data to a File” on page 90

Screen Fields

lib, rail, col, side, row

Library, rail, column, side, and row. Together these values identify the library 
internal address where the cartridge is located. 

For a detailed description of the library internal address format, see “Library 
Internal Address” on page 591“Internal Address” on page 664.

Location Type

Type of library location where the cartridge is located. Options are:

• CAP – Rotational or AEM CAP cell

• cell – Regular storage cell

• drive – Loaded in a tape drive

• sysCell – System (reserved) cell; cleaning or diagnostic cartridges are typically 
stored in these cells 
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Media Type

Type of media in the cartridge. For example, Lto Gen3_400GB, 9840_R, T10000. 

Type

Domain, or usage type, of the cartridge. Options are:

• clean – Cleaning cartridge

• data – Data cartridge

• diagnostic – Diagnostic cartridge

Label 

Unique VOLID of the cartridge. Standard VOLIDs are eight characters in length. 

A value of #UREAD indicates the barcode label is unreadable. Possible reasons for 
this are as follows:

• The label is missing, damaged, or upside-down. In this case, the Custom Label 
field also indicates #UREAD. 

• The label has a non-standard format, such as a ten-character VOLID, or an 
unrecognized cartridge domain or media type indicator. In this case, the non-
standard VOLID is displayed in the Custom Label field. 

The library controller does not allow you to mount an unlabeled or unknown type 
cartridge into any tape drive. 

Custom Label

Non-standard VOLID of the cartridge, if applicable (requires the Open Format 
Volser feature). Possible entries for this field are as follows:

• Blank – The cartridge has a readable, standard eight-character VOLID cartridge 
label, as indicated in the Label field. 

• #UREAD – The cartridge label is truly not readable, possibly because it is 
missing, damaged, or upside-down. 

• Any other value – Indicates the non-standard VOLID of the cartridge. 
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▼ List Library Cartridges

Use this procedure to display information about all library cartridges, including their 
VOLIDs, locations, and media types. 

Note – To display the same data in a tabular format, see “Display 
Library Cartridge Information in Tabular Format” on page 427

1. Select Tools > Reports. 

All library report options are listed in the navigation bar. 

2. Expand the Status Summary folder.

All Status Summary reports are listed. 

3. Click Cartridge Summary. 
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The Cartridge Summary Report is displayed. See “Screen Fields” below for a 
detailed description of each screen field.

4. If you want to search the report data or save it to a file, see the following 
procedures:

• “Display a Library Report” on page 86 

• “Save Library Report Data to a File” on page 90

Screen Fields

Location

Library, rail, column, side, and row. Together these values identify the library 
internal address where the cartridge is located. 

For a detailed description of the library internal address format, see “Library 
Internal Address” on page 591“Internal Address” on page 664.

Location Type

Type of library location where the cartridge is located. Options are:

• CAP – Rotational or AEM CAP cell

• cell – Regular storage cell

• drive – Loaded in a tape drive
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• sysCell – System (reserved) cell; cleaning or diagnostic cartridges are typically 
stored in these cells 

Media Type

Type of media in the cartridge. For example, Lto Gen3_400GB, 9840_R, T10000. 

Type

Domain, or usage type, of the cartridge. Options are:

• clean – Cleaning cartridge

• data – Data cartridge

• diagnostic – Diagnostic cartridge

Cartridge 

Unique VOLID of the cartridge. Standard VOLIDs are eight characters in length. 

A value of #UREAD indicates the barcode label is unreadable. Possible reasons for 
this are as follows:

• The label is missing or damaged. 

• The label has a non-standard format, such as a ten-character VOLID, or an 
unrecognized cartridge domain type or media type indicator. 

The library controller does not allow you to mount an unlabeled or unknown type 
cartridge into any tape drive. 
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▼ Locate a Cartridge by VOLID

Use this procedure to display the current location of a cartridge with a specified 
volume ID. The location can be displayed in one of the following formats:

• Library internal address

• HLI-PRC address (HLI hosts only)

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the Search tab.

The Library Search screen appears. 

3. In the Search Type pull-down, click VOLID. 

4. Enter the VOLID, Requester, and Cartridge Type. 

The Requester field controls the address format that will be displayed for the 
cartridge location. 

• To display the library internal address, click default.

• To display the HLI-PRC address, click hli0 or hli1. 

Note – You can use wildcards in the VOLID field. 

5. Click Search. 

The screen displays all cartridges meeting the search criteria. 
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▼ Locate a Cartridge by Address

Use this procedure to display detailed information for cartridges with a specified 
location. Wildcards allow you to display all cartridges in a specified general area (for 
example, in a specified panel, row, or column). You can specify the location using 
one of the following formats:

• Library internal address

• HLI-PRC address (HLI hosts only)

• FC-SCSI address (FC-SCSI hosts only) 

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the Search tab.

The Library Search screen appears. 

3. In the Search Type pull-down, click Location. 

Note – The default Search Type is VOLID. 

The screen is updated to display fields allowing you to search by location. 

4. In the Location pull-down, select the type of match you want to perform in the 
search.

5. In the Requester pull-down, select the type of address format you want to use 
for the search. 

6. In the Location field, enter the parameters for the search. 

The format you use must correspond to the Requester you have specified. For 
example:

• Use the library internal address format if Requester is “default”.

• Use the HLI-PRC address if Requester is an HLI host.

• Use the FC-SCSI address if Requester is an FC-SCSI host. 

Note – You cannot use wildcards in this field. 

7. Click the Search button. 
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The screen displays all locations meeting the search criteria. 

8. To see details about a cartridge or to view a location mapping, click the ... 
button in the Details column. 

The Location Details screen appears. 

9. Click Close to dismiss the popup. 
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▼Move a Specified Cartridge by VOLID

Use this procedure to move a cartridge with a specified VOLID to a specified location 
within the library. 

Note – This procedure updates the cartridge’s location in the 
library controller database, but not in the host database. Therefore 
after performing this procedure, you must perform an audit from 
the host software to update the host database. Failure to do so will 
cause future mount requests from the host software to fail. 

Caution – Use caution when performing this procedure in 
partitioned libraries. You could inadvertently move a cartridge 
from one partition to another, allowing the new partition to 
overwrite data on the cartridge. 

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the RcvrMove tab. 

The Recovery Move screen appears. 

3. In the Source Location Mode field, click VOLID. 

The screen is updated with the appropriate Source Location fields. 

4. In the VOLID field, specify the VOLID of the cartridge you want to move. 

5. In the Destination Location Type pull-down menu, select the type of location 
where you want to move the cartridge to. Options are:

• CAP

• Storage Slots 

• Drive

• Reserved Slots

• The following restrictions apply:

• The destination can be a drive only if the source is a CAP or reserved slot. 

• For you to move a a cartridge to a drive, the cartridge media type must be 
compatible with the drive type. 

• You cannot move a cartridge to a location that is already occupied. 

• Although not strictly enforced, it is recommended that only diagnostic or 
cleaning cartridges be moved to reserved slots. 

6. In the Destination Location table, specify the library internal address of the 
destination location by making the appropriate selections in the following pull-
down menus:

The following special selections are available on the pull-down menus:

• Min—First element of that location type——in the library 

• Max—Last element of that location type——in the library 
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Caution – If the library is partitioned, make sure to keep the 
cartridge in the same partition it is currently allocated to. Moving a 
cartridge to a cell allocated to a different partition could result in a 
host treating the cartridge as scratch and overwriting the data. 
Moving the cartridge to an unallocated cell will result in the 
cartridge being inaccessible to all hosts. 

7. Click the Start button in the Options Bar.

The robot moves the cartridge. A success message popup appears when the 
operation is complete. 

8. Click OK.

9. To verify the new location, you can display a Cartridge Summary Report. See 
“List Library Cartridges” on page 430 for details. For example: 

10. To update the new cartridge location in the host database, initiate a library 
audit from the host software. See the appropriate tape management software 
documentation for the procedures and commands.
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▼Move a Cartridge From a Specified Location

Use this procedure to move a cartridge from one specified location to another within 
the library. 

Note – This procedure updates the cartridge’s location in the 
library controller database, but not in the host database. Therefore 
after performing this procedure, you must perform an audit from 
the host software to update the host database. Failure to do so will 
cause future mount requests from the host software to fail. 

Caution – Use caution when performing this procedure in 
partitioned libraries. You could inadvertently move a cartridge 
from one partition to another, allowing the new partition to 
overwrite data on the cartridge. 

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the RcvrMove tab. 

The Recovery Move screen appears. 

3. In the Source Location Mode field, click Location. 

The screen is updated with the appropriate Source Location fields. 

4. In the Source Location Type pull-down menu, select the cartridge’s current 
location type. Options are:

• CAP

• Slot

• Drive

• Reserved Slots

5. In the Source Location table, specify the library internal address of the source 
location by making the appropriate selections in the following pull-down 
menus:

The following special selections are available on the pull-down menus:

• Min—First element of that location type——in the library 

• Max—Last element of that location type——in the library 

6. In the Destination Location Type pull-down menu, select the type of location 
where you want to move the cartridge to. Options are:

• CAP

• Storage Slots 

• Drive

• Reserved Slots

• The following restrictions apply:

• The destination location can be a drive only if the source is a CAP or reserved 
slot. 
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• For you to move a a cartridge to a drive, the cartridge media type must be 
compatible with the drive type. 

• You cannot move a cartridge to a location that is already occupied. 

• Although not strictly enforced, it is recommended that only diagnostic or 
cleaning cartridges be moved to reserved slots. 

7. In the Destination Location table, specify the library internal address of the 
destination location by making the appropriate selections in the following pull-
down menus:

The following special selections are available on the pull-down menus:

• Min—First element of that location type——in the library 

• Max—Last element of that location type——in the library 

Caution – If the library is partitioned, make sure to keep the 
cartridge in the same partition it is currently allocated to. Moving a 
cartridge to a cell allocated to a different partition could result in a 
host treating the cartridge as scratch and overwriting the data. 
Moving the cartridge to an unallocated cell will result in the 
cartridge being inaccessible to all hosts. 

8. Click the Start button in the Options Bar.

The robot moves the cartridge, and then a success message popup appears.

9. Click OK.

10. To verify the new location, you can display a Cartridge Summary Report. See 
“List Library Cartridges” on page 430 for details. For example: 

11. To update the new cartridge location in the host database, initiate a library 
audit from the host software. See the appropriate tape management software 
documentation for the procedures and commands.



440  SL3000 User’s Guide March 2011 

 

▼Display the Media Events Report

Note – This feature is available starting with SL3000 firmware 
version FRS_2.30 and SL Console version FRS_4.30. 

The Media Events Report summarizes library cartridge media events. The report is 
updated whenever a media event or error occurs on any drive. You can use the 
report to help identify and diagnose faulty cartridges. 

For each cartridge that has experienced media events, the report lists the VOLID of 
the cartridge, the type of event, the number of occurrences, and the date and time of 
the last such event. The report can display up to 2000 entries.

By default, the report is sorted in VOLID order. Optionally, you can change the sort 
order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 64. 

Note – For cartridge events associated with particular drives, see 
“Display the Drive Media Events Report” on page 411. 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Media Events. 

Screen Fields

Cartridge Label 

VOLID of the cartridge that has experienced an event. 
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Event Type

Type of media event being tracked. Options are:

• Media Error – The drive indicated there was a problem with the media; this 
could possibly also indicate a problem with the drive.

• Misbuckle Error – The drive was unable to grab the buckle of the media and 
could not thread the tape. The media is likely damaged. 

Number of Events

Total number of events of this type that have been recorded for this cartridge. 

Last Seen

Date and time of the most recent occurrence of the event. 
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11

Drive Cleaning

Library tape drives require periodic cleaning to prevent read/write errors. A drive is 
cleaned by mounting a compatible cleaning cartridge in response to a cleaning 
request from the drive. 

The SL3000 allows you to manage drive cleaning in either of the following ways. 

• Library Auto Clean—All cleaning cartridge and drive clean functions are 
managed by the library controller. Check your tape management software 
documentation to determine whether this method is recommended for your 
library. 

See “Library Auto Clean” on page 444 for a detailed description of this feature. 

• Host-Managed Tape Cleaning—All cleaning cartridge and drive clean functions 
are managed by host applications, such as ACSLS or ELS, or by direct-attach 
applications, such as Symantec and NetBackup. This method is available for HLI 
libraries and partitions. 

See “Host-Managed Tape Cleaning” on page 445 for additional information. 

Note – These methods are mutually exclusive. In non-partitioned 
libraries, you must choose one method or the other for the entire 
library. In partitioned libraries, the method can be assigned by 
partition, but each partition must use only one method. 

Note – This chapter describes the library auto clean feature only. 
If you want to manage drive cleaning using the host tape 
management software (ACSLS or ELS), see “Host-Managed Tape 
Cleaning” on page 445 for additional information. 
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Library Auto Clean 
Note – This feature is available starting with SL3000 firmware 
version FRS_3.0 and SL Console version FRS_5.00. 

The library auto clean feature allows all drive clean functions to be managed by the 
library controller. You can import cleaning cartridges into the library, where they are 
stored in reserved system cells. As soon as a drive indicates that it needs cleaning, the 
library controller automatically selects a compatible cleaning cartridge from the 
system cells and mounts it on the drive. When the cleaning activity is completed, the 
library controller dismounts the cartridge and returns it to a system cell. 

With the auto clean feature, the library tracks cleaning cartridge usage and notifies 
you when cleaning cartridges have expired or have reached a user-defined usage 
threshold. You can automatically export cleaning cartridges from the library, in bulk, 
by expiration date, or by selected cartridge volume ID (VOLID or volser). 

In partitioned libraries, auto clean can be configured for the entire library or for 
individual library partitions. 

See “Special Considerations” on page 445 for additional details about library auto 
clean operations. 

Note – Library auto clean differs from drive cleaning managed by 
ACSLS or ELS; see “Host-Managed Tape Cleaning” on page 445 to 
compare the two methods.

Library Auto Clean Process Summary 

Following is a summary of the actions you should take to configure and use the 
library auto clean feature. 

1. Enable library auto clean. In partitioned libraries, the feature can be enabled or 
disabled separately for each partition. See “Configure Library Auto 
Clean” on page 451 for details.

2. Configure the maximum usage warning threshold for each cleaning cartridge 
type. See “Define Cleaning Cartridge Warning Thresholds” on page 452 for 
details. 

3. Import cleaning cartridges into the library. The cartridges are placed in reserved 
system cells. See “Import Cleaning Cartridges” on page 454 for details. 

Note – When using the library auto clean feature, do NOT use 
ACSLS or ELS to enter cleaning cartridges into the library. ACSLS 
and ELS store cleaning cartridges in regular storage cells, and the 
library controller does not have access to these cells for the auto 
clean function. 

4. Have the library controller manage drive cleaning as required.

5. Monitor status of cleaning cartridges and drives. See the following procedures for 
details:

• “Display Cleaning Cartridges” on page 459

• “Display Drive Cleaning Status” on page 461
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6. Export cleaning cartridges from the library as necessary. You can use any of the 
following methods:

• Export all cartridges

• Export expired cartridges

• Export selected cartridges

See “Export Cleaning Cartridges” on page 456 for details. 

See “Drive Cleaning Tasks” on page 450 for a list of all tasks related to drive cleaning. 

Special Considerations

Following are details and special considerations about the library auto clean feature. 

Host Interactions

With the auto clean feature, the library controller initiates a drive clean operation 
immediately upon receipt of a cleaning request from the drive, which typically occurs 
when the drive dismounts a data cartridge. While the drive is being cleaned, the data 
cartridge dismount remains pending to the host. The host is not notified that the data 
cartridge dismount is complete until the drive clean operation has finished and the 
cleaning cartridge has been returned to a system cell. 

While a drive is being cleaned, it is marked as busy to all hosts. If an FC-SCSI host 
requests the drive while the drive is being cleaned, the request is rejected. 

Unsuccessful Cleaning Operations

If the library controller cannot locate a non-expired cleaning cartridge that is 
compatible with the drive, the library controller sends messages to the system Event 
Log and the Status Module screen. See “Library Events” on page 479 and “Status 
Alert Messages” on page 332 for details. 

After a cleaning cartridge has been mounted on a drive, if the drive indicates that the 
cartridge is unusable, the library controller automatically returns the cartridge to a 
reserved system cell and selects another cartridge to fulfill the cleaning request. 

Use of Reserved System Cells 

When cleaning cartridges are imported into the library, the library distributes the 
cartridges as evenly as possible among the sides of the library. Cleaning cartridges 
can be stored in any available system cell. 

The reserved system cells are not assigned to partitions. Therefore a cleaning 
cartridge can be used to clean compatible drives allocated to any library partition. 

Host-Managed Tape Cleaning 

The host tape management software (ACSLS or ELS) can be used to manage drive 
cleaning in HLI libraries or partitions. Following is a summary of the actions you 
should take in order to use host-managed cleaning. For full details, see the ACSLS or 
ELS documentation.
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Note – This method differs from the library auto clean feature; see 
“Library Auto Clean” on page 444 to compare the two methods. 

1. Disable the library auto clean function. In partitioned libraries, you can do this on 
a per-partition basis. See “Configure Library Auto Clean” on page 451 for details.

Library auto clean must be disabled in order for ACSLS or ELS to receive 
notification from the library when drives need cleaning. 

2. Enable automatic cleaning within the tape management software. 

• For ELS, see the MNTD AUtocln(ON) command in the ELS System 
Programmer's Guide for instructions on enabling the cleaning function. 

• For ACSLS, automatic cleaning is enabled by default. For details, see the 
AUTO_CLEAN variable, which is set by the acsss_config utility, in the ACSLS 
Administrator’s Guide. 

3. Use the applicable ACSLS or ELS commands to enter cleaning cartridges into the 
library. 

Do NOT use the SL Console Import/Export screen to enter cleaning cartridges, as 
the library controller will store the cartridges in reserved system cells. ACSLS and 
ELS do not have access to these cells. 

4. Have the tape management software manage drive cleaning as required.

5. Use the applicable ACSLS or ELS commands to monitor status of cleaning 
cartridges and drives. 

6. Use the applicable ACSLS or ELS commands to eject cleaning cartridges from the 
library. 

You cannot use the SL Console Import/Export screen to eject host-managed 
cleaning cartridges. 
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Cleaning Cartridge Management
You must ensure that the library contains a sufficient number of cleaning cartridges 
that are compatible with each drive type in your library. See the drive manufacturers’ 
documentation for compatibility requirements. 

The library auto clean feature requires that cleaning cartridge volume IDs (VOLIDs 
or volsers) be eight characters in length, with “CLN” as the first three characters. The 
library Import/Export function only accepts cleaning cartridges that have labels with 
this format. 

With the library auto clean feature, cleaning cartridges are stored in reserved system 
cells which are controlled by the library and are not accessible to library host 
applications. The number of system cells available for cleaning cartridge storage 
varies, depending on the configuration of your SL3000 library. See “Reserved System 
Cells” on page 615 for details. 

Importing and Exporting Cleaning Cartridges

In order for cleaning cartridges to be available for the library auto clean feature, they 
must be entered into the library with the SL Console Import function. See “Import 
Cleaning Cartridges” on page 454 for detailed instructions. 

Any cleaning cartridges entered with the host tape management software (ACSLS or 
ELS) are stored in data cells and cannot be used for the library auto clean feature. 

To remove cleaning cartridges from the library, you must use the SL Console Export 
function. See “Export Cleaning Cartridges” on page 456 for detailed instructions. You 
can choose to export all cartridges, selected cartridges, or all expired cartridges. 

Note – The command line interface (CLI) also provides cleaning 
cartridge import and export commands accessible to your Oracle 
support representative. 

Cartridge Usage Count

Cleaning cartridges have a limited life span. See the drive manufacturers’ 
documentation for maximum recommended usage for each type of cleaning 
cartridge.

When you import a cleaning cartridge into the library, the library controller considers 
the cartridge to be new and sets the usage count to zero. Therefore, if you import a 
used cleaning cartridge, the usage count for that cartridge will not be accurate. 

Each time a cleaning cartridge is mounted on a drive, the library controller 
increments the usage count for that cartridge. See “Display Cleaning 
Cartridges” on page 459 to display the current usage count. 

Warning Threshold

You can use the cleaning cartridge warning threshold to notify you when a cleaning 
cartridge is nearing time for replacement. You can selectively activate or deactivate 
the warning threshold feature for each cleaning cartridge type. By default, the feature 
is deactivated for all.
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To activate the feature, you can assign a threshold to a selected cartridge type. See 
“Define Cleaning Cartridge Warning Thresholds” on page 452 for details. The 
warning threshold is based on the cartridge usage count. You should set the warning 
threshold lower than the cartridge’s maximum recommended usage to allow time to 
replace the cartridge. 

When a cleaning cartridge’s usage count reaches the threshold you have defined, the 
library controller updates the cartridge’s status to “warning” and sends messages to 
the system Event Log and the Status Module screen. (See “Library 
Events” on page 479 and “Status Alert Messages” on page 332 for details.) The 
messages are repeated each time the cleaning cartridge is used, until it is exported 
from the library or expires. 

Cleaning Cartridge Expiration

Cleaning cartridges are expired based on information from the drives. If a drive is 
not able to use a cleaning cartridge—due to reaching the end of tape, for example—
the drive sends a “drive expired” notification to the library controller. The library 
controller dismounts the cartridge from the drive and returns it to a system cell, 
updates the cartridge’s status to “expired”, and sends messages to the system Event 
Log and the Status Module screen. (See “Library Events” on page 479 and “Status 
Alert Messages” on page 332 for details.)

The library controller does not use expired cleaning cartridges for cleaning 
operations. Expired cartridges should be replaced as soon as possible. When you 
export an expired cleaning cartridge from the library, you must be sure to remove it 
from the CAP. If you leave an expired cartridge in the CAP, it could inadvertently be 
re-entered into the library by another user. 

Note – Although the library controller keeps track of cleaning 
cartridge usage, it does not expire cleaning cartridges on the basis 
of the usage count. 

Cleaning Cartridge Status

You can use the SL Console to display the status of a cleaning cartridge at any time. 
A cleaning cartridge can have any of the following statuses:

• OK—The cartridge is usable for cleaning. 

• warning—The usage count has reached or exceeded the warning threshold 
defined for this cartridge type. 

• expired—The cartridge has expired, based on information from the drives. 

See “Display Cleaning Cartridges” on page 459 for details. 
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Manual Cleaning 
Drive cleaning is normally managed either by the library auto clean feature or by the 
host tape management software (ACSLS or ELS). However, there may be occasions 
when you need to perform a manual clean. 

Caution – Cleaning a drive before it is due is not recommended. 
Excessive drive cleaning can wear out a drive head prematurely. 

See the drive manufacturer’s documentation for information on whether manual 
cleaning is allowed. Some drive types allow manual cleaning at any time, while 
others do not allow cleaning to be initiated unless a usage threshold has been met. In 
the latter case, the library controller may allow you to mount a cleaning cartridge on 
a drive, but the drive will not actually perform the cleaning operation. 

To verify whether a drive needs cleaning, you can display the drive’s cleaning status 
and the date when it was last cleaned. See “Display Drive Cleaning 
Status” on page 461 for details. 

To locate the correct type of cleaning cartridge for a particular drive, you can 
generate a list of available cleaning cartridges and their types. See “Display Cleaning 
Cartridges” on page 459 for details.
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Drive Cleaning Tasks

Task Page

Configure Library Auto Clean  451

Define Cleaning Cartridge Warning Thresholds  452

Import Cleaning Cartridges  454

Export Cleaning Cartridges  456

Display Cleaning Cartridges  459

Display Drive Cleaning Status  461

Clean a Drive Manually  463



March 2011   451

 

▼Configure Library Auto Clean

Use this procedure to enable or disable the library auto clean feature. If the library is 
partitioned, library auto clean can be enabled or disabled for individual partitions. 

1. Select Tools > Configuration. 

The Library Configuration Options screen appears. 

2. Set the Enable Auto Clean checkbox for the partition you want to configure. 
Options are:

• Checked – Turns library auto clean on. The library controller will manage all 
drive cleaning functions. 

• Unchecked – Turns library auto clean off. Drive cleaning must be managed 
through the host library management software (ACSLS or ELS). This is the 
default setting. 

Note – If the library is partitioned, there is one checkbox for each 
partition, allowing you to enable or disable library auto clean 
separately for each partition. If the library is not partitioned, there 
is only one checkbox (labeled Partition 1), which applies to the 
whole library. 

3. Click Apply.

The library configuration is updated, and the feature settings are available 
immediately. 
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▼Define Cleaning Cartridge Warning Thresholds

Use this procedure to assign usage warning thresholds to selected cleaning cartridge 
types. 

Note – This procedure applies only to libraries or partitions that 
have the library auto clean feature enabled. 

1. Select Tools > System Detail, and select the library folder on the device tree.

2. Click Auto Clean and then Warning Threshold.

The Warning Threshold screen appears. 

3. Complete the screen fields as follows:

• In the Threshold warning index to change pull-down, select the index number 
of the cleaning cartridge type you want to configure. 

The numbers in the pull-down refer to the Index entries in the table on the 
bottom part of the screen. 

• In the New warning threshold count field, enter the warning threshold you 
want to assign to the cartridge type. An entry of 0 deactivates the warning 
threshold feature for that cartridge type. The default is 0.
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Note – You should set the threshold lower than the cartridge’s 
recommended maximum usage to allow time to replace the 
cartridge. The Recommended Max Usage values on this screen 
are pre-defined, based on the manufacturers’ published 
recommendations. See your drive manufacturers’ documentation 
for additional information. 

4. Click Apply. 

The new threshold value is assigned to the cartridge type, and the Warning 
Threshold value on the screen is updated. 



454  SL3000 User’s Guide March 2011 

 

▼ Import Cleaning Cartridges

Use this procedure to enter cleaning cartridges into the library through a specified 
CAP. The library controller reserves the CAP for the entire operation. The cleaning 
cartridges are distributed as evenly as possible in reserved system cells, and their 
usage counts are set to 0. Only one cleaning or diagnostic cartridge import or export 
operation can be performed at a time. 

Note – This procedure applies only to libraries or partitions that 
have the library auto clean feature enabled. 

Note – Only rotational CAPs, not AEM CAPs, can be used for this 
procedure. 

Before beginning this procedure, verify that the following conditions are met:

• The CAP is empty, available for use (not reserved by a host), and closed and 
locked. 

• The library has enough empty reserved system cells to store the cleaning 
cartridges you want to import. At least one system cell on each side of the library 
must be left open for TallBot recovery or library initialization. 

1. Select Tools > Diagnostics.

2. Expand the CAP Folder, highlight the CAP you want to use, and then select the 
Import/Export tab.

The Import/Export screen appears. 
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3. Select Import Cleaning/Diagnostic cartridges, and then click Start.

The import operation begins, and the Import/Export screen displays the ongoing 
status. 

4. The library controller reserves the CAP and unlocks and opens the CAP door. 

If the library is partitioned and the CAP is associated to an FC-SCSI partition, the 
library controller associates the CAP to the default requestor for the duration of 
the import operation. 

5. Load the cleaning cartridges into the CAP. 

For detailed instructions, see “Enter Cartridges Through a Rotational 
CAP” on page 417.

6. After you close the door, the cleaning cartridges are moved to available system 
cells. 

Any data cartridges or cleaning cartridges with invalid labels are ignored and left 
in the CAP. 

7. When all cleaning cartridges have been moved from the CAP, the library 
controller proceeds as follows:

• If the CAP is empty, the library controller releases the CAP reservation and re-
associates the CAP to the original FC-SCSI partition, if applicable. 

• If cartridges are left in the CAP, the CAP door is opened, and the Import/
Export screen displays a message that the cartridges need to be removed.
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▼ Export Cleaning Cartridges

Use this procedure to export cleaning cartridges from the library through a specified 
CAP. The library controller reserves the CAP for the entire operation. The cleaning 
cartridges are retrieved from reserved system cells and placed in the CAP for 
removal. Only one cleaning cartridge import or export operation can be performed at 
a time. 

Note – This procedure applies only to libraries or partitions that 
have the library auto clean feature enabled. 

Note – Only rotational CAPs, not AEM CAPs, can be used for this 
procedure. 

Before beginning this procedure, verify that the CAP is empty, available for use (not 
reserved by a host), and closed and locked. 

1. Select Tools > Diagnostics.

2. Expand the CAP Folder, highlight the CAP you want to use, and then select the 
Import/Export tab.

The Import/Export screen appears. 

3. Select the type of export operation you want to perform. You have the following 
options: 

• Export expired cleaning cartridges—Automatically exports all cleaning 
cartridges with a status of “expired”. To display a list of expired cartridges, see 
“Display Cleaning Cartridges” on page 459. 
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• Export specific cleaning cartridges—Allows you to specify the cleaning 
cartridges you want to eject. The screen displays a list of all cleaning cartridges 
in the library, and you can select one or more for export. 

• Export all cleaning cartridges—Exports all cleaning cartridges from the library. 

4. Click Start.

A confirmation popup appears. 

5. Click OK to continue. 
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The export operation begins, and the Import/Export screen displays the ongoing 
status. 

6. The export operation proceeds as follows:

a. If the library is partitioned and the CAP is associated to an FC-SCSI 
partition, the library controller associates the CAP to the default requestor 
for the duration of the export operation. 

b. The library controller reserves the CAP. 

c. The cleaning cartridges are moved to the CAP, according to your request. 

d. The Import/Export screen displays a message when the CAP is ready to be 
unloaded. 

7. Remove the cartridges from the CAP. 

For detailed instructions, see “Eject Cartridges Through a Rotational 
CAP” on page 418.

8. When you close the CAP door, the library controller proceeds as follows:

• If the CAP is empty, the library controller releases the CAP reservation and re-
associates the CAP to the original partition, if applicable. 

• If cartridges are left in the CAP, the CAP door is opened, and the Import/
Export screen displays a message that the cartridges need to be removed.
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▼    Display Cleaning Cartridges

Use this procedure to display detailed information about all cleaning cartridges 
stored in reserved system cells. In particular, you can use this procedure to monitor 
the status and usage count for all cleaning cartridges under library control. 

A cleaning cartridge may not appear on this screen in the following cases:

• The cartridge is in use. 

• The cartridge is in transit. 

• The cartridge was entered into the library using the host tape management 
software (ACSLS or ELS). See your tape management software documentation for 
details about managing these cartridges.

1. Select Tools > System Detail, and select the library folder on the device tree.

2. Click Auto Clean and then Cleaning Cartridges.

The Library Cleaning Cartridges screen appears. 

Screen Fields

Tape Location 

Library, rail, column, side, and row. Together these values identify the library 
internal address where the cartridge is located. 

All cartridges in this report are located in reserved system cells. 
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VOLID 

Volume ID (VOLID or volser) of the cartridge. The first three characters are 
always “CLN”. 

Usage Count 

Number of times the cartridge has been used for cleaning. When a cleaning 
cartridge is imported into the library, its usage count is set to 0. Each time the 
cartridge is mounted on a drive, its usage count is incremented. 

Status 

Current status of the cartridge. Options are:

• expired—The cartridge has expired, based on information from the drives (see 
“Cleaning Cartridge Expiration” on page 448). This cartridge is not usable and 
should be replaced as soon as possible. 

This status supersedes the “warning” status; therefore, if a cartridge is both 
expired and has reached or exceeded its usage count threshold, only “expired” 
is displayed. 

• OK—The cartridge is usable for cleaning. 

• warning—The usage count has reached or exceeded the warning threshold 
defined for this cartridge type (see “Warning Threshold” on page 447). The 
cartridge can still be used for cleaning, but you may want to replace it at your 
earliest convenience. 

Cart Type 

Type of cleaning cartridge. You should have an adequate supply of usable 
cleaning cartridges for each type of drive in the library. See the drive 
manufacturer’s documentation for cleaning cartridge requirements. 
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▼Display Drive Cleaning Status 

Use this procedure to display the current cleaning status of a drive. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and highlight the drive you want to display. 

The Drive Status screen appears. 

Screen Fields

The following screen fields relate to drive cleaning. 

Drive needs cleaning

Indicates whether the drive has issued an unfulfilled cleaning request. Options 
are:

• true—Drive needs cleaning. 

• false—Drive does not need cleaning. 

Drive Last Autocleaned

Date and time when the drive was last cleaned using the library auto clean 
feature. 
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If the library auto clean feature is not enabled, or if the drive was last cleaned 
using the host tape management software (ACSLS or ELS), the field indicates 
“Unknown”. 
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▼Clean a Drive Manually

Drive cleaning is normally managed either by the library auto clean feature or by the 
host tape management software (ACSLS or ELS). However, there may be occasions 
when you need to perform a manual clean. 

Caution – Cleaning a drive before it is due is not recommended. 
Excessive drive cleaning can wear out a drive head prematurely. 

1. Display the drive status to verify that it needs cleaning. See “Display Drive 
Cleaning Status” on page 461 for detailed instructions.

2. Display a list of cleaning cartridges. See “Display Cleaning 
Cartridges” on page 459 for detailed instructions. 

Your library could contain more than one type of drive. You must verify that there 
is a compatible cleaning cartridges for the drive. 

3. Move a compatible cleaning cartridge from a system cell to the drive that needs 
cleaning. See “Move a Cartridge From a Specified Location” on page 438 for 
detailed instructions. 

4. Display the status of the cleaning operation on the Drive Clean Status Console. 
See “Display Drive Cleaning Status” on page 461 for detailed instructions. 

5. When the cleaning operation is complete, move the cleaning cartridge from the 
drive back to a system cell. See “Move a Cartridge From a Specified 
Location” on page 438 for detailed instructions.
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12

Robot and Power Supply Management

TallBots 
The library TallBot moves cartridges throughout the library storage slots, tape drives, 
and CAPs. It also performs audits of the library. 

The TallBot is included with the Base Module and is accessible from the front of the 
rack, or through the optional Access Expansion Module (AEM). The three main 
components of the TallBot are:

• X table assembly – Provides 180-degree lateral motion. 

• Z drive assembly – Provides vertical motion. 

• Hand assembly – Includes the following components:

• Grippers to carry cartridges. 

• Laser bar-code scanner to calibrate position and read cartridge labels. 

• Proximity sensor to detect empty storage cells and unlabeled cartridges. 

See “Robot Monitoring Tasks” on page 467 for details about displaying and 
managing TallBot status and other information. 

SCSI FastLoad Feature

Note – This feature is available starting with SL3000 firmware 
version FRS_2.33 and SL Console version FRS_4.47. 

Note – This feature applies only to libraries with FC-SCSI host 
connections; it is not applicable to libraries that have only HLI 
(TCP/IP) host connections. 

SCSI FastLoad is an optional feature which can enable faster mount/dismount 
operations for libraries or partitions with FC-SCSI host connections. 

Normally with the SCSI interface, a cartridge mount is considered complete only 
when the drive indicates that it is ready for read/write operations. This can result in 
the TallBot standing idle for several seconds between mount/dismount requests 
while it waits for the cartridge to load and thread in the drive. 
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When SCSI FastLoad is enabled, a cartridge mount is considered complete as soon as 
the drive indicates that it has accepted the cartridge. As soon as the TallBot puts the 
cartridge in the drive, the TallBot is released and the library returns a success status 
to the host. The TallBot is immediately available to process the next library request. 

The advantage of the FastLoad feature is that it allows for faster activity in the 
library. However, if a cartridge fails to load after the TallBot has been released, it is 
up to the FC-SCSI host to move the cartridge from the drive back to the source 
element.

In a partitioned library, the FastLoad feature can be enabled or disabled separately 
for each FC-SCSI partition. 

For detailed instructions on enabling the FastLoad feature, see the following 
procedures:

• “Configure SCSI FastLoad in a Non-Partitioned Library” on page 468 

• “Configure SCSI FastLoad for a Partition” on page 470 

Robot Procedures

For detailed TallBot management procedures, see “Robot Monitoring 
Tasks” on page 467. 

Power Supplies
The SL3000 provides full redundancy for tape drives, robotics units, and electronics. 
The following redundancy options are available: 

• N+1 

• 2N 

• 2N+1 

Note – The second power distribution unit (PDU) supports N+1 
for tape drives and electronics only, not robotics. 

The following power source options are available:

• 120–127 VAC, single phase (not available with the redundant robotics feature)

• 200–240 VAC, single phase

See “Power Options” on page 49 for additional details. 

Power Supply Procedures

For detailed power supply procedures, see “Power Supply Monitoring 
Tasks” on page 475. 
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Robot Monitoring Tasks

Task Page

Configure SCSI FastLoad in a Non-Partitioned Library  468

Configure SCSI FastLoad for a Partition  470

Display Robot Summary Information  472

Display Robot Status  473
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▼Configure SCSI FastLoad in a Non-Partitioned Library

Note – This feature is available starting with SL3000 firmware 
version FRS_2.33 and SL Console version FRS_4.47. 

Use this procedure to configure the SCSI FastLoad feature for an FC-SCSI library. For 
details on this feature, see “SCSI FastLoad Feature” on page 465. 

Note – This procedure applies only to libraries with FC-SCSI host 
connections; it is not applicable to libraries that have only HLI 
(TCP/IP) host connections. 

Note – This procedure is used for non-partitioned libraries only. 
For partitioned libraries, see “Configure SCSI FastLoad for a 
Partition” on page 470. 

1. Select Tools > Configuration. 

The Library Configuration screen appears. 

2. Use the Enable FastLoad Feature checkbox to indicate whether you want to 
enable the FastLoad feature for the entire library. 

Note – The Partition Name “scsi0” indicates a non-partitioned 
library. 

Checkbox settings are as follows:

• Checked – Turns SCSI FastLoad on. A cartridge mount is considered complete 
as soon as the drive indicates that it has accepted the cartridge. 



March 2011   469

 

• Unchecked – Turns SCSI FastLoad off. A cartridge mount is considered 
complete only after the cartridge has been loaded and threaded in the drive 
and the drive indicates that it is ready for read/write operations. This is the 
default setting. 

3. Click Apply.

A confirmation popup appears. The new SCSI FastLoad feature setting is effective 
immediately; the library does not need to be rebooted. 

4. Click OK to dismiss the popup. 
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▼Configure SCSI FastLoad for a Partition

Note – This feature is available starting with SL3000 firmware 
version FRS_2.33 and SL Console version FRS_4.47. 

Use this procedure to configure the SCSI FastLoad feature for an FC-SCSI library. For 
details on this feature, see “SCSI FastLoad Feature” on page 465. 

You can enable or disable SCSI FastLoad separately for each partition.

Note – This procedure applies only to libraries with FC-SCSI host 
connections; it is not applicable to libraries that have only HLI 
(TCP/IP) host connections. 

Note – This procedure is used for partitioned libraries. For non-
partitioned libraries, see “Configure SCSI FastLoad in a Non-
Partitioned Library” on page 468. 

1. Select Tools > Configuration. 

The Library Configuration screen appears. 

2. Use the Enable FastLoad Feature checkbox for each partition to indicate 
whether you want to enable the FastLoad feature. You can use multiple 
checkboxes to indicate settings for more than one partition at a time.

Checkbox settings are:

• Checked – Turns SCSI FastLoad on. A cartridge mount is considered complete 
as soon as the drive indicates that it has accepted the cartridge. 



March 2011   471

 

• Unchecked – Turns SCSI FastLoad off. A cartridge mount is considered 
complete only after the cartridge has been loaded and threaded in the drive 
and the drive indicates that it is ready for read/write operations. This is the 
default setting. 

3. Click Apply.

A confirmation popup appears. The new SCSI FastLoad settings are effective 
immediately; the library does not need to be rebooted. 

4. Click OK to dismiss the popup. 
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▼Display Robot Summary Information

Use this procedure to display summary information for the library TallBots. 

Note – This information is also available through 
Reports > Robot Summary. See “Display a Library 
Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail. 

2. Click the Robot folder on the device tree.

The Robot Data screen appears. 
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▼Display Robot Status 

Use this procedure to display the current operational state of a TallBot. 

Note – This information is also available through 
Reports > Robot Details. See “Display a Library 
Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the robot you want to display. 

3. Click Status.

The screen displays the current status of the selected TallBot. 
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▼Display Robot Properties 

Use this procedure to display detailed TallBot configuration information, including 
the serial number and current firmware levels.

Note – This information is also available through 
Reports > Robot Details. See “Display a Library 
Report” on page 86 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the robot you want to display. 

3. Click Properties. 

The Robot Properties screen appears. 
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Power Supply Monitoring Tasks

Task Page

Display Power Supply Summary Information  476

Display Power Supply Detail  477
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▼Display Power Supply Summary Information

The Power Supply Data screen displays summary information for all power supplies 
in the library. You can use this screen to monitor the status of the power supplies. 

By default, the display is sorted by power supply internal address. Optionally, you 
can change the sort order, and rearrange and resize the columns. See “Modifying the 
Screen Layout” on page 64. 

1. Select Tools > System Detail.

2. On the Library tree, click the Power Supply Folder.

3. The Power Supply Data screen is displayed. 
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▼Display Power Supply Detail 

The Power Supply Status screen displays detailed information for a selected power 
supply. You can use this screen to determine whether the power supply is in need of 
maintenance or replacement. 

1. Select Tools > System Detail.

2. On the Library tree, expand the Power Supply Folder.

3. Click the power supply you want to display.

4. The Power Supply Status screen is displayed. 
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13

SL Console Diagnostics and Utilities

Library Events
The library controller continually monitors library operations and logs all events. 
Events are stored under three headings:

• Communication events – Includes host-to-library, library-to-library, and library-
to-drive communications. 

• Error event – Each error event is assigned a four-digit (hexadecimal) action code. 

• Warning events – Indicate a loss of performance or conditions that may be 
indicative of future, fatal errors. 

Event Monitors

You or your Oracle support representative can use the SL Console monitors to review 
library events. You can spool the event monitor information to a text file. 

The following information can help to diagnose the cause of the event: 

• Date/time stamp – Identifies when the event occurred. 

• Action codes – Identifies the command that was issued, such as “load drive”.

• Result codes – Identifies the result of the requested action. See “List a Result 
Code” on page 499 to look up a result code. 

• Known service plan (KSP) diagnosis – Identifies the mechanism or component 
responsible for the task or fault. 

Note – There is no option to clear the event log.
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Library Firmware Upgrades
The library firmware resides on the library controller. The initial firmware is installed 
at the factory. When new firmware is released, you must use the code load utility to 
upgrade the firmware on the library and associated devices (rotational or AEM CAP 
and TallBot). 

Note – Library firmware does not contain drive code upgrades.   

Firmware Upgrade Process

The process for loading firmware code on the library controller is as follows: 

1. Locate the firmware upgrade package (.jar file) on the Oracle download site. See 
“Firmware Download Site” on page 480. 

2. Download the code to a folder on your local PC or workstation. 

3. Download the firmware package from your PC or workstation to the library 
controller. This process also unpacks the package after downloading to make it 
ready for activation. See “Download Code to the Library Controller” on page 501. 

4. Activate the downloaded code on the library controller. See “Activate Code on the 
Library Controller” on page 507. 

5. Reboot the library to make the code operational. See “Download Code to the 
Library Controller” on page 501. 

Firmware Download Site

The SL3000 library firmware package is a .jar (Java Archive) file. The file is 
available at the Oracle E-Delivery website at the following URL: 

http://edelivery.oracle.com/ 

Multiple Versions of Firmware

You can store up to two versions of the SL3000 firmware in the library controller 
flash memory. This provides the following advantages:

• It allows the library to continue normal operations, running one version of 
firmware, while you download and unpack an upgrade package. Then you can 
activate the upgrade at a time that is convenient for library users. 

• It allows you to revert to a previous version of firmware without having to 
download and unpack the code package again. 

Upgrades and Redundant Electronics

Note – This feature is available starting with SL3000 firmware 
version FRS_3.0 and SL Console version FRS_5.00. 

Firmware upgrades for libraries with the Redundant Electronics feature are 
minimally disruptive to library operations. New code is loaded simultaneously on 
the active and alternate controller cards and on all devices. The code is then 
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activated, and the active and alternate controllers and most devices are reinitialized; 
under most circumstances, TallBot initialization is bypassed. During the upgrade 
process, the library continues normal operations without interruption.

See Chapter 7, “Redundant Electronics Management”  on page 359 for details about 
this feature. 

Related Procedures

For detailed firmware upgrade procedures, see “Library Utility Tasks” on page 500. 
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Library Self-Tests 
The self-test diagnostic utility is intended to help diagnose basic problems with the 
library. A self-test is typically run after the library is installed. It can be run whenever 
necessary. 

The library self-test routines can be run in either non-disruptive or disruptive mode. 
In non-disruptive mode, all cartridges used in the test are returned to their original 
locations. Disruptive mode may leave cartridges in a different location from where 
they started. 

Library self-tests involve the following process:

1. Checks the communication path between the library controller, drives, and 
TallBots. 

2. Performs get and put operations to check the health of the TallBots and rotational 
or AEM CAPs. This includes get and put operations from a reserved system cell to 
a random empty:

• Storage cell 

• CAP cell

3. Performs a full library audit. 

4. Performs mounts and dismounts of diagnostic cartridges for all the drives 
installed in the library.

Note – The self-test will not start unless a diagnostic cartridge is 
found in the system cells.

Note – The self-test is repeated for each drive type if a compatible 
diagnostic cartridge is found in the system cells. If a diagnostic 
cartridge is not found for a drive type, the mount/dismount 
operation is skipped for the drive.

Related Procedures

• For detailed procedures, see “Library Utility Tasks” on page 500. 
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Diagnostic Cartridge Management
Library self-tests and some other diagnostic activities require the use of diagnostic 
cartridges. You must ensure that the library contains a sufficient number of 
diagnostic cartridges for these activities. 

The library requires that diagnostic cartridge volume IDs (VOLIDs or volsers) be 
eight characters in length, with “DG” as the first two characters. The library Import/
Export function only accepts diagnostic cartridges that have labels with this format. 

Diagnostic cartridges are stored in reserved system cells which are controlled by the 
library and are not accessible to library host applications. The number of system cells 
available for diagnostic cartridge storage varies, depending on the configuration of 
your SL3000 library. See “Reserved System Cells” on page 615 for details. 

Importing and Exporting Diagnostic Cartridges

In order for diagnostic cartridges to be available for library diagnostic activities, they 
must be entered into the library with the SL Console Import function. See “Import 
Diagnostic Cartridges” on page 528 for detailed instructions. 

Any diagnostic cartridges entered with the host tape management software (ACSLS 
or ELS) are stored in data cells and cannot be used for library diagnostic activities. 

To remove diagnostic cartridges from the library, you must use the SL Console 
Export function. See “Export Diagnostic Cartridges” on page 531 for detailed 
instructions. You can choose to export all diagnostic cartridges or selected ones. 

Note – The command line interface (CLI) also provides diagnostic 
cartridge import and export commands accessible to your Oracle 
support representative. 

Related Procedures

For detailed procedures, see “Diagnostic Cartridge Management Tasks” on page 527. 
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Audits 
An audit is the process of reading and cataloging cartridges within a library, 
verifying the locations of cartridges, or validating a range of slot locations. The 
library controller maintains a cartridge database that contains the following 
information for all the cartridges in the library:

• Volume ID (VOLID or volser) 

• Current location (in library internal address format)

• Verified status (true or false)

The library audits all cartridge locations in the storage and reserved areas at the 
following times:

• After one or both access doors have been opened and closed. 

• An audit request is made through the SL Console. 

• A host request to audit the library is entered. 

You can use the SL Console to perform the following types of audits:

• Physical Audit 

• Verified Audit

Caution – System-level problems may occur if a host’s cartridge 
record does not match what is in the library controller cartridge 
database. 

Physical Audit

In a physical audit, the TallBot visits cartridge locations and verifies the VOLID of 
resident cartridges, and the library controller updates the cartridge database. This 
audit changes the “verified” status of the cartridge locations to “True.” Audit times 
vary according to the size of the library. Audits take approximately 1/2 second per 
cartridge slot, per TallBot.

The library performs a physical audit at the following times. 

• At library power-up, or when a library access door has been opened and closed. 
This is always a full audit of the entire library. 

• In libraries with an AEM, whenever the AEM access door is closed. This is a full 
audit of the AEM. 

• When initiated manually from the SL Console. There are two types of manually 
initiated physical audits:

• Entire library audit – The TallBot visits all cells (storage, rotational and AEM 
CAP, and drive), catalogs the VOLIDs and locations, and updates the library 
controller cartridge database. This audit is a background process and so does 
not interrupt online library operations. See “Audit the Entire 
Library” on page 537 for details.   
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• Specific range audit – The TallBot visits only a specific range of cells (storage, 
rotational or AEM CAP, and drive) and updates the library controller cartridge 
database. The audit information is displayed on the SL Console while the audit 
is performed. See “Audit a Range of Cells” on page 539 for details.

Verified Audit

A verified audit validates the status of a specific cartridge location or range of 
locations (including rotational and AEM CAPs and drives) in the cartridge database. 
If a cartridge address has a verified status of “false” then a physical audit of that 
location is performed and the cartridge database is updated. The progress of the 
audit is displayed in the Audit Console section of the SL Console. See “Perform a 
Verified Audit” on page 541 for details. 

Related Procedures

For detailed procedures, see “Audit Tasks” on page 536. 
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Robot Diagnostic Moves
Diagnostic moves are used to monitor or diagnose a problem with a TallBot. The 
move can be performed with or without cartridges. 

Successful diagnostic moves do not rearrange the cartridges in the storage cells; 
cartridges are returned to their original locations after the diagnostic move is 
completed. However, some diagnostic move failures can cause cartridges to be left in 
new locations. 

A diagnostic move involves the following elements:

• Target Address Range

• Pool Address Range

• Move Access Order

• Robot Selection

Target Address Range 

The target address range defines the location parameters in a library within which 
the get operation is performed in a diagnostic move. There are two types of access 
orders for a target address:

• “Sequential Access Order” on page 487 

• “Random Access Order” on page 487 

Following are valid target address types:

• Storage cells – Reserves storage locations as the target/pool range

• CAP – Reserves cells in a rotational or AEM CAP as the target/pool range. 

• Drive and Storage cells – Reserves drives and storage cells as the target/pool 
range.

• System cells – Reserves system cells, which contain cleaning or diagnostic 
cartridges, as the target/pool range. 

• All – Reserves storage cells, system cells, rotational or AEM CAP cells and drives 
as the target/pool range.

Note – Selecting the Storage, CAP, drive, system, or All option 
does reserve all the associated locations as the target range. 
However, only the location currently being accessed by the 
TallBot for a get/put operation is unavailable to the host.

Pool Address Range

The pool address range locations are used to supply cartridges required for 
diagnostic moves to and from the target address range. A pool address is also used in 
a get operation if a target address does not contain a cartridge. There is no specified 
access order within the pool address range. The pool address ranges does not include 
drive locations.

Note – The pool address ranges cannot contain drive locations.
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Move Access Order

Sequential Access Order

In a sequential access order diagnostic move, the TallBot performs a get operation 
starting with the first location in the target address ranges and then continues 
visiting the locations sequentially through the range until it completes the requested 
number of moves. 

Note – If you choose not to move cartridges the get/put 
operations are not performed. The TallBot just positions itself at 
the target and pool addresses.

Random Access Order

In a random access order diagnostic move, the TallBot randomly picks a location in 
the target address range to get a cartridge. The TallBot can also visit the same 
location in the in the target address range multiple times to get a cartridge. The 
random access routine ends after the requested number of moves is complete. 

If you choose not to move cartridges the get/put operations are not performed. The 
TallBot just positions itself at the target and pool addresses. 

Robot Selection

The TallBot for the diagnostic move is selected based on the minimum and maximum 
ranges you set for the target and pool addresses. Multiple robots maybe selected if 
the address range requires it.
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Diagnostic Move Control Functions

The following options are available to manage the moves currently open:

To Select Menu Option Notes

Start File > Start Sequence

Pause File > Pause Sequence Stops all diagnostic moves, but maintains the 
current location in the access order.

Stop   File > Stop Sequence Stops a running or paused exerciser.

Resume File > Start Sequence Resumes a paused exerciser starting with the 
last known location in the target address 
range.

Clear the messages 
displayed in the 
monitor window

File > Clear Output Window Erases the previous message lines and 
continues to fill the screen with new messages.

Spool Spool File > Start Spooling Directs the move output to a file.

Stop spooling the 
exerciser output to a 
file

Spool File > Stop Spooling Stops directing the move output to the spool 
file.

Note – If multiple diagnostic moves are open, then each move has 
its own monitor screen.

Related Procedures

For detailed procedures, see “TallBot Utility Tasks” on page 553. 
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Troubleshooting 
Before you run diagnostic tests, check the following areas of the library using the 
troubleshooting tips in the following table:

TABLE 13-1  Troubleshooting Table 

Problem What to do

Service Required (amber) 
LED is constantly on.

Perform the following procedure:

Using the SL Console, check the health of the library and the attached 
devices (drives, rotational and AEM CAPs, and TallBots). See “StorageTek 
Library Console” on page 61 for more details about operations.

To perform a health check:

1. Log in to the SL Console application.

2. Access the System Detail module, View > System Detail.

3. Check the device tree for the following indicators:

• Device Healthy

• Device Error

The Status (for example, online/offline) and Statistics (for example, 
uptime, downtime, errors and warnings) tabs provide more information 
on the health of the library and devices. 

Other checks:

• Make sure that cartridges are fully seated and properly oriented in 
their storage cells.

• Inspect the X table for any foreign objects or debris; remove them if 
found.

CAP Open LED is on and 
blinking.

Open the rotational or AEM CAP and make sure that the cartridges in the 
CAP cells are properly seated. 

The SL Console does not 
display modified data or 
information remains 
static.

Check the SL Console Heartbeat icon.
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Robot Fault or Library 
Fault Amber LED is 
constantly on.

1. Check the SL Console for any displayed error messages. Write down 
the error messages reported.

2. Open the front door. Observe and note the state of the cartridges, 
hand, and tape drives.

3. .Make sure that cartridges are fully seated and properly oriented in 
their storage cells.

4. Make sure that packing materials have been removed.

5. Inspect the library floor for any objects or debris; remove them.

6. Check the status of the tape drives.

7. Close the front door.

8. Make sure that the tape drives are fully seated and locked forward by 
pushing and pulling on the rear of the drive tray. Any motion of the 
tray indicates that it requires reseating and locking down.

Tape drive is unable to 
eject a cartridge.

Manually remove the cartridge from the tape drive. “Remove a Cartridge 
from a Tape Drive” on page 791.

The client computer 
cannot communicate with 
the library or tape drives.

1. Make sure that cables are securely attached to their connectors on the 
rear of the library, the tape drives, and the client computer.

2.  

The library is unable to 
communicate with the 
drives.

Drive status on the 
SL Console displays Not 
communicating.

1. Make sure that cables are securely attached to their connectors on the 
rear of the library, the drives, and the client computer. 

Repeated or excessive 
drive cleanings or 
cleaning messages.

1. Replace the cleaning cartridge with a new cleaning cartridge.

2. Run the Library Self-Test and note if errors are reported for the drive.

3. Run any client computer-based drive diagnostic tests.

TABLE 13-1  Troubleshooting Table (Continued)

Problem What to do
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Diagnostic Support Files
The following diagnostic support files are maintained on the library in order to aid in 
troubleshooting and diagnosing problems:

• MIB File

• Library Log Snapshot File

Depending on circumstances, your Oracle support representative may request you to 
transfer one or both of these files to Oracle for further evaluation, or he or she may 
do this him or herself. 

MIB File

The management information base (MIB) file is an small network management 
protocol (SNMP) database used to manage your library devices. This file can be 
saved as a text file. See “Transfer the Library MIB File” on page 516 for detailed 
instructions. 

Library Log Snapshot File

Note – This feature is available starting with SL3000 firmware 
version FRS_2.30 and SL Console version FRS_4.30. 

Your Oracle support representative can use privileged CLI commands to generate an 
encrypted snapshot of the library event log. You cannot view or edit this file. This file 
is available for only 15 minutes from the time it is generated. See “Transfer the 
Library Log Snapshot File” on page 519 for detailed instructions. 

Related Procedures

For detailed procedures, see “Library Utility Tasks” on page 500. 
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Diagnostic and Utility Tasks 
Library diagnostic and utility tasks are divided into the following categories:

• “Event Monitor Tasks” on page 493

• “Library Utility Tasks” on page 500

• “Diagnostic Cartridge Management Tasks” on page 527

• “Audit Tasks” on page 536

• “Rotational and AEM CAP Utility Tasks” on page 543

• “Drive Utility Tasks” on page 549

• “TallBot Utility Tasks” on page 553

• “AEM Safety Door Utility Tasks” on page 570
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Event Monitor Tasks

Task Page

Display an Event Monitor  494

Spool Event Monitor Data to a File  495

Display Multiple Monitors  496

List a Device Status Code  497

List a Result Code  499
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▼Display an Event Monitor

Event monitor information is dynamically updated depending upon occurrence of 
the selected events. The information sent during an e-mail, print, save, or spool 
operation reflects the data (and format) shown on-screen at the time the operation is 
requested. 

Note – Event monitors are useful tools for root cause analysis of 
errors. If the library is experiencing reproducible errors, you can 
open an event monitor and spool all events to a file to capture the 
data. Later, you can send the file to your Oracle support 
representative for analysis. 

Note – To monitor multiple events, see “Display Multiple 
Monitors” on page 496.

1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder. 

The library monitors you have access to are displayed. 

3. Click the event monitor you want to use, and then click Open from the Options 
Bar. 

The system displays the associated data collected for the event.

4. Use these options to manage the information displayed on the screen for the 
event selected:

Select To

Monitor > Pause Pause the continuous display of data related to the event 
selected

Monitor > Resume Resume displaying the events

Monitor > Stop Permanently stop the continuous display of data related to 
the event selected

Monitor > Clear Clear the event monitor display 

5.  To close a monitor, click the X in the upper right corner of the window. 
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▼ Spool Event Monitor Data to a File

Use this procedure to spool and save event monitor data to a file. You can send the 
file to your Oracle support representative to assist in diagnosing problems. 

1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder. 

The library monitors you have access to are displayed. 

3. Click the event monitor you want to use, and then click Open from the Options 
Bar. 

The system displays the an event monitor window.

4. In the event monitor window, select Spool File > Start Spooling. 

The Save popup appears.

5. Browse to the directory where you want to save the file. In the File Name field, 
enter the file name, and click Save. 

All event data is spooled to the specified file. 

6. To stop spooling, select Monitor > Stop Spooling. 

Following is a sample of the spool file:
2008-05-29T11:23:27.448  0,1,0,0     root  default       internal        281    
warn   0  rb_Reboot::reboot(): Resetting drive [0,3,4,9]
2008-05-29T11:23:27.760  0,1,0,0     root  default       internal        281    
info   0  Service Beacon is ACTIVE: Current Health Event indicates Drive 04 in 
Module 03 is not operational
2008-05-29T11:23:53.211  0,1,0,0     root  default       internal        281    
info   0  Service Beacon is ACTIVE: Current Health Event indicates Drive 04 in 
Module 03 is operational 



496  SL3000 User’s Guide March 2011 

 

▼Display Multiple Monitors

You can open and manage multiple event monitors using these selections from the 
Options Bar:

To Select

Custom arrange the open monitors on screen Window > Arrange

Arrange the event monitor windows horizontally Window > Tile Horizontal

Arrange the event monitor windows vertically Window > Tile Vertical

Stack the event monitors Window > Cascade



March 2011   497

 

▼ List a Device Status Code

Use this procedure to list device status codes and their descriptions. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Search tab.

The Library Search screen appears. 

4. In the Search Type pull-down, click Device Status. 

5. Complete the Device Status field, as follows:

• To search for a specific device status code, enter the complete code; wildcards 
or partial codes are not accepted. 

• To list all device status codes, click the List All checkbox. 

6. Click Search in the Options Bar. 
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The screen lists the specified device status codes and their descriptions. 
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▼ List a Result Code

Use this procedure to list result codes and their descriptions. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Search tab.

The Library Search screen appears. 

4. In the Search Type pull-down, click Result Code. 

5. Complete the Result Code field, as follows:

• To search for a code, enter the complete code; wildcards or partial codes are 
not accepted. 

• To list all codes, click the List All checkbox. 



500  SL3000 User’s Guide March 2011 

 

Library Utility Tasks 

Task Page

Download Code to the Library Controller  501

Activate Code on the Library Controller  507

Reboot the Library  501

Transfer the Library MIB File  516

Transfer the Library Log Snapshot File  519

Perform a Non-Disruptive Library Self-Test  521

Perform a Disruptive Library Self-Test  524
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▼Download Code to the Library Controller

Use this procedure to download and unpack library firmware upgrades on the 
library controller. 

After completing this procedure, you can choose a convenient time to activate the 
code on the library. See “Activate Code on the Library Controller” on page 507 for 
detailed instructions. 

Note – This procedure is not used for downloading drive 
firmware updates.

Note – You can perform this procedure from the standalone 
SL Console or Web-launched SL Console only. It is not available at 
the local operator panel. 

1. Locate the firmware upgrade package (.jar file) on the Oracle download site. 
See “Firmware Download Site” on page 480. 

2. Download the code to a folder on your local PC or workstation. 

3. Log into the SL Console. 

4. Select Tools > Diagnostics, and click the Library folder. 

5. Click the Load Code tab. 

The Load Code screen appears. 

6. In the File Name field, enter the full path of the firmware package you want to 
download, and press Enter. Optionally, you can click Browse and navigate to 
the file location on your local PC or workstation. 
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The SL3000 library firmware package is a .jar (Java Archive) file.
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7. The contents of the file is displayed. Review the contents and file name to 
verify that you have specified the correct firmware package. 

8. Click the Load button on the Options Bar.

The Code Load confirmation appears.

9. Click OK to confirm the download. 

Note – The download process could take up to ten minutes. 
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10. The system begins downloading the code to the library controller. The File 
Load Console Window section of the screen indicates the progress of the file 
transfer.

11. When the code is fully transferred to the library controller, the code unpack 
process begins.
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12. The screen indicates the progress of the unpack. 

13. The screen indicates when the unpack process is complete. 
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In the Failed field, you should see 0. If there are any failures indicated, contact 
your Oracle support representative for assistance. 

14. After the package is successfully unpacked, you can activate the code 
immediately or wait until a later time. See “Activate Code on the Library 
Controller” on page 507 for detailed instructions.
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▼Activate Code on the Library Controller 

Use this procedure to activate a version of library firmware currently residing in the 
library controller flash memory. Up to two versions of firmware can be resident in 
memory at one time, but only one can be active. The active version is identified as 
“running”. 

Prior to performing this procedure you must download and unpack the code you 
want to activate. See “Download Code to the Library Controller” on page 501 for 
detailed instructions. 

This procedure involves a reboot of the library. You should schedule it for a time that 
is convenient for users. 

You can restore the earlier firmware version if required. 

Note – You can perform this procedure from the standalone 
SL Console or Web-launched SL Console only. It is not available at 
the local operator panel. 

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the Activate Code tab. 

The Activate Code screen appears. 

3. In the Target pull-down, select the code package you want to activate.
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The pull-down may display a library firmware package and an SL Console 
package. For this procedure, select the firmware package (SL3000 Code). 

4. The Available Versions section of the screen displays the versions currently 
residing in flash memory. 
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The version identified as “running” is the currently active code. You cannot select 
this version again to activate.
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5. Select the code version you want to activate. 

6. Click the Activate button in the Options Bar.

The Activation Confirmation dialog appears, verifying that you want to continue 
with the process. 

7. Click OK to begin the activation.

If you click Cancel, the process terminates and returns to Step 5. 

The code activation process begins, and the Activate Console section of the screen 
displays the status of the process. 
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Caution – POTENTIAL INTERNAL FILE CORRUPTION. Do not 
reboot any devices in the library or execute any operations on the 
library while code is being activated.
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8. When the activation process is finished, a dialog appears, prompting you to 
reboot the library. 

9. Click OK to reboot the library.

If you click Cancel, the process terminates; you will need to reboot the library 
at a later time. See “Download Code to the Library Controller” on page 501 for 
detailed instructions. 

The reboot process begins, and a popup appears indicating that your SL Console 
session will be terminated.

10. Click OK to terminate the SL Console session.

You are logged off the library. 

11. When the library initialization has completed, you can log in again to the 
library through the SL Console login screen. 

The SL Console gets all library configuration data from the library controller. 
Therefore, you should be careful when logging in to the SL Console before the library 
has fully initialized. You may see warnings that configuration data is not yet 
available, in which case you need to exit and log in again at a later time. 
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Additionally, if a library audit is performed as part of initialization, until the audit is 
complete, any configuration data displayed may not be completely up-to-date and 
accurate. 
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▼Reboot the Library

Use this procedure to reboot the library. This process involves reloading the 
firmware from flash memory and restarting the library controller.

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click Reboot in the Options Bar.

The Reboot confirmation popup appears. 

4. Click OK to continue. 

If the library is online, the Offline confirmation popup appears.

5. Click OK to vary the library offline. 

The Reboot confirmation popup appears 

6. Click OK to continue. 

The SL Console termination popup appears.

7. Click OK to terminate this SL Console session. 
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You are logged off the SL Console. 

The library controller reboots the library. This may take several minutes. 

Note – You will not be able to log back in to the SL Console until 
the library has fully initialized. 
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▼ Transfer the Library MIB File

Use this procedure to copy the public SNMP management information base (MIB) file 
to a specified location on your local PC or workstation. The file is saved as a text file. 
You can e-mail the file to your Oracle support representative to help diagnose 
problems with the library. 

1. Select Tools > Diagnostics, 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the TransferFile tab. 

The file transfer screen appears. 

4. In the Transfer SNMP public MIB text file field, click the Transfer button. 
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The Save popup appears. 

5. Browse to the directory where you want to save the file, and enter the file name 
in the File Name field. Be sure to give it a .txt suffix. 

6. Click Save. 

The data is saved to the specified file, and the Transferred Successful popup 
appears. 

7. Click OK to dismiss the popup. 

Following is a partial sample of the MIB file output.



-- **********************************************************************
--          STREAMLINE-TAPE-LIBRARY-MIB (1.3.6.1.4.1.1211.1.15)
--
-- Copyright (c) 2005, 2010, Oracle and/or its affiliates. All rights 
reserved.
--
-- **********************************************************************

STREAMLINE-TAPE-LIBRARY-MIB DEFINITIONS ::= BEGIN
IMPORTS     
    enterprises, Counter32, Integer32 FROM SNMPv2-SMI
    --OBJECT-TYPE FROM RFC-1212
    OBJECT-GROUP, NOTIFICATION-GROUP, MODULE-COMPLIANCE FROM SNMPv2-CONF
    TEXTUAL-CONVENTION FROM SNMPv2-TC
    OBJECT-TYPE, MODULE-IDENTITY, NOTIFICATION-TYPE FROM SNMPv2-SMI;

streamlineTapeLibrary MODULE-IDENTITY
    LAST-UPDATED "201010280000Z" -- Oct 28, 2010
    ORGANIZATION "Oracle"
    CONTACT-INFO "Please contact Oracle/Sun Support: 
                    http://www.sun.com/contact/support.jsp"
    DESCRIPTION  "The MIB module for StreamLine Tape Library.
                  Copyright (c) 2005-2010,
                  Oracle. All Rights Reserved."
...
-- *******************************************************************
--
-- Generic traps: 1-10
--
-- *******************************************************************

slTrapError  NOTIFICATION-TYPE
    OBJECTS
    {
        slTrapLibrarySerialNumber,
        slTrapDeviceId,
        slTrapDeviceTime,
        slTrapDeviceAddress,
        slTrapDeviceUserName, 
        slTrapDeviceInterfaceName, 
        slTrapDeviceActivity, 
        slTrapDeviceRequestId,
        slTrapDeviceSeverity,
        slTrapDeviceResultCode,
        slTrapDeviceFreeFormText
    }
    STATUS current
    DESCRIPTION "An error trap - a device condition which is critical to 
machine operation was encountered"
::= { slSnmpNotifications 1 }
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▼ Transfer the Library Log Snapshot File

Note – Use this procedure only under the direction of your Oracle 
support representative. Your Oracle support representative must 
have generated a library log snapshot file within the previous 15 
minutes.

Use this procedure to copy the library log snapshot file to a specified location on 
your local PC or workstation. The file is saved in an encrypted format, and you 
cannot view or edit it. You can e-mail the file to your Oracle support representative 
to help diagnose problems with the library. 

1. Select Tools > Diagnostics, 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the TransferFile tab. 
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The file transfer screen appears. 

4. In the Transfer log snapshot file field, click the Transfer button. 

The Save popup appears. 

5. Browse to the directory where you want to save the file, and enter the file name 
in the File Name field. 

6. Click Save. 

The data is saved to the specified file, and the Transferred Successful popup 
appears. 

7. Click OK to dismiss the popup. 
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▼ Perform a Non-Disruptive Library Self-Test 

Use this procedure to perform a non-disruptive library self-test, which can be used to 
help diagnose operational problems with the library. 

In order for the test to run completely, the proper diagnostic cartridges for library 
drives must be present in the library. To verify this, see “List Library 
Cartridges” on page 430.

1. Select Tools > Diagnostics, and click the Library folder.

2. Click the SelfTest tab.

The Self Test screen appears. 

3. In the Mode pull-down, select Non-Disruptive. 

4. Click Run to start the test. 
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The test begins, and the Diagnostic Console section of the screen displays the status 
of the various diagnostic tests as they are performed.
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5. When the test completes, the results of the test are displayed in the Diagnostic 
Console. 



524  SL3000 User’s Guide March 2011 

 

▼ Perform a Disruptive Library Self-Test 

Use this procedure to perform a disruptive library self-test, which can be used to help 
diagnose operational problems with the library. 

In order for the test to run completely, the proper diagnostic cartridges for library 
drives must be present in the library. To verify this, see “List Library 
Cartridges” on page 430.

Prior to performing this procedure, the library must be varied offline to all hosts. See 
“Vary the Library Offline” on page 577 for detailed instructions. 

1. Select Tools > Diagnostics, and click the Library folder.

2. Click the Self Test tab.

The Self Test screen appears. 

3. In the Mode pull-down, select Disruptive. 

4. Click Run. 

A popup appears to confirm that you have already varied the library offline to all 
hosts.  

5. Click OK to begin the test. 
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The test begins, and the Diagnostic Console section of the screen displays the status 
of the various diagnostic tests as they are performed.
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6. When the test completes, the results of the test are displayed in the Diagnostic 
Console. 

7. Vary the library online to resume normal operations.  

See “Vary the Library Online” on page 579 for detailed instructions. 
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Diagnostic Cartridge Management Tasks

Task Page

Import Diagnostic Cartridges  528

Export Diagnostic Cartridges  531

Display Diagnostic Cartridge Information  534
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▼ Import Diagnostic Cartridges

Use this procedure to enter diagnostic cartridges into the library through a specified 
CAP. The library controller reserves the CAP for the entire operation. The diagnostic 
cartridges are distributed as evenly as possible in reserved system cells. Only one 
diagnostic or cleaning cartridge import or export operation can be performed at a 
time. 

Note – You can also import cleaning cartridges with the 
diagnostic cartridges. See “Import Cleaning 
Cartridges” on page 454 for details about importing cleaning 
cartridges. 

Note – Only rotational CAPs, not AEM CAPs, can be used for this 
procedure. 

Before beginning this procedure, verify that the following conditions are met:

• The CAP is empty, available for use (not reserved by a host), and closed and 
locked. 

• The library has enough empty reserved system cells to store the diagnostic 
cartridges you want to import. At least one system cell on each side of the library 
must be left open for TallBot recovery or library initialization. 

1. Select Tools > Diagnostics.

2. Expand the CAP Folder, highlight the CAP you want to use, and then select the 
Import/Export tab.
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The Import/Export screen appears. 

3. Select Import Cleaning/Diagnostic cartridges, and then click Start.
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The import operation begins, and the Import/Export screen displays the ongoing 
status. 

4. The library controller reserves the CAP and unlocks and opens the CAP door. 

If the library is partitioned and the CAP is associated to an FC-SCSI partition, the 
library controller associates the CAP to the default requestor for the duration of 
the import operation. 

5. Load the diagnostic cartridges into the CAP. 

For detailed instructions, see “Enter Cartridges Through a Rotational 
CAP” on page 417.

6. After you close the door, the diagnostic cartridges are moved to available 
system cells. 

Any data cartridges or diagnostic cartridges with invalid labels are ignored and 
left in the CAP. 

7. When all diagnostic cartridges have been moved from the CAP, the library 
controller proceeds as follows:

• If the CAP is empty, the library controller releases the CAP reservation and re-
associates the CAP to the original FC-SCSI partition, if applicable. 

• If cartridges are left in the CAP, the CAP door is opened, and the Import/
Export screen displays a message that the cartridges need to be removed.
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▼ Export Diagnostic Cartridges

Use this procedure to export diagnostic cartridges from the library through a 
specified CAP. The library controller reserves the CAP for the entire operation. The 
diagnostic cartridges are retrieved from reserved system cells and placed in the CAP 
for removal. Only one diagnostic cartridge import or export operation can be 
performed at a time. 

Note – Only rotational CAPs, not AEM CAPs, can be used for this 
procedure. 

Before beginning this procedure, verify that the CAP is empty, available for use (not 
reserved by a host), and closed and locked. 

1. Select Tools > Diagnostics.

2. Expand the CAP Folder, highlight the CAP you want to use, and then select the 
Import/Export tab.

The Import/Export screen appears. 

3. Select the type of export operation you want to perform. You have the following 
options: 

• Export specific diagnostic cartridges—Allows you to specify the diagnostic 
cartridges you want to eject. The screen displays a list of all diagnostic 
cartridges in the library, and you can select one or more for export. 
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• Export all diagnostic cartridges—Exports all diagnostic cartridges from the 
library. 

4. Click Start.

A confirmation popup appears. 

5. Click OK to continue. 
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The export operation begins, and the Import/Export screen displays the ongoing 
status. 

6. The export operation proceeds as follows:

a. If the library is partitioned and the CAP is associated to an FC-SCSI 
partition, the library controller associates the CAP to the default requestor 
for the duration of the export operation. 

b. The library controller reserves the CAP. 

c. The diagnostic cartridges are moved to the CAP, according to your request. 

d. The Import/Export screen displays a message when the CAP is ready to be 
unloaded. 

7. Remove the cartridges from the CAP. 

For detailed instructions, see “Eject Cartridges Through a Rotational 
CAP” on page 418.

8. When you close the CAP door, the library controller proceeds as follows:

• If the CAP is empty, the library controller releases the CAP reservation and re-
associates the CAP to the original FC-SCSI partition, if applicable. 

• If cartridges are left in the CAP, the CAP door is opened, and the Import/
Export screen displays a message that the cartridges need to be removed.
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▼Display Diagnostic Cartridge Information 

You can use any of the following SL Console reports and searches to display 
information about diagnostic cartridges: 

• Cartridge Table Report

• Cartridge Summary

• Cartridge Search by VOLID

Cartridge Table Report

• Select Tools> >Reports >Status Summary > Cartridge Table 

See “Display Library Cartridge Information in Tabular Format” on page 427 for 
the full procedure.

The Cartridge Table report displays detailed information about all library 
cartridges in a sortable, tabular format. By default, this report is sorted in 
cartridge volume ID (VOLID or volser) order. You can scroll directly to the 
cartridges that begin with “DG” to see detail about all diagnostic cartridges. 

Following is a sample:

Cartridge Summary

• Select Tools> >Reports >Status Summary > Cartridge Summary 

See “List Library Cartridges” on page 430 for the full procedure.

The Cartridge Summary displays detailed information about all library cartridges 
in a text format. By default, this report is sorted in location order. You can search 
for cartridges that begin with “DG” to see detail about diagnostic cartridges. 
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Following is a sample:

Cartridge Search by VOLID 

• Select Tools> >Diagnostics > Library > Search. 

See “Locate a Cartridge by VOLID” on page 433 for the full procedure.

This search displays detailed information about all library cartridges. By default 
the results are sorted in location order. You can change the sort order to VOLID 
and then scroll directly to the cartridges that begin with “DG” to see detail about 
all diagnostic cartridges. 

Following is a sample:
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Audit Tasks

Task Page

Audit the Entire Library  537

Audit a Range of Cells  539

Perform a Verified Audit  541
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▼Audit the Entire Library

During this audit the TallBot visits all the storage cells, catalogs the VOLIDs and 
locations, and updates the library controller database. 

Note – Although this audit is a background process and does not 
interrupt library operations, it does require sharing of TallBot 
resources. Therefore, it is not recommended that you run this 
audit during peak activity periods. 

Note – You cannot stop this audit once it has initiated. The audit 
will take approximately 1/2 second per cartridge slot. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Audit tab.
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The Library Audit screen appears. 

4. In the Entire Library field, click Yes. Then click the Audit button in the Options 
Bar.

A confirmation popup appears. 

5. Click OK to perform the audit as a background process or Cancel to cancel the 
audit.

Note – Once you click OK, you cannot stop the audit; it will run 
until completion. 

6. You can view the Cartridge Summary report after a few hours for the latest 
cartridge locations and VOLIDs. See “Display a Library Report” on page 86 for 
details.
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▼Audit a Range of Cells

During this audit the TallBot visits only a specific range of storage cells (including 
the cap and drives) and updates the library controller database.

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Audit tab.

The Library Audit screen appears. 
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4. In the Entire Library field, click No. In the Physical Audit field, click Yes. In the 
Verified Audit field, click No.

5. In the Start Address and End Address fields, select the device types you want to 
audit and the starting and ending library internal address locations.See 
“Library Internal Address” on page 591 for a detailed explanation of this 
address format. 

6. Click the Audit button in the Options Bar.

A confirmation popup appears. 

7. Click OK to perform the audit as a background process or Cancel to cancel the 
audit.

Note – Once you click OK, you cannot stop the audit; it will run 
until completion. 

8. The Audit Console section displays the progress of the audit. 

Note – You can also view the Cartridge Summary report for the 
latest cartridge locations and VOLIDs. See “Display a Library 
Report” on page 86 for details.
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▼ Perform a Verified Audit

A verified audit validates the status of a specific cartridge location or a range of 
locations (including rotational and AEM CAPs and drives) in the library controller 
database. If a cartridge address has a verified status of “false” then a physical audit 
of that location is performed and the library controller database is updated. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Audit tab.

The Library Audit screen appears. 

4. In the Entire Library field, click No. In the Physical Audit field, click No. In the 
Verified Audit field, click Yes. 

5. In the Start Address and End Address fields, select the device types you want to 
audit and the starting and ending library internal address locations.See 
“Library Internal Address” on page 591 for a detailed explanation of this 
address format. 

6. Click the Audit button in the Options Bar.

The Audit Console section displays the progress of the audit. 
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Rotational and AEM CAP Utility Tasks

Task Page

Perform a Self-Test on a Rotational or AEM CAP  544

Vary a Rotational or AEM CAP Offline  545

Vary a Rotational or AEM CAP Online  547
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▼ Perform a Self-Test on a Rotational or AEM CAP 

Note – At present, the CAP self-tests perform the same routines as 
the library self-test. Specific rotational and AEM CAP self-tests 
will be available at a later date.

1. Select Tools > Diagnostics.

2. Expand the CAP folder, and click the CAP you want to test. 

Note – AEM CAPs are identified as follows: column “–31” for a 
left AEM CAP, and column “31” for a right AEM CAP. 

3. Click the SelfTest tab.

4. In the Mode pull-down menu, click Non-Disruptive. 

5. Click the Run button from the Options Bar.

Status messages are displayed as the self-test is run. A Diagnostic completed 
message appears when the test finishes. 
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▼ Vary a Rotational or AEM CAP Offline 

Use this procedure to vary a rotational or AEM CAP offline through the SL Console. 

Note – You should use this procedure only if you are not using 
ACSLS or ELS tape management software, or if their servers are 
not able to communicate with the library. ACSLS and ELS are not 
notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in 
library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

Note – AEM CAPs are identified as follows: column “–31” for a 
left AEM CAP, and column “31” for a right AEM CAP. 

3. Click the Status tab.

The screen displays the current status of the CAP. 

4. In the Transition Request field, click Take Offline. Click Apply. 

All outstanding jobs for the CAP are completed, and then the CAP status is 
changed, as follows:

• Health State: Warn
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• Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 

• Access State: Offline
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▼ Vary a Rotational or AEM CAP Online 

Use this procedure to vary a rotational or AEM CAP online through the SL Console. 

Note – You should use this procedure only if you are not using 
ACSLS or ELS tape management software, or if their servers are 
not able to communicate with the library. ACSLS and ELS are not 
notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in 
library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

Note – Library devices that are offline in an error state cannot go 
online; the error condition must be cleared first. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

Note – AEM CAPs are identified as follows: column “–31” for a 
left AEM CAP, and column “31” for a right AEM CAP. 

3. Click the Status tab.

The screen displays the current status of the CAP. 

4. In the Transition Request field, click Bring online. Click Apply. 

The CAP status is updated, as follows:



548  SL3000 User’s Guide March 2011 

 

• Health State: ok

• Device State: Ready

• Access State: Online
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Drive Utility Tasks

Task Page

Perform a Drive Self-Test  550

Vary a Drive Offline  551

Vary a Drive Online  552



550  SL3000 User’s Guide March 2011 

 

▼ Perform a Drive Self-Test 

1. Select Tools > Diagnostics.

2. Expand the Drive Folder, and click the drive you want to test. 

3. Click the SelfTest tab.

4. In the Mode pull-down, click Non-Disruptive. 

5. Click the Run button from the Options Bar.

Status messages are displayed as the self-test is run. A Diagnostic completed 
message appears when the test finishes. 
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▼ Vary a Drive Offline 

Use this procedure to vary a drive offline through the SL Console. 

Note – You should use this procedure only if you are not using 
ACSLS or ELS tape management software, or if their servers are 
not able to communicate with the library. ACSLS and ELS are not 
notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in 
library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to modify. 

3. Click the Status tab.

The screen displays the current status of the drive. 

4. In the Transition Request field, click Take Offline. Click Apply. 

All outstanding jobs for the drive are completed, and then the drive status is 
changed, as follows:

• Health State: Warn

• Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 

• Access State: Offline
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▼ Vary a Drive Online 

Use this procedure to vary a drive online through the SL Console. 

Note – You should use this procedure only if you are not using 
ACSLS or ELS tape management software, or if their servers are 
not able to communicate with the library. ACSLS and ELS are not 
notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in 
library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

Note – Library devices that are offline in an error state cannot go 
online; the error condition must be cleared first. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to modify. 

3. Click the Status tab.

The screen displays the current status of the drive. 

4. In the Transition Request field, click Bring online. Click Apply. 

The drive status is updated, as follows:

• Health State: ok

• Device State: Ready

• Access State: Online
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TallBot Utility Tasks

Task Page

Perform a TallBot Self-Test  554

Vary a TallBot Offline  555

Vary a TallBot Online  556

Define a Diagnostic Move  557

Manage Diagnostic Move Definitions  561

Save a Diagnostic Move to a File  563

Start a Diagnostic Move  566

Monitor and Control Open Diagnostic Moves  568



554  SL3000 User’s Guide March 2011 

 

▼ Perform a TallBot Self-Test 

Note – To perform a TallBot self-test, diagnostic cartridges must 
be available in the library. 

1. Select Tools > Diagnostics.

2. Expand the Robot Folder, and click the robot you want to test. 

3. Click the SelfTest tab.

4. In the Mode pull-down, click Non-Disruptive. 

5. Click the Run button from the Options Bar.

Status messages are displayed as the self-test is run. A Diagnostic completed 
message appears when the test finishes. 
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▼ Vary a TallBot Offline 

Use this procedure to vary a TallBot offline through the SL Console. 

Note – You should use this procedure only if you are not using 
ACSLS or ELS tape management software, or if their servers are 
not able to communicate with the library. ACSLS and ELS are not 
notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in 
library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the TallBot you want to modify. 

3. Click the Status tab.

The screen displays the current status of the TallBot. 

4. In the Transition Request field, click Take Offline. Click Apply. 

All outstanding jobs for the TallBot are completed, and then the TallBot status is 
changed, as follows:

• Health State: Warn

• Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 

• Access State: Offline

5. The TallBot is moved to the end of the rail and is not usable by the library. If 
the library is using the redundant TallBot feature, the second TallBot will take 
all requests. 
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▼ Vary a TallBot Online 

Use this procedure to vary a TallBot online through the SL Console. 

Note – You should use this procedure only if you are not using 
ACSLS or ELS tape management software, or if their servers are 
not able to communicate with the library. ACSLS and ELS are not 
notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in 
library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

Note – Library devices that are offline in an error state cannot go 
online; the error condition must be cleared first. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the TallBot you want to modify. 

3. Click the Status tab.

The screen displays the current status of the TallBot. 

4. In the Transition Request field, click Bring Online. Click Apply. 

The TallBot status is updated, as follows:

• Health State: ok

• Device State: Ready

• Access State: Online
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▼Define a Diagnostic Move 

Multiple diagnostic move routines can be set up and run simultaneously, as long as 
the target and pool address ranges do not overlap. 

Note – This procedure requires sharing of TallBot resources; 
therefore, it is not recommended that you run it during peak 
activity periods. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.

4. In the Defined Sequence section, click Add.



558  SL3000 User’s Guide March 2011 

 

The TARGET screen appears. 

5. Complete the TARGET screen as follows. See “Target Address 
Range” on page 486 for details. 

• In the Selection Mode field, click the type of cells you want to diagnose. 

• In the Minimum Address and Maximum Address fields, select the library 
internal address of the starting and ending locations of the cells you want to 
diagnose. 

6. Click Next. 

The SOURCE screen appears. 
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7. Complete the SOURCE screen as follows. See “Pool Address 
Range” on page 486 for details. 

• In the Selection Mode field, click the appropriate cartridge pool address type. 

• In the Minimum Address and Maximum Address fields, select the library 
internal addresses of the starting and ending locations of the cartridge pool 
you want to use.

8. Click Next.

The Sequence screen appears. 

9. Complete the Sequence screen as follows. See “Move Access 
Order” on page 487 for details. 

• Name of the diagnostic move

• Move Count (specify a number between 1 and 5000)

• Access order (Sequential or Random)

• Move Type (Robot and Cartridge or Robot Only) 

• Disable pre move cartridge compatibility check

10. Click Finish to complete the setup.
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The Diagnostic Move Manage screen appears. The diagnostic sequence you have 
just defined is listed in the Defined Sequences section. 
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▼Manage Diagnostic Move Definitions 

Use this procedure to manage diagnostic move sequence definitions. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.

4. From the Defined Sequences section, select any of the following options:



Select 
Option To Notes

Add Define a diagnostic move 

Open Start a diagnostic move Multiple diagnostic moves may be open at 
a time, so long as the target and pool 
address ranges setup for the moves do not 
overlap.

Modify Modify options for a 
diagnostic move

This diagnostic move routine must not be 
open or if open must be in a “Stopped” 
state.

Remove Remove a diagnostic move This diagnostic move routine must not be 
open.

Copy Copy an existing diagnostic 
move

Copy a diagnostic move definition, make 
changes if necessary, and assign a different 
name.
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5. To manage the diagnostic moves currently open, see “Monitor and Control 
Open Diagnostic Moves” on page 568.
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▼ Save a Diagnostic Move to a File 

Use this procedure to save a defined diagnostic move to a local file on your 
workstation or PC. The file is saved as a JavaBean component represented as an 
XML 1.0 document (.xml). 

Possible uses for the saved file are:

• Can be used to restore a move that has been deleted from the library. 

• Can be copied to a different library for use there. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 
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The Diagnostic Move Manage screen appears.

4. Click the diagnostic move you want to save, and then click the Save button in 
the Options Bar. 

The Save popup appears.

5. Browse to the directory where you want to save the file. In the File Name field, 
enter the file name. 
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6. Click Save. 

The data is saved to the specified file. Following is a sample excerpt:
<?xml version="1.0" encoding="UTF-8"?> 
<java version="1.5.0_11" class="java.beans.XMLDecoder"> 
 <object 
class="com.stortek.ats.elib.opel.model.SequenceBeanList"> 
  <string>FRS_4.10</string> 
  <string>SL500</string> 
  <void method="add"> 
   <object 
class="com.stortek.ats.elib.opel.model.SequenceBeanList$Sequence
Bean"> 
    <void property="accessOrder"> 
     <string>Sequential</string> 
    </void> 
    <void property="moveCartridge"> 
     <boolean>true</boolean> 
    </void> 
    <void property="moveCount"> 
     <int>10</int> 
    </void> 
    <void property="name"> 
     <string>DriveDiagMove1</string> 
    </void> 
    . . .
    <void property="targetType"> 
     <string>Drive</string> 
    </void> 
   </object> 
  </void> 
 </object> 
</java> 
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▼ Start a Diagnostic Move

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.

4. From the Defined Sequences section click a diagnostic move and then click 
Open. 

The Monitor window is activated. 

You can repeat this step to open multiple moves, as long as the target and pool 
address ranges for the moves do not overlap.

A monitor window is displayed for each move you open.
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5. From each monitor window, select File > Start Sequence to start the move. 
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▼Monitor and Control Open Diagnostic Moves

Use this procedure to control and monitor the status of one or more open diagnostic 
moves. 

1. See “Start a Diagnostic Move” on page 566 for instructions on starting one or 
more diagnostic moves. 

2. Click the Monitor tab. 

The Monitor screen appears, with one monitor window for each open move.

Each monitor window has the following status indicators:

Status Indicators Description Valid Values

Spooling Status Indicates if the move output is 
being spooled to a file 

True, False

State Current execution state of the 
move

Running, pausing, paused, 
stopping, stopped

Health Current health state of the 
move

OK, warning, error

Completed moves Number of moves completed 
in the requested move count 

3. Use the File menu in each Monitor window to perform any of the following 
functions:



Select Option To Notes

File > Start Sequence Start 

File > Pause Sequence Pause Stops all diagnostic moves, but maintains 
the current location in the access order.

File > Stop Sequence Stop   Stops a running or paused move.

File > Start Sequence Resume Resumes a paused move starting with the 
last known location in the target address 
range.

File > Clear Output Window Clear the messages 
displayed in the monitor 
window

Erases the previous message lines and 
continues to fill the screen with new 
messages.

Spool File > Start Spooling Spool Directs the move output to a file.

Spool File > Stop Spooling Stop spooling the move 
output to a file

Stops directing the move output to the 
spool file.
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AEM Safety Door Utility Tasks

Task  Page

Reboot an AEM Safety Door  571
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▼Reboot an AEM Safety Door 

Use this procedure to reboot an AEM safety door. You may need to do this to clear 
errors if the AEM safety door has experienced an abnormal condition. 

1. Select Tools > Diagnostics.

2. Expand the Safety Door Folder, and click the AEM safety door you want to 
reboot. 

3. Click Reboot in the Options Bar.

If the safety door is online, the Offline Confirm popup appears. 

4. Click OK to vary the safety door offline. 
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The Reboot Confirm popup appears. 

5. Click OK. 

The library controller reboots the safety door. The safety door is re-initialized, and 
the TallBot audits the AEM CAP.

The Reboot Success popup appears. 

6. Click OK to dismiss the popup. 
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14

Manual Operations

When in manual mode of operation, the library is unavailable for host access. This 
may be because the library has experienced an unrecoverable error or a library 
component requires service or installation. When the library is in this mode, cartridge 
mounts and dismounts require human intervention. 

Library Safety
Thoroughly review the safety precautions in this section before attempting to enter 
the library. It is essential that you follow proper safety procedures at all times. 

General Safety Precautions

Warning – To prevent accidental closure of the access door while 
someone is in the library, it is recommended that when you 
unlock the access door, you lock it open and retain the key on 
your person. 

Before entering the library, be sure you: 

• Know the location of the emergency door unlocking mechanisms. See “SL3000 
Door Interlocks” on page 574.

• Leave the access door open whenever working inside the library. There is a switch 
on each door frame that disconnects DC power and signal lines to the library’s 
motors when an access door is opened. See “SL3000 Servo Power 
Interrupt” on page 574.

• Know the location of the mechanical door releases. See “Mechanical Door 
Releases” on page 574. 

• Know the physical restrictions. See “Physical Restrictions” on page 575. 
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SL3000 Door Interlocks

Door safety interlocks are located behind the front access doors of the Base Module 
and DEM. To open either access door, an access key is required. 

Door safety interlocks are constantly monitored by the library controller. During 
normal operation, if an access door is opened an Emergency Robotics Stop condition 
is initiated and all library motors are immediately disabled. This prevents motors 
from operating while a library door is open. If the library is varied offline, opening 
the access door disconnects DC voltages to the rails and the power bus. 

The door switches are also monitored when the library is powered off. A battery 
supplies power for the circuitry to detect a door opening/closing event while the 
library is powered off.

When a Base Module and DEM are connected together, opening an access door to 
either module automatically suspends operations within the entire library (the two 
door switches are connected in series).

SL3000 Servo Power Interrupt

An additional safety feature is the servo power interrupt (SPI). If the library 
controller detects that a library motor is out-of-range, it will generate an SPI to turn 
off drive voltage to the faulty motor. This prevents a servo runaway condition until 
the cause of the problem can be determined. 

Mechanical Door Releases

Each lock handle on the access doors of the Base Module and DEM includes a 
mechanical release which is painted yellow (see FIGURE 14-1.) This release serves as 
a safeguard in case a person is inside the library and the access door is accidentally 
closed and locked. When you push the release, it unlocks and opens the door. 

FIGURE 14-1  Mechanical Door Release 



March 2011   575

 

Interior Lighting

The interior of the library is always illuminated by white LEDs on the ceiling. 

Physical Restrictions

The library does not allow much free room for movement. You must be mindful of 
the restricted space at all times. 

• Be careful not to snag your clothing on the plastic arrays that house the cartridges 
(only 0.4 m [18 in.] of aisle clearance).

• Be careful not to bump your head or body against the arrays. 

• To gain access to a cartridge, you may have to move a TallBot, in which case you 
must avoid damaging the TallBot’s electronic components. 

• If you are loading or unloading a cartridge manually, your hands must remain 
clear of the drive’s mechanical and electronic load components. 
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Manual Operation Tasks

Task Page

Vary the Library Offline  577

Vary the Library Online  577

Power Down the Library  577

Power Up the Library  577

Open the Library Main Access Door  577

Close and Lock the Library Main Access Door  585

Perform an AEM “Fast Access”  586

Close the AEM Access Door After a “Fast Access”  587
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▼ Vary the Library Offline 

Use this procedure to vary the library offline through the SL Console. 

Note – You should use this procedure only if you are not using 
ACSLS or ELS tape management software, or if their servers are 
not able to communicate with the library. ACSLS and ELS are not 
notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in 
library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

You may need to use this procedure at the following times:

• Before powering down the library

• Before opening a library access door

• When the library is inoperative and requires maintenance 

1. Vary all library drives offline. 

See “Vary a Drive Offline” on page 551 for details. 

2. Select Tools > System Detail.

3. Click the Library folder on the device tree.

4. Click the Status tab, and then the General tab.
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The current status of the library is displayed. 

5. In the Transition Request field, click Take offline. Click Apply.

All outstanding library jobs are completed, and then the library status is changed, 
as follows:

• Health State: Warn

• Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 

• Access State: Offline 
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▼ Vary the Library Online 

Use this procedure to vary the library online through the SL Console. 

Note – You should use this procedure only if you are not using 
ACSLS or ELS tape management software, or if their servers are 
not able to communicate with the library. ACSLS and ELS are not 
notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in 
library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

Note – LTO Ultrium drives are automatically brought online 
when you bring the library online.

1. Select Tools > System Detail.

2. Click the Library folder on the device tree.

3. Click the Status tab, and then the General tab.

The screen displays the current status of the library. 

4. In the Transition Request field, click Bring online. 

5. Click Apply. 

The library status is updated, as follows:

• Health State: ok
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• Device State: Ready

• Access State: Online

6. If applicable, vary the library online to ACSLS and ELS hosts. See the ACSLS 
and ELS documentation for detailed procedures. 
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▼ Power Down the Library

Use this procedure to power down the library. 

1. Vary all library drives offline. 

See “Vary a Drive Offline” on page 551 for details. 

2. Vary the library offline. 

See “Vary the Library Offline” on page 577 for details. 

3. Open the rear doors of the Base Module and DEM (if present). 

4. Turn off the power enable switches. 

5. If necessary, turn off the circuit breakers on the PDUs. 
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▼ Power Up the Library

Use this procedure to power up the library. If the access doors have been opened and 
closed, a full audit of the library will be performed. 

1. Open the rear doors of the Base Module and DEM (if present). 

2. If necessary, turn on the circuit breakers on the PDUs. 

3. Turn on the power enable switches. 

4. The library goes through the initialization sequence, as follows:

1. Library controller code is activated.

2. The library controller performs electronic discovery of library components:

a. Determines the AC power configuration (N+1 or 2N). 

b. Verifies tape drive controller function. 

c. Checks optional functions (for example, a local operator panel). 

d. Establishes communication and configuration of the TallBot controller. 

e. Polls all tape drives and determines their locations. 

f. Queries all rotational and AEM CAPs:

• If a CAP door is fully open, the door will be left open. 

• If the state of a CAP door is undetermined, it is updated to closed and 
locked.

3. The TallBot performs the physical discovery process:

a. The TallBot sweeps the entire library to determine the library size. 

b. The TallBot scans the module identification block in each module. 

c. Depending on this information, the library is auto configured. 

4. If one of the access doors was opened and closed, a library audit will begin, as 
follows: 

a. The TallBot targets on each column of arrays (from the top, down). 

b. The TallBot scans up each column, recording the VOLIDs of all cartridges. 

c. The location of each VOLID is recorded in the library controller database. 

d. Storage cells without cartridges are flagged as empty.

e. If a cartridge is found in a rotational or AEM CAP, the CAP is closed and 
locked. 

Note – This audit does not update the host cartridge databases. 
See the appropriate tape management software documentation for 
details about updating the host databases. 

f. The library comes to a Ready state.

5. Vary the library online.

See “Vary the Library Online” on page 579 for detailed instructions. 
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The SL Console gets all library configuration data from the library controller. 
Therefore, you should be careful when logging in to the SL Console before the library 
has fully initialized. You may see warnings that configuration data is not yet 
available, in which case you need to exit and log in again at a later time. 
Additionally, if a library audit is performed as part of initialization, until the audit is 
complete, any configuration data displayed may not be completely up-to-date and 
accurate. 
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▼Open the Library Main Access Door 

Use this procedure to open the main doors of the library. 

Warning – To prevent accidental closure of the access door while 
someone is in the library, it is recommended that when you 
unlock the access door, you lock it open and retain the key on 
your person. 

1. Vary all library drives offline. 

See “Vary a Drive Offline” on page 551 for details. 

2. Vary the library offline. 

See “Vary the Library Offline” on page 577 for details. 

3. Insert the key into the door lock, and turn the key to unlock the door. 

4. Pull up on the door latch to release it, and open the door.

5. Turn the key in the lock, to lock the door open, and then remove the key from 
the lock and keep it with you. This will prevent the door from being closed 
while you are in the library.

6. Enter the library. 
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▼Close and Lock the Library Main Access Door 

Use this procedure to close and lock the main doors of the library. 

1. Verify that there are no loose items in the library.

2. If the access doors were locked open, insert the key into the door lock, and turn 
the key, to unlock the door. 

3. Push the door closed and make sure it latches securely. 

4. Turn the key in the lock, to lock the door closed.

5. Remove the key from the lock and keep it in a safe place. 

6. If the library has been powered down, power it up. 

See “Power Up the Library” on page 582 for details. 

Note – Because the access doors have been opened, the library 
will go through a full audit. 
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▼ Perform an AEM “Fast Access”

Use this procedure to gain emergency access to the AEM. 

Caution – This procedure has the same effects on library operations 
as opening the main library access door. It causes an abrupt 
interruption of library activity and should be used only in 
exceptional circumstances, such as an AEM component failure. This 
procedure does not lower the internal AEM safety door. 

Note – When the AEM access door is closed, a full audit of the 
library is initiated. See “Close the AEM Access Door After a “Fast 
Access”” on page 587. 

1. Insert the library access door key in the Deadbolt Override lock, and unlock the 
door by turning the key clockwise.

Note – The key cannot be removed from the lock while it is in the 
unlocked position.

2. Lift the AEM access door latch, and open the door.

Caution – Possible Equipment Damage. DO NOT force the AEM 
access door to open or close.

All power to the rails is killed, and the TallBots are stopped immediately. 

All in-process jobs are stopped abruptly, and the TallBots and AEM CAPs are 
brought offline. 

Caution – The AEM safety door is not lowered. 
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▼Close the AEM Access Door After a “Fast Access”

Use this procedure to close the AEM access door and re-initialize the library after 
performing an AEM “fast access.” 

Note – This procedure initiates a full audit of the library. 

1. Close and latch the AEM access door.

Caution – Possible Equipment Damage. DO NOT force the AEM 
access door to open or close.

2. Lock the door by turning the key counter-clockwise in the Deadbolt Override 
lock. 

• The library re-initializes. 

• The TallBots go through their initialization sequence. 

• A full audit of the library is conducted. 

• The AEM CAP is brought online and returned to its default state. 
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A

Library Resource Addresses 

This appendix describes the following library addressing schemes: 

• Library Internal Address – Used by the library controller.

• HLI-PRC Locations – Used by hosts with TCP/IP connections to the library.

• FC-SCSI Element Locations – Used by hosts with FC-SCSI connections to the 
library. 

• Drive Hardware Numbers – Physical array slot into which a drive is installed. 

• Drive Dynamic World-Wide Names – Automatically generated by the library 
controller for installed drives. 

These schemes are used to locate all library resources, including:

• Cartridge storage cells

• Tape drive slots

• Installed drives 

• Reserved system cells

• Rotational and AEM CAP cells 

CenterLine Technology 
The SL3000 modular design uses CenterLine technology to help balance the work 
load and improve performance of the library. The left side of the Base Module –
 which is the only required module – serves as the centerline. You can add other 
modules to the left and right of the Base Module. Columns to the right of the 
centerline have positive (+) numbers, while columns to the left have negative (–) 
numbers. 



FIGURE A-1  Centerline and Column Addressing 

Center Line

Negative (–) Numbered Columns Positive (+) Numbered Columns 

 Drives -4,    -3,    -2,     -1   1,     2,     3,     4 

Cartridges -12, -11, -10, -9, -8, -7 -6, -5, -4, -3, -2, -1  1,  2,  3,  4,  5,  6 7,  8,  9,  10, 11, 12
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Library Internal Address

Storage Cells

There are five components to the SL3000 library internal addressing scheme: 

1. Library number: always “1.” 

2. Rail number: always “1.”

3. Column number: the horizontal location. Column numbering starts from the left 
edge of the back wall of the Base Module, as viewed from the front of the library. 
Columns to the right of this edge, whether within the Base Module itself or in 
modules connected to the right, are numbered positively (+), from left to right, 
starting with +1. Columns in modules connected to the left of the Base Module are 
numbered negatively (–), from right to left, starting with –1. 

4. Side: the back wall = 1, the front wall = 2.

5. Row: the vertical position. Row numbering runs from top to bottom and can 
range from 1 to 52. 

Note – For any library, the actual numbering of columns and rows 
depends on the modules installed and the configuration of drives 
vs. storage cells. See TABLE A-1 on page 592 for details. 

Library Internal Address Example – Base Module

As an example of using the library internal addressing scheme, refer to 
TABLE A-1 on page 592, drive hardware number 13 would be 1, 1, +4, 1, 4, as 
follows: 

1. Library number = 1 

2. Rail number = 1

3. Column number = +4

4. Side = 1

5. Row = 4



TABLE A-1  Base Module – Rear Wall Locations (viewed from front of library) 

Row  1 +2 +3 +4

+1

Drive 4 Drive 3 Drive 2 Drive 1

+2

 Drive 8  Drive 7 Drive 6 Drive 5

+3

Drive 12 Drive 11 Drive 10 Drive 9

+4

Drive 16 Drive 15 Drive 14 Drive 13

+1 +2 +3 +4 +5 +6

+24 Storage cells Storage cells Storage cells Storage cells Storage cells Storage cells 

  ~

+35

+36 Storage cells Storage cells Storage cells Storage cells Storage cells Storage cells 

  ~

+48

+49
  ~

No array Top two = 
Drop off

4-cell 
Diagnostic/
Cleaning

4-cell ID 4-cell 
Diagnostic/
Cleaning

4-cell 
Diagnostic/
Cleaning+52 Bottom = 

Swap

Note – Perspective is from the front of the library.
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As a second example, the location for the two drop-off cells on this wall are...

1. Library number = 1

2. Rail number = 1

3. Column number = +2

4. Side = 1

5. Rows = 49 and 50

...which translates to 1, 1, +2, 1, 49 and 1, 1, +2, 1, 50.

Library Internal Address Example – DEM

See TABLE A-2 on page 594 for drive hardware number 27. As an example of using 
the library internal addressing scheme, this drive location would be... 

1. Library number = 1

2. Rail number = 1

3. Column number = -3

4. Side = 1

5. Row = 1

...which translates to 1, 1, -3, 1, 1.

As a second example, the location for the four-cell array that can contain diagnostic 
cartridges on this wall are...

1. Library number = 1

2. Rail number = 1

3. Column number = -4

4. Side = 1

5. Rows = 49 through 52

...which translates to 1, 1, -4, 1, 49 through 1, 1, -4, 1, 52.



TABLE A-2  Drive Expansion Module – Rear Wall Locations (viewed from front of library) 

-4 -3 -2 -1 Row

Drive 28 Drive 27 Drive 26 Drive 25 1

 Drive 32 Drive 31 Drive 30 Drive 29 2

-6 -5 -4 -3 -2 -1

Storage cells Storage cells Storage cells Storage cells Storage cells Storage cells 13

~

23

Storage cells Storage cells Storage cells Storage cells Storage cells Storage cells 24

~

35

Storage cells Storage cells Storage cells Storage cells Storage cells Storage cells 36

~

48

    No array Top 2 = Drop 
off

4-cell 
Diagnostic/
Cleaning

4-cell ID 4-cell 
Diagnostic/
Cleaning

4-cell 
Diagnostic/
Cleaning

49
~

Bottom = 
Swap

52

Note – Perspective is from the front of the library.
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Reserved System Cells 

A total of two cells are reserved within the Base Module only for drop-off locations, 
and one cell is reserved as a swap cell. All remaining system cells can be used for 
diagnostic or cleaning cartridges; these are listed in TABLE A-3 on page 595.

There are a total of 12 cells for diagnostic or cleaning cartridges in the Base Module; 
there are a total of 12 or 15 cells for diagnostic or cleaning cartridges in the DEM. 
These are also listed in TABLE A-3 on page 595.

There are no system cells in a CEM or PEM.



TABLE A-3  Reserved System Cells 

Cell Locations Module Type Use Location

1, 1, 2, 1, 49 – 50 Base module Drop off cells (Reserved) Back wall of the Base 
Module 

1, 1, -4, 1, 49 – 50 DEM Cleaning/Diagnostics 
Cartridges

Back wall of the DEM 

1, 1, 2, 1, 51 Base module Swap cell (Reserved) Back wall of the Base 
Module 

1, 1, -5, 1, 51 DEM Cleaning/Diagnostics 
Cartridges

Back wall of the DEM 

1, 1, 5, 1, 49 – 52
1, 1, 6, 1, 49 – 52

Base module Cleaning/Diagnostics 
Cartridges 

Back wall of the Base 
Module 

1, 1, -1, 1, 49 – 52
1, 1, -2, 1, 49 – 52

DEM Cleaning/Diagnostics 
Cartridges

Back wall of the DEM 

Note – Do not place data cartridges in a system cell. These cells are masked from the customer’s 
database (that is, an online TallBot will never go to these cells).
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CAP Cells 

Cell locations within the CAPs follow a similar notation scheme as other locations 
within the library: 

1. Library number: (always “1”)

2. Rail number: (always “1”)

3. Column number: the horizontal location. This is referenced from the left edge (as 
you face the inside front) of the Base Module. From this point, columns are 
numbered as positive (+), consecutively, from left-to-right, throughout all 
modules connected to the right side of the Base Module. 

Conversely, if a module is attached to the left of the Base Module, column 
locations are numbered as minus (-), consecutively, from right to left, throughout 
all modules.

4. Side: (always “2” [front wall]).

5. Row: the vertical position, as referenced from the top cell in the column. Cells are 
numbered from 1 – 13 for the top magazine and 14 – 26 for the lower magazine. 
Magazine handles are located at the tops of each CAP magazine. 

Note – The magazine handle is not counted as a cell.
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Library Internal Address Examples – CAP Cells

The fourth CAP cell down in a Base Module would be... 

1. Library number = 1

2. Rail number = 1

3. Column number = +5

4. Side = 2

5. Row = 4

...which translates to 1, 1, +5, 2, 4.

The sixth CAP cell down in a DEM would be...

1. Library number = 1

2. Rail number = 1

3. Column number = -2

4. Side = 2

5. Row = 6

...which translates to 1, 1, -2, 2, 6.
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HLI-PRC Locations

Storage Cells

The host library interface-panel, row, column (HLI-PRC) location (address) is an 
eight-digit, comma-separated value (LL, PP, RR, CC) representing LSM, Panel, Row, 
Column. This addressing scheme is used by HLI clients, including ACSLS and ELS, 
to represent cartridge storage cells accessible to those HLI clients. 

Note – The SL3000 library internal address identifies the physical 
location of the cartridge in the library and the HLI-PRC refers to 
the address assigned by the host software.

The cell location appears in the following format: 

L L P P R R C C

where, 

• LL: LSM number (always “00”) 

• PP: Panel (relative to the Base Module – descending numbers on the left and 
ascending numbers to the right; even numbers = rear walls, odd numbers = front 
walls)

• Base Module = panels 12 & 13

• DEM added to the left = panels 10 & 11

• Exception: If a CEM is added to the left of a Base Module instead of a DEM, 
that module’s panel numbering will be 8 & 9 (see “HLI-PRC Storage Cell 
Locations – Example Three” on page 599). This allows for a DEM to be 
installed at a later date without the necessity of re-numbering the modules.

• module added to the right = panels 14 & 15

Note – RR: Row in the panel (a number from 0 – 51) 
Note the difference here. Library internal address rows begin with 
“1” and HLI-PRC rows begin with “0.”

• CC: Column in the row (numbered left to right, from the front of the module)

Note – CC: Columns in the panel (a number from 0 – 5.
Note the difference here. Library internal address columns begin 
with “1” and HLI-PRC rows begin with “0.”
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HLI-PRC Storage Cell Locations – Example One

For an example of how this numbering scheme is formulated, refer to TABLE A-4. 

TABLE A-4  Host Library Interface Cell Locations – Example One

Drive Expansion Module Base Module

Rear Wall = Panel 10 Rear Wall = Panel 12

Cartridge Column Numbers Cartridge Column Numbers

0 1 2 3 4 5 0 1 2 3 4 5

0 1 2 3 4 5 0 1 2 3 4 5

Cartridge Column Numbers Cartridge Column Numbers

Front Wall = Panel 11 Front Wall = Panel 13

Note – Perspective is from the front of the library.

In example one, the library is composed of two modules. The cell location of a 
cartridge on the rear wall of the Base Module at Column 5, Row 24, would translate 
to the following: 

LL = 00, PP = 12, RR = 24, CC = 05; or 00, 12, 24, 05 

HLI-PRC Storage Cell Locations – Example Two

Adding a module to the left of the library described in Example One illustrates the 
“left descending” numbering scheme. Refer to TABLE A-5 to see how this works. 

TABLE A-5  Host Library Interface Cell Locations – Example Two

Cartridge Expansion Module   Drive Expansion Module               Base Module

Rear Wall = Panel 8 Rear Wall = Panel 10 Rear Wall = Panel 12

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

Front Wall = Panel 9 Front Wall = Panel 11 Front Wall = Panel 13

Note – Perspective is from the front of the library.

In this example, a CEM has been added to the left of the DEM. Its panels are now 
numbered 8 and 9. Add another module to the left of this library and its panels 
become 6 & 7. 

Conversely, adding a module to the right of the Base Module would make that 
module’s panel numbers 14 & 15, and so forth. 
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HLI-PRC Storage Cell Locations – Example Three

For an exception to continuous panel numbering, a third example is presented in 
TABLE A-6. In this library, two CEMs have been added to the left of a Base Module. 
Notice that, without a DEM, panel numbering to the left of the Base Module is now 8 
& 9, instead of 10 & 11.

This illustrates:

• The one exception to the consecutive panel numbering scheme

• That if a DEM is installed in the future, no panel numbering will change for the 
existing modules

TABLE A-6  Host Library Interface Cell Locations – Example Three

Cartridge Expansion Module Cartridge Expansion Module Base Module

Rear Wall = Panel 6 Rear Wall = Panel 8 Rear Wall = Panel 12

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

Front Wall = Panel 7 Front Wall = Panel 9 Front Wall = Panel 13

Note – Perspective is from the front of the library.

Note – This numbering scheme benefits customers greatly since 
adding a module does not require any change to their existing 
panel configurations.

Although the host tape management software follows a five-digit numbering scheme 
like that in the SL3000 address, there are significant differences in cell designations, 
rotational and AEM CAP behavior, and other operational considerations as described 
below.

If you need to locate a cartridge’s HLI-PRC location, see “Locate a Cartridge by 
VOLID” on page 433. This procedure displays the cartridge information in both 
library internal address and HLI-PRC address formats. 
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Drive Slots

For the drives, HLI-PRC locations are different from the notation you will see with 
cartridge storage cells. TABLE A-7 illustrates how this numbering scheme works, as 
viewed from the rear of the library. 

TABLE A-7  Host Library Interface Tape Drive Locations

Base Module Drive Expansion Module

Rear Panel =12 Rear Panel = 10

13 22 31 40 253 262 71 280

57 66 75 84 297 306 315 324

911 1010 119 128 3311 3410 359 368

1315 1414 1513 1612 3715 3814 3913 4012

1719 1818 1917 2016 4119 4218 4317 4416

2123 2222 2321 2420 4523 4622 721 4820

4927 5026 5125 5224

5331 5430 5529 5628

Note – 

Perspective is from the rear of the library.

The superscript numbers (in bold) represent the HLI-PRC locations (which translate into the Row 
number).

The standard number notation represents the drive hardware number. 

• The standard numbers correspond with the physical numbering of the drives.

• The superscript numbers (in bold) correspond with the HLI-PRC (Row) locations.

• HLI-PRC numbering is sequential from right-to-left – from 0 to 3 – for the first 
(top) row of the first module.

• HLI-PRC sequential numbering scheme restarts, right-to-left – from 0 to 3 – in the 
next module.

• The Column number is always 0.

HLI-PRC Drive Locations – Example One

Drives use drive numbers in place of row and column locations. The drive number is 
assigned to the position taken by a cell’s row, and the position taken by a cell’s 
column is always “00”. For example, tape drive hardware number 20 is equivalent to 
this HLI-PRC location:

Library = 00

Panel = 12

Drive = 16

Column = 00
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HLI-PRC Drive Locations – Example Two

As a second example, going from an HLI-PRC location to a hardware location, tape 
drive 00, 10, 25, 00 is equivalent to tape drive hardware number 51.

CAP Cells 

CAP HLI-PRC locations are different from the notation used for cartridge storage 
cells. CAPs use CAP numbers in place of panel numbers. 

Rotational CAPs

• Library = always 00

• CAPs = 01–10, as follows:

• Left side CEMs = 01 – 04, from left to right

• DEM = 05

• Base Module = 06

• Right side CEMs = 06 – 10, from left to right

• Rows = 00–25

• Column = always 00

AEM CAPs

• Library = always 00

• AEM CAPs = 00 or 11, as follows:

• Left side AEM = 00

• Right side AEM = 11

• Rows = 00–38

• Columns = 00–05 
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FC-SCSI Element Locations
Since the SL3000 offers a Fibre Channel SCSI (FC-SCSI) control interface, you must be 
aware of SCSI element numbering for storage cells, CAPs, and installed drives. SCSI 
element numbers are assigned according to the following scheme:

• For storage elements – Numbering runs top-to-bottom, left-to-right, beginning at 
the back wall (as viewed from the front of the library, numbered 2000) and 
continuing with the same scheme at the front walls (also viewed from the front). 

• For rotational CAP elements (import/export elements) – Numbering runs top-to-
bottom, left-to-right, beginning with element number 10 at the left-most module’s 
CAP. 

• Tape drives (data transfer elements) –  Numbering runs top-to-bottom, left-to-
right, as viewed from the front of the library. Only installed drives are included in 
the numbering sequence; vacant slots are skipped. Numbering starts in the Base 
Module, at the top-left installed drive and runs to the bottom-right. It then moves 
to the top-left slot in the DEM and runs to the bottom-right slot. 

• If additional storage modules are added to the library, all element numbers are 
reassigned. If a module is added to the left of the existing library modules, 
numbering would re-start with the left-most rear cell. If a module is added to the 
right of existing modules, the top, left, front cell would increment by the number 
of additional cells in the new module. 

The following cells are not assigned SCSI storage element IDs. As such, they are 
never seen by the host as storage cells. Customer cartridges must never be placed in 
these cells.

• The bottom four rows on the rear wall of the Base Module.

• The bottom four rows on the rear wall of the DEM.

• All CAPs; CAPs are assigned CAP element IDs.

• In single TallBot library, the front and rear left-most columns.

• In a dual TallBot library with PEMs, the three front and rear left-most columns 
and three front and rear right-most columns. 

• All module identification label cells. 

FIGURE A-2 and FIGURE A-3 on page 603 illustrate SCSI element numbering for a 
sample SL3000 library with the following configuration:

• Four modules

• 166 activated cartridge storage cells 

• 36 tape drives 

FIGURE A-2 represents the back walls of the library, and FIGURE A-3 represents the 
front walls. 

Note – The library in these examples is not partitioned. For details 
about SCSI element numbering for partitions, see “Host SCSI 
Element Address” on page 192. 



FIGURE A-2  FC-SCSI Element Locations – Back Walls (as viewed from the front)) 

Cartridge 
Expansion 

Module

Drive Expansion Module 
(Center Line)

Base Module 
(Center Line) Cartridge 

Expansion 
Module

2000 2010 1022 1023 1024 1025 1000 1001 1002 1003 2060 2070

2001 2011 1026 Empty 1027 1028 1004 1005 1006 1007 2061 2071

2002 2012 1029 1030 Empty 1031 1008 1009 1010 1011 2062 2072

2003 2013 1032 1033 1034 1035 1012 1013 1014 1015 2063 2073

2004 2014 2020 2026 2032 2038 1016 Empty 1017 1018 2064 2074

2005 2015 2021 2027 2033 2039 1019 1020 1021 Empty 2065 2075

2006 2016 2022 2028 2034 2040 2044 2048 2052 2056 2066 2076

2007 2017 2023 2029 2035 2041 2045 2049 2053 2057 2067 2077

2008 2018 2024 2030 2036 2042 2046 2050 2054 2058 2068 2078

2009 2019 2025 2031 2037 2043 2047 2051 2055 2059 2069 2079

Note – Tape drives begin numbering from the center line (left wall of the Base Module).
Empty tape drive slots are not counted.

FIGURE A-3  FC-SCSI Element Locations – Front Walls (as viewed from the front) 

Cartridge 
Expansion 

Module

Drive Expansion Module 
(Center Line)

Base Module 
(Center Line) Cartridge 

Expansion 
Module

2080 2090 2100 2107 (CAP) 10 2123 2130 (CAP) 36 2146 2156

2081 2091 2101 2108              2124 2131               2147 2157

2082 2092 2102 2109               2125 2132               2148 2158

2083 2093 2103 2110             ~ 2126 2133             ~ 2149 2159

2084 2094 2104 2111               2127 2134               2150 2160

2085 2095
 Door
 Latch

2112               
 Door
 Latch

2135               2151 2161

2086 2096 2113 35 2136 51 2152 2162

2087 2097 2114 2117 2120 2137 2140 2143 2153 2163

2088 2098 2105 2115 2118 2121 2128 2138 2141 2144 2154 2164

2089 2099 2106 2116 2119 2122 2129 2139 2142 2155 2155 2165

Note – Perspective is looking through the front of the library.
Cartridge storage cell locations are consecutive, skipping locations for the door latches.

CAP cells are unique and sequential, from the left-to-right, as viewed through the front of the library
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Drive Hardware Numbers
The hardware number of a drive is strictly internal to the library, defined by the 
electrical wiring to the drive slot. These numbers are printed on decals on the interior 
of the rear doors of the library modules.

TABLE A-8 illustrates this numbering scheme for the Base Module, as viewed from 
the rear of the module. TABLE A-9 on page 605 illustrates the numbering for the 
DEM.

TABLE A-8  Base Module Tape Drive Numbering – Hardware 

Array Number Drive Trays

1 Drive 1 Drive 2 Drive 3 Drive 4

Drive 5 Drive 6 Drive 7 Drive 8

Array Number Drive Trays

2 Drive 9 Drive 10 Drive 11 Drive 12

Drive 13 Drive 14 Drive 15 Drive 16

Array Number Drive Trays

3 Drive 17 Drive 18 Drive 19 Drive 20

Drive 21 Drive 22 Drive 23 Drive 24

Note – Numbers shown are referenced from the rear of the Base Module.



TABLE A-9  Drive Expansion Module Tape Drive Numbering – Hardware

Array Number Drive Trays

1
Drive 25 Drive 26 Drive 27 Drive 28

Drive 29 Drive 30 Drive 31 Drive 32

Array Number Drive Trays

2
Drive 33 Drive 34 Drive 35 Drive 36

Drive 37 Drive 38 Drive 39 Drive 40

Array Number Drive Trays

3
Drive 41 Drive 42 Drive 43 Drive 44

Drive 45 Drive 46 Drive 47 Drive 48

  Array Number Drive Trays

4
Drive 49 Drive 50 Drive 51 Drive 52

Drive 53 Drive 54 Drive 55 Drive 56

Note – Numbers shown are referenced from the rear of the DEM.
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Drive Dynamic World-Wide Names
Drive dynamic World-Wide Names (dWWN), or Fibre Channel addresses, are 
automatically generated by the library controller during library initialization. 
dWWNs are assigned to library drive slots rather than devices. If a drive is replaced, 
the new drive receives the same name as the one it replaced, thereby eliminating the 
need for system re-configuration There are three World Wide Names reserved for 
each drive slot: Node, Port A, and Port B.

Note – The dWWN feature is usually enabled at installation time. 
The library and tape drives all must have firmware that supports 
the dynamic World Wide Naming feature. When dWWN is 
enabled, all drives must be at the proper firmware level. If a drive 
has down-level firmware, it remains in the “configuring” state 
and is unavailable for host use.
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B

Wall Diagrams 

This appendix provides diagrams and tables detailing the following:

• “Base Module Walls” on page 608

• “Drive Expansion Module Walls” on page 609

• “Cartridge Expansion Module Walls” on page 610

• “Parking Expansion Module Walls” on page 611

• “Access Expansion Module Walls” on page 612

• “Configuration Block” on page 613

• “Row Numbering” on page 614

• “Reserved System Cells” on page 615



FIGURE B-1  Base Module Walls 

Base Module 

F
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t 
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a
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• 140 data cartridge cells

• With 26-cell rotational CAP 

• With operator panel or 
window

• 163 data cartridge cells 

• With 26-cell rotational CAP 

• With window cartridge array

R
e

a
r 

W
a

ll
 

• 8 tape drive slots 

• 180 data cartridges 

• 16 tape drive slots 

• 125 data cartridges 

• 24 tape drive slots 

• 65 data cartridges 
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Note – The light gray cells are not accessible unless an adjacent 
module is installed on that side. 



FIGURE B-2  Drive Expansion Module Walls 

Drive Expansion Module 
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• 253 cartridge cells 

• With window 
cartridge array 

• No rotational CAP

• 230 cartridge cells 

• With operator panel 
or window 

• No rotational CAP 

• 176 cartridge cells 

• With 26-cell 
rotational CAP 

• With window 
cartridge array 

• 153 cartridge cells 

• With 26-cell 
rotational CAP 

• With operator panel 
or window 

R
e

a
r 

W
a

ll
 

• 8 tape drive slots 

• 180 data cartridges 

• 16 tape drive slots 

• 125 data cartridges 

• 24 tape drive slots 

• 65 data cartridges 

• 32 tape drive slots 

• 0 data cartridges 
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Note – The light gray cells are not accessible unless an adjacent 
module is installed on that side. 



FIGURE B-3  Cartridge Expansion Module Walls 

Left Cartridge Expansion Module 

Front Wall 

• 260 cartridge cells 

Front Wall 

• 182 cartridge cells

• With 26-cell rot. CAP

Rear Wall 

• 256 cartridge cells

Right Cartridge Expansion Module 

Rear Wall 

• 308 cartridge cells 

Front Wall 

• 234 cartridge cells 

• With 26-cell rot CAP

Front Wall 

• 312 cartridge cells 
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Note – The light gray cells are not accessible unless an adjacent 
module is installed on that side. 



FIGURE B-4  Parking Expansion Module Walls 

Left Parking Expansion Module 

Front Wall 

• 156 cartridge cells 

Rear Wall 

• 152 cartridge cells 

Right Parking Expansion Module 

Rear Wall 

• 156 cartridge cells 

Front Wall 

• 156 cartridge cells 
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Note – Six columns of arrays – three rear-wall and three front-
wall – on both the left and right sides – are not accessible to allow 
for a defective robotics unit. 



TABLE B-1  Access Expansion Module Walls 

Left Access Expansion Module 

Front Wall 

• 117 AEM CAP cells 

Rear Wall 

• 117 AEM CAP cells

Right Access Expansion Module 

Rear Wall 

• 117 AEM CAP cells 

Front Wall 

• 117 AEM CAP cells 

612  SL3000 User’s Guide March 2011 

 



March 2011   613

 

Configuration Block
Each module in the SL3000 library has a configuration block on the lower rear wall in 
column 4, rows 49, 50, 51, and 52. This block identifies the: 

• Type of module 

• Back wall configuration 

• Front wall configuration 

• Options for that module

During library initialization, the robotic assembly visits this configuration block to 
determine the configuration of the module.

FIGURE B-5  Configuration Block 

I   I\I   I

Module types: 

• Base Module 

• DEM 

• CEM 

• PEM

• AEM 

Back wall configuration: 

Target 

Front wall configuration: 

Options: 

• Local operator panel 

• Window 

• Cartridge arrays
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Row Numbering 

FIGURE B-6  Row Numbering 

Example 1 
Base Module 

Example 2 
CEM 

Rows indicate the vertical location of a cartridge or tape 
drive.

Rows are always positive numbers. 

Storage cell rows are numbered from the top (1) to 
bottom (52). 
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Reserved System Cells 
Both the Base Module and the Drive Expansion Module have reserved system cells 
on the lower rear wall. These cells provide special functions for the library and tape 
drives. 

FIGURE B-7 shows an example of these cells: 

1. Swap cells (2) in column 2, rows 49 and 50.

2. Diagnostic cell (1) in column 2, row 51. 

3. Diagnostic cell (4) in column 3, rows 49, 50, 51, and 52. 

4. Configuration block in column 4, rows 49, 50, 51, and 52.

5. Cleaning cartridges (4) in column 5, rows 49, 50, 51, and 52. 

6. Cleaning cartridges (4) in column 6, rows 49, 50, 51, and 52. 

FIGURE B-7  Reserved system cells 

Swap
Diagnostic Diagnostic

Configu-
ration 
Block Cleaning Cleaning
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C

Cartridge Handling 

This appendix provides information on labeling and handling tape cartridges used in 
Oracle StorageTek libraries. 

Cartridge Requirements
Library cartridges must meet specifications defined in American National Standard 
Magnetic Tape and Cartridge for Information Interchange. Refer to your drive vendor’s 
publication and Web site for specific cartridge requirements and specifications.

Colored cartridges are approved only if the measured reflection density is greater 
than 0.1 as measured by an X-rite 404G color reflection densitometer. For more 
information about colored cartridges, contact your Oracle support representative 

Colored measurements are:

Bandwidth ANSI Status T Wide band (380 to 780 nm)

Measuring range Density (0.00 to 2.50) D

Accuracy ±0.02 D

Repeatability ±0.01 D

Aperture diameter 3.4 mm (0.13in.)

For more information about colored cartridges, contact your Oracle support 
representative.
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Valid Cartridge Labels 
Library cartridges must be labeled with a valid external label. Several standard 
Code 39 bar code labels are supported by the library. 

Note – Unlabeled cartridges are not supported. See “Unlabeled 
Cartridges” on page 622.

Pre-labeled cartridges are available from Oracle Corporation. For information on 
ordering these cartridges, see “Ordering Cartridges and Labels” on page 623.

If you do not order pre-labeled cartridges, see “Apply a Label to a 
Cartridge” on page 624 for detailed instructions on labeling the cartridges correctly. 
Oracle does not supply cartridge labels. For a supplier of labels only, see “Ordering 
Cartridges and Labels” on page 623. 

To display detailed cartridge information, see the following procedures:

• “Display Library Cartridge Information in Tabular Format” on page 427

• “List Library Cartridges” on page 430

Media Domain and Media ID

The media domain and media ID together identify a cartridge’s media and usage to 
the library. They allow you to mix tape drive types and media types in a library. The 
media ID label corresponds to the tape drive or transport capable of using the 
cartridge. The media domain reflects the cartridge usage: data, cleaning, diagnostic.

Cleaning and Diagnostic Cartridges 

Cleaning cartridges have CLN in the VOLID; diagnostic cartridges have DG in the 
VOLID

Each cleaning and diagnostic kit includes one labeled cleaning cartridge and one 
labeled diagnostic cartridge, with a volume ID (volume serial number or VOLID) of 0 
for each. Extra cleaning and diagnostic labels are sent with each library. 

Cleaning and diagnostic cartridges cannot be used as scratch cartridges or initialized 
by software utilities.

Caution – PROCEDURE ERROR: When you enter a cleaning 
cartridge, the software considers it to be new, and sets the usage 
counter to zero. DO NOT RE-ENTER A CLEANING CARTRIDGE 
THAT LIBRARY EJECTS THROUGH THE CAP. 

Cartridge Codes

The SL3000 library supports the following types of barcode labels: 

• For T9840 drives, 1/2-inch labels supplied by Trioptic (Engineered Data 
Products/Colorflex) or Tricode (American Eagle/Writeline). Both versions require 
a separate Media ID Type, which is one character. 

• For T10000 drives, labels with eight characters, the last two of which are the 
required Media ID Domain and the Media ID Type characters.
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• For LTO drives, labels with eight characters, the last two of which are the required 
Media ID Domain and the Media ID Type characters. 

Oracle StorageTek Tape Drives and Cartridges

Cartridge labels for Oracle StorageTek T9840 (models C and D) and T10000 tape 
drives are listed in TABLE C-1. These tape drives also support encryption. 

TABLE C-1  Oracle StorageTek Cartridge Codes

Media ID Cartridge Type Drive Type

VOLID + R Data T9840

VOLID + R (Green background) VolSafe Data T9840C

VOLID + R (Purple background) VolSafe Data T9840D

VOLID + T1 Data T10000 A/B

VOLID + T2 Data T10000 C

VOLID + TS Sport Data T10000 A/B

DG (blank space) VOLID + R Diagnostic T9840

DG (blank space) VOLID + T1 Diagnostic T10000 A/B

DG (blank space) VOLID + T2 Diagnostic T10000 C

DG (blank space) VOLID + TS Sport Diagnostic T10000 A/B

CLN (blank space) VOLID + CC Cleaning T10000 C

CLN (blank space) VOLID + CL Cleaning T10000 A/B/C

CLN (blank space) VOLID + CT Cleaning
Sport Cleaning

T10000 A/B

CLN (blank space) VOLID + U Cleaning T9840
(all except T9840D)

CLN (blank space) VOLID + Y Cleaning T9840D

LTO Tape Drives and Cartridges

Note – LTO technology was initially developed by IBM, 
Hewlett-Packard, and Quantum. LTO is an “open format’ 
technology, which means that users have multiple sources of 
product and media. 

LTO cartridge labels have eight characters. The last two characters are the media ID 
(L3, L4, L5, LT, LU, or LV). CLN or DG are the first characters on the cleaning or 
diagnostic labels. LTO4 and LTO5 tape drives also support encryption. 

Note – 



TABLE C-2  LTO Cartridge Codes  

Media ID Type of Cartridge

L3 Generation 3 data cartridge

L4 Generation 4 data cartridge

L5 Generation 5 data cartridges

LT Write once read many times (WORM)—400 GB, 
LTO Gen 3 drive only

This feature prevents the user from altering or erasing 
information from the tape. For more information, go to 
your vendor Web site and do a search on WORM. 

LU Write once read many times (WORM)—800 GB, 
LTO Gen 4 drive only

LV Write once read many times (WORM)— 1500 GB, 
LTO Gen 5 drive only

CLN (blank space) + CU Universal cleaning cartridge

Oracle recommends using the CLN + CU universal 
label instead of a vendor-unique label (CLN + C1 for 
Hewlett-Packard or CLN + C2 for IBM).

DG (blank space) + 
VOLID

Diagnostic cartridge (apply a DG label to a blank data 
cartridge to be used for library diagnostic tests) 
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Handling Cartridges
Improper handling of cartridges can result in a loss of data or damage to a library 
component. To handle a cartridge correctly:

• Do not carry several cartridges loosely in a container. The leader blocks can snag 
on other cartridges and become unlatched. 

Note – LTO Ultrium cartridges have leader blocks. T9840 
cartridges do not.

• Make sure that the leader block is latched every time you pick up a cartridge. 

• Keep cartridges clean. 

• Inspect a cartridge before each use and never put a damaged cartridge into a drive 
or library. 

• Never release a leader block and pull tape from a cartridge. 

• Never open a cartridge. 

• Do not handle tape that is outside the cartridge; the tape edge might be damaged. 

• Do not expose the tape or cartridge to direct sunlight or moisture. 

• Do not expose a recorded cartridge to magnetic fields; this might destroy data on 
the tape. 
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Inspecting a Cartridge

A defective or dirty cartridge can damage a tape drive. Always inspect a cartridge 
before you insert it into a tape drive or a library. Look for:

• Cracked or broken cartridge

• Broken leader

• Broken leader latch

• Damaged write-protect switch

• Liquid in the cartridge

• Labels not firmly or neatly attached or extending over the cartridge edge

• Any other obvious damage

Inserting a Cartridge in a Drive or Cell

A defective or dirty cartridge can damage a drive. Always inspect a cartridge before 
you insert it into a drive or into a tape library. Look for:

• Cracked or broken cartridge

• Broken leader

• Broken tape access door

• Damaged file-protect selector or write-protect switch

• Liquid in the cartridge

• Labels not firmly attached or extending over the cartridge edge

• Any other obvious damage

A cartridge must be inserted in a storage cell, rotational or AEM CAP cell, or drive 
with the bar code on the bottom, and the VOLID readable from right to left. The 
cartridge hub must always be down. 

Unreadable Cartridges
Cartridges may be identified as unreadable for the following reasons:

• Unlabeled Cartridges

• Upside-Down Cartridges

ELS and ACSLS automatically eject unreadable cartridges from the library. FC-SCSI 
hosts may not; an unreadable cartridge may be moved automatically to a CAP during 
library initialization. 

Note – If a large number of cartridges are reported as unreadable, 
you may suspect a faulty TallBot camera or scanner. This could 
result in a large number of cartridges mistakenly ejected from the 
library. 
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Unlabeled Cartridges

Cartridges without external labels are not fully supported in the SL3000. Unlabeled 
cartridges will not be mounted on drives; however, they can be moved between 
CAPs and storage cells. 

• If an unlabeled cartridge is placed in a CAP, the TallBot will leave the cartridge 
there. The cartridge’s disposition depends on the host software. 

• If an unlabeled cartridge is placed in a library storage cell, during an audit the 
cartridge will be reported as “unreadable, invalid media type.” Depending on the 
host software, the cartridge may not be recognized by the host, or it may be 
ejected through the CAP. 

Upside-Down Cartridges

Insertion of upside-down cartridges should never be attempted, especially for Oracle 
StorageTek cartridges. How the library handles this situation depends upon the 
cartridge type.

Oracle StorageTek Cartridges

Caution – Upside-down Oracle StorageTek T9840 and T10000 
cartridges do not fit in library storage cells and may cause damage 
to the cartridge and the TallBot.

• If a Oracle StorageTek cartridge is placed upside-down in a CAP magazine, the 
CAP will not be able to close. 

• If a Oracle StorageTek cartridge is placed upside-down in a library storage cell, 
the cartridge will extend from the storage cell may and damage the TallBot. 

LTO Cartridges

• If an LTO cartridge is placed upside-down in a CAP magazine, the TallBot will 
leave the cartridge there. The cartridge’s disposition depends on the host 
software. 

• If an LTO cartridge is placed upside-down in a library storage cell, during an 
audit the cartridge will be reported as “unreadable, invalid media type.” 
Depending on the host software, the cartridge may not be recognized by the host, 
or it may be ejected through the CAP. 
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Maintaining Cartridges
The following section describes general maintenance guidelines for cartridges. 

Cleaning the Cartridge Exterior 

Caution – CARTRIDGE DAMAGE: Certain solvents can damage 
the cartridges. DO NOT USE ACETONE, TRICHLOROETHANE, 
TOLUENE, XYLENE, BENZENE, KETONE, METHYL ETHYL 
KETONE, METHYLENE CHLORIDE, ETHYLDICHLORIDE, 
ESTERS, ETHYL ACETATE, OR SIMILAR CHEMICALS TO 
REMOVE LABELS OR TO CLEAN CARTRIDGES. 

Wipe all dust, dirt, and moisture from the cartridge with a lint-free cloth. 

Use Oracle StorageTek Tape Cleaner Wipes to clean the cartridges. These wipes are 
saturated with isopropyl alcohol. Do not let any solution touch the tape or get inside 
the cartridge. 

Repairing a Detached Leader Block 

When an LTO Ultrium cartridge tape is damaged, use a backup tape if possible. If a 
cartridge leader block is detached, there is no backup tape, and the cartridge or tape 
has no obvious damage, you may repair the leader block using a repair kit provided 
by the tape supplier. You can use the tape one time to copy the data onto another 
tape. 

Storing Cartridges

Following are guidelines for cartridge storage:

• Do not take a cartridge out of its protective wrapping until you are ready to use it. 
Use the tear string, not a sharp instrument, to remove the wrapping. 

• Store cartridges in a clean environment that duplicates the conditions of the room 
in which they are used. 

• Before using a cartridge, make sure that it has been in its operating environment 
for at least 24 hours.

• Archival storage is 1 to 10 years for 9840 cartridge tapes and 15 to 30 years for 
LTO Ultrium cartridge tapes.

Ordering Cartridges and Labels
Contact your authorized Oracle selling agent for labeled cartridges.

For cartridge labels, contact EDP/Colorflex at:

• Web site: http://www.colorflex.com

For technical questions, contact your Oracle support representative. 

http://www.colorflex.com


624  SL3000 User’s Guide March 2011 

 

▼Apply a Label to a Cartridge

Cartridge labels reflect the cartridge media and usage. If your cartridges were not 
ordered with labels already applied, you must apply them yourself. You must 
correctly label all cartridges for library use. Use labels that do not leave a residue 
when they are removed.

Caution – Possible misread of volume number label: Make sure the 
edges of the labels do not curl; curling causes the cartridges to stick 
in the tape drive loader and the robot to misread the label.

1. Make sure that the cartridge has been at room temperature for at least 24 hours.

2. Clean the surface where the label will be placed using a cleaning solution made 
for this purpose. See “Cleaning the Cartridge Exterior” on page 623. 

3. Locate the type of label that you need.

Note – Make sure that the label contains a VOLID.

4. Peel the backing from the cartridge label. 

5. Hold the cartridge so that the write-protect switch is toward you. 

6. Position the cartridge label with the bar-code characters below the alphanumeric 
characters. Press it into place.

Note – On LTO Ultrium cartridge labels, the alphanumeric 
characters can be either vertical or horizontal.

Note – The label must be within the indented area of the cartridge 
so that the edges of the label are parallel to the edges of the 
cartridge. The label should be close to the inside edge of the 
indented area but must never overlap the edge of this area. 

7. If the cartridge has a customer label, place the label in the area and press it into 
place. 

8. Repeat Step 2 through Step 6 for the media ID label.
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D

Web-launched SL Console Server

Oracle’s Web-launched SL Console server, which is a standard feature of the SL3000, 
enables the SL Console to be installed on a centralized Web server. Individual clients 
can use a supported Web browser to download and log in to the Web-launched 
SL Console server. 

You download the server from the Oracle E-Delivery website. It is distributed as a 
Java WebARchive (.war) file. Once you have downloaded the file, you can deploy it 
on the Web server of your choice. See your Web server documentation for specific 
deployment instructions and requirements. 

Security Considerations
The customer is responsible for implementing all appropriate security systems, 
including firewalls, user access, etc. 

Updating the Web-launched SL Console Server
You can update the Web-launched SL Console server while it is running. Updates are 
automatically propagated to the clients when they retrieve the Web-launched 
SL Console application from the server. 
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▼Download the SL Console Media Pack 

Use this procedure to download and extract the current SL Console Media Pack from 
the Oracle E-Delivery website. The Media Pack includes the Web-launched 
SL Console server, as well as the Web-launched SL Console client and the standalone 
SL Console. 

Once you have completed this procedure, you can deploy the Web-launched 
SL Console server on the Web server of your choice. See your Web server 
documentation for specific deployment instructions and requirements. 

1. Start a Web browser on your PC or workstation, and navigate to the Oracle 
E-Delivery website at the following URL:

http://edelivery.oracle.com/ 

 

2. Click Continue. 

3. On the Export Validation screen, make the following entries:

• Enter your contact information.

• Read the License Agreement and Export Restrictions, and click the check boxes 
to indicate your acceptance. 
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• Click Continue. 

 

4. On the Media Pack Search screen, make the following selections: 

• In the Select a Product Pack pull-down, select Oracle StorageTek Products. 

• In the Platform pull-down, select Generic Platform. 
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• Click Go. 
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5. All media packs meeting your selection criteria are displayed in the Results 
section of the screen. Select the SL Console version you want to download. 
Click Continue. 

 



630  SL3000 User’s Guide March 2011 

 

6. On the specific media pack screen, review the information to verify that you 
have selected the correct media pack. Click Download. 

 

7. In the popup, click Save File to save the media pack to your PC or workstation. 
Click OK. 

Note – This process may take several minutes.

8. Use the appropriate extraction utility (for example, gunzip, pkunzip) to extract 
the media pack to the location of your choice. 
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The Web-launched SL Console server filename is opel.war, located in the 
Weblaunch directory. 
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printing reports 160
reports 158–159, 177–183
saving reports 162
SL Console workspace 165, 174
SL Console workspace and 149

AEM
allocating to partitions 214, 282
associating to a partition 244
bulk load cartridges to a partition 246
bulk unload cartridges from a partition 247
described 41
emergency access 586–587
library partitions and 196–200, 382
non-disruptive maintenance and 382
override a reservation 249
properties 389
rebooting 571
removing partition associations 248
status 386
summary information 385
using to bulk load cartridges 381
using to bulk unload cartridges 381
wall diagrams 612

AEM access door 382
audits and 484, 586, 587
closing 393
described 381
fast access 586–587

AEM CAP
described 382
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AEM operations
summarized 381–383
tasks 384–393

AEM safety door 382
described 382
properties 398
status 397
tasks 396–398
utility tasks 570–572

airborne contaminants statement 23
Any Cartridge, Any Slot technology 29
audits

access door and 582
AEM access door and 484
described 484–485
full library 537–538
library initialization and 582
main access door and 484
physical 484, 537–538, 539–540
range of cells 539–540
tasks 536–541
verified 485, 541

auto clean (drive)
described 444

auto enter mode (CAPs)
described 378
library partitions and 197

automated mode (library) 59
described 325
determining 326

B

barcode presentation 414, 423, 425
Base Module

described 32–33
drive configurations 31
physical capacity 31
wall diagrams 608

bulk load operations 246, 419
bulk unload operations 247

C

CAP allocations
library partitions and 196

CAP associations
library partitions and 199, 244
removing 248, 318

CAP cells
FC-SCSI address 602
HLI-PRC address 601

CAP operations
library partitions and 197

summarized 377–379
tasks 384–393

CAP reservations
library partitions and 198–199
overriding 249–251
partitioned libraries and 198
removing 322

capacity
activated. See activated capacity.
allocated (in partitioned libraries) 189
non-disruptive changes. See non-disruptive 

capacity changes.
of library modules 31
physical 30, 144

Capacity on Demand 143–185
features of 143
terminology 143

CAPs
auto enter mode 378

partitioned libraries and 197
capacity of 45
closing 378, 393
library partitions and 196–200, 243–251, 

317–323, 380
library partitions and shared 197
making available for diagnostic moves 394
manual mode 378
maximum 45
maximum number of 45
opening 378
properties 389
self-test 544
states

library partitions and 198, 379
status 386
summary information 385
using to eject cartridges 377
using to enter cartridges 377
utility tasks 543–547
varying offline 545
varying online 547

cartridge access ports. See CAPs.
Cartridge Expansion Module. See CEM.
cartridges

applying labels 624
barcode presentation 414, 423, 425
bulk load 419
cleaning. See cleaning cartridges.
color specifications 617
diagnostic 620
diagnostic. See diagnostic cartridges.
ejecting from a partition 247
ejecting through the CAP 377
ejects 414
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entering into a partition 246
entering through the CAP 377
enters 413, 417
exterior cleaning 623
handling 620
handling of 617–622
home cell 413
inserting in a cell or drive 621
inserting in the CAP 413
inspecting 621
labels 618
listing 427, 430
loading through the AEM 381
locating by address 414, 434
locating by VOLID 414, 433
LTO 619, 622
management tasks 416–439
mounts and dismounts 325
ordering 623
recovery moves 415, 436, 438
repairing detached leader block 623
requirements 617
StorageTek 619, 622
storing 623
unlabeled 413, 618, 622
unloading through the AEM 381
unreadable 621
upside-down 622
valid labels 618

cautions
reentering cleaning cartridge 618
solvents for cleaning a cartridge 623

CEM
described 38
physical capacity 31
wall diagrams 610

CenterLine Technology 28, 589
cleaning cartridges 618

described 447
exporting 456
for LTO drives 620
importing 454
listing 459
status 448
storage of 595
warning threshold 452

command line interface 55
configuration block

diagram 613

control path 52–54
cooling 51

D

data path 55
DC power supplies 49
degraded mode (library) 60
DEM 35–36

drive configurations 31
physical capacity 31
wall diagrams 609

device status
listing codes 497

diagnostic cartridges 618
described 483
displaying information 534
exporting 531
importing 528
library self-tests and 482
management tasks 527–535

diagnostic moves (robot)
control functions 488
controlling 568
defining 557–560
described 486–488
managing definitions 561–562
monitoring 568
pool address range 486
random access order 487
robot selection 487
saving 563–565
sequential access order 487
starting 566–567
target address range 486

diagnostic support files 491
diagnostics

CAPs and 394
dismount operations 326
domain, media labels 618
drive cleaning

automatic 444
configuring library auto clean 451
described 443–449
exporting cleaning cartridges 456
importing cleaning cartridges 454
library auto clean 444
manual 449, 463
status of 461
tasks 450–463
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drive controller 347
Drive Events Report 409
Drive Expansion Module. See DEM.
Drive Media Events Report 411
drive slots

HLI-PRC address 399, 600
drive trays 44

status 408
drive VOP

displaying for T10000 405
drives

addressing 399
cleaning. See drive cleaning.
cooling of 51
dynamic World Wide Name 605
FC-SCSI address 602
hardware numbering 604
LED status 407
management tasks 400–412
maximum 31, 399
network data 406
properties 404
SCSI FastLoad and 468, 470
self-test 550
states 399
status 403
summary information 401
supported 43
utility tasks 549–552
varying offline 551
varying online 552

dWWN 399
dynamic World Wide Name 605
dynamic World Wide Naming. See dWWN

E

eject operations 414
partitioned libraries and 247

ELS 57
emergency power-off. See emergency robotics stop
enabled capacity

partitioned libraries and 189
Energy Monitor Reports 350, 352, 354
enter operations 413, 417

partitioned libraries and 246
environment specifications 50
event monitors

described 479
displaying 494
displaying multiple 496
spooling data to a file 495
tasks 493–499

F

FC-SCSI interface 348
barcode presentation and 423, 425
displaying port status 341
FastLoad feature and 468, 470

FC/+SCSI interface 54
FC-SCSI address

CAP cell 602
drive 399, 602
storage cell 602–603

G

garage door. See AEM safety door.
General Events Statistics Report 356

H

hardware activation file
comparing to current features 115–117, 134, 

136, 138
deleting 123–126, 190
described 109
displaying contents of 115–117
downloading 113
Feature Audit Log 127, 140
file type 109
installing 111, 118–120, 131–133, 136
library serial number and 116, 119, 132

hardware activation key file
activated capacity and 143
overlaying 110

hardware activation screen reference 128–137
hardware activation tasks 111–126
health indicators 327
HLI interface 53–54, 348

displaying port status 340
HLI-PRC address

CAP cell 601
drive slot 399, 600
storage cell 597–599

host interfaces
changing the type 348
HLI. See HLI interface. 340
non-partitioned libraries and 329, 348
partitioned libraries and 187, 227, 229, 231, 

263, 265, 266, 329
SCSI. See SCSI interface. 341

L

LCM 58
library addressing 52

FC-SCSI 602–603
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HLI-PRC 597–601
library internal address 591–596
partitioned libraries and 191–194

library auto clean 444
library configuration

displaying 343
Library Console. See SL Console
library controller

display redundant electronics 367, 369
log in to alternate 375
properties 346

library electronics
cooling of 51

library events 479
library events. See Also event monitors.
library features 27
library firmware upgrades 480

activating 507
downloading 501

library initialization sequence 582
configuration block and 613

library internal address
CAP cell 595
partitioned libraries and 191–194
storage cell 591–594

library management software 57–58
library management tasks 333–357
library operating modes 59–60
library partitions

activated capacity and 145
AEM associations and 244
allocated capacity 189
allocating an AEM CAP 214
barcode presentation and 425
boundaries of 190
CAP allocations and 196
CAP associations and 199, 244, 248, 318
CAP operations 197
CAP reservations and 198–199, 249–251, 322
CAP states and 198, 379
committing 220, 291, 293
configuration requirements 187
configuration tasks 204, 207–222
creating 209, 268
deleting 225, 270
deleting the Partitioning feature 190
described 187
design and commit screen reference 273–297
designing 190, 212, 276
displaying 163, 241
ejecting cartridges from 247
entering cartridges into 246
features of 187
hosts and 187, 189, 210, 227, 229, 231, 263, 

265, 266
installing the Partitioning feature 188
library hardware changes and 235
library resources and 194, 234, 296
modifying summary information 224, 271
orphaned cartridges in 194, 219, 307
planning 188–190
printing reports 239
reports 236–240, 298–316
saving reports 240
SCSI FastLoad feature and 470
shared CAPs and 197, 199
SL Console workspace and 204, 233, 291
summary screen reference 253–272
task summary 206
using AEMs in 196–200
using CAPs in 196–200, 380
verifying 216, 288

library power down 581
library power up 582
library reboot 514
library reports 65

displaying 86
saving data to a file 90
searching 88

library self-tests 482
performing 521, 524

library status
displaying 334

library utility tasks 500–520
local operator panel

described 67–69
entering data 68
factory alignment 69
logging in 74
pen and stylus 67
re-calibrating 69, 93–95
resetting calibration to factory settings 96
touch-screen 67
virtual keypad 68

log snapshot file
described 491
transfer process 519–520

login IDs 62
logs

Feature Audit Log 127, 140

M

main access door
audits and 484
automated mode and 326
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maintenance mode (library) 59
Management Information Base. See MIB file.
manual CAP 378
manual cleaning (drive) 449, 463
manual mode (library) 59
manual operations

safety precautions 573–575
access door interlocks 574
access door release 574
general 573
physical restrictions 575
server power interrupt 574

tasks 576–585
media

domain labels 618
ID labels 618

Media Events Report 440
MIB file

described 491
transfer process 516–517

mixed-media support 29
modules 28

AEM 41
Base Module 32–33
capacity 30
CEM 38
DEM 35–36
PEM 39

mount operations 325

N

NDP. See non-disruptive partitioning.
NearLine Control Solution 57
non-disruptive capacity changes 146
non-disruptive partitioning

FC-SCSI partitions and 202
HLI partitions and 201

O

Oracle support services
deaf/hard of hearing access 23

orphaned cartridges
non-partitioned libraries and 145
partitioned libraries and 194, 219, 307

P

Parking Expansion Module. See PEM.
partitioned library. See library partitions.
partitioning

non-disruptive. See non-disruptive 
partitioning.

partitions. See library partitions.
passwords

modifying 84
PEM

described 39
physical capacity 31
wall diagrams 611

physical capacity 30, 144
of library modules 31

power down the library 581
power redundancy 49
power source options 49
power supplies 49, 466

cooling of 51
monitoring tasks 475–477
status of 477
summary information 476

power up the library 582

R

RealTimeGrowth 143
reboot

library 514
recovery moves 415
redundant electronics

manual switch 373
tasks 366–376

reserved system cells 594
diagram 615

result codes
listing 499

robot
bar code scanner 47

faulty 621
described 46–48, 465
diagnostic moves. See diagnostic moves.
monitoring tasks 467–477
properties 474
redundant 47
SCSI FastLoad and 468, 470
self-test 554
status of 473
summary information 472
utility tasks 553–568
varying offline 555
varying online 556

row numbering, diagram 614

S

safety door. See AEM safety door.
safety precautions 573–575

access door interlocks 574
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access door release 574
general 573
physical restrictions 575
servo power interrupt 574

SCSI FastLoad 468, 470
self-tests

CAP 544
drive 550
library 482, 521, 524
robot 554

SL Console
activation password 62
active storage region workspace and 149, 165, 

174
communications failures 328
described 56, 61
first-time access 62
layout of screen 63
local operator panel. See local operator panel.
logging off 83
login IDs 62
modes 61
modifying passwords 84
modifying the screen display 64
partition workspace and 204, 233, 291
security 62
standalone. See standalone SL Console
Web-launched. See Web-launched SL Console

SL Console Help
accessing 66
described 66
navigation 66

SL Console report tasks 85–91
SL Console reports

Drive Events 409
Drive Media Events 411
Energy Monitor 350, 352, 354
General Events 356
Media Events 440
Options Bar 65
types 65

SLC. See SL Console
SMC 58
SNMP

library support of 55
transferring the library MIB file 516–517

specifications
environment 50

standalone SL Console
described 70–71
installing 98–107
installing updates 71
logging in 82

status alerts
clearing 338
described 332
displaying 335

Status Module. See status alerts.
storage cells

FC-SCSI address 602–603
HLI-PRC address 597–599
library internal address 591–594
physical capacity 30
wall diagrams 607–615

StorageTek Library Console. See SL Console

T

TallBot. See robot.
tape drives. See drives
TCP/IP interface 53–54
transferring the log snapshot file 519–520
troubleshooting 489

V

vary the library offline 577–578
vary the library online 579–580
VOP

displaying for T10000 drives 405

W

wall diagrams
AEM 612
Base Module 608
CEM 610
configuration block 613
DEM 609
PEM 611
reserved system cells 615
row numbering 614

Web-launched SL Console
client requirements 70
described 69–70
Java WebArchive file 625
logging in using a browser 75–78
logging in using an icon 79–81
security 69
starting on a client 70
updating on a client 70

Web-launched SL Console server
described 625
installing 626–630
security 625
updating 625

World Wide Name. See dWWN
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