Troubleshooting - VMware Restore

Backup Restore  

The following section provides information on some of the troubleshooting scenarios related to restore:

Restore Failure

After Upgrading Proxy Server from 8.0 to 9.0 Uninstall VDDK 1.1 on the proxy computer and re-install VDDK 1.2 before performing restore.

*For 64-bit operating systems: From the VDDK x64 installation directory, unzip the vddk64 folder to a temporary location. Once unzipped, copy the bin, lib, and plugins folders to:

C:\Program Files\VMware\VMware Virtual Disk Development Kit

Browse operation yields a message stating "There are no items to show in this view" The MediaAgent selected in the Browse Options dialog box may be installed on a Unix computer. Unix-based MediaAgents are not supported for direct restores. To resolve this issue, select a Windows-based MediaAgent.
When using IP Address of the Virtual Machine Provide the name of the virtual machine you are restoring instead of the IP address.
File level restores cannot be performed If the cluster size (allocation unit) on the disk that you backed up was less than 1024 bytes, the backup job completes with the error: "Metadata collection failed for Virtual machine [B_VM1_disk_Full], File and Volume browse will not be available for this VM. [Failed to open volume for metadata processing, Cluster size is not supported]". Increase the disk size to perform a file level restore on this disk.
File level restores complete with errors Do not perform a restore of a SymLink file.
When using SAN transport mode if proxy is on Windows Server 2008 Clear the read-only mode, by following the steps given below:
  1. Open Command Prompt
  2. Run diskpart
  3. List and select the SAN shared disks
  4. Type attribute disk clear readonly

For Example:

C:\Users\Administrator> diskpart

Microsoft DiskPart version 6.0.6002 Copyright (C) 1999-2007 Microsoft Corporation. On computer: COMPUTERNAME

DISKPART> list disk

Disk ### Status Size Free Dyn Gpt -------- ---------- ------- ------- --- --- Disk 0 Online 64 GB 0 B Disk 1 Offline 78 GB 2048 KB <--- The share disk is usually reported as Offline

DISKPART> select disk 1

Disk 1 is now the selected disk.

DISKPART> detail disk

ROCKET IMAGEFILE SCSI Disk Device Disk ID: 02872505 Type : iSCSI Bus : 0 Target : 0 LUN ID : 0 Read-only : Yes <--- Make sure of read-only mode Boot Disk : No Pagefile Disk : No Hibernation File Disk : No Crashdump Disk : No

There are no volumes.

DISKPART> attribute disk clear readonly

Disk attributes cleared successfully.

VMX and VMDK files are on different datastores Ensure the following:
  1. Before performing the backup, ensure that VMX and VMDK files are on the same datastore. Create at least one VMX file on the datastore that contains the VMDK files.
  2. If configured for ESX Server backups, ensure a folder exists on the secondary datastore(s) and that the folder is given the exact name of the virtual machine.
With "Duplicate GUID" error Virtual machines with the same GUID may fail on restore.
VMware converter restores of backups done via the vStorage API Backups performed via the vStorage API cannot be restored through the VMware converter. The converter does not understand the format of vStorage.

Restoring Independent Disk/Physical RDM results in VM not powering on

Problem

If the virtual machine under backup includes independent disks/physical RDMs, these disks will be skipped. During a full restore the independent disk/Physical RDM also gets restored with 0MB, and the virtual machine cannot be powered on.

Solution

Prior to restore, manually delete the independent disks/Physical RDMs and then power on the virtual machine.

File-Level Restores Introduce a Different File Size and Checksum

Problem

If a file-level restore is performed from a backup that used VCB mounter, the restored files may have a different size and a checksum.

Solution

  1. From the Backup Set Properties dialog box, switch the backup mode to vStorage.
  2. Re-run the backup.
  3. Restore the files again.

SAN mode restores may be slower than NBD transport mode

Problem

When attempting restoration of a VMware virtual machine from disk backup in SAN environments, the restore job slows down with the events in VMware client GUI displaying “clear lazy zero”. This results in the performance of restores with SAN transport mode to be slower than in NBD transport mode.

Solution

To resolve this issue, perform restores directly to ESX server instead of vCenter.

While Restoring VM as Template, Registering Template VM Fails

Problem

When attempting restoration of a VMware virtual machine as a Template virtual machine, registering the Template virtual machine might fail.

Solution

Manually register the template virtual machine if the host is present under the folder.

Recovering Data Associated with Deleted Clients and Storage Policies

The following procedure describes the steps involved in recovering data associated with the following entities:

Before you Begin

This procedure can be performed when the following are available:

Recovering Deleted Data

  1. Locate the latest Disaster Recovery Backup which contains the information on the entity (Storage Policy, Client, Agent, Backup Set or Instance) that you are trying to restore.
  2. On a standby computer, install the CommServe software. For more information on installing the CommServe, see CommServe Deployment.
  3. Restore the CommServe database using the CommServe Disaster Recovery Tool from the Disaster Recovery Backup described in Step 1. (See Restore a Disaster Recovery Backup for step-by-step instructions.)
  4. Verify and ensure that the Bull Calypso Client Event Manager Bull Calypso Communications Service (EvMgrS) is running.
  5. If you did not have a CommCell Migration license available in the CommServe when the disaster recovery backup was performed, apply the IP Address Change license and the CommCell Migration license on the standby CommServe. See Activate Licenses for step-by-step instructions.
  6. Export the data associated with the affected clients from the standby CommServe as described in Export Data from the Source CommCell.
    When you start the Command Line Interface to capture data, use the name of the standby CommServe in the -commcell argument.
  7. Import the exported data to the main CommServe as described in Import Data on the Destination CommCell.

    This will bring back the entity in the CommServe database and the entity will now be visible in the CommCell Browser. (Press F5 to refresh the CommCell Browser if the entity is not displayed after a successful merge.)

  8. If you have additional data that was backed up after the disaster recovery backup and before the deletion of the entity, use the procedure described in Import Metadata from a Tape or Optical Media to obtain the necessary information.
  9. You can now browse and restore the data from the appropriate entity.

    As a precaution, mark media (tape and optical media) associated with the source CommCell as READ ONLY before performing a data recovery operation in the destination CommCell.

Restores from snap fails in case of read-only disks in SAN mode

In case of restores for SAN storage with any vendor type, you need to assign write permission to the disk on the Virtual Server proxy.

For Example:

If disk 12 is the disk you are trying to restore:

Z:\Henry\vmware>diskpart

select disk 12

DISKPART> disk attributes

attributes disk clear readonly

Revert Operation in Pending State

symptom

The Revert job may go to Pending state with the following error:

File level revert is not supported for a Virtual Machine [%VMNAME%] which is on VMFS datastore. [Datastore(s) [%DatastoreName%] does not support file level revert.

Cause

The virtual machine may have NFS and iSCSI disks. Ensure that all the disks reside on the NFS data store. If the data does not reside on the NFS data store, you cannot perform the revert operation.

Solution

Perform the conventional Container Restore to bring the data back to the point-in-time.

Revert Operation Fails

Before starting the revert operation, ensure that the Snapshot which you are using to perform the revert operation is not mounted.

File level restore fails

Symptom

While restoring files and folders from a virtual machine, you may get following error:

Volume name not found in the restore source path <source_path>, this is a volume restore.

Cause

This error appears when you have selected all files and folders in a virtual machine for the restore.

The file level restore of entire contents of the VM is not supported.

Solution

If you want to restore entire contents of a VM, perform a full VM restore.

Virtual Machine is restored successfully but not added to the correct resource pool

Symptom

The virtual machine is not added to the correct resource pool after the restore.

Cause

This error appears in the following scenarios:

Solution

If the ESX Server is managed by the a vCenter, do not configure the instance for the ESX server. Configure an instance for the vCenter and then perform the backup.

Similarly, before performing the restore, ensure that the instance is configured for the vCenter and not for the ESX server.  

Virtual machine client names are getting created with '_1' appended to the original client name

Symptom

When viewing virtual machines in the Client Computers list, you may see duplicated client names (for example, <ClientName> and <ClientName>_1).

Cause

Virtual machine information is added to the database during the discovery phase of a backup. If information changes, a new client is discovered during the discovery phase.

Making changes to information such as the virtual machine fully qualified domain name (FQDN), the GUID, or the host name can cause this issue.

Resolution

To avoid duplicate client entries caused by different client or host name:

Use the install software option for the client level in the CommCell Console (rather than interactively installing software to the virtual machine Guest Operating System).

To correct existing clients:

If duplicate clients are created with '_1" appended to the original client name, you can perform the following steps to merge the duplicate client back into the original: 

  1. At a command prompt, navigate to the software installation path, log in to the CommServer, and run the following script:

    qoperation execscript -sn QS_SetVMClient -si @sourceClient='<ClientName>_1' -si @destClient='<ClientName>'

    where <ClientName> is the original client name and <ClientName>_1 is the duplicate.

    This script reassigns all backup history from <ClientName>_1 to <ClientName>. This enables you to view backup history, and to generate Job Summary Reports with the Include Protected VMs option enabled.

  2. Remove the duplicate clients:
    1. In the CommCell Console, go to Control Panel | User Preferences.
    2. Click the Client Computer Filter tab.
    3. Select the Show Virtual Server Discovered Clients option.
    4. Delete the duplicate clients from the CommCell Browser.

Failed to start the virtual machine

Symptom

When a virtual machine has been replicated in vSphere and backed up, and a full VM restore is performed from the backup, the following status message might be displayed in vCenter:

Failed to start the virtual machine.

Cause

If the Power ON Virtual Machine After Restore option is selected when performing a full VM restore, VMware attempts to power on the restored VM before disabling replication.

Resolution

Clear the Power ON Virtual Machine After Restore option when initiating the restore. VMware automatically disables replication when the restore is completed, and you can power on the virtual machine manually.

Cannot restore files from a Windows 2012 virtual machine using deduplication

Symptom

When restoring from a backup of a Windows 2012 virtual machine that has deduplication enabled, a file-level restore completes successfully but only creates stub files.

Cause

File-level restores are not supported for deduplicated volumes from a Windows 2012 VM.

Resolution

To retrieve files from a backup for a Windows 2012 VM using deduplication, restore the disk that contains the file.

Alternatively, you can install a local file system agent on the Windows 2012 VM to enable file-level restores.