Troubleshooting - Windows File System Agents Backup

Backup Restore  
 

The following section provides information on some of the troubleshooting scenarios related to backup:

Backup Failure while backing up Large Files or System Volumes

Cause

When backing up large files and/or system volumes, the Windows memory pool resources may run low and the backup may fail with errors reported in the Windows Event Viewer and the iDataAgent logs.

Solution

Review the Microsoft documentation for increasing the maximum memory pool usage and paged memory pool size.

Backup Goes to pending state while backing up an unformatted volume and mount points

Symptom

The Event Viewer displays following message: Cannot scan <path>

Solution

Add the NSkipDirErrors Registry Key and set the value at 1 (or any value other than 0)

Backup Goes to pending state for Polyserve (Non-Microsoft Clusters)

Symptom

The backup job for a Polyserve goes to pending state

Solution

Exclude the following folders from the backup and anti-virus scan:

For backup c:\program files\polyserve\matrixserver\conf\mounts
For anti virus scans c:\program files\polyserve\matrixserver\conf

<Calypso install directory>/Base

During Disaster Recovery, open up the Polyserve Configuration Utility and export the configuration to the node that was rebuilt. This will ensure complete synchronization prior to introducing a rebuilt node again into the matrix.

Backup of subclient that contains only files and no folders

Cause

When a subclient contains only files and no folders, the backup can fail if you select Data Classification as the scan method.

Solution

When a subclient contains only files and no folders, always use Classic File Scan as the scan method.

Completed with One or More Errors

Backup jobs from Windows File System iDataAgent will be displayed as "Completed w/ one or more errors" in the Job History in the following cases:

For subclient containing only system state backup:

For subclient containing system state backup along with File system data: