Troubleshooting - Windows File System Agents Restore

Backup Restore  
 

Error messages during Browse operation

When you are browsing the backup data, one of the following error condition can occur:

Symptom

Failure to connect the MediaAgent

Solution

Check the connectivity between MediaAgent and the client computer. Add the client host name and IP address in the host file on the MediaAgent.

Symptom

Index Cache Inaccessible

Solution

Check the connectivity between MediaAgent and the client computer. Add the client host name and IP address in the host file on the MediaAgent.

Files prevented from overwriting

Cause

When a file is in use by the operating system or open with exclusive read access by an application, the file is locked and cannot be overwritten.

Solution

The system automatically restores the file with another file name within the same directory and records the instance in the Windows registry. These are restored automatically at the time when the computer is restarted.

These files can be viewed from the Restore Job Summary Report They have a "Needs Reboot" tag attached to it. They can be viewed in the Restore History from the CommCell Console. In order to view these files you need to select the Failed Objects check box in Job Summary Selection tab. These files are displayed as Skipped files.

Cluster Services are not Started Automatically during Disaster Recovery

Cause

If the cluster disks were repartitioned, a failure message may appear because the disk GUIDs for the quorum may have been changed.

Solution

If the cluster service does not start, or if you see Event ID 1034 in the System Event Log, reference the KB 305793 and KB 280425 Microsoft Knowledge Base articles on http://support.microsoft.com/ to get the cluster service back online.

If the cluster service does not start automatically, start it manually in the service control manager.

Recovering Data Associated with Deleted Clients and Storage Policies

The following procedure describes the steps involved in recovering data associated with the following entities:

Before you Begin

This procedure can be performed when the following are available:

Recovering Deleted Data

  1. Locate the latest Disaster Recovery Backup which contains the information on the entity (Storage Policy, Client, Agent, Backup Set or Instance) that you are trying to restore.
  2. On a standby computer, install the CommServe software. For more information on installing the CommServe, see CommServe Deployment.
  3. Restore the CommServe database using the CommServe Disaster Recovery Tool from the Disaster Recovery Backup described in Step 1. (See Restore a Disaster Recovery Backup for step-by-step instructions.)
  4. Verify and ensure that the Bull Calypso Client Event Manager Bull Calypso Communications Service (EvMgrS) is running.
  5. If you did not have a CommCell Migration license available in the CommServe when the disaster recovery backup was performed, apply the IP Address Change license and the CommCell Migration license on the standby CommServe. See Activate Licenses for step-by-step instructions.
  6. Export the data associated with the affected clients from the standby CommServe as described in Export Data from the Source CommCell.
    When you start the Command Line Interface to capture data, use the name of the standby CommServe in the -commcell argument.
  7. Import the exported data to the main CommServe as described in Import Data on the Destination CommCell.

    This will bring back the entity in the CommServe database and the entity will now be visible in the CommCell Browser. (Press F5 to refresh the CommCell Browser if the entity is not displayed after a successful merge.)

  8. If you have additional data that was backed up after the disaster recovery backup and before the deletion of the entity, use the procedure described in Import Metadata from a Tape or Optical Media to obtain the necessary information.
  9. You can now browse and restore the data from the appropriate entity.

    As a precaution, mark media (tape and optical media) associated with the source CommCell as READ ONLY before performing a data recovery operation in the destination CommCell.

Error during the Full System Restore of Windows Vista or Windows Server 2003

Symptom

During the Disaster Recovery of Windows Vista or Windows Server 2003, you may get the following error:

An unauthorized change was made to Windows

Solution

When rebuilding an entire computer, it is required that the Windows service pack and hotfixes in the backup are also applied on the target computer. The service pack on the target must always match the backup prior to a restore. To restore the hotfix from the backups, select the Overwrite Files check box on the Restore Options dialog box and then select the Unconditional Overwrite option.

Select this option if the source computer had Internet Explorer 8.0 and the target computer has Internet Explorer 7.0.

An unauthorized change was made to Windows. You must retype your Windows Service Product Key to activate the license.

Symptom

During the Disaster Recovery of Windows Vista or Windows Server 2003, you may get the following error:

An unauthorized change was made to Windows. You must retype your Windows Service Product Key to activate the license.

Solution

If the Windows product license key is not activated on the target computer prior to a full restore, you will receive the following message, and you will be required to provide the product license key after the restore. Refer to the check list that you have creating while planning for disaster recovery.

Files on the Single Instance Storage linked volumes appear corrupted after Restore

Symptom

After the full system restore, the SIS-linked files are not be accessible, and they appear to be corrupted. The name and size of a SIS-linked file appear as normal. However, the file is a zero-length file and it does not have access to the data it should contain.

Solution

Before starting the restore, ensure the following

For more information on How to restore a volume that is managed by Single Instance Storage, refer the KB 263027 Microsoft Knowledge Base article on http://support.microsoft.com/.

Completed with One or More Errors

Restore jobs from Windows File System iDataAgent will be displayed as "Completed w/ one or more errors" in the Job History in the following cases:

For subclient containing only system state restore:

For subclient containing system state restore along with File system data:

Updating Features and Roles on Windows Server 2008

On Windows Server 2008, when you perform the Full System Restore, the Features and Roles do not get updated.

Select Configure Refresh from the Server Manager main page and update Features and Roles as they are not updated during a restart.

BSoD Error after a Full System Restore Operation

Symptom

After the full system restore, the computer reboots with a BSoD error screen.

Resolution

Make sure that the following are not filtered while performing the full system restore operation:
  1. *:\drivers\*
  2. *:\win*\inf\*

Distributed Component Object Model (DCOM) Component Appears Disabled After a Restore Operation

Symptom

Distributed Component Object Model (DCOM) component appears disabled after a restore operation is performed on the client computer.

Solution

Run the following command from the command prompt on the client computer after the restore operation is complete:

%windir%\system32\msdtc.exe –resetLog

System State Restore Fails

Symptom

If you back up certain system protected files in a cluster shared drive and the drive is no longer available, then the System State restore fails.

Solution

Create the nIgnoreNonexistingClusterDrivePathErrors additional setting to skip the files that belong to the cluster shared drive. The restore operation then completes successfully for other files.